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ACH Universal

1 ACH Universal

ACH Universal™ creates ACH / NACHA files for electronic fund transfers.  

Get up and running in less than one hour.  We highly suggest watching our
tutorials --less than 15 minutes in length--and, at the end, you'll be able to
create an ACH file for testing with your bank.

1.1 Absolute basics

Welcome New Users

Have you been asked to create an ACH file to send to your bank?

ACH Universal enables you to create ACH / NACHA files from the data in your
accounting, payroll or other system.  

Create ACH transactions for:
• Direct Deposit for employees
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• Collections from customers or vendors
• Payments to vendors

We highly recommend that you click the links below to view the tutorials now.

Brevity is critical--and we value your time.  The videos are less than 6 minutes
each and, at the end, you will be able to create your ACH files for testing with
your bank.

If you do not have speakers at your current computer, or would prefer to view it later, feel free to copy the links below and play the
video back later:
http://www.treasurysoftware.com/support2-Research.html

1.2 Getting Started

Steps for Getting Started

To begin using ACH Universal, please refer to the instructions at each tab:

1. Download and install the software

2. Gather your data

https://www.youtube.com/watch?v=xxT7J8JBozk
https://www.youtube.com/watch?v=R6Dfvmr8p-A
http://www.treasurysoftware.com/support2-Research.html
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3. Create and set up accounts

4. Import transactions (from Excel or CSV)

5. Create and transmit the ACH file to the bank

Next: Download and install >>

1.2.1 Download and Install

Download ACH Universal

Download ACH Universal from our website at
http://www.treasurysoftware.com/download/index.aspx

When prompted, save this file to your Desktop.  The file is approximately 75
MB. 

http://www.treasurysoftware.com/download/index.aspx
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Install ACH Universal

After the download is complete, double-click the file to begin installation. 

Proceed through the installer.

For detailed assistance, please visit our Support Center at
http://www.treasurysoftware.com/Support/support2-Install-Center.aspx.

Once the installation is complete, you are ready to begin using ACH Universal.

Next: Gathering Data >>

1.2.2 Gathering Data

Gathering Data

Enter transactions easily and automatically with ACH Universal. You can import
files already in electronic format--or you can simply key them in.

The import (or 'source') data files typically would be created from within your
accounting software.  They may be as simple as Excel or CSV (comma
delimited) reports, or they can be custom-written data dumps from third-party
reporting packages, such as Crystal Reports.

The most popular choices for these files are:
· Comma-separate values (CSV) - recommended
· Excel spreadsheet
· Tab-delimited

Basic Importing 

The advantage of the Basic ("On-The-Fly") method is that you can generate a
one-time payment without being forced to set up a profile for a party you will not
need in the future.  If your system is capable of storing the bank account and
ABA/routing numbers, this is the simplest method of importing.

http://www.treasurysoftware.com/Support/support2-Install-Center.aspx
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This is an excellent method of populating data for non-recurring transactions,
web server or other integration scenarios, where transactions are often made
with new customers, employees and vendors. 

You should be able to create an Excel or CSV file that contains all the required
information:
· Name
· Account number
· ABA/Routing number
· Amount
· Checking or Savings indicator

These fields contain enough information to generate an electronic payment.  If
your data resembles this format, follow instructions for On-the-Fly or "Ad Hoc"
File Imports.

Additional fields of information can be in your source document and then
disregarded in the ACH software.  Often these files contain the date and an ID
number, for instance. You do not have to delete the additional data.

The order of the columns is not significant--ACH Universal has a mapping
wizard.

If all of your transactions are to/from checking accounts, you do not need to
map a column for Checking/Savings. The system will automatically default to
checking.  
If your transactions are mixed between checking and savings, include a
Checking/Savings column for this with field entries "CHK" or "SAV".

Profile-Based Imports
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Profile-based "lookups" are excellent for off-the-shelf accounting packages
such as Peachtree and other systems that do not have the ability to store bank
account and routing information.

In this scenario you would create profiles for each of your Customers,
Employees and Vendors in the ACH software (yes, it is possible to import this
information).  Profiles are retained automatically by ACH Universal.
  

Profile-based imports make the transaction file very simple.  The only fields
required are an amount and a lookup field.  

Should I Use Ad Hoc or Profile Based Importing?
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The current layout of your data should determine whether you choose Ad Hoc
imports or Profile lookups.  The resulting ACH file will be exactly the same
regardless of import method.

Next: Create and Setup accounts >>

1.2.3 Create an Account

Create an Account

Open Treasury Software and the Welcome New Users page will load. Select
the Option for “ACH Universal."

Create Account

The first thing you want to do is to create a New Account for your work.  Click
File>New Account.

Important - Any data saved in the 'Sample'  account will be reset, as it
synchronizes with the tutorial.  It is advisable to work in a new, "Test" account
that is set up rather than the Sample account.
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Select the option to “Create an Account and Add it to your Catalog” and click
Next.
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Enter a name for the Account. This name is strictly internal and should help you
identify the purpose of the account. For example,if you are using ACH Universal
for payroll, you might name the account Payroll.  Once the name is entered,
click Next.
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Congratulations! You have finished creating the account. Click Finish to begin
using this Account. 
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Next Step

If you have your account information from your bank, you can enter it now at
ACH Setup.
However, you can create ACH files for internal testing without this information.

Next: ACH Setup >>

1.2.4 ACH Setup

ACH Setup

In-house testing?
If you are simply performing in-house testing (such as IT testing), you can skip
this step, as you can create ACH files without entering this information. 

Testing with your bank?
If you will be testing with your bank, you will need to perform this step prior to
creating the files that you send to them.
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To start the ACH Setup Wizard select the 'Settings' tab > 'ACH File Setup'.

The ACH Setup Wizard will be displayed.  Click Next.

ACH File Header Record - Screen 2

The ACH File Header Record is the first record in the ACH file, and is identified
by a '1' in the first position.  It's primary purpose is to identify who sent the file
(your organization) and where it is going (to your financial institution/processor).

If you already signed up with your bank for ACH service, this information will be
in your Welcome packet.

If you have been creating ACH files, but do not have the original documentation
form your bank, ACH Universal can pull this information off of a file that you
have already created.
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If you have neither documents above, follow our guidelines within the wizard
below.  Of course, we can't guarantee compliance with your bank, but it is a
very conservative approach to start.

Batch Header Records - Screen 3

Note: If you are using ACH Universal's Multiple Origination account feature in
the Processor edition, this advanced feature will override some of the values
below. 
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Which Standard Entry Class (SEC) code do I use?

If you have a standing authorization in writing to perform collections/payments,
and the other party is located in the U.S., you may be eligible to use:
PPD - Personal/Consumer Accounts (Prearranged Payment and Deposit)
CCD - Corporate/Non-consumer Accounts (Corporate Debit or Credit)

A good example is payroll to domestic employees--when you should use PPD. 
Please consult your banker before starting to insure that you are using the
correct code.
Other formats that ACH Universal supports are available at SEC Codes.

Offset Record and completion of Basic setup - Screen 4
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Offset Record
Only use an offset record if your bank notifies you that it is required.  
If your bank does require an offset record, click this check-box on Screen 4. 
- Enter the ABA or Routing Number for your organization's bank.
- Enter your organization's bank account number.

For the vast majority of users, you can click 'Finish' to complete the wizard. 
This will save your work.
If you have advanced needs, or are curious as to the additional settings, click
'Advanced'.

Preferences - Screen 5
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Description on your recipient's bank statement - In the text field, enter the
description of the transaction that will show on customer, employee, and vendor
bank statements.  For example, you might enter "Payroll" for a direct deposit
payment to an employee.  This entry is located in the ACH file in the Batch
Header (5 record, positions 54 - 63).

Company Discretionary Data - Typically not entered unless requested by your
processor or bank.  This entry is located in the ACH file in the Batch Header (5
record, positions 21- 40).

Default effective date - Select when you want the bank to process the
transactions.  For example, some banks want an ACH file two days prior to
processing.  In that case, change the dropdown to Two Days.  
Notes:
--This setting only effects transactions when a date is not entered.  Therefore, if
you import a 'Date' field with your transactions, this setting has no effect.
--For maximum control, import a 'Date' with your transactions
--This setting takes into account Saturday and Sundays, but not holidays.
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--The bank's rules determine the exact date of processing.  Contact your bank
for their exact policies.

Same Day ACH  

ACH Universal supports the NACHA cutoff indicator in the descriptive date (positions
64 - 69).

For additional information, refer to the Advanced Topics> Same Day

When finished, click Next.

Third-party Processors and preferences - Screen 6
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Third party NACHA compliance, and multiple origination account
Turn 'On' the feature here.  Remember, when you turn it on, you will need to
map an 'Origination Account' field during the import process.

Profile Lookup
ACH Universal has full support of profiles for creating payments.  Profiles are
not required by ACH Universal, however, as it is capable of ad hoc payments.  
When using profiles, the lookup can be done by Name or by ID Number.
Profile Lookup - This setting only comes into play during the import process.

Checking or Savings Accounts
If your file contains a field that differentiates an account between a checking
account and a savings account, enter the appropriate checking account text into
the text field.  ACH Universal will interpret all other text as indicating a savings
account.

Consumer or Corporate Accounts
Similar to Checking or Savings Account text above, use text in this field to
identify a consumer account.  All other text in that field will cause ACH
Universal to treat the record as a corporate account. 
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Pre-notification
Pre-notifications are used to test a transmission to ensure all settings are
correct before transmitting live data.  A pre-note is indicated in your data by a 0
amount.  In the dropdown box, select the transaction type you wish to test (DR-
>collecting funds or CR->paying funds).

When finished, click Next.

Profile and Advanced settings - Screen 7

The next screen is the last screen in the process.  In most cases, you can
simply click Finish.  

You have finished creating and setting up an ACH Universal account.  You can
now begin importing data into the account and transmitting ACH files.  

Next Step:  Import Data >>
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1.2.5 Change Location of ACH File

Need to change the location of your ACH file when it is
automatically saved?

By default the Treasury Software will automatically save your file in the location
listed below.
C:\Users\Public\Treasury Software\To Bank

However, if you need to change this location, just follow these simple steps.

1.  Click on the 'Go To Create ACH File Page' button.
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2. Next click on 'Change transmission file name/location'

3.  Lastly, navigate to a location like your Desktop or any other location and click
Save
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1.2.6 Import Data

Obtaining Import Data

Before importing transaction files into ACH Universal, they must be obtained
from your accounting package. The exact process depends on the package,
but in general you will run an appropriate report for a given date range and then
export this report to an Excel spreadsheet or CSV file. For more information or
assistance in this, contact your corporate IT.

Importing Transactions

Click on Import Transactions from the icon in the center of the homepage.

Click the Import Transactions icon.

Select your file to Import and click Open. Common file types are Excel
(.xlsx, .xls), Comma Delimited (.csv or .txt) and tab delimited (.txt).  In addition,
fixed width text imports are available for manual imports.

Click Next.
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Mapping

The Column Mapping screen allows the user to tell the File Formatter what
information is in each column on the import file. Simply Highlight a column, and
select the appropriate column mapping from the drop down for the data. 
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After selecting the Column Mapping, the section about the column names (F1,
F2, F3, etc) will switch from Red to Green and list the selected mapping.
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Repeat this for all required columns. The required fields are Amount or
Amount_Reverse_Sign, Bank_Account_Number, ABA_Routing_Number, and
Name. When all the necessary columns are mapped, click next to continue the
Import Wizard.

Pay, don't collect your payroll - use Amount_Reverse_Sign when needed
Negative amounts decrease your balance, and represent payments out to
employees and vendors.
Positive amounts increase your balance, and typically represent collections
from customers and others.

If the Excel or other file that you are importing is displaying the amounts in
positive format, and the transactions represent payments out - then map the
field as Amount_Reverse_Sign.  This has the effect of multiplying the amount
by a negative 1.



34

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

Review Records

This screen will display a list of the importable rows and invalid rows. To review
the list of Importable Records, click on the “+” sign as shown below. 

If the “Amount” and “# of Records” columns are correct, click Next and go to
Finish.
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The grid will display the importable transactions and the basic information.

The Invalid Rows section will list all rows that will not be imported into ACH
Universal. The software will automatically mark Header rows, footer rows,
summation lines, and blank lines as invalid. For each row that is invalid, a
check mark will be placed in the appropriate column indicating why the row
was invalid.  In this case, the records were Invalid because the system detected
that one was a summary row and the other was a header row.  This caused
both Amount and the ABA number to be invalid.
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Once you have verified the importable information is accurate, click Next. If you
wish to Cancel the import process and try again, simply hit Cancel.

Click Finish to complete the Import Wizard.
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Next Step

You are now ready to create and transmit your ACH file.

Next: Create and transmit ACH file >>

1.2.7 Create and Transmit File

Create and Transmit ACH File

You are now ready for the final step: creating the ACH pay file and transmitting
to the bank.
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Click the Create ACH File button in the center of the homepage.

This will take you to Create ACH File Page (see below)

The first paragraph contains basic instructions on how to proceed.

The second paragraph lists the transmission method. 
In most cases, you will upload your file to your bank through their website. Your
bank will provide you with instructions for doing so.

The third paragraph displays where the Transmission File will be saved. The
default file name is the name of the account, followed by an underscore and the
word ‘transmit’. The default location for the file is the following:

Windows XP:
C:\Program Files\Treasury Software\Treasury Desktop\To Bank directory (on
XP) 

Vista, Windows 7, Windows 8, Windows 10
C:\Users\Public\Treasury Software\To Bank  
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The Review Records link on the Right Side Explorer Bar allows you to access
the Reports Section for review or deletion of Records

Click Create ACH File to create the file.

Once you click on Create ACH File, ACH Universal will ask if you want to view
the file. Select Yes if you want to verify the format or review the file. Otherwise
click No.

At this point, transmit the file to your bank using their procedures.

Congratulations! You have completed your first ACH file transmission.

If you have any questions, please consult our FAQ. This contains answers to
many common questions from first-time ACH Universal users.

Next Step

Review our FAQ for answers to many common questions.

Next: FAQ >> 

1.2.8 Getting Started FAQ

Frequently Asked Questions
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Q) Do I use Amount or Amount_Reverse_Sign when mapping headers?

A) The sign of the amount field determines whether ACH Universal treats the
transaction as a collection or a payment.  

Positive amounts increase your account balance and represent collections (i.e.,
from customers)
Negative amounts decrease your account balance and represent payments
(i.e., vendors, employees)

If negative numbers are in your import file (for example, you are doing payroll
and the amounts are shown as negative), use Amount.  

If this is exactly the reverse (for example, you are doing payroll and the amounts
in the import file are positive), use Amount_Reverse_Sign.

Q) How do I change where the ACH file is saved?

A) On the blue pane on the right under FAQ, click on the question "How do I
change the name and/or location of the ACH file?"

Q) How do I delete a record?

A) If a record has been imported, but not put into an ACH file, it is possible to
delete it.  From the Home tab > Untransmitted Records report from the drop
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down box. Click Run. Select a record in the grid (it will turn blue), and click the
Red X on the toolbar. 
Note: To preserve the audit trail, transactions already included in an ACH file
cannot be deleted.

Q) How can I delete an entire import?

A) An entire import can be deleted as long as none of the records from the file
have been transmitted.  From the Home tab > Import Logs. Highlight the import
you wish to delete and click the Red X on the toolbar. Deleting an import will
remove all records from that import file from ACH Universal.

1.2.9 Automate Backup

Set up Automatic Backups

When you are just getting started with setting up the software it is a good idea

to create an automatic backup.  In the event there is database corruption you
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will be able to restore your work quickly and easily.   There are just three steps

you need to follow to set this up.

1.  Select “File” then “Backup” from within the software.

2. Next select “Browse”

3. Browse to a network directory or to another location on your hard drive

and select “OK”.  The location that you select should ideally be backed

up on a regular basis but this is not required.

Next:  Importing Transactions >>

1.3 Importing Transactions

Importing Transactions - Overview
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Importing is the process that brings data into ACH Universal.  There are
actually several different ways to bring in data.  

Data can be classified into two categories:

· Transactions - Data represents a transaction to be imported and mapped in
the ACH file.

· Profiles - Data represents a Customer, Employee or Vendor Profile, which is
used in conjunction with a transaction file to create the entries in the ACH file

Profiles alone do not contain enough information to create an ACH file as they
are not associated with any specific transaction.  Transactional data can include
the payee information.  If your accounting system uses Profiles, transactional
data includes a field that identifies a specific payee by name or ID number
(most common).
[NOTE:  QuickBooks Online users will be required to set up Profiles in ACH
Universal.]

In some situations, you may want to enter a transaction (or sometimes several
transactions) manually instead of using a file import.  
See Entering Transactions Manually for information on manual entry.

1.3.1 Importing Transactions

Importing Transactions

The file that you are importing should be in Excel, comma delimited (CSV), tab
delimited or another tabular format.  
See Gathering Data for more information.

From the ACH Universal Home Page, click the Import Transactions icon.
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To start the Import Wizard click on 'Import Transactions'.

Browse to select a file, or 'copy and paste' from Excel.
Tip: Browse to select a file is much faster and efficient in large imports.
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Click Next.

The ACH Transaction Column Mapping screen will be displayed (below).
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Mapping

In a typical scenario, you will need to map the following fields (in no required
order):
· Name
· Bank_Account_Number
· ABA_Routing_Number
· Amount or Amount_Reverse_Sign
· Checking_or_Savings

· In addition, you will most likely also add:
· Date
· ID_Number

Disbursements - use Amount_Reverse_Sign when needed

Negative amounts decrease your balance, and represent payments out to
employees and vendors.
Positive amounts increase your balance, and typically represent collections
from customers and other funds received.
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If the Excel or other file that you are importing is displaying amounts as positive
numbers--and the transactions represent payments out--then map the field as
Amount_Reverse_Sign.  This has the effect of multiplying the amount by a
negative 1.

Afterwards, click Next.

Review Records

This screen will display a list of the importable rows and invalid rows. Expand
the summary rows to view the detail by clicking on the  “+” sign as shown
below.  The one invalid row is usually the source data column headers, which
will not be transferred to the transmission file.

Click 'Next' to complete the Wizard.
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See also Entering Transactions Manually >>

1.3.2 Entering Transactions Manually

Entering Transactions Manually - Overview

While the bulk of records should be imported as files for maximum accuracy
and efficiency, there can be situations where entering a record manually is a
better choice.  

For example, to create a one-time payment for a vendor, it may be easier to
input the information directly than to enter it into a file and then import the file. 

From the Home Page, select the 'Add a Record' icon.
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If using Profiles:

If you are using Profiles, click the first radio button and select the profile from
the dropdown box.
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All fields are required.

Applicatio
n

Select the Standard Entry Class Code you wish to use for this
transaction.  In this case, CCD is selected for a payment to another
company.

Date Select the date the requested processing date.  Note: You cannot
force a same-day transaction by using the current date. Contact
your bank for their exactly time frame.

Debit/Cre
dit

Select whether you are paying or receiving funds

Payment Enter the amount as a positive number.

If not using Profiles or if making a one-time payment:

If you are not using profiles or are making a one-time payment and do not wish
to create a profile, click the second radio button.
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Enter the appropriate information. All fields are required with the exception of
the Addenda Record.

Account # Other party's bank account number

Routing/AB
A #

Other party's bank ABA/Routing number

Internal
name

Other party's name

Internal ID An identifier for the other party, such as vendor ID

Account
Type

Checking or Savings

Addenda
Record

Optional addenda record.  Maximum length of 80 characters.

Click OK. 

Next:  Deleting an Import >>

1.3.3 Deleting An Import

Deleting an Import

Follow the steps below to delete an entire file import (every transaction from the
imported file).  
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From the Home tab select Delete Entire Import > select the record (the row will
turn blue) > select delete ' '.

Click Yes to confirm the deletion, No to cancel.

Next  Deleting a Single Transaction >>

1.3.4 Deleting A Single Transaction

Deleting a Single Transaction

Follow the steps below to delete a transaction or group of transactions.

From the Home tab select Delete Records.

Select the transactions (yes, you can select multiple records) to be deleted,
then click the  button.  Click Yes to confirm the deletion, No to cancel.
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Next  Editing Untransmitted Records >>

1.3.5 Editing Untransmitted Records

Editing Untransmitted Records

Run the Untransmitted Records report from the Home tab, select a record (the
row will turn blue), then click 'Edit Record'.
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This will then open the Edit screen as below.  

Edit information as needed, then click 'OK'.  Run the report to see the changes.

NOTE:
You can edit transactions as long as they have not been included in an ACH
file. 
Once a record has been included in a file--regardless of whether it was actually
transmitted to the bank--the record cannot be edited.
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1.3.6 Filtering Imports

Filtering Imports

By using accounts, ACH Universal allows you to create a logical separation of
transactions.  For example, you can create a Payroll account for direct deposit
transactions and a Checking account for vendor payments.  Filtering becomes
necessary when source files contain transactions for multiple ACH Universal
accounts.  By filtering the import, transactions are imported into the proper
account.

By definition, a filter is only required if you have already created multiple ACH
Universal accounts.  

Before beginning

The steps below must be repeated for each ACH Universal account.  In the
example of Payroll and Checking, the steps must be done once in the Payroll
account and once in the Checking account.  

Creating the filter

A filter consists of nothing more than an identifier used to distinguish data for
one account from other data. This can be a field containing the text "payroll"
and "checking", an account number, or some other identifier.  Each filter must
be unique from that of all other accounts. 

1. Make sure you are in the proper account.
2. From the Ribbon bar select Settings > 'Import, System' icon (legacy menu
users - File from the main menu, then Options, then General).
3. In the textbox corresponding to "Filter Import - GL", enter the identifier you
wish to use for the current account.
4. Click Close.
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Repeat these steps for every account you need to filter.  The identifiers must be
different for each account.

Using the filter

There are two ways to use the filter.  You can schedule imports using the
Control Panel for recurring imports or you can perform the import manually.  

Using a manual import filter

Import your transaction file as outlined in Importing Transactions.

Map all fields in the file as usual with one addition: map the field representing
the filter text as 'Filter.'  ACH Universal will import all transactions from the file
into the proper account based on the filter text.  If you do not map 'Filter' the
entire import will be brought into the account currently opened.
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NOTE:  You can also click "Scheduler" to schedule the import using the
Automated Scheduler. 

When finished, click Close.

 

1.3.7 Mapping Fields - Reference

The required fields to map in a non-profiles scenario are:
• Name
• ABA_Routing_Number
• Bank_Account_Number
• Amount (or other amount field)

We of course recommend that you map the following fields, but the system can
use defaults:
• Date - to the next day (or other default)
• Checking_or_Savings - to checking
• ID_Number - to blank - this is the other party's identification in your system (ie.
payroll - this would be employee #). 

There are over 40 additional fields available.  Please see the individual help
topics.

If you are using profiles for your import, see Profiles.

Please remember, that this page relates to the other party's data - such as your
clients, employees and vendors.

Name

This is the name of the party that you are paying or collecting from.  It does not
need to be an 'exact' match of the name on the account.

ABA_Routing_Number

The 9 digit number assigned to each bank.
For all of you trivia experts - technically the ABA is an 8 digit number, and the
ninth digit is a check sum.  However, common use dictates to always use all 9
digits unless specified otherwise.
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ACH Universal performs a checksum verification on each imported or manually
entered transaction's ABA number.

Using Excel - don't worry about the leading zero dropped.  Depending on your
formatting, Excel may drop the leading zero, ACH Universal will automatically
add the leading zero, and then perform it's verification.

If you are on our Corporate or Processor edition, you can look up and report on
the current list of ABA numbers (Reports > ABA Listings).

Bank_Account_Number

This is the bank account number of the party that you are paying or collecting
from.  Do not include dashes or other non-numeric data.  If leading zeroes are
included, we recommend passing them along.

Amount
The amount being paid or collecting.

Sign in
Amount Field

Funds flow Transaction Use

Positive From other party to
you

Debit Collect from customers

Negative From you to other
party

Credit Pay vendors and
employees

The metaphor is:
Positive amounts increase your account balance, and typically represent
collections from customers and others.
Negative amounts decrease your account balance, and represent payments out
to employees and vendors.

If the file you are importing contains both debit and credit transactions, sign the
amounts accordingly.

Special issues
Amount_Reverse_Sign
If the file that you are importing is displaying the amounts in positive format, and
the transactions represent payments out - then map the field as
Amount_Reverse_Sign.
Tip: This field saves you the step of opening the file in Excel and multiplying by
negative 1.
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Separate field with 'Debit' or 'Credit'
Some files will have a separate field with a value similar to Debit/Credit or
DR/CR.  You can map this field as 'Sign', and then make sure that the
appropriate value is in File > Options >General > Import tab.

No decimals
If the amount you are importing does not contain a decimal point, from the main
menu select the 'Settings' tab > 'Import,System' > 'Import tab'.  Scroll to
'Imported Amounts need decimals - G/L' and turn 'on'.

Example:  The imported amount is $5.00, and is shown in the file as 500. In this
scenario, turn on the option above.

Note: By default, a zero amount will generate a pre-note (pre-notification) entry.
 To filter out zero transactions, set the appropriate switch in File > ACH Setup.

Date

If a 'Date' field is mapped, ACH Universal will use that date as the effective
date.

Default date
If no date column is mapped, the system will use the next available business
date, without regard for holidays.
You can change the default setting of 'Next day' to 'Two days', etc... in ACH
Setup (File > ACH Setup).

Note: If a date field is mapped, but a record has an invalid date, the system will
filter out the record.

Importing non-standard date formats (YYYMMDD, etc...)
As a general rule, if you can display the date in Excel, ACH Universal can
import it.  

However, if it is a non-standard format (per Excel), such as YYYYMMDD, you
need to set Custom Date Import options in ACH Universal.  
From  the main menu select File > Options > General > Import tab.  Scroll to
Custom Date Import (CDI) G/L - turn it 'On'.  Then set the appropriate
selections below it.
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Checking or Savings

If all of your transactions are to/from checking accounts (such as a vendor
payment run), you do not need to map a column.  The system will assume
'checking' as the default. 

If the data you are importing is mixed, ie.containing transactions which will be
received by checking and savings accounts, you will want to map the field as
Checking_or_Savings.
The values in the data can be (case insensitive):
Checking Saving
0 1
C S
CHK SAV
Checking Saving
Checkings Savings

Special issues:
If you have a non-standard value representing checking/saving, you can select
it ACH > Setup > Last Panel > Advanced > Legacy 1.

1.3.8 Profiles

Profiles

As mentioned earlier, all the fields needed to create a transaction may not be
available in the accounting system.

Profile-based importing is excellent for off-the-shelf accounting packages such
as QuickBooks Online, Peachtree and any other system which does not have
the ability to store account and routing information.

First, you would create profiles for each of your Customers, Employees and
Vendors (yes, you can import profiles).

Then, simply export from your accounting package transactional information.  It
can be as simple as an amount field and either a Name or ID number of the
related profile.
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1.3.8.1 Creating Profiles

Creating Profiles

You can create profiles manually, one at a time, or you can create multiple
profiles at one time by importing an Excel, comma delimited (CSV) or other
tabular file type that contains the profile information.



62

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

Manually Creating Profiles

Select the 'Profiles' tab > 'Add'.

... and then manually key in the information.

Importing Profiles 
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First, create a spreadsheet with the basic information.

From the main menu select the Profiles tab > Import > Customers, Employees
and Vendors to start the Import Wizard.
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The Profile Import Wizard Mapping screen will be displayed (below).  Map the
file as appropriate...
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...  and complete the wizard

Afterwards, run a Profiles report (Profiles > View/Edit) to review/confirm your
work.

Profile Options in ACH Setup

You can set the following options in ACH File Setup which can be accessed by
selecting the 'Settings' tab > 'ACH File Setup'.  On screen 7 select the
'Profiles/Origination Accounts' tab.
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1.3.8.2 Using Profiles

Using Profiles

Mapping

Start the Import Transactions Wizard as usual from the ACH Universal home
page.

At the mapping window, click on the 'Show all fields selection', and map the
following two fields:
--Amount or Amount_Reverse_Sign
--ACH_Name_Internal (Profile Lookup) or ACH_ID_Internal (Profile Lookup)
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Click next to review your records.  If there are no exceptions, simply complete
the Import Wizard

Working with missing profiles

If you imported a transaction, but didn't yet create a profile for the Vendor (or
Client or Employee), the transaction will not be imported.

At this point you can either:
--continue importing the file without the record - and add the record later, or
--stop the import, create the profile - and then re-import the file

Unimportable Records reports

If you have automated the process, or would simply like to review your records
which were not imported, select the View tab > All Reports > Unimportable
Records.
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Remember:  the 'Unimportable Records' report contains all unimportable
records (blank rows, headers, etc.), not just those 'Not on File'.

Tip - There is an 'Unimportable Records - Last Import' report which is a bit of a
time saver.

1.3.9 IAT - International Transactions

IAT - International Transactions

You can import data files to create IAT transactions--just like any other type of
transaction.

Requirements:

Knowledge of IAT

The IAT format is a fairly complex format compared to our other formats, such
as CCD and PPD.  
For example, instead of four required fields for CCD and PPD (Name, Amount,
ABA/Routing and Account number), there are over forty different fields required
by IAT!

If you are not familiar with the complexities of IAT, we recommend that you use
our Add a Record interface which can walk you through the process.
Unfortunately, Treasury Software is not structured to provide training in IAT,
only in the use of our software.

Map all fields!

All fields noted below are required to be mapped - even if they are empty
(blank), or of $0.00 amount.
Failure to import all of the fields may result in the inability of ACH Universal to
create a proper transaction; while other omissions may allow the transaction to
be created, but ultimately the file may be rejected by the NACHA network.
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Tip: Use the mapping template International - IAT

We have pre-mapped the fields to match the template supplied with the Excel
file 'International - IAT.xls'.
Of course, you can certainly map your own template.

Mapping Fields

Below are screen shots of the fields as shown in the Sample account, along
with Sample data.
We recommend using the file below as a template (included with ACH
Universal):
C:\Users\Public\Treasury Software\Tutorial\ACHData\International - IAT.xls

Note: The data samples below indicate the range of data that can be imported.
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Field references

Field Name Sample
Data

Description of data

Date 9/18/2009 Date format
Name Joe Worker Alphanumeric

Amount ($1,983.34) Numeric/currency. Use standard sign protocols
(positive DR; negative CR)

Receiver_ID_Number Emp#8763 Alphanumeric

Originator_Name Hershey
USA

Alphanumeric

Originator_Street 4567 Kiss
St.

Alphanumeric

Originator_City Hershey Alphanumeric

Originator_State PA Alphanumeric

Foreign_Exchange_Indicator FF Acceptable 2 position values: 'FF' (Fixed-Fixed); 
'FV' (Fixed-Faviable);  or 'VF' (Variable-Fixed)

Originator_Status_Govt_Bank_TF FALSE Acceptable values: 'True' (Gov't entity) or
'False' (Bank or anyone else)

Foreign_Exchange_Rate Alphanumeric. Note:  This is a nickname for ease
of use, as the actual field is named Foreign
Exchange Reference.

Foreign_Amount $0.00 Numeric/currency
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Originating_Currency USD Alphanumeric - must be valid abbreviation

Foreign_Exchange_Reference_Indi
cator

3 Acceptable values (one digit): '1' (Foreign
Exchange Rate); '2' (Foreign Exchange Reference
Number); or '3' (Space).  Describes content of
Foreign_Exchange_Rate field. Tip: If Foreign
Exchange Indicator is FF, then this entry should be
'3' (space filled).

Outbound_Inbound_TF 0 Acceptable values (one-digit): '0' (zero -
Outbound - originates in US); '1' (inbound -
originates from international). Note: Do not
confuse the origination with the cash DR/CR flow.

Receiver_Currency USD Alphanumeric - must be valid abbreviation

RDFI_ABA 81519361 Numeric

RDFI_Account 88776699 Numeric

Company_Entry_Description Payroll Alphanumeric

SEC_Code IAT Alphanumeric - must be valid abbreviation

Originator_Country US Alphanumeric

Originator_Zip 17033 Alphanumeric

Originator_ID_Number 227777777 Numeric

OFAC_Screening_Gateway  All users - leave blank unless specifically
instructed. (For Gateway operators '0' indicates  a
blocked party has not been found.  '1' Indicates a
blocked party)

OFAC_Screening_Secondary  All users - leave blank unless specifically
instructed. (For Gateway operators '0' indicates  a
blocked party has not been found.  '1' Indicates a
blocked party)

Foreign_Trace Batch#2393 Alphanumeric

Transaction_Type_Code SAL Alphanumeric

Remittance Alphanumeric.  Free form text that is inserted into
the '17' records, a.k.a Remittance Information.

Receiver_Street 7654 Oak
Dr

Alphanumeric

Receiver_City Jericho Alphanumeric

Receiver_State NY Alphanumeric

Receiver_Country US Alphanumeric

Receiver_Zip 11753 Alphanumeric

ODFI_Name Bank of
Hershey

Alphanumeric

ODFI_US_Foreign_TF 02 Acceptable values (two-digit): '01' US; '02' Foreign

ODFI_ABA 063000047 Alphanumeric

ODFI_Branch_Country_Code US Alphanumeric - must be valid abbreviation

RDFI_Name Bank of
Jericho

Alphanumeric

RDFI_US_Foreign_TF 01 Acceptable values (two-digit): '01' US; '02' Foreign

RDFI_Branch_Country_Code US Alphanumeric - must be valid abbreviation

Gateway_Operator 223092390 Numeric
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1.4 File Creation and Transmission

Creating an ACH file

After transactions have been imported, from the Home Page, click on the 'Go
To Create ACH File Page' icon.

The Create ACH File screen (below) will be displayed.
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The top pane will list the file transmission method.  After creation, ACH
Universal will use this method to transmit the file to your bank.  In this case,
Web Upload is the selected method.  For more information on transmission
methods, see Transmission Methods.  Also, you will see listed the archive
location, or the absolute path on your local system where the created ACH file
will be saved.

The bottom pane contains a table showing a summary of all imported data, and
is stored for later use as part of the audit trail in the 'Transmission Logs' report.
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To create and transmit
the file, click 

A dialog box will appear asking if you wish to view the created file. Click Yes to
view the file. Note: You can always view the file later.

The file creation and transmission is now complete.

1.4.1 Balanced Files - Offsetting Records

Balanced Files - Offsetting Records

Typically, an ACH file contains only the transactions that you specify.

Example: If you have to pay five contractors each $1,000, the file will contain the
five 'Credit' transactions - one for each payment.  Your bank knows to debit
your account for the offset, which in this case would be $5,000.

If your bank requires an offset record

In the above example, if a bank did require an offset record (also known as a
'balanced file'), then the file would contain the five transaction records (Credits)
PLUS an additional record for a $5,000 debit.

To enable balanced files (offsetting records), from the top menu select the
'Settings' tab > 'ACH Setup' and proceed to the 4th screen (by going to the
Advanced section).
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Check the box and enter your settings, and complete the wizard.

1.4.2 Prenotification

Pre-notification

Due to the sensitive nature of electronic transfers, it is important to ensure that
both your organization and your bank are set up to receive and process ACH
files properly.  A pre-notification is a zero-dollar transaction that is transmitted
and processed to ensure you have the proper information for your bank for
transmission and processing, as well as having the proper information for the
other party.  In other words, a pre-notification is a test transaction sent before
the transmission of live data.

Creating a Pre-notification

When importing transactions as a file, ACH Universal will treat all zero-dollar
amounts as pre-notifications.  It will create a debit or credit pre-notification
based on your default selection during Account Setup.  It is important to create
one pre-notification for debits and one pre-notification for credits.
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File Level Import

In creating a pre-notification, you can import or enter all transactions as you
normally would.  

During transmission, on the 'Transmit to Bank' screen you will see the number
of pre-notifications listed in the summary information in the "Pre-Note" column.  

Manually Entered Pre-notification

Similar to transactions, a pre-notification can also be entered manually. 

From the Home screen select 'Add A Record'.
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Fill out all fields exactly as you would for a dollar transaction, except the amount
must be $0.00.  Click OK.  A dialog box will be displayed to confirm that you
intended to create a pre-notification.  (This is to verify that the amount was
intended to be zero and was not left blank unintentionally).  Click Yes to create
the pre-notification.

You can import or enter all other types of transactions as you normally would.  

During transmission, on the 'Transmit to Bank' screen you will see the number
of pre-notifications listed in the summary information in the 'Pre-Note' column.  

1.4.3 Recurring Transactions

Recurring Transactions 

Recurring Transactions are those transactions which you may want to use over
and over again. To begin, make sure you have entered in your Profile
information manually, or have imported Profiles from an Excel or CSV file.
Please visit Profiles for more information on creating Profiles. 

Set up
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After you have created your Profiles, from the main menu in Treasury Software,
select the 'Profiles' tab > 'View /Edit'.
Select a Customer, Employee or Vendor that you want to create a recurring
transaction for (row should be highlighted in blue) and then click Edit Record.

Click on the 'Recurring Transactions' tab.
Enter the Amount and indicate whether a Debit or Credit.
If you're not using Groups, you can click Save now.
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Groups for recurring transactions

We highly recommend using Groups for recurring transactions.  This enables
you to batch and process multiple transactions at a time.

For example, a number of credit unions use this feature to collect payments
from their clients.  Some payments are due on the 1st of the month, others the
2nd of the month, and so on.

Below, as an example, are some transactions that are recurring each month. 
Note that each has been assigned to a Group.

Click Profiles > Recurring.
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How to batch and process all records in a group

Click on the down arrow key and select the Groups/filter you want to create
transactions for.
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A confirmation window will display telling you the number of transactions that
will recur and the total amount to process. Click OK.
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An additional pop-up window will show and click OK.

Finally go to the home page of Treasury Software under your account and click
on the Create ACH File icon.
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Setting up Groups

When you're editing the Customer, Employee or Vendor record, you can enter
the Group in the lower left corner.
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Tip:  Refresh if you don't see the Group name

Click Save when you're done.

1.4.4 Addenda Records (CCD+, PPD+)

Addenda Records

We help you create:

--Tax payments in the TXP10 format, and in any format 
Includes Federal, State and local taxes such as cigarette, liquor, lottery and
excise taxes.
TXP*651122334*94105*120901*1*300000*2*104400*3*430000*34
35\   (941 Federal Payroll)
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TXP*651122334*0108M*120901*1*T*23900******YOURCO*120901*
3435\ (State Excise Tax)

--Child support in DED/CS formats
DED*CS*FD146*110204*54789*6576562134*N*DOE, JOHN*28001\
 (State child support)

--Private sector (vendor) payments in RMR, or any format
RMR*IV*8045551212**34563\  (Telecommunications payment)
656876532*34563\    (Simple account number with payment)

How to create an Addenda Record

1. If you already created the field, simply import the addenda information
with your data

2. If you don't have the data, ACH Universal can create the addenda
record for you.
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In all profiles (i.e., Vendor and Government Agencies), you can enter the layout
of the specified format (below).
See Tax Payments (TXP)  for detailed information on TXP and Vendor
payments.

3. Need to create a CTX file with multiple addenda records?

See CTX on how to create EDI in an 820 transaction set using our embedded
EDI engine.

1.4.5 Reversals

Reversals

A reversal is used to correct an erroneous transmission.  Per NACHA rules, the
exact amount of the erroneous transaction must be reversed. A second
transaction must then be originated for the correct amount.  
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Important

Reverse the entire original transaction and resubmit the correct transaction.  Do
not reverse an amount to make the 'net' correct.  

I. Creating a reversal - the easy method

From the Home tab select Create Reversals.

Select the records, and then from the Reports sub-menu Actions > Reverse.

II. Creating a reversal manually - for entries not originated in ACH
Universal

Only use this method if the original entry was not made from ACH Universal.
If the original entry was made in ACH Universal, use the 'Easy Method' above. 
It much less error prone.

1. From the Home Page, select 'Add a Record' to display the Add a Record
screen.

2. Fill out the screen exactly as the original entry has it, except for the
debit/credit selection and date.
Enter the opposite debit/credit type as the original transaction.  If the erroneous
transaction was submitted as a debit, you must create the reversal as a credit
and vice-versa. 
The date will be the new transaction date (not the original entry).
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3. Click the 'Reversal' link at the bottom of the page.  This will display the
check-box below.  Leave the check-box 'checked', and click 'OK' to save the
transaction.

III. Import a file

If you want to import, prepare an import file as you would normally do, however,
reverse the amount sign.  If you originally had positive amounts, use negative
amounts (yes, you may remap using Amount_Reverse_Sign).
In the 'Select a file' screen, in the lower left corner, there will be a check-box
titled 'Reversal'.  Check this box.
The only function of this check-box is to enter the word 'REVERSAL' in the
appropriate location within the ACH file.
Remember: You must reverse the sign of the transaction yourself in this option.

Notes:

--You may edit a reversing transaction prior to transmission, just as you would
any other transaction, however, you may not change the status of a transaction
from reversing to regular or vice versa.

--The reversal process simply creates a transaction.  Follow your normal
procedures for creating and transmitting an ACH file.
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--Treasury Software does not warrant the viability of any return that you create
as to whether it is within the acceptable date range or other conditions set by
NACHA.

1.4.6 Transmission Methods

Transmission Methods

There are six choices available as transmission methods. See Changing File
Transmission Method to learn how to change methods.

The method you use is based primarily on how your bank requires the file to be
transmitted and, secondarily, on your company's policies regarding electronic
fund transfers.
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Methods

None The ACH file will be created and archived, but it will not be
transmitted.  You must transmit the file to the bank manually.

FTP After creation, ACH Universal will transmit the file to the FTP server
you specify.  This should be your bank's FTP server.  Contact your
bank for information on their requirements. 

SSH-
FTP

After creation, your file is created and Treasury Software can
automatically transmit your file via SSH to your bank. 

Web
Upload

After creation, your default Internet browser will be started to a
specified web page that corresponds to your bank's upload portal. 
Upload the created file.
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Email ACH Universal will email the created file as an attachment to the
email addresses specified.  This method is not recommended as it is
unsecured.

Other For backward compatibility only.  Used to transmit the file using
modem commands.

By default, ACH Universal will use Web Upload and load a generic page on the
Treasury Software website, reminding you to upload the file in your bank's
website.  See Changing File Transmission Method to set up the transmission
method as required by your bank.

1.4.7 Email notification - file level

Email Notification - File Level

Follow the steps below to enable email notifications of all ACH file
transmissions to other personnel in your organization.  If you wish to set up
notifications for your customers, employees, or vendors, see Notifying
Customers, Employees, and Vendors.

Note: You may need to configure your firewall to allow email to be sent through
TreasurySoftware_email.exe.  Contact your system administrator regarding this
issue.

From the Home tab select Email > Email Setup.  The necessary information
can be obtained through your mail client (for example, Outlook) or by contacting
your system administrator.  Information in the Email tab lists addresses to
receive the created ACH file.  Information in the Notification tab lists addresses
who should receive notification of a transmission, but not a copy of the actual
file.

Advanced Setup (not using Outlook integration)

Select the Email tab.  You will see below.
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In the To: and CC: fields, enter the email addresses of your organization's
personnel you wish to receive notifications.  Enter your email address into the
From: field.  To send a notification to yourself, leave the check-box enabled.

Enter a suitable subject to use for all notifications in the Subject field.  The
transmitted file will be given the name in the New File Name textbox.  Enter a
file name you wish to use.  

In Mail Server, enter your company's email server.  For example,
smtp.mailserver.com  

Click the Email Advanced tab to display the the advanced mail server settings
screen (Figure 2 below). 
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Figure 2 - Email Advanced tab

Enter the appropriate settings into the fields above.  

When finished, return to the Email tab and click the Test link.  This will generate
a test email using the entered settings.  If entered correctly, a test email will be
sent to the email address listed in the To: field.  If entered incorrectly, you will
be alerted to a problem in the transmission.  Please ensure all settings are
correct as notifications will be not usable. 

Click Close to complete notification setup.  These settings will now be used to
notify the listed personnel of all file transmissions.

1.4.8 File encryption AES

File Encryption - AES 256

ACH has the capability to secure files with AES 256 encryption.  

This feature:
--is compatible with WinZip.  Therefore, your bank can decrypt using WinZip
(assuming you supply them with the password).
--can be used for any file, not just for ACH files.  Feel free to secure any
communication file.
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To access this feature from the Settings tab > Encrypt ACH File.

Encrypting files - one-time setup

Click Encrypt files > Defaults to enter your default password.  This is the
password that you will need to provide to your bank.
In addition, you may select an encryption strength.  Unless contra-indicated, we
would recommend maximum (256)
Click Save.
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Select a file from the browse button.  
Leave the 'Use defaults' checked to apply your default password from the prior
screen. 

Click Encrypt to process.
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ACH Universal leaves the original file (in this case a text file) untouched, and
creates a password encrypted zip file.

Decrypting files - one-time setup

Most ACH Universal users will never use the decryption process, as this was
intended to be used by banks and anyone else receiving your files.
The good news is, if you do need to decrypt a file, you have the tools.
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Then, select a file to decrypt and select 'Decrypt'.
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ACH Universal will leave the encrypted zip file untouched, and extract out the
file(s).

1.4.9 Consolidation/Summary of Records

Consolidation/Summary of Records

This feature enables you to import detailed information and summarize it for
payments, as well as email (if needed).

Your detailed data from your accounting system:

Will be paid in summary as:

In addition, if you are sending emails, we will send one consolidated email
with the check stub information as below:
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To enable this feature:

From within the Settings tab > ACH Setup > Panel 7 > Advanced tab > General
tab.  Finish the wizard to save your updates.
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How it works:

1. Import and manually add records.

When importing, remember to import your remittance information mapped as
the ID_Number and ACH_Text_Addenda fields (although you do not need to
use both fields).
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2. After you import/add records (Step #1), but before you create the ACH
files (Step #3),
the system will display the records as detailed.

If you run reports, you will see the detail as usual.
If you were to send emails (prior to step #3 below), an email would be created
for each individual transaction.  Therefore, using the example on this page -
Staples would receive 3 emails and Verizon would receive 4.

3. Create the ACH File    ****It is at this point that the records are
consolidated****

During the ACH file creation process, the system will create summary records
by grouping the untransmitted records based on the banking information (ABA
and Account number) of each record, as well as all batching rules (payment
date, etc.).

The newly-created summary records will contain the check stub information
from the detailed records.  This will include data from the following fields:
--Amount
--ID Number
--ACH_Text_Addenda

If you were to send emails at this time, a summary email would be sent.  Using
the example on this page, Staples and Verizon would each receive one email
showing the check stub information.

You can run reports, such as the Transmittal Log report, and view either
detailed or consolidated information.

Notes:

--ACH Universal Corporate or Processor edition is required for
Consolidation/Summary of Records
--Use with SEC codes of PPD and CCD only
--Turn off ACH Universal encryption
--Not for use with QuickBooks, as ACH Universal already has a check stub
feature within the QuickBooks Integration module.
--The ACH file contains the payment summary amount, but not does not contain
the remittance (check stub) information, as the ACH/NACHA file does not have
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any fields to accommodate it.  The remittance (check stub) information is
included by default in the check stub information of the email.  If you are using a
third party report writer and our SQL Server platform, this information is also
available in the 'Memo-Field'.

1.4.10 Security / Login record

Security (Login) Records

Several large banks, such as JP Morgan Chase and Wells Fargo, require an
additional security record within the ACH file.

Your login record may look like:
$$ADD ID=ABCDEFGH BID='COMPANY ARP INPUT FILE'
or
LOGDX ......

To enter your security record, select from the main menu: 
Select the Settings tab > Transmission Options > Local File. 

Enter the information in the field as below, and then click 'Close'.
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1.4.11 General Ledger and Loan Records

General Ledger and Loan Records
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This is for users who need to create Financial Institution General Ledger
records with a transaction code of 41 - 49, and Loan Account records with
transaction codes of 51 - 56.

Note: These codes are typically used internally within financial institutions and
their processing partners, and should not be used unless specifically
requested.

Just as there are multiple ways to import and manually add transactions into
ACH Universal, there are just as many ways to indicate their Transaction Code.
 The methods below are not mutually exclusive and you can use any one or
combination of methods.

You may create transactions with:
-Manual Addition
-Profile Storage
-Importing
-QuickBooks Integration
-Recurring and Quick Pay transactions
-Importing Profile Information

Manual addition

If you want to manually enter in a record, from within the Home tab select 'Add
a Record'.

By selecting from the drop down list, the system will auto-select between 42/47
and 52/55.  If you wish another code in the 40 or 50 series, you may key it in
directly into the drop down list.
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Profile Storage

If you are using Profiles, you may enter the G/L or Loan category from the drop
down list.  The system will auto-select between 42/47 and 52/55 for debits vs.
credits.
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Importing

Map the field containing your two digit transaction codes as
'ACH_Transaction_Code'.
Note: Remember that your Amount field should be positive amounts, as the
sign designated by the Transaction Code will determine whether it is a debit or
credit.

QuickBooks Integration

From within QuickBooks, navigate to the Vendor, Employee or Customer
Profile that you want to to be General Ledger (40 series) or Loan (50 series).
In the CHK/SAV field, enter in either a 40 or 50.  The system will auto-select
between 42/47 and 52/55 for debits vs. credits.
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Recurring and Quick Pay transactions

As ACH Universal pulls the underlying banking information from the Profile,
these transactions will be compatible for 40 series and 50 series transactions
as well.

Importing Profile Information

When you are importing Profiles, you can specify the Profile type:

Type Allowable values (not case sensitive)
Checking c, chk, checking, checkings, 0
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Savings s, sav, saving, savings, 1
General ledger genledger, gl, g/l, g, 40
Loan loan, loans, l (letter L), 50

1.4.12 Separate Batches DR vs. CR

Separate Batches DR vs. CR

ACH Universal handles batching in accordance with all NACHA requirements.

In addition, some banks have some additional requirements, and that is the
separation of Debits from Credits in their batches.

To separate out debits and credits, simply enable the feature within ACH Setup
(Settings tab > ACH Setup).  
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Upon starting ACH Setup, proceed to screen 5, enable the feature and
complete the wizard.

Notes:
--The separation of Debits and Credits is inherently contra-indicated with the
use of balanced records, as a balanced batch will always create an offset
debit/credit record.
--Pre-notification ($0.00) entries are not covered by this feature.  Therefore
simply process pre-notes separately to create separate batches.

1.4.13 SSH - SFTP

Use SSH-SFTP to automatically transmit a file to your bank. 
Here's how to set it up.

What is SSH (Secure Shell)?
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File Transfer Protocol (FTP) enables the automated transmission of a file over
the Internet.  However, FTP by itself offers no encryption.
By adding SSH, we encrypt the tunnel between the two computers, making it a
secure transmission.

Next steps:
1. Create your Public and Private keys (if you don't have any).
2. Exchange Public keys with your bank:  You will send them your Public key. 
They will send you their Public key.
3. Complete the SSH setup in Treasury Software.

All SSH functions, including key creation and setup - can be accessed from
Settings > Transmission Options > Transmission Method > SSH Settings (see
below).
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While our SSH file transmission tool enables you to work with the majority of
banks, we cannot guarantee compatibility with every bank.  If your bank has
unique requirements, we recommend using an FTP client, such as Ipswitch's
WS_FTP.

Note: SSH requires either a Corporate or Processor level ACH Universal
license.

1.4.13.1 Create SSH Keys

SSH Public and Private Key creation

If you do not have keys, please follow the instructions on this page to create
keys.
If you already have keys, skip this page.

Key Creation with PuTTY

While there are many key creation tools, the most common is PuTTY.  

For your convenience, a copy of the PuTTY generation tool has been included
with Treasury Software.

Notes: 
--If you installed prior to build 347, download from
http://www.treasurysoftware.com/setup/puttygen.exe
--The example below illustrates the use of PuTTY, but you may use any tool you
wish.

To access the copy of PuTTY already on your computer, click Settings >
Transmission Options > Transmission Method > SSH Settings (see below).

https://www.ipswitch.com/ftp-client
https://www.ipswitch.com/ftp-client
http://www.treasurysoftware.com/setup/puttygen.exe
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This will start the SSH Wizard

Click on "I need to generate a Private and Public key".



115

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

This will now start PuTTY

Click on Generate.
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Follow the prompt to move the mouse.
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Congratulations.

Please backup your keys.

Send your PUB (public) key to your bank.
Save your PEM (private) key for use with Treasury Software.
Note:  You will also need your bank's PUB (public) key to begin transmission.

While our SSH file transmission tool enables you to work with the majority of
banks, we cannot guarantee compatibility with every bank.  If your bank has
unique requirements, we recommend using an FTP client, such as Ipswitch's
WS_FTP.

Note: SSH requires either a Corporate or Processor level ACH Universal
license.

https://www.ipswitch.com/ftp-client
https://www.ipswitch.com/ftp-client
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1.4.13.2 SSH Setup

SSH Setup

This page will show you how to configure the SSH transmission.

Note: You will need your Private key and your Bank's Public key to complete
this setup.

To access SSH setup, click Settings > Transmission Options > Transmission
Method > SSH Settings (see below).
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This will start the SSH Wizard.  Click Next.

Enter your settings as needed.
You can click on 'Test Connection' to test your work.

Notes:
--If the User ID appears to be an email address, check with your bank.
For example if they send you jjones@yourbank.com they may only want you to
enter jjones as the User ID.
They may want you to leave off the bank domain name (i.e., yourbank.com).
--If your bank has specified a remote folder, type it in on 'Remote Folder'--
otherwise leave blank.

When finished, click 'Finish'.

mailto:jjones@yourbank.com
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Reminder - Don't forget to turn 'On' SSH - by selecting SSH.
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While our SSH file transmission tool enables you to work with the majority of
banks, we cannot guarantee compatibility with every bank.  If your bank has
unique requirements, we recommend using an FTP client, such as Ipswitch's
WS_FTP.

Note: SSH requires either a Corporate or Processor level ACH Universal
license.

1.4.14 Tax Payments (TXP)

Tax (TXP) Payments and Addenda Records

https://www.ipswitch.com/ftp-client
https://www.ipswitch.com/ftp-client
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Paying taxes is easy.  However, sending the remittance information, so you (or
your client) gets credit is the tricky part.

ACH Universal creates the Addenda records, also called the '7' or TXP record.
This is commonly referred to as a CCD+ transaction.

We help you create:

--Tax payments in the TXP10 format, and in any format
Includes Federal, State and local taxes such as cigarette, liquor, lottery and
excise taxes.
TXP*651122334*94105*120901*1*300000*2*104400*3*430000*34
35\ (941 Federal Payroll)
TXP*651122334*0108M*120901*1*T*23900******YOURCO*120901*
3435\ (State Excise Tax)

--Child support in DED/CS formats
DED*CS*FD146*110204*54789*6576562134*N*DOE, JOHN*28001\
 (State child support)

--Private sector payments in RMR, or any format.
RMR*IV*8045551212**34563\  (Telecommunications payment)
656876532*34563    (Simple account number with payment)

Please note that Addenda record creation requires either ACH Universal
Corporate or Processor edition.

1.4.14.1 Overview

Tax Payments (TXP) - Overview

1. Setup a Tax profile for each agency you want to pay.

Profiles tab > select Add.

Paying a vendor?  From the Profiles tab > select Add.
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Enter the payment information as you normally would.

Note: When adding a Government Agency, rather than a Vendor profile, ACH
Universal will auto-populate as CCD.

Turn on and enter the addenda format.

This will be covered in great detail in the next few pages.  Save your work when
complete.
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2. How can I create transactions?  There are several options.

a. Manually add a payment

Note: If you used tags for the tax period ending date or verification numbers,
these fields will be available to you here.
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b. Use Quick Pay and Recurring

You can use the Quick Pay and Recurring entries windows for any payment that
has an Addenda record.  Please note that, by definition, these windows are
batch oriented and do not provide fields to populate period ending dates, etc.  If
you require these fields, use the 'Add a Record' form.

c. Import transactions using 'Profiles'

Import as you would any other Profile-based vendor.
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1.4.14.2 Formatting the Addenda Record

Formatting the Addenda Record

To enter the Addenda format, you will need to open a Profile--whether a
governmental agency or Vendor profile--the processes are identical.  For
brevity, we will assume tax payments for agencies.

Either:
--Create a profile from the Profile tab  or
--Open an existing Profile from the main menu   
Edit/Add > Profiles - TXP Gov't Agencies > Edit/Listing > select the profile, and
click 'Edit Record' on the sub-menu

Click on the tab 'Addenda Records - Child Support, Invoices and Tax Payments
(TXP)', and then check the check-box to activate this feature.
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1. Deciding what is Static vs. Dynamic text in the Addenda record

Review the requirements of your vendor or governmental agency and decide
what is static text and what text changes on each transaction.
For example, the format may call for   TXP*tax payer ID*Amount\

If you are only paying the agency on behalf of one taxpayer, the taxpayer ID is
static.  In this example, everything prior to the amount would be static.

a. Enter static text

If your taxpayer ID is 651122334, you would type in the static part of the
addenda line, which (so far) would look like:
TXP*651122334*T*\

b. Add tags for dynamic text

As the amount will vary on each transaction, insert the tag (including the
brackets) for Amount:
TXP*651122334*T*[Amount]\
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Note: The brackets are required, although the tag itself is case-insensitive.

c. What not to enter

ACH Universal will automatically take care of the leading '705', as well as any
spaces and trace numbers following the Addenda record.

Save your work, by clicking 'Save.

1.4.14.3 Additional tags/fields

Additional Tags / Fields

With the fields below, you can create any TXP10 Federal or State addenda
record, as well as virtually any vendor specified format.

Overview

While the [Amount] tag is certainly the most commonly used tag, the other two
most commonly used tags include:

[Period_Date] - Signifies the period ending date of the tax period to which the
payment applies.  Tip: Federal is always the 1st of the month.  The default
format is YYMMDD, and it can be changed on a profile by profile basis.

[Verification] - The Verification field is typically the 10th field in a TXP10
format (verification, issue or receipt number), but is an excellent alphanumeric
field to use whenever user input is needed in State and Local taxes (not needed
in Federal forms).  

All tags:
Tag/Field (in
profiles)

Description Source

[Amount] Amount, no decimal From transaction
[Amount_with_dec
imal]

Amount, with decimal From transaction
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Tag/Field (in
profiles)

Description Source

[Date_Transaction
]

Transaction date From transaction

[Period_Date] Tax Period Ending
Date

Can be added at Add a
Record & Imported

[Verification] Used as TXP10, or
misc field

Can be added at Add a
Record & Imported

[Tax_TXP5_SS] Any TXP5 field, and for
Fed 941

Can be added at Add a
Record & Imported

[Tax_TXP7_Med] Any TXP7 field, and for
Fed 941

Can be added at Add a
Record & Imported

[Tax_TXP9_WH] Any TXP9 field, and for
Fed 941

Can be added at Add a
Record & Imported

[Name_Multiple] Tax payer - Name
(multiple)

Imported

[ID_Multiple] Tax payer - ID
(multiple)

Imported

Tag Sources

1. From transaction

This information will be pulled from the transaction.

2. Can be added at 'Add a Record'
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3. Imported

You can import these fields with the following mappings:
Tag/Field Import Mapping
[Period_Date] TAX_PeriodEndDate
[Verification] TAX_Verification
[Tax_TXP5_SS] Amount_TXP05_TXP
[Tax_TXP7_Me
d]

Amount_TXP07_TXP

[Tax_TXP9_WH
]

Amount_TXP09_TXP

[Name_Multiple]TAX_TaxpayerName
[ID_Multiple] TAX_TaxpayerID
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See TXP10 example (Fed 941)

1.4.14.4 TXP10 example (Fed 941)

TXP10 Example - Federal Form 941

As an example, the Federal Form 941 tax deposit (the taxpayer ID is
651122334)
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For those tags which can be added at 'Add a Record', these fields will be
available for you

Creates the addenda record:
705TXP*651122334*94105*120901*1*8400.1*2*2342.2*3*6840\
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If you want to import this information:

Notes:

Don't forget to substitute your taxpayer name and your Federal taxpayer ID
number into the ACH Entry Detail record (also known as the payment and '6'
record).   See Substitution into 6 Record.
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Reference for Federal forms:  Federal - EFTPS formats

1.4.14.5 6 record substitution

6 Record Names (Substitution)

Up until now, the Tax Payments section has dealt with the Addenda records,
which are also know as the '7' records.

However, Federal formats and many State formats require that the taxpayer
name and ID be placed in the payment ('6') record.

While this can be accomplished by simply entering in the name and ID number
of the taxpayer into the Vendor or Agency profile, it is overly simplistic, as you
would be limited to paying only one type of tax, for one entity.

How to enter in your tax payer name and number into the payment ('6')
record:

Typically, you would enter your name and taxpayer ID number into the fields
below by going to Profiles >Government Agencies / View/Edit.
If you are a processor, or paying on behalf of multiple entities, select the second
radio button and import the data.

http://www.treasurysoftware.com/ffedigui.pdf
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1.4.14.6 Child Support ACH Addenda

Child Support ACH Addenda

While there is no national standard format, many states use a format similar to
the Commonwealth of Virginia, which is shown below:
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The states require a CCD+, which is simply a CCD record with the + referring
to the Addenda record.

1. Create a Tax Profile for the Governmental Agency 

From the Profiles tab > select Add.

Enter the information for the agency as you normally would.

ACH Universal will auto-populate as CCD (CCD+ will be when the Addenda
record is created).



142

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

Click the addenda tab, and turn on (check) the 'Create an addenda record'
option.
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On the Child Support sub-tab, click the hyperlink 'Populate the entry above...'  
For most users, this is all you need to do.
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Note: If you will only be paying the state on behalf of one employee, you can
overwrite any of the variables and hard-code the Addenda record.
For example, you can update the template to pay on behalf of John Jones, with
a case identified of 12345678, and Social Security number of 333224444.

From (default template):
DED*CS*[Case_Identifier]*[Pay_Date]*[Amount]
*[Soc_Sec_Num_NonCustodial]*[Medical_Support_Ind]
*[Parent_Name_NonCustodial]*[FIPS]*[Employment_Termination_Ind]\
To:
DED*CS*12345678*[Pay_Date]*[Amount]*333224444]*[Medical_Support_Ind]
*Jones,John*[FIPS]*[Employment_Termination_Ind]\

Of course, if you are paying on behalf of multiple employees, leave the default.

Click Save when done.

2. Creating transactions
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Method I - Manually add a payment

In the New Record screen, select the Government Agency and enter in the
balance of the fields.  Click OK when finished.

Method II - Importing transactions
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a. Create a CSV or Excel file that looks similar to this:

b. Start the Import Transactions Wizard from the Home page and select the file
that you created.

At the mapping screen, map the fields in a manner similar:

Complete the Import Wizard.

When finished with importing or adding records, create the ACH file as normal.

Your file will include the Addenda records (7 records) and should look similar
to:
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Advanced Options

Advanced Option features require the Processor edition of ACH Universal.

Want the funds to come out of different bank accounts?

Use the Multiple Origination Accounts feature.

Want different taxpayer name and ID's in the payment (6) record?

Turn on the 'Substitution' feature in the Government Agency's profile.

Then, during the import process, you can map the TAX_TaxpayerName,
TAX_TaxpayerID fields (located in the Tax section of the dropdown mapping
list) as well as the Origination_Account field as needed.
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1.4.14.7 Legacy tax payments

1.4.14.7.1  Multiple Tax Payers

All features in this 'Legacy tax payments' section have
been discontinued.

Multiple Taypayers

Need to make payments on behalf of multiple taxpayers, but it is impractical to
create a profile for each one?

1. Create a profile for the state agency as you would for a single taxpayer
- and enter the banking information.
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2. Click to the Addenda tab.  Below is what our earlier example looks like
for a single taxpayer.
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We are going to change the addenda line (bold indicates changes)
FROM:
DED*CS*YS2324*[Period_Date]*[Amount]*065932314*N*Doe,
John*417300*N\

TO:
DED*CS*[Verification]*[Period_Date]*[Amount]*[ID_Multiple]
*N*[Name_Multiple]*417300*N\

and save.

Note: The Verification field is used as the 'Case Identifier'.

3. Then import your file, mapping the fields.

TAX_TaxPayerName and TAX_TaxpayerID
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Create and process the file as normal.

Note: You may still need to substitute the Tax Payer Name and ID on the '6'
record.  If so, please see '6 record substitution'.

1.4.14.7.2  Creating an Agency Profile

All features in this 'Legacy tax payments' section have
been discontinued.

Creating an Governmental Agency Profile (similar to a Vendor Profile)

There are two parts to paying taxes:
1. The actual payment
2. The remittance information (also called the addenda record or TXP record).

In this first step, we are going to address the actual payment.
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I. From the Profiles tab > select Add. 

This will prompt you with the form below.  Enter in the fields as indicated, and
confirm that 'Checking' and 'CCD' are selected.

Note: If you are paying taxes to the same agency on behalf of different Taxpayer
ID's (subsidiary, parent company, etc...) we recommend that you use an
internal or nickname for the Name and ID Number fields.  The system will
populate them with 'IRS', etc... as show in the next help topic.
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Congratulations - At this point, you have entered all the information needed to
make an ACH payment.

1.4.14.7.3  Creating a Tax Form

All features in this 'Legacy tax payments' section have
been discontinued.

Creating a Tax Form

Following from the previous help page, we are now displayed with a tax form.

Think of the tax form as a template, or if you've ever performed a mail-merge -
this is the letter.
You enter in the format that you want, as well as several constants.

Format tab
Below is a tax form for Federal payroll tax payments with Form 941.

While it looks like a lot, a number of the fields are pulled from the transactional
and profile information.

By reviewing the instructions for the Federal Form 941, we realize that we need
to make four entries, and enable two check boxes.  
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Whether a Federal or State agency, each piece of the addenda is labeled from
TXP01 to TXP10.  Fill out each field as required by the tax code:

TXP0
1

Taxpayer ID number.  This field is filled automatically during ACH file
creation based on the governmental agency profile.

TXP0
2

Tax code number

TXP0
3

Tax period end date format. For example, enter YYMMDD, not 090107 as
the specific date is filled in automatically for each payment.

TXP0
4

For most states, enter T. For most federal payments, enable the
checkbox labeled "Repeat from TXP02."  Consult your specification for
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exact requirement.
TXP0
5

If the tax only contains a single payment, this field is the transaction
amount. If the tax has subcategories, this is the amount for subcategory 1.
 

TXP0
6

Tax code subcategory.  Enter as specified by the tax code.  If using, must
enable "Use subcategory 2" checkbox.

TXP0
7

Subcategory transaction amount. Cannot edit this field.

TXP0
8

Tax code subcategory.  Enter as specified by the tax code.  If using, must
enable "Use subcategory 3" checkbox.

TXP0
9

Subcategory transaction amount. .

TXP1
0

Verification number used only for state tax codes (never used for Federal
tax payments).  This field will be automatically filled during ACH file
creation based on the governmental agency profile.

Please note that Treasury Software does not maintain a database or service for
any taxing authorities.

Settings tab
Now click on the Settings tab at the top of the form.

Note: The top section (Form Identification) does not carry over to the ACH file -
it is for your internal use only.
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When you are done, click 'OK' save your work and close the form.

Advanced
Question: Why do we need a Payment Profile (Gov't Agency) and a Tax
Form?  Why isn't the Tax Form just another tab on the Payment Profile?
Answer - Reuse.
You can use the same tax form for multiple profiles.  If you are responsible to
make tax payments under multiple tax payer ID's, you only need to create one
tax form, but can use it with an unlimited number of Profiles.
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1.4.14.7.4  Importing TXP transactions

All features in this 'Legacy tax payments' section have
been discontinued.

Importing TXP transactions

At this point, you should have already created a Governmental Agency Profile
(similar to a Vendor profile) and a Tax form.  You should have also tested the
addenda record by creating a manual transaction.

Creating the Excel or csv file
Your import file will need to have the name (or ID number) of the Governmental
Agency in one of the fields.  This is called the Profile Look-up field.
In addition, you will need to have at a minimum: the amount of the tax to be
paid, as well as tax period that it covers.

Examples
Enter into the Sample account within ACH Universal and select from the main
menu Import > Tax Payments (either)
You will see the location of the Excel file on your computer.  Please feel free to
use this as a template. 
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Mapping the imported file
We have mapped:
1. ACH_Name_Internal (Profile Lookup) - This matches the Gov't Agency
Profile.  Of course, if we used an ID number in the file, we would then have
used ACH_ID_Internal (Profile Lookup) 
2. Period_Ending_Date_TXP
3. Amount_Reverse_Sign - Of course, if the file contained negative signed
numbers, we could have mapped this as simply 'Amount'.  This represents the
total payment.
4. Social_Security_941_TXP - Specific to Federal Form 941
5. Medicare_941_TXP - Specific to Federal Form 941
6. Withholding_941_TXP - Specific to Federal Form 941
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This will enable you to create an ACH file with TXP transactions (technically a
CCD+ payment, with a TXP formatted addenda record):
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1.4.14.7.5  Completing the Agency Profile

All features in this 'Legacy tax payments' section have
been discontinued.

Overview

Upon closing the Tax form, you will be returned to the Gov't Agency Profile.

Click the Advanced tab. 

Review the information on the screen.  In almost all cases, taxing authorities
require taxing authority name and taxpayer ID be listed in the ACH detail
record.  Unless the tax format you are creating specifically states otherwise,
leave the defaults (of course, fill in the 'Name' field'). Your screen will resemble:
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Click Save.  The Govt' Agency profile will be saved.
1.4.14.7.6  Make a tax payment

All features in this 'Legacy tax payments' section have
been discontinued.

Make a manual tax payment

From the main menu select Add a Record to display the screen below.
Then select from the drop down list one of your Governmental Agency Profiles.



162

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

The form will then reset to accommodate the tax information, as well as
populate default fields:
All you need to do is enter the amounts and click 'OK'

Date notes:
The Date field on the 1st row is the effective date of the transaction (the date
you are going to pay), and will appear in the Batch Control/Header '5' record. 
The TXP_Date field on the 2nd row is the tax period that your payment applies
to and will appear in the addenda '7' record. The format is configurable in the
Tax Form.  Tip - the Federal format is YYMM01 (the date is always 01, the first
of the month).
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Advanced - Need to see or tweak the TXP (addenda) record manually?
After entering in your amounts, click on the 'Preview TXP' link to the left of the
OK button.

Click OK to save your work.

The next time that you create an ACH file, this transaction will be included.
1.4.14.7.7  Fiduciary Mode

All features in this 'Legacy tax payments' section have
been discontinued.

Fiduciary Mode (Requires Pro Plus or Trading Partner editions)

In the previous help pages, the TXP import centered around creating a
separate profile for each taxpayer ID.

However, what if you are a payroll processor or other fiduciary sending in
hundreds or thousands of tax payments?  

To create a profile for each taxpayer ID would be a logistic nightmare.
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The Fiduciary mode enables you to import the Tax Payer ID (TXP01),
Verification (TXP10) and the name and ID for the ACH payment record.   

Setup

1. Create a tax form and taxing authority profile.
From the main menu select Edit > Profiles - TXP Government Agencies > Add
new
Select the 'TXP - Tax payments start here' tab (see below), then click 'Add new
tax form'.

The New Tax form will be displayed.  For illustration purposes, we will mock up
a Kentucky State Withholding tax payment.
Addenda record requirements (mock-up):
Segment Identifier TXP
KY Revenue Account
Number

(different for each client)

Tax Type Code 02200
Tax Period End Date YYMMDD format
Payment Amount TypeT
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Payment Amount Amount
Terminator \

Only enter the 'constants'.  In this example we will enter for:
Tax Type Code
Payment Amount Type

Also, check the box to 'Repeat total payment'.

Then click the 'Settings' tab at the top, and enter the following fields as
highlighted:
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Notes: 
--The ABA and account numbers are the governmental agency's that you are
paying
--The 'substitute' checkboxes - here it does not matter whether checked or not,
as we will be over-riding the values - by importing the taxpayer's name and ID
into these fields. 

When done, click 'OK', to close and return to the Governmental Agency Profile
form.

Click the drop down list and select the newly created form.
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Click on the 'Advanced' sub-tab.  Make sure both check boxes are un-marked.
Note: These substitution check boxes are different then the ones we saw earlier
on the tax form.
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Select the 'General' tab and enter the Name and 'Save'.

The 'Name' should be the same value and match the text in your Excel/csv file
that you are importing.
This value will not appear within the ACH transaction or any file sent to the bank
or governmental agency.  
It is simply the 'link/lookup' value between your data and this profile.
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Click 'Save' to save the profile.

1.4.14.7.7.1  Importing and mapping data

1. Create an Excel or csv file with the following fields:
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2. From within Treasury Software, start the Import Wizard.
When prompted to map the fields, map as below:

Notes:
--Click on the 'Show all field selections' to display the fields.
--The verification field (TXP10) is not always used.  If it is not needed, do not
map it.
--If you do not have the Tax_Payer_Name_6_Record field in your drop down
list, map it as the Text16 field.  Then you will also need to substitute Text15 for
Tax_Payer_ID_6_Record.

--If you do not see the <<Processors-TXP>> section, you may not be licensed
at the correct edition
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Complete the import wizard as usual.
1.4.14.7.7.2  Creating and reviewing the file

Click Create file.

Your file will look similar to:

101 063000047165777777710030910088094101BANK OF ANY TOWN       ABC PAYROLL PROCESSING
00000000
5220ABC PAYROLL PROC                    1657777777CCDEPAY      100310100310  
1063000040000001
622063000047343205552        0000703654SEVEN SEAS IMPO248238184              
1063000040000150
705TXP*248238184*02200*100214*T*703654*****17709\                                 
00010000150
622063000047343205552        0000555986BOTTOM-DOLLAR M730888330              
1063000040000151
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705TXP*730888330*02200*100214*T*555986*****57960\                                 
00010000151
622063000047343205552        0000231437ERNST HANDEL   208441649              
1063000040000152
705TXP*208441649*02200*100214*T*231437*****90074\                                 
00010000152
622063000047343205552        0000695228SAVE-A-LOT MARK780873395              
1063000040000153
705TXP*780873395*02200*100214*T*695228*****34137\                                 
00010000153
622063000047343205552        0000791862HUNGRY COYOTE I860847885              
1063000040000154
705TXP*860847885*02200*100214*T*791862*****77583\                                 
00010000154
622063000047343205552        0000365262EASTERN CONNECT722887268              
1063000040000155
705TXP*722887268*02200*100214*T*365262*****18281\                                 
00010000155
622063000047343205552        0000068643RATTLESNAKE CAN549040602              
1063000040000156
705TXP*549040602*02200*100214*T*68643*****58390\                                  
00010000156
822000001400441000280000000000000000034120721657777777                        
063000040000001
9000001000002000000140044100028000000000000000003412072 

or

If we chose not to import the verification number
101 063000047165777777710030910139094101BANK OF ANY TOWN       ABC PAYROLL PROCESSING
00000000
5220ABC PAYROLL PROC                    1657777777CCDEPAY      100310100310  
1063000040000001
622063000047343205552        0000703654SEVEN SEAS IMPO248238184              
1063000040000157
705TXP*248238184*02200*100214*T*703654\                                           
00010000157
622063000047343205552        0000555986BOTTOM-DOLLAR M730888330              
1063000040000158
705TXP*730888330*02200*100214*T*555986\                                           
00010000158
622063000047343205552        0000231437ERNST HANDEL   208441649              
1063000040000159
705TXP*208441649*02200*100214*T*231437\                                           
00010000159
622063000047343205552        0000695228SAVE-A-LOT MARK780873395              
1063000040000160
705TXP*780873395*02200*100214*T*695228\                                           
00010000160
622063000047343205552        0000791862HUNGRY COYOTE I860847885              
1063000040000161
705TXP*860847885*02200*100214*T*791862\                                           
00010000161
622063000047343205552        0000365262EASTERN CONNECT722887268              
1063000040000162
705TXP*722887268*02200*100214*T*365262\                                           
00010000162
622063000047343205552        0000068643RATTLESNAKE CAN549040602              
1063000040000163
705TXP*549040602*02200*100214*T*68643\                                            
00010000163
822000001400441000280000000000000000034120721657777777                        
063000040000001
9000001000002000000140044100028000000000000000003412072                                  
    



173

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

Why is our client's name and ID number in the 6 records?
This is highly recommended by virtually all state taxing authorities.  Should
there be a transmission error at the state's location, this will aid them in
identifying the payment.
Note: We do not supply the client's name into the batch header - that is
reserved for your company - the payroll processor.

1.4.15 Returns

Returns

This section assumes that you are a bank customer and have submitted
transactions which have 'bounced' - or have been otherwise rejected.

If you are a bank and need to create a Returns file to send to your clients,
please see Banking Edition.

Returns vs. Reversals

A return is an entry that you made which could not be honored by the other
party's bank.

An example:
You attempt to collect funds from a customer, but there are not enough funds in
the customer's account. The transaction is returned to you as Insufficient Funds
(return code R01).

A reversal is an entry that you create, which is used to correct an earlier
erroneous transaction.

An example:
An employee left your company in February, but you neglected to remove the
person from the payroll system. In March you erroneously sent that employee a
direct deposit payment and immediately noticed the error.
To correct the erroneous payment, you would send a reversal entry to correct it.
For more on reversals.

What happens to the transaction returned and how are you notified?
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If you were paying 100 employees and one employee closed his account, only
the payment to the one account will be returned.  The other 99 transactions
would be fine.

How the bank notifies you depends on the services that your bank offers and
what you've signed up for.
Some small banks may call you, others may email or fax you, and others may
have you log into their website to see the postings.  Many will provide you with
an ACH Return file (below).

ACH Universal™ Corporate and Processor editions

The balance of this Help file focuses on utilizing ACH Universal™ Corporate
and Processor edition's features of importing and resubmitting return
transactions from an ACH Return file.

If you do not have the Corporate edition or higher, or you are not receiving an
ACH Return file, you will need to track and resubmit transactions manually.

ACH Return Files

The ACH Return file contains all the details of the transaction you originally
submitted, as well as detailed information as to why the transaction was unable
to be fulfilled.
The return code is noted with a 3 digit code starting with 'R'.

Some sample codes are:
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R01 Insufficient Funds
R02 Account closed

This file can be imported directly into ACH Universal™ and be used to track
and resubmit transactions, when applicable.

1.4.15.1 Working with ACH Return Files

Importing ACH Return Files

Importing ACH Return files enables you to track the returned transactions and,
if you choose, it will also allow you to resubmit the transactions.

Note: When ACH Return files are imported, the transactions are saved into a
separate 'Returns' table.  The records are placed into this table where they
await your action.  No action occurs during the import process, other than
populating this table.
  
From the Home tab select the ACH Return Files drop down box arrow.

Note: If you are unable to view the menu selection above, you do not have the
Corporate or Processor edition.  Please upgrade your ACH Universal edition to
use this feature.

This will start the Import Wizard.  Select the file and complete the Wizard as
you normally would.  

Return Reports

From the Home tab select ACH Return Files drop-down menu and then select
Review returned transactions and resubmit (default).
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Returns fall into one of two categories:

1. Eligible for resubmission (have a return code of R01 - Insufficient funds)
2. Ineligible for resubmission (have any other code)

If a record has been returned for Insufficient funds, you may resubmit the
transaction.
However, if a record has been returned for any other code, it is not eligible to
be resubmitted.

The logic is that if the account is closed, or there is a wrong ABA number--or
any other reason (other than ISF)--resubmitting the transaction will still result in
the transaction being returned.

Resubmitting transactions returned as Insufficient Funds (R01)

Select the transaction(s) and then click Resend.

These records will be placed into the Untransmitted ACH records holding
queue along with any other untransmitted records that you may have.
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When the record is eventually transmitted, the status is updated from
'Untransmitted' to 'Sent' with a resubmitted date.

1.4.16 CTX - EDI (Processor edition)

CTX - Corporate Trade Exchange

Note:  CTX requires ACH Universal's Processor edition

What is CTX?

CTX, or Corporate Trade Exchange, is a Standard Entry Class code that can
contain multiple addenda records which provide additional information on
each transaction (also called remittance information, such as invoice
numbering).

What is EDI?

EDI, or Electronic Data Interchange, is a set of standards governing the
structure of electronically-transferred information.  EDI provides the engine
that structures the transmission of CTX transactions.  EDI is standardized
under ANSI ASC X12.  There are multiple transaction sets available under
EDI, the most commonly used through ACH Universal being the EPN-STP
820 set.

Why use CTX?

The common SEC Codes, such as PPD and CCD, provide specific
transaction information.  However, they both lack the ability to use more than
one addenda record.  An addenda is an extension to a transaction entry that
provides additional information about the nature of the transaction, most
commonly remittance information.  One common example is an invoice
number.  PPD+ and CCD+ add the ability to use an addenda record, but you
are limited to at most one addenda record per transaction and a maximum
length of 80 characters.  If your organization wanted to make one payment for
multiple invoices and provide remittance information, there is no way to do so
using a non-CTX SEC Code.  
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CTX has a limit on the number of addenda records--9,999 per entry--but it is
so high as to be almost unapproachable in practice.  In addition, CTX
specifically defines the structure of the addenda records into segments.  This
provides ease of processing as well as flexibility in making your payments.

Using CTX in ACH Universal

The same processes used in ACH Universal for other SEC Codes are used to
create and transmit CTX files.  However, CTX has a few added requirements
that other codes are not subject to.

ACH Universal's Processor edition is different than earlier editions, because it
includes the ACH format 'CTX' - Corporate Trade Exchange.
 
The other formats you may already be familiar with are on a one-payment-to-
one-invoice scenario.  For example, an ACH-PPD entry containing an
employee's direct deposit payroll payment is a one-payment-to-one-paycheck
scenario.
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With ACH-CTX, you can pay hundreds of invoices from one payment. This is
a one-payment-to-many-invoices scenario.
 
The key here is not just the fact that you are paying multiple invoices, but that
you are including the remittance information as well.  CTX passes along the
detailed remittance information in the addenda records that follow the
payment records.
 
 
Addenda Records

PPD, CCD:

In other formats such as PPD and CCD, you can include one addenda record
to provide additional information about the payment.  When attaching the
addenda record, these payments are often referred to as PPD+ and CCD+
(plus sign for addenda).
 
These formats only allow one record, and the addenda record text is free form
- meaning there is no standard as to the syntax or layout (unless, of course,
one was agreed to by the originator and receiver).
 
CTX:

With CTX, you can have up to 9,999 addenda records, and the system
expects the records to be in an EDI format.
 
 
ACH Universal's EDI Engine

There are many EDI standards, each with its own derivatives, dialects and
subsets.
 
Treasury Software's built-in EDI engine supports the common business format
often referred to as the ANSI ASC 820 transaction set. Virtually all business
formats are a derivative or subset of this format. 

1.4.16.1 Account Creation

The first step in using ACH Universal is to create an account to hold your
imported data.  This applies to both CTX and non-CTX codes.  If you will be
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creating CTX as well as non-CTX files, it is recommended you use one account
for CTX-only transactions and one account for all other transactions.

Creating an Account

Create an account by selecting from the main menu File > New Account.

Format Selection

In the ACH Setup Wizard (lower left corner of ACH Universal), on screen 4 of 6,
you will see Figure 1 (below).  Select the radio button for CTX-EDI Subsets.  In
almost every situation you will use EPN STP 820.  Make sure it is visible in the
dropdown box.

Figure 1 - Account Setup

CTX Tab

On the final screen (Screen 6 of 6), select the CTX tab.  You will see Figure 3
(below).
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Figure 3 - Account Setup

In the first dropdown box, select the method your organization is using to
identify yourself at the transaction level.  This is decided by your bank. Your
choices are:

U.S. Federal
ID

Federal ID number

DUNS Dun and Bradstreet number

DUNS plus
suffix

Dun and Bradstreet number with a mutually-agreed upon suffix
string

Enter the ID number of the type selected into the textbox.

Leave the defaults for all other fields unless instructed differently by your bank.

1.4.16.2 Account Setup - CTX

Account Setup
From the Settings tab select 'ACH File Setup'.  
 
On screen 4 of 6, select the radio button 'CTX-EDI Subsets' and select from the pull down menu the
subset you want to work with.  If you are unsure of the subset, leave the default presented - you can
change it any time.
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On screen 6 of 6, select the 'CTX' tab and enter your Federal ID, DUNS, or other identifying number
as required by your Trading Partner (CTX receiver).  Again, if unsure, leave blank for now - you can
modify at any time.  Click 'Finish' to save your work and close the ACH Setup Wizard.
 
 
Setting up a Payee Profile 
From the main menu select 'Edit', 'Add/Edit Customers, Employees and Vendors'.  Click on the Plus
sign on the toolbar to add a new record.
 
Name:  Enter the name which will appear on your import file.  Example: If you are paying an office
supply company and their company name (which appears on each line item of the detailed report you
are using as an input file) is 'Office Depot', enter that here.
 
Account # and ABA routing number - Using our previous example, enter the office supply company's
information here.
 
ID number - This is for your records - enter your internal vendor number here.  Using our example, it
may be 'OfficeDepot001'.  Note: Very often, this entry is simply the same as the Name.
 
Checking or Saving - Leave as Checking unless instructed otherwise by your Trading Partner.
 
ID Type and Number - Enter as provided by your Trading Partner.
 
Origination - Leave blank.
 
Application - Select 'CTX - Create EDI' if it is not already displayed.
 
Click 'Save' to close the window and update your modifications.
 
 
 

1.4.16.3 Mapping - Basic

Prepare an import file with at least the following minimum fields:
--Vendor
--Amount/Paid
--Invoice Number
 

The fields that you prepare for your report are directly related to your Trading Partner's
requirements.  Additional fields such as purchase order, trace and adjustments will be covered in the
next topic Mapping CTX Files - Advanced
 
 
Importing and Mapping
Use the import wizard to import the file.  At the mapping screen, map the example above as:
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ACH_Name_Internal - You should already be familiar with - this populates the payees name in the
payment line, as well as provides as a 'look-up' field to the Customer, Employee and Vendor table.
 
Amount_Payment_RMR - Map your detailed invoice amounts using this field.
Note the last three letters of the field may indicate an EDI 'segment'.  This will be covered in the next
topic.  The RMR segment refers to the 'Remittance' segment.
 
Invoice_Number_RMR - Map your detailed invoice numbers using this field.
 
Continue with the Import Wizard until finished.  Afterwards, you can create and transmit the file, just
as you would any other ACH file.
 
 

1.4.16.4 Mapping - Advanced

Mapping CTX Files - Advanced
  
In addition to the information listed in the Mapping CTX Files - Basic topic, the addenda records can
contain the following detailed information.
 
The fields below relate to the detailed information you are importing and mapping.  In the EDI output,
you will see additional segments - these are header and footer records which are created
automatically by the system.
 
Notes:
--The CTX setup window referenced below can be accessed from the 'Settings' tab > 'ACH Setup'.  
--You do not need to map every field.  The fields below which have not already been mentioned in the
'Basic' section are used infrequently.
 
Fields:
 

Remittance Used to provide remittance information.  The
Invoice_Number_RMR and Amount_Payment_RMR are
always used.

Type_RMR Do not map unless otherwise instructed to.  Default is set
to 'IV' = Invoice. The default can be set on the CTX setup
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window to Invoice, Purchase Order or Accounts
Receivable Open item. If importing different types in the
same file, use the following two character abbreviations:
IV - Invoice
PO - Purchase Order
R7 - A/R Open Item
Notes:
--If you want to include both an invoice and purchase
order number, leave the default alone as invoice - and
use the reference section below as the purchase order.
--To specify a default not listed above, simply enter it in
the CTX setup window.

Invoice_Number_RMR Invoice number, or number as identified in Type_RMR

Amount_Payment_RMR Amount to be paid

Amount_Total_Invoice_RMR Used when the total invoice amount is different from the
amount paid.  Difference can be accounted for in either
an adjustment (example - back order, short shipment,
damaged goods), or from use of payment discount
(example 2% 10, net 30)

Amount_Discount_RMR Used to indicate amount taken as a prompt payment
discount (example 2% 10, net 30).  Do not use this field
to show other adjustments.

Reference Used when a purchase order (or other information)
number is supplied in addition to the invoice number in the
remittance segment.

Type_REF Default setting is 'PO', and can be updated on the CTX
setup window.
If importing different types in the same file, use the
following two character abbreviations:
PO - Purchase Order
R7 - A/R Open Item
BM - Bill of lading
VV  - Voucher
Note: To specify a default not listed above, simply enter it
in the CTX setup window.

PO_Number_REF Purchase order number, or number as identified in
Type_REF

PO_Description_REF Free form description.  As with all descriptions, do not
use an asterisk or backslash.

Trace Enables you to reference the transaction back to your
internal system.  An example would be a check number
to an accounts payable system

Trace_TRN Trace number (actually an alphanumeric field).
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Date/Time Used to specify the date of the information in the
remittance (RMR) tag.

Type_DTM Do not map unless otherwise instructed to.  Default is set
to '003' = Invoice. The default can be set on the CTX
setup window to Invoice, Purchase Order or Contract
Effective. If importing different types in the same file, use
the following three digit abbreviations:
003 - Invoice
004 - Purchase Order
092 - Contract Effective

Date_DTM Use local settings - US MM/DD/YYYY; UK
DD/MM/YYYY.

Adjustments Used to transmit payer-generated debit/credit memos.

Adjustment_Amount_ADX Amount.  Sign is stripped away and is determined by
'type' below.
Note: The following equation should be true - the system
will not alter your entries:
Amount_Payment_RMR = Amount_Total_Invoice_RMR - 
Amount_Discount_RMR +/- Adjustment_Amount_ADX

Adjustment_Type_ADX Two character code indicating debit or credit memo:
01 Pricing Error
03 Extension Error
04 Item not acceptable - Damaged
05 Item not acceptable - Quality
06 Quantity contested
07 Incorrect Product
11 Returns - Damaged
12 Returns - Quality
59 Item not received
75 Total order not received
81 Credit as agreed
CM Covered by credit memo

Adjustment_Description_ADX Alphanumeric description

Name

Name_Full_NM1 Individual or organization name.  Do not map unless
otherwise instructed to - as it can be duplicative of the N1
segment.
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1.4.16.5 Mapping - Without Profiles

Creating CTX files without using profiles (On-the-fly)

Depending on your scenario, you may not need to create a vendor profile for
each vendor.  

If your vendors will accept a standard format - you can create files 'on-the-fly' as
noted on this page.
If your vendors have specific requirements, you will need to use our profiles.

To create CTX files without creating any vendor profiles:
1. At the mapping wizard, instead of mapping a profile lookup, simply use
'Name'
2. Remember to map your vendor's routing number and Account numbers.
New:
3. Recommended - Also import your Vendor's ID # (typically a Fed ID) - and
map it is as Receivers_ID_Number (details below).

Reminder: The ABA, Account, Receiver ID (if used) and Receiver Qualifier (if
used) - need to be on each line for each vendor.  
If you don't have the ID number for a vendor - you can leave it blank,  but there
will be no ID in the CTX-EDI and you run the risk of it not be received by the
vendor.
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Tip: You can find the fields in the 'On-The-Fly-Only' grouping of the drop down
list. 

Advanced topic - Receiver's ID and Qualifiers
While a CTX file can be created without using the Receiver's ID (technically
called the Interchange Receiver ID - ISA08), we recommend that it be included.

When you map and import the ID, the system will assume that it is a Federal ID
- and enter the appropriate value (30 - indicates a Fed ID) as the type
(technically called the Interchange ID Qualifier - ISA07).

You do not need to include/map the Qualifier if all of your ID's are
Federal ID #'s.
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However, if you do need to map the Qualifier field, please use the following two
character values:
01 Duns (Dun & Bradstreet)
14 Duns Plus Suffix
17 ABA number
30 US Federal Tax Identification Number

1.4.16.6 CTX Output

Create your ACH-CTX transmission file, just as you would any other ACH file, by clicking 'Transmit to
Bank'.
 
If you view the file, you'll notice that there are a number of addenda records after each payment line.
 
We've clipped out only the EDI portion of the addenda information from the Office Depot example
(we've alternated the color to help identify the beginning and ending of each segment):

 
 
 
ISA*00*          *00*          *30*227777777      *30*445555555     
*060206*0858*U*00401*000000001*0*P*~
The ISA (Interchange Control Header) segment is system generated and identifies the
receiving and sending parties and defines the data.
 
\GS*RA*227777777*445555555*20060206*0858*1*X*004010
The GS (Functional Group Header) segment is system generated and the function is largely
redundant to the ISA (in a non-ACH EDI file there would be multiple groups - and the
role would be more significant).
 
\ST*820*0001
The ST (Transaction Set Header) segment is system generated and marks the beginning of
the transaction set.
 
\BPR*C*21249.54*C*ACH*CTX*****1657777777**01*960785245*DA*58722229*20060
207
The BPR (Beginning segment for Payment order/Remittance advice) segment is system
generated and contains summary payment information.
 
\TRN*1*342111
The TRN (Trace) segment provides a unique identification for the transaction.  If one is
not provided (mapped), the system generates a unique sequential identifier.
 
\N1*PR*YOUR COMPANY*91*227777777
The N1 (Originator Name Identification) segment is your company name. 
Note: the PR - indicates Payer.
 
\N1*PE*OFFICE DEPOT
The N1 (Receiver Name Identification) segment is the receiver's company name. 
Note: the PE - indicates Payee.
 
\ENT*1
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The ENT (Entity) segment is required, but typically not significant in non-tax
applications as payments are all on behalf of the same entity.
 
\RMR*IV*13334567**7251.52*7451.52*150.50
The RMR (Remittance Advice) segment contains the invoice number, amount to be paid,
total of the invoice and any amounts taken as a discount.
 
\REF*PO*24238*NEW YORK (FIRST)
The REF (Reference) segment contains any additional information - typically a purchase
order number.
 
\DTM*003*20050601
The DTM (Date/Time) segment contains date information, if needed, for the RMR segment.
 
\ADX*-49.50*01*TD*PRICING FROM OLD CATALOG
The ADX (Adjustment) segment contains payer generated debit or credit information.
 
Remember - Check your math if using discounts and adjustments!
For each invoice:
Amount Paid = Total Invoice - discount +/- adjustments
$7,251.52 = $7,451.52 - $150.50 - $49.50
 
-------
\RMR*IV*13357893**6637.61*6700*57.39
2nd invoice
 
\REF*PO*24247*NEW YORK (SECOND)
2nd invoice
 
\DTM*003*20050701
2nd invoice
 
\ADX*-5*59*TD*NEVER RECEIVED AT CORPORATE
2nd invoice
 
-------
 
\RMR*R7*13361023**7360.41*7400*39.59
3rd invoice
 
\REF*R7*24298*NORTHEAST
3rd invoice
 
\DTM*092*20050702
3rd invoice
 
-------
 
\SE*18*0001
The SE (Transaction Set Footer) segment is system generated and marks the end of the
transaction set (offset to ST).
 
\GE*1*1
The GE (Functional Group Footer) segment is system generated and marks the end of the
group (offset to GS).
 
\IEA*1*000000001\                                         
The IEA (Interchange Control Footer) segment is system generated and marks the end of
the Interchange Control (offset to ISA).
 

1.4.16.7 XML

XML Initiative

Currently, EDI is the standard for populating the remittance records (7 records)
for CTX.
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However, a new XML based standard has been proposed for the remittance
records, and ACH Universal has added this newly proposed standard as well.

Please note that while we are supporters of the proposed standard, it
can only be used between parties that have elected to opt-in.  

Want to use ACH Universal for CTX-XML?
Next steps:
1. XML Setup
2. XML Importing data files and Creating ACH Files

Reference:
Sample XML-based ACH-CTX file.
Sample EDI-based ACH-CTX file (as a guide for comparison).

Notes:
--ACH Universal has incorporated the Opt-in Rules for Incorporating XML
Messaging in ACH Addenda Records (XML-ACH) as of August 30, 2013.  
For a copy of this document, as well as additional information, please see:
https://www.nacha.org/XML-ACH-Remittance

--Support in ACH Universal for XML segments is 100% compliant with the EPN
STP 820 transaction set for EDI.

--Need additional support?  Follow the documentation in this section (CTX) - or
contact Treasury Software Support.

1.4.16.7.1  XML Setup

Download and install:
If you have not done so already, download and install ACH Universal from:
http://www.treasurysoftware.com/download.aspx

http://www.treasurysoftware.com/Help_Reference_Files/CTX_XML.txt
http://www.treasurysoftware.com/Help_Reference_Files/CTX_EDI.txt
https://www.nacha.org/XML-ACH-Remittance
http://www.treasurysoftware.com/download.aspx
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ACH Universal setup:

--Upon starting the software, at the 'Welcome New User' page - select ACH
Universal.

--Select ACH File Setup on the Ribbon Bar

--Proceed to screen three. 
Reminder: To navigate past the 'basic' setup, you'll need to opt for 'Advanced'
on the bottom of page two.

--On screen three (below), select CTX, then click 'Next' > 'Finished'.  

Note: The drop down to the right of the selection will not display XML, as it has
not yet been formally adopted.  
In the next step, we will enable the standard for specific vendors.
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--Select the Profiles tab > View Customers, Employees and Vendors.
Then select a profile and click Edit Record.
Tip: If you are in the Sample account, and following this demo - select Office
Depot.
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4. Click the CTX tab (far right).  
In the 'Format to use for this vendor' field - select the XML option and then save.
 Repeat these steps to enable as many vendors as needed.
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If following the demo, repeat for Walmart.

Congratulations - you're all done with setup.  Now let's import some data and
create an ACH File.

1.4.16.7.2  XML Importing Files

The process of importing files to create CTX-XML files is identical to the
process of importing files to create CTX-EDI.

Note: If you are working in the Sample account - you have a demo file ready to
import.

If you're not in the sample account, prepare an import file (and matching profile) with at least
the following minimum fields:
--Vendor name (which matches the lookup name in the profile)
--Amount/Paid
--Invoice Number
 
Of course, additional fields are available -  Mapping CTX Files - Advanced
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Please note that the field names are in EDI (EPN STP 820) syntax.  This enables you to send EDI-
based files to some vendors, while simultaneously sending XML to others.

1. Start the Import Wizard by clicking either icon below:
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2. Select the file to import (or leave the default if in the Sample account)

3. If in the Sample Account - leave the default settings.  Otherwise, map as needed.
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ACH_Name_Internal (Profile Lookup) - You should already be familiar with - this populates the payees
name in the payment line, as well as provides as a 'look-up' field to the Customer, Employee and
Vendor table.
 
Amount_Payment_RMR - Map your detailed invoice amounts using this field.
Invoice_Number_RMR - Map your detailed invoice numbers using this field.
PO_Number_REF- Map your Purchase Order numbers using this field (optional).

 
4. Click 'Next', 'Finish' - to complete the Import Wizard.  

5. Navigate to the Create ACH File page, and click 'Create ACH File'
You can now view the completed file. 
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1.4.17 Health Care Reassociation

Health Care Reassociation

Easily create the Health Care Reassociation record ('7' addenda record)
with ACH Universal Corporate and Processor Editions.

ACH Universal enables users to meet the Federal Regulations established by the
Patient Protection and Affordable Care Act.

This includes, amongst other items: the ANSI ASC X12 835 version 5010 TRN
Reassociation Trace Number data segment.

Setup - Custom Code

This format requires that a Custom Code be entered.  The Health Care
Reassociation format uses code 344.
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To enter the code, click on the Settings tab, then > 'Import, System'.  The
Options window will pop-up.
Click on the Custom tab, enter 344 in the top line - and click Update.

Enter your Origination Company ID (referred to as TRN03 in supporting
documentation).  This is typically a 1 followed by your 9-digit Federal ID.

The Reference Identification field is optional and can be left blank.  If you
choose to, you may enter a value here.  This value is referred to as TRN04.
Click Close when complete.
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Use

You can import files as you normally would.  
In addition, you will want to map the Trace_Reassociation field.  
Tip: Click the 'Show all field selections' to view this field.
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Complete the import and create an ACH file as typical.

The ACH file with Reassociation Addenda fields

Your ACH file will look similar to the image below.

Notes:
CCD is the Standard Entry Class code (SEC) - automatic
HCCLAIMPMT will be the Company Entry Description - automatic

The addenda records are also included. 
705 - 7 is the Addenda record, 05 is the type of addenda record, then followed
by the Healthcare format:
TRN*1*1032529592*1227777777\ (example from first record)

The format is:
TRN*TRN01*TRN02*TRN03*TRN04 Segment Terminator (format)
TRN01 Trace Type code -always 1
TRN02 Reassociation information - trace number
TRN03 Origination Company ID - typically a 1 followed by the
Federal ID
TRN04 Reference Identification - Optional.  Used when the
TRN03 needs additional information
Segment terminator can end with either a \ backslash (default) or a ~ tilde.
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NOTE:  Older versions of ACH Universal may require a Service Pack
update

Obtain a service pack by clicking on the Help tab, then within the Update Group
> Software.  Allow the software to exit and re-start.

1.5 Reporting

Reporting

ACH Universal has a wide selection of industry standard reports which include
transactions, profile listings, audit trail logs and more.
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Basic

To run a report - select the View tab > All Reports.

From the toolbar icons, you can

Features

Once you've run a report, you can change the:
-Columns - add, remove, move, sort
-Grouping - 'Outlook-style' grouping 
-Filtering - 'Excel-style' filtering
and save your changes for use next time.

1.5.1 General Usage

Reporting - Customizing Fields

You can arrange the fields in any order.  To do so, click and drag the column
header to its new location.  
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Custom Layouts

If you prefer your report to be different than the default display, simply modify
the report to your preference.
The saved layout will retain all information in the current report, including filters,
groupings, summary information, and field order. 

Afterward, click on the 'Save' icon.

The next time you run the report, it will be displayed per your settings.

Note: To remove the custom layout - click the 'Remove' icon, just to the right of
the 'Save' icon.

1.5.2 Grouping Data

Reporting - Grouping Data

Reports are only useful if they can be interpreted quickly and accurately. It is
both cumbersome and error-prone to be forced to scroll through tens or
hundreds of records looking for certain ones. 

Advanced Reporting allows you to group report data on many different fields to
see a breakdown by category. 



205

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

In Figure 1 (below), the Advanced Reporting grid is displaying the All Records
report.

In this case, the records are grouped by Date.  To create a grouping, drag the
header into the gray bar.  It is possible to create multiple groupings.  For
example, to group by company name inside the date grouping, drag the
Description header onto the gray bar.  To un-group, drag the header from the
bar to a position in the header row.

Selecting fields

The number of usable fields depends on your data.  Follow the steps below to
select the specific fields you wish to view in a report.  These fields are retained
in a user layout.

There are two ways to open the Field Chooser.  One method is to click the 
button the toolbar.
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1.5.3 Filtering Data

Filtering Data

Immediately below the column headers is the filter row.  Each field in the report
can have its own filter.  Select the type of filter for the field and then enter the
filter text into the appropriate box.  

Selecting Type of Filter

For each field you want to filter, click the corresponding  button.  This will
display the filter choices.

For numerical filtering, your options are:
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Note: The comparisons are based on the sign of the data.  For example, if you
want to see issued checks larger than $10,000 and all issued checks have
negative signs, create a filter of "Less than" and enter -$10,000 as the amount.

For textual filtering, your options are all the above, plus:

Textual comparisons use simple text searches for the filter text, with the
exception of "Matches Regular Expression" which uses regular expressions to
create matches.  Regular expressions, while powerful, create an extra layer of
complexity and normally are not needed for basic text filtering.

Entering Filter Data

In the text box next to the filter type button, enter your filter criteria.  As you type,
the data in the report will be filtered automatically. 

Summarizing Data

Advanced Reporting also provides the ability to create data summaries for any
fields you wish.  The summary information available is:
· Count (number of records)
· Minimum
· Maximum
· Sum
· Average

These summaries are stored as a part of user layouts and can be exported with
the report data if you wish to retain them. 
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To turn on summaries, select View from the main menu, then Enable Summary.
 A  will be displayed in each field.  To enable summary information for a field,
click the  in the field header.  

The Select Summaries box will be displayed.  Below is the box for the Amount
field.  All other fields have Count, Maximum, and Minimum available. 

To turn on a summary value, enable the check-box.  When finished, click OK.  

The summary information will be displayed after the last row of report data.  

To turn off summaries, select View from the main menu, then Disable
Summaries.  Summaries are stored as a part of the user layout.  Summaries
are automatically disabled when you switch reports.  

1.5.4 Exporting Data

Exporting Data

Your report data can be exported from Advanced Reporting to an Excel
spreadsheet or a CSV file.  Note:  You can export to Excel without having Excel
installed, but it must be installed in order to view the exported file. 
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All export options are accessible through the Export option on the main menu. 
These options are:

Excel Export - All
Records

Export all displayed records.  Records filtered out will
not be included.  All visible columns will be exported.

Excel 'Copy' -
Selected Records

Export all manually selected records.  All visible
columns will be exported.

CSV Export - All
Records

Same as Excel Export- All Records, but exports to a
CSV file

CSV Export -
Selected Records

Same as Excel 'Copy' - Selected Records, but exports
to a CSV file

Data Dump - All
Records, All Columns

Exports all records (regardless of filter) and all columns
(visible and not visible) to a txt file.

Also under the Export menu is the option "Open Excel when exporting to Excel
or CSV."  Leave this checked if you wish to load the exported file immediately in
Excel (Note: Excel must be installed).  To export to a file but not view the file,
select the option and uncheck it.

1.6 Automation and Integration

Automation and Integration - Overview
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Our Software Integration Kit (SIK) enables you to automate most routine
processes, such as importing files, creating transmission files (for ACH and
Positive Pay) and for running Automated Transaction Matching (for Bank Rec).

No programming is required--just simply point and click.

To access the Software Integration Kit for the first time:
ACH Universal - Automation tab > SIK
Bank Rec - Automation tab > SIK
Positive Pay - Settings tab > SIK
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Notes:
Legacy (Basic) automation has been replaced by the Software Integration Kit.
The Software Integration Kit requires either ACH Universal Corporate or
Processor editions, Bank Rec or Bank Positive Pay automation edition.

1.6.1 Software Integration Kit - Advanced

Software Integration Kit - Advanced

This section is devoted to accounting software developers and other third party
developers (including end-users) who are looking to integrate Treasury
Software applications into a seamless and automated process for their users.

Our Software Integration Kit (SIK), unlike most automation development kits, is
included directly in the runtime edition and is available to both power users and
software developers in a Graphical User Interface.

Treasury Software's SIK includes full automation tools to seamlessly:
--import any file
--import all files within a directory
--archive (move) the imported files
--preserve the audit trail of archived files (append the file name of each file with
a date/time stamp to insure that each file is uniquely named in the archive
directory)
--provide summary reporting

and, of course

--perform any Treasury Software core module process including:
----ACH and Positive Pay file creation
----ACH and Positive Pay file transmission
----Automated Transaction Matching (ATM) for bank reconciliation

Note: The Software Integration Kit is referenced as the 'Custom Import Menu
Setup' in some documents and will be used here interchangeably.

To access the Software Integration Kit (formerly called Custom Import Menus),
from the Automation tab select Software Integration Kit.
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You can have up to 20 integration routines per account.  Select one that is not
being used and click 'Add/Edit'.
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1.6.1.1 Settings

Settings pages - Basic, Advanced and Automation

Visible - Check this box if you want this process to be available to the user from
the main menu (Import submenu).  This checkbox only drives visibility - it does
not activate or inactivate a process.

What do you want to import?
File - select the file
Folder - point to a folder. Note: Each of the files should have the same format.

Tip:
If you only want to import one file, but the file name is dynamic (keeps
changing), then use the folder option.
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Mapping Templates
Each custom process has it's own custom import layout.  For example, here in
the 1st process, the system defaults to the Custom Menu #1 template in the
drop down list.  The 2nd custom process will have a Custom Menu #2, and so
on.

This enables each custom process to have its own file layout.

Bank Reconciliation only
There will be two Custom Menu layout drop down lists.  One is for the G/L (on
the left), the other is for the Bank data (on the right).  If automating both bank
and G/L imports - create a separate process for each (and keep each set of
files in a different folder if using the folder import).

Fixed Width formats
If a fixed width files is to be imported, the file needs to be parsed.  In a similar
manner, a second row of drop down lists will be displayed - these are for fixed
width files only.  To display the second row of drop down lists, click on
'Unsupported file formats' hyperlink on the second page.

Advanced - Second Page
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Archive
This is used to preserve the audit trail and keep the original import file available for future research and
review.

The file is moved to the archive directory after a successful import.  We recommend appending the file
name with a date/time stamp, as this will make the file name unique, and insure that when the file is
copied into the archive directory it will not over-write any existing files.

Note: Fixed width text files are not supported in the archive process.

Tip:  Confirm that the user triggering the custom process will have rights/privileges to the archive
directory - as it will be performed under their security profile.

File format
Notes:
Tabular - includes Excel, comma delimited (csv) and tab delimited files.

Fixed width file notes:
Select tabular - and also click the hyperlink 'Unsupported file formats' to display the second row of
mapping templates.  
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Automation - Third Page

Command Line Group

This enables the process to be triggered from the Command Line Interface.

Processes are triggered by the numeric value set here.  Therefore, all twenty
processes could be called from a single command line - assuming all has the
same value.  

The basic syntax for the trigger is:
[path]\BRCOM.exe /ACCT="sample" /MENU /AUTO=1

· Account (database) - /ACCT
· Include to activate (static to trigger) - /MENU
· Group to use (numeric value in the Command Line Group number
box)- /AUTO
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This example triggers the Custom Import Menu group #1 (AUTO=1) for the
'sample' account. 

Chaining multiple processes:
Select a numeric value in the Command Line Group number box.  When
passed to the program, it will trigger sequentially all custom menu selections
with the same value.

Example:
You want to trigger three import processes and then create and transmit an
ACH file.
Import process 1 - Import a single payroll file
Import process 2 - Import all trade payable files in a directory
Import process 3 - Import all customer collection files in a directory

Create three separate custom menus, with all having the same Command Line
Group number (1).  As the processes are sequenced based on the process
order (from the list top to bottom), make sure they are in sequence, as the last
one will contain the automation process.

On Import process 3 (only), select the 'Custom Action After Import' to 'ACH File
- Create and Transmit'.

Custom Action after import
This can be:
ACH File - Create and Transmit
Positive Pay File - Create and Transmit
Automated Transaction Matching
Select as needed.

Custom Date Formats
Enables you to import non-standard date formats.

Question - How do you know if the format is a custom format?  
Try opening the source file in Excel.  If Excel opens the file and the date looks
appropriate, you do not need to enter any settings.  However, if Excel has a a
problem interpreting the date - so will Treasury Software.
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1.6.1.1.1  SIK Testing

Triggers and Testing

Enables the automation of Custom Import Menus (Software Integration Kit) -
regardless as to whether the program is set for ACH Universal, Bank Positive
Pay or Bank Reconciliation.

Triggers
The syntax for the command line trigger is simply:
[path]\BRCOM.exe /ACCT="sample" /MENU /AUTO=1

· Bank Account (database) - /ACCT
· Include to activate (static to trigger) - /MENU
· Group to use (numeric value in the Command Line Group number
box)- /AUTO
This example triggers the Custom Import Menu group #1 (AUTO=1) for the
'sample' account.  Detailed syntax information is available.

Supported Software Platforms and Portability
As the Treasury Software runtime contains and drives the automation process,
there are no restrictions as to the underlying development environment (VB,
VB.NET, C, C++, etc...) or as to the platform (rich client vs. ASP) used to
trigger the process.

All that is required is for the triggering application is to access a command
prompt (shell out) and issue a single command line.

Sample Testing Plan
There are three stages to testing
1. User interface (alpha)
2. Shortcut from the desktop (isolated)
3. Third party software triggers or scheduled task triggers (start to finish)

We recommend that you perform testing sequentially, starting at the user
interface.

1. User interface - primarily for 'alpha' testing.  
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From the user interface, select 'Import', then the name of the process you
created.  The system will walk you through the import process 'step-by-step'.

Tip:  'Step-by-step' is literal - there can be five clicks per file.  If testing a folder
import, plan the number of files in a folder accordingly to minimize the test time.

Note: Actions after import, such as file creation and transmission, will only
occur from the command line (see testing methods #2 and #3 below to trigger).

2. Shortcut from the desktop - isolated
From within Windows Explorer, navigate to the Program
Files\TreasurySoftware directory, right click on BRCOM.exe and send a
shortcut to your desktop.  Close Windows Explorer.

Right click on the shortcut, select 'Properties', and in the 'Target:' (path) add the
trigger.  A sample Target might look like:
c:\Program
Files\TreasurySoftware\BRCOM.exe /ACCT="sample" /MENU /AUTO=1

3. Third party software triggers or scheduled task triggers (start to finish)
A complete test environment, which includes third party software testing or a
scheduled task from the host Windows Operating System.

For event driven triggering, such as from a the third party software:
--shell to a command prompt and send a command line trigger, such as above
in #2.

For recurring, scheduled actions:
--use the host operating system's scheduled tasks.  

Notes - upon successful completion of testing:
--Migrate triggers to production third party environments.
--To conform with common Audit Trail requirements, ACH transactions which
have been transmitted cannot be deleted via the user interface.  Either
manually delete with SQL tools, or create a new account.  
--If creating a new account, copy your import mappings by entering into the
newly created account and selecting 'Import', then 'Column Mapping Templates
- Import' from the main menu.  Remember - This copies your column mapping
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templates, but not your custom selections.  Don't forget to re-click any custom
selections.

Remember:  Settings and customizations are stored in each bank account's
database.

1.6.1.2 SQL Insertion

The SQL Integration feature enables other software systems to push data
directly into a Treasury Software SQL Server (not SQL Express) based
platform.  This eliminates the need for 'pass-thru' files.

This feature requires an advanced knowledge and skill set with SQL Server.  It
is best used for high volume and highly automated environments.     

We highly recommend printing out these instructions for reference.

Overview
1. You will populate data into the Treasury Software holding table.  The holding
table exists in each SQL Server database.
2. Then, when Treasury Software is triggered, it will move the data from the
holding table into a permanent table and create an ACH file.

Settings
1. Start the Software Integration Kit.
Select the Automation tab > Software Integration Kit.
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Select an unused process and click Add/edit.

2. Basic tab:
--Check the 'Visible' box (described later) and name this process (example
Daily Processing)
--Select 'SQL Insertion'.****  
--Click the 'SQL Insertion - Select Fields' link *****
Note: As the mapping templates are not used, you can leave the default.
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3. SQL Insertion tab
After you click the 'SQL Insertion - Select Fields' link, you will be brought to the
SQL Insertion tab
Select the top selection 'SQL - Insertion'
Leave the Transaction Code option to the default Populating CHK/SAV field
only, unless you are a Financial Institution.
When complete, select the Automation tab.
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4. Automation tab
Select a non-zero command line group number (typically 1).
Select an action from the drop down list (ACH File - Create and Transmit).
Copy the command line noted below.  You will use this line to trigger moving
this process.

Click 'Save' when complete.
Note: Do not make any other changes in the other tabs.
Specifically, leave the default file format to 'tabular' and do not enable archiving.
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Populating data into the Treasury Software holding table.
The following fields exist in each Treasury Software created SQL Server
database.  
Notes:  
--All fields are text fields and located in the table tblHoldingGLIntegration.  
--All are mandatory unless otherwise noted.
--You can add records as often as you want
--The table is automatically cleared (deleted) each time you trigger the
Software Integration Kit to run.
--Strip out special characters (especially apostrophes) in the Description/Name.

Due to our existing system processes, please note that not all
transaction types and fields are available for insertion.  
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Field name Description
Mandatory fields
Amount Can import as signed or absolute amounts, depending

on whether or not you are supplying the Transaction
Type codes.  Regardless of sign, always include a
decimal point as needed.  Do not include commas or
dollar signs.
Tip: Typically you will sign the amount as positive when
you are collecting funds, and negative when you are
sending out funds.

Either:
1. If Transaction codes are supplied in the
ACH_CheckingorSavings field, enter all amounts in
absolutes (positive).
2. If Transaction codes are NOT supplied, indicate
whether the amount is a Debit (collecting funds, ie from
clients) by signing it positive, or a Credit (paying funds,
ie. employees and vendors) by signing it with a negative
sign.

Date The effective date, in MM/DD/YY format.  Note: The
month and day can be one or two digit, the year can be
two or four digit.
International format? - Use your local regional settings.

Description Name of receiving party (no apostrophes or special
characters).

Text1 Identification (ID#) of receiving party.  Optional field.
ACH_Account Bank Account number of receiving party
ACH_Routing_ABA Routing number of receiving party
Class_3_Letters Standard Entry Class code (PPD, CCD, WEB, TEL,

etc....). Optional field.
ACH_CheckingorSa
vings

Numeric entry only.  Either enter:
1. Simple checking (0) or savings (1) indicator
or
2. Transaction codes (22, 27, 32, 37, etc...)

Using Multiple Origination Accounts On-The-Fly (not profiles)?



226

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

For Company Name - import into fldOriginationAccountText
For Company ID - import into Comp_ID_Resend
Note: Yes, these are odd sounding field names, but they are not a typo.

Testing
After you have performed your one-time setup, and then populated your data,
you can test your work.
Start the Software Integration Kit, select the process, and then click 'Run'. 
Complete the import wizard.  

Upon a successful import, the ACH file will be automatically created.  The file
can typically be found (by default) at:
C:\Users\Public\Treasury Software\To Bank

Note: Your data that you populated will be cleared out of the
tblHoldingGLIntegration.  

No valid records? - Remember that the software will filter out invalid ABA
numbers.  Make sure that you use valid ABA numbers in testing.

Need a test SQL script to populate the table?  
Tip: Start SQL Server Management Studio and click on 'New Query' (make
sure that you're in the right database).  Then copy the script below.
INSERT into tblHoldingGLIntegration
(tblHoldingGLIntegration.Amount,
tblHoldingGLIntegration.Description,
tblHoldingGLIntegration.Text1,
tblHoldingGLIntegration.ACH_Account,
tblHoldingGLIntegration.ACH_Routing_ABA,
tblHoldingGLIntegration.ACH_CheckingorSavings,
tblHoldingGLIntegration.Class_3_Letters,
tblHoldingGLIntegration.Date) VALUES
('123.45', 'ABC Company', 'ABC01',
'88888888','063000047', '0', 'CCD', '12/31/2013')

Script for Multiple Origination Accounts On-The-Fly (no profiles)
INSERT into tblHoldingGLIntegration
(tblHoldingGLIntegration.Amount,
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tblHoldingGLIntegration.Description,
tblHoldingGLIntegration.Text1,
tblHoldingGLIntegration.ACH_Account,
tblHoldingGLIntegration.ACH_Routing_ABA,
tblHoldingGLIntegration.ACH_CheckingorSavings,
tblHoldingGLIntegration.Class_3_Letters,
tblHoldingGLIntegration.Date,
tblHoldingGLIntegration.fldOriginationAccountText,
tblHoldingGLIntegration.Comp_ID_Resend) VALUES
('123.45', 'ABC Company', 'ABC01',
'88888888','063000047', '0', 'CCD', '12/31/2013', 'XYZ
Corp.', '998765432')
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Production
Trigger the Software Integration Kit using the command line noted in the
Automation tab.

General notes
--This feature requires SQL Server (not SQL Express), and access to the
Software Integration Kit.

--This integration is designed to be run in an automated fashion.  If you trigger
the import manually via the menu structure as noted in testing - once you are at
the review records screen, the records have been removed from the temporary
holding table. 

1.6.1.3 Global batch processes - across many accounts

Global batch processes - across many accounts

In the previous pages, we discussed how to automate imports, archiving, file
creation and transmission for a single account.

Here we will address the issue of performing the same task for multiple
accounts.

The Global Batch Process saves you the 'pain' of writing batch commands or
scripts to trigger processes in each account.
The system will start with command line group 1 and run the processes
sequentially.

The advantages of using the Global Process over batch commands:
--no need for scripts
--no need to try to estimate how long each process will take - minimizes overall
start-to-end processing time
--easy to trigger - table based.

The Global process is an advanced feature and requires:
--the Software Integration Kit
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--to be displayed, prior to accessing

To display the Global Batch Process
Settings tab > System tab > scroll to Suppress Automation - Global Batch
Process menu and set the option to 'Display'.
Close the window.
Exit and re-enter the account to redraw the menu.

Access the Global Batch Process (after re-entering the account)

The icon to access the Global Batch Process - Across Accounts - will always be
to the right of the SIK.
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Click on the Automate Across Accounts to display the form.

Notice that no accounts are listed.  Click the link 'Utilities to add/create'.

We recommend using the auto-populate feature.  Then click to return to the
main window.
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Your Main screen is now populated with a list of accounts that you have on your
computer.
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Cleanup

Remove the accounts you don't need, or simply remove the checkboxes.  The
system will only run the process if there is a check box.

In this example, we are only using process #1 - we'll simply click 'Uncheck
all' (lower right corner), and then check the processes we need.
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Triggers
The syntax for the command line is (assuming default location and command
line group 1):
c:\Program Files (x86)\Treasury Software\version 201X XX\BRCOM /GLOB=1

This may be copied into a user's desktop shortcut for on-demand processing,
or used in Windows Task Scheduler for after hours processing.

The GLOB=1 parameter indicates that it is process 1.  GLOB=2 would trigger
processes with a command line group of #2 and so on.

This trigger - regardless of how it is called (you can use any third party utility or
program) can:
Import the source file(s)
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Archive the source file(s)
Create a transmission file and/or match records for bank reconciliation 
Provide a Notepad style report of the activities.

This feature is a legacy feature of the Processor edition and will be retired
shortly.  
Do not use this feature, or any other legacy feature in a new setup/configuration
- as it may not be compatible with all other features in our current product
offering.  
Access to this feature has been suppressed by default and should not be
activated without authorization from Treasury Software support.

1.6.2 Command Line Syntax

Command Line Syntax

The Treasury Desktop™ contains a rich command line interface that allows
for full automation from other applications.

While the command line interface compliments a number of features which
are available in our point-and-click 'Control Panel', the interface allows for full
customization and control of output files' location/names.
 
Differences between Control Panel and Command Line automation:

Control Panel

1. Triggers are preset - at standard date/time and standard intervals.
2. Cannot programmatically change file names. Must specify source files or
output files.
3. Ease of use - has a point and click interface.
 
Command Line Interface:

1. Triggers - Can be triggered on command.
2. Full control over both source files and output files. Can programmatically
change file names.
3. The command line requires an intermediate to advanced knowledge of
systems.

 



235

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

1.6.2.1 Command Line Interface

Overview

The Command Line interface is used to schedule import and transmission jobs through the Windows
scheduling system.  This is similar to using the Scheduler, but by using the Command Line you are able
to schedule multiple jobs and do not have to load ACH Universal to do so. 

Command Line Options

BRCom.exe /ACCT="account" /ACHX [/XMIT] /SRCE="file name"

/ACCT - specifies account by name
/ACHX - specifies to use the ACH Universal module
/XMIT   - directs ACH Universal to create and then transmit the file after creation
/SRCE - specifies file to be imported (using absolute positioning)

Example: 

c:\Program Files\TreasurySoftware\BRCOM.exe /ACCT="sample" /ACHX /XMIT /SRCE="C:
\aaavb\1000\Tutorial\GLData\ACH_with_Accounts.xls" 

This example imports a source file named ACH_with_Accounts.xls at the specified absolute position
into the Sample account in ACH Universal (ACHX). After import, the system creates and transmits
(XMIT) the NACHA file. 

Valid source files include comma delimited text files, tab delimited text files, fixed width text files and
Excel worksheets.

Notes for all applications:
· The order of the parameters is not significant
· Capitalization is not significant
· When specifying a file name (SRCE), use the full file path and name within quotes. When using
mapped drives, remember that the path should be centric/relative to the machine where Treasury
Desktop is located, not the machine issuing the trigger/command.
· Place the account name in quotes.

Working with multiple users and multiple account:
Each command line trigger - will create an independent instance of the application. There is no limit to
the number of instances.

If processing simultaneous command line requests, use different accounts (Sample1, Sample2, etc...)
to minimize any record locking issues. If this is not an alternative, consider processing sequentially, or
using our Control Panel. 

For Web and Citrix based applications, please contact a Treasury Software support representative.

1.6.2.2 ACH Universal

ACH Universal
(ACH File Software)
· Account - /ACCT
· Data Import (include to activate) - /ACHX
· ACH File Creation and Transmittal (include to activate) - /XMIT
· Source File for import - /SRCE
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Syntax Example
If Treasury Desktop was installed in the default location:
 
c:\Program
Files\TreasurySoftware\BRCOM.exe /ACCT="sample" /ACHX /XMIT /SRCE="C:
\aaavb\1000\Tutorial\GLData\ACH_with_Accounts.xls"
 
This example imports a source file (identified with SRCE) for ACH Universal (ACHX).
After import, the system creates and transmits (XMIT) the NACHA file. This example
takes place in the sample account (ACCT).
 
Valid source files include comma delimited text files, tab delimited text files, fixed
width text files and Excel worksheets.
 
 
Notes for all applications:
· The order of the parameters is not significant
· Capitalization is not significant
· When specifying a file name (SRCE), use the full file path and name within quotes.
When using mapped drives, remember that the path should be centric/relative to the
machine where Treasury Desktop is located, not the machine issuing the
trigger/command.
· Place the account name in quotes.
 
Working with multiple users and multiple account:
Each command line trigger - will create an independent instance of the application.
There is no limit to the number of instances.
 
If processing simultaneous command line requests, use different accounts (Sample1,
Sample2, etc...) to minimize any record locking issues. If this is not an alternative,
consider processing sequentially, or using our Control Panel.
 
For Web and Citrix based applications, please contact a Treasury Software support
representative.

1.6.2.3 ACH-2-Excel

ACH2Excel
· Account - /ACCT
· Data Import (include to activate) - /ACH2
· Source File for import - /SRCE
· Output File - /OUTD
 
Valid source files include ARC, CCD, CIE, CTX, DNE, ENR, POP, PPD, RCK, TEL, TRC,
TRX, WEB, XCK. Note: Some formats may require further parsing.
 
Syntax Example
If Treasury Desktop was installed in the default location:
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c:\Program Files\TreasurySoftware\BRCOM.exe /ACCT="sample" /ACH2 /SRCE="C:
\transmit.txt" /outd="c:\testACHdetail.csv"
 
 

Reminder:
Turn on/off appropriate settings.  From the main menu 'File', 'ACH File Conversion',
'Output' tab - unselect open in Excel afterwards.

 

 
Notes for all applications:
· The order of the parameters is not significant
· Capitalization is not significant
· When specifying a file name (SRCE), use the full file path and name within quotes.
When using mapped drives, remember that the path should be centric/relative to the
machine where Treasury Desktop is located, not the machine issuing the
trigger/command.
· Place the account name in quotes.

Working with multiple users and multiple account:
Each command line trigger - will create an independent instance of the application.
There is no limit to the number of instances.
 
If processing simultaneous command line requests, use different accounts (Sample1,
Sample2, etc...) to minimize any record locking issues. If this is not an alternative,
consider processing sequentially, or using our Control Panel.
 
For Web and Citrix based applications, please contact a Treasury Software support
representative.

1.6.2.4 BAI-2-Excel

BAI2Excel
· Account - /ACCT
· Data Import (include to activate) - /BAI2
· Source File for import - /SRCE
· Output File Detail - /OUTD
· Output File Summary- /OUTS
 
 
A valid source file would be any file formatted in BAI version 2.
 
Syntax Example
If Treasury Desktop was installed in the default location:
 
c:\Program Files\TreasurySoftware\BRCOM.exe /ACCT="sample" /BAI2 /SRCE="C:
\aaavb\1000\Data\citi.txt" /OUTD="c:\testdetail.csv" /OUTS="c:\testSumm.csv"
 
 
Reminder:
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Turn on/off appropriate settings.  From the main menu 'File', 'BAI File Conversion',
'Output' tab - unselect open in Excel afterwards.
 
Notes for all applications:
· The order of the parameters is not significant
· Capitalization is not significant
· When specifying a file name (SRCE), use the full file path and name within quotes.
When using mapped drives, remember that the path should be centric/relative to the
machine where Treasury Desktop is located, not the machine issuing the
trigger/command.
· Place the account name in quotes.

Working with multiple users and multiple account:
Each command line trigger - will create an independent instance of the application.
There is no limit to the number of instances.
 
If processing simultaneous command line requests, use different accounts (Sample1,
Sample2, etc...) to minimize any record locking issues. If this is not an alternative,
consider processing sequentially, or using our Control Panel.
 
For Web and Citrix based applications, please contact a Treasury Software support
representative.

 

1.6.2.5 Software Integration Kit

Custom Import Menus

Enables the automation of Custom Import Menus - regardless as to whether the program
is set for ACH Universal, Bank Positive Pay or Bank Reconciliation.

Settings
· Account - /ACCT
· Include to activate - /MENU
· Group to use - /AUTO

Syntax Example
If Treasury Desktop was installed in the default location:

c:\Program Files\Treasury Software\version 2012
01\BRCOM.exe /ACCT="sample" /MENU /AUTO=1

This example triggers the Custom Import Menu group #1 (AUTO=1) for the 'sample'
account.  

Notes:
--The group number can be set for each Custom Import Menu selection.  From the main
menu select 'Import', 'Custom Import Menu Setup', then select to edit.  From the Custom
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Menus Setup window, select the 'Advanced' tab.  Change the group number in the 'Other
Settings' section.

Notes for all applications:
· The order of the parameters is not significant
· Capitalization is not significant
· Place the account name in quotes.

Working with multiple users and multiple account:
Each command line trigger - will create an independent instance of the application.
There is no limit to the number of instances.

If processing simultaneous command line requests, use different accounts (Sample1,
Sample2, etc...) to minimize any record locking issues. If this is not an alternative,
consider processing sequentially, or using our Control Panel. 

For Web and Citrix based applications, please contact a Treasury Software support
representative.

1.6.2.6 Bank Positive Pay

Bank Positive Pay
· Account - /ACCT
· Data Import (include to activate) - /POSP
· ACH File Creation and Transmittal (include to activate) - /XMIT
· Source File for import - /SRCE
 
Syntax Example
If Treasury Desktop was installed in the default location:
 
c:\Program
Files\TreasurySoftware\BRCOM.exe /ACCT="sample" /POSP /XMIT /SRCE="C:
\aaavb\1000\Tutorial\GLData\Check Register 2003-04-08csv.csv"
 
This example imports a source file (identified with SRCE) for Bank Positive Pay (POSP).
After import, the system creates and transmits (XMIT) the positive pay file. This
example takes place in the sample account (ACCT).
 
Valid source files include comma delimited text files, tab delimited text files, fixed
width text files and Excel worksheets.

Notes for all applications:
· The order of the parameters is not significant
· Capitalization is not significant
· When specifying a file name (SRCE), use the full file path and name within quotes.
When using mapped drives, remember that the path should be centric/relative to the
machine where Treasury Desktop is located, not the machine issuing the
trigger/command.
· Place the account name in quotes.

Working with multiple users and multiple account:
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Each command line trigger - will create an independent instance of the application.
There is no limit to the number of instances.
 
If processing simultaneous command line requests, use different accounts (Sample1,
Sample2, etc...) to minimize any record locking issues. If this is not an alternative,
consider processing sequentially, or using our Control Panel.
 
For Web and Citrix based applications, please contact a Treasury Software support
representative.
 

1.6.2.7 Profile Importing

ACH Universal Profiles
(ACH File Software)

To import Customer, Employee and Vendor (CEV) profiles

· Account - /ACCT
· Import Customer, Employee and Vendor profiles - /CEVX
· Source File for import - /SRCE

Syntax Example
If Treasury Desktop was installed in the default location:

c:\Program Files\TreasurySoftware\BRCOM.exe /ACCT="sample" /CEVX /SRCE="C:
\aaavb\1000\Tutorial\GLData\CustomersEmployeesVendors1.xls" 

This example imports a source file (identified with SRCE). This example takes place in
the sample account (ACCT). 

Valid source files include comma delimited text files, tab delimited text files, fixed width
text files and Excel worksheets.

Notes for all applications:
· The order of the parameters is not significant
· Capitalization is not significant
· When specifying a file name (SRCE), use the full file path and name within quotes.
When using mapped drives, remember that the path should be centric/relative to the
machine where Treasury Desktop is located, not the machine issuing the
trigger/command.
· Place the account name in quotes.

Working with multiple users and multiple account:
Each command line trigger - will create an independent instance of the application.
There is no limit to the number of instances.

If processing simultaneous command line requests, use different accounts (Sample1,
Sample2, etc...) to minimize any record locking issues. If this is not an alternative,
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consider processing sequentially, or using our Control Panel. 

For Web and Citrix based applications, please contact a Treasury Software support
representative.

1.6.3 Scheduler - Basic Automation

Scheduler - Basic Automation

Note - This feature has been replaced by the Software Integration Kit and
is no longer supported in versions 2013 and on.

This documentation is included for our existing legacy clients, and the inclusion
of this feature in future versions of software cannot be guaranteed.

Overview

The Scheduler is used to schedule single file imports and file transmission. If
you need to schedule multiple files during the same
routine, see Custom Import Menus.

Process

There are two steps to scheduling an automated file import and transmission
(from now on called a job). 

1. Create the job.  This would be the account to be used and the file to be
imported.
2. Running the job. This instructs ACH Universal on time and frequency the job
should be run.

Create the job

Select the Automation tab > Basic and you will see a form similar to the one
below.

Note: If you are using a version prior to 2013, select Control Panel from the
main menu.  The Control Panel (below) will be displayed.  
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Figure 1 - Control Panel

All the accounts are shown in the grid.  In this case, Checking and Payroll have
been created for live data. (Remember: Never use the Sample account for live
data).  They both can be scheduled to run at the same time, or you can choose
to schedule just one account.  Note: It is not possible to schedule them at
different times and days using the Scheduler. See Custom Import Menus if you
need this type of setup.

To create a job:

Enable the checkbox in the Import column of the account you wish to use.

Click the gray box under the Import ACH File Name to browse for the source
file to be imported.

Select how you wish the system to handle transmission of the ACH file.  Your
choices are:

· No (ACH file is created, but not transmitted. You must transmit manually).
· Only when new records imported
· Yes, always (On every job, the file is transmitted using the method you set) 

Schedule the job:

Click the Scheduler button. 
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A screen will pop up requiring a Windows user name and password.  The
Scheduler will use this user name and password to schedule the job.  You may
leave the password blank, but the job may not run due to lack of authorization
as required by Windows.

After entering user name and password, click Next.

The Scheduler will now be displayed (below).

Figure 1 - Scheduler

To schedule a job to run once a day on certain days and at certain times, select
the checkboxes for each day and then enter the time in Start Time textbox.

If you need to schedule a job to run multiple times per day, click the "Repeat
throughout the day" button.

Information shown in Figure 2 (below) will be displayed in the Scheduler
window.

Figure 2 - Repeat throughout day
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Click the checkbox.  

The job can be scheduled to run in increments of hours or minutes.  Enter the
length of time between job runs and then select hours or minutes from the drop-
down box.

In the textbox on the right side, you can specify the end time for the schedule.

For example, ABC Company wants to run their job every 30 minutes, but only
between 11 AM and 3PM.

In Figure 1, ABC would set the start time to 11:00 AM and choose the
appropriate days.  In Figure 2, ABC would enable the checkbox, then enter 30
into the first textbox, change the dropdown to minutes, and put 3:00 PM in the
remaining textbox.

When completed, click Finish.

1.7 Advanced Topics

Advanced Topics - Overview

The articles contained in Advanced Topics deal with features of ACH Universal
that are not necessary to basic ACH file creation, but enhance your efficiency in
using ACH Universal.

1.7.1 Remote Desktop (Terminal Services / Citrix) Platform

Remote Desktop (Terminal Services/ Citrix) Platform

For the purposes of this Help page, the term 'Remote Desktop' will include
Terminal Services and Citrix.  

Installation
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For instructions on initial setup and system requirements, please see our
Installation checklist at:
http://www.treasurysoftware.com/support2-Installation-Citrix.html

Turn On/Off 

To turn Remote Desktop on or off:
Enter into an account and from the Home page, go to Settings > 'Migrate to
Remote Desktop/ Citrix.'  In earlier versions of the software, from the main
menu select File > Maintenance > 'Remote Desktop' tab.  Check / (uncheck) the
'Enable' check box.  Exit and re-enter into the system.

Understanding Remote Desktop mode

Simple (non-Remote Desktop Mode)
In a simple desktop or SQL Server environment, when a user starts Treasury
Software, the system looks for a settings file which contains a catalog of
accounts, Treasury Software licensing information, as well as user-based
preferences.

Typically only one settings file is on a computer.  This file is opened in
'exclusive' mode in that multiple users should not read/write to the file.  While
this is not an issue when a computer is in use by one person, it needs to be
addressed if the computer is a Remote Desktop Server.

Remote Desktop Mode
Once Treasury Software is turned 'on' for Remote Desktop Mode, the system
will protect the original settings file.  Remember: the settings file is user
specific.  More than one user should not access the file at a time.  

WARNING - Unexpected results will occur if Treasury Software is
installed on a Remote Desktop Server and Treasury Software's Remote
Desktop Mode is not turned 'on'.

Technical discussion - 'Under the hood'

Simple
In a simple environment, the settings file is accounts.brd  and is located at c:

http://www.treasurysoftware.com/support2-Installation-Citrix.html
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\Program Files\Treasury Software\version xxxx\accounts.brd (or for Windows 7
.c:\Users\Public\Treasury Software\accounts.brd)

Remote Desktop
When the system is 'switched' to Remote Desktop, the system protects the
accounts.brd from being accessed.

As each user starts Treasury Software for the first time, the system creates an
accounts.brd specific for that individual, and it is placed in the \users directory.
Notes:
The accounts.brd file is appended with their login id.
The users directory will be either below the Program Files\Treasury Software
tree (Windows XP), or in the Users\Public\Treasury Software tree (Vista,
Windows 7 on). 

Planning - 'When' to turn on Remote Desktop mode

Remember: The system's accounts.brd is used as a template for each user's
accounts.brd file.  
Everything that you do in the system PRIOR to a user logging in for the first
time will be included in that new user's accounts.brd.

Therefore:
If you create two new accounts (i.e., Checking and Savings) prior to any users
logging in, each user when logging in for the first time will have Checking and
Savings accounts in their catalog.

As a corollary, if you are the system administrator and make changes to the
system, such as entering new license codes, this information will:
--not be available to existing users (their accounts.brd's have already been
created)
--will be available to any new users, as the system will use the updated
accounts.brd as a template.

Making system changes after users have already logged in

1. Make Treasury Software temporarily unavailable to users.
2. Enter into Treasury Software through the Remote Desktop as an
administrator - not as a user through a published application (Citrix).
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3. Enter into an account.
4. Turn off the Remote Desktop function.
5. Exit, and then re-enter Treasury Software.  Enter into an account.  Confirm
that the Remote Desktop function is off.
6. Perform any maintenance, add any licenses, or add any accounts as needed.
      As a reminder - you are now updating the accounts.brd file.  This will be
used as a template for each of your users.
7. Turn the Remote Desktop function back 'on'.
8. Exit the software.

Optional
If you want to force this change to all existing users, you will need to delete the
user settings files.  Then, once each user logs in, the system will create a new
settings file for them (using the newly updated settings file as a template).

Warning - Deleting the user's settings files will reset all of their settings to the
default settings file (which you just updated).
This includes:
--License information
--Account catalogs
--SQL Server server name and authentication method (no effect if using
Windows Authentication)
--Minor settings

To delete the user's settings files--using Windows Explorer--delete the contents
of the \users directory.
The files in the folder will have a syntax of [login id]_accounts.brd.  

The \users directory can be located at c:\Program Files\Treasury
Software\version XXXX XX\users\
If the folder is empty (on Vista or later), then look to the
c:\Users\Public\Treasury Software\users\ directory.

9. Make Treasury Software available again to your users.

If there is a setting that you missed, or wish to change, you can repeat this
process.
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1.7.2 Multiple Origination Accounts

Multiple Origination Accounts and Third Party NACHA (Processor)
Rules

What is an Origination Account?
An Origination Account is a bank account that you own (or control), that you
send payments from, or where incoming funds are collected.
For example, a company's payroll account that is set up for ACH service would
be an origination account.

How do we work with more than one account?
We are a large company and have two origination accounts--one for payroll and
one for vendor payments (A/P).
How do we work with multiple accounts?

Two approaches: 'Traditional' vs. 'Consolidated' 

When working with multiple origination accounts, a company can choose
whether to create and send an ACH file from each account or to consolidate all
into one single ACH file.

I. Traditional approach

You would create multiple accounts (databases) within ACH Universal.

Each account will create an ACH file.
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The traditional approach is best used when there is a need to segregate duties
and access to data.  Often, payroll will be a separate function, and the the 'net
pay' needs to be private.

II. Consolidated (a.k.a. Multiple Origination Accounts - Third Party
Fiduciary NACHA Rules)

With ACH Universal Processor edition, we offer our customers the ability to
work with a single ACH file.

Example:
A benefit plan administrator (processor) needs to make payments weekly on
behalf of their 50 clients.
In this case, it is best to use the consolidated approach.  What would have been
50 separate files is now a 'batch' within one ACH file.
The Batch Header provides the bank with the 'Origination' account.



250

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

Advantages

By using a single, consolidated file, the processor can minimize the tedious and
error-prone process of transmitting (and confirming) 50 individual files.  Also, if
the processor is normally charged a service fee of $15 per ACH file by their
bank, for instance, the processor saves $735 each week (49 files not
transmitted x $15).

NACHA compliance

By placing the originating Company Name in the batch header ('5' record,
positions 5 - 20), you will stay in compliance with NACHA's Third Party Rules
and Regulations.

Not just for processors

The Processor edition of ACH Universal is for: 

• Law firms - or other fiduciaries who cannot co-mingle escrow accounts
• Company administrators - with divisional/regional/sites and consolidation or
sweep accounts
• Company administrators - who need segregation of duties for disbursements,
payroll and depository accounts
• Service providers - ACH processors who collect funds on behalf of others
• Outside legal ownership - such as a payroll company drafting on others'
accounts

1.7.2.1 On-The-Fly based

Working with Multiple Origination Accounts without the use of
Origination Profiles
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(Also known as 'On-The-Fly').

Setup

1. In the Processor edition of ACH Universal, please turn on this feature by
selecting ACH Setup from the Home screen, and continuing to screen 6 of 7.
Check the 'On-The-Fly' option, and then complete the wizard to save this
selection.

Importing transactions

2. Prepare your import file.  In addition to the fields that your file would typically
have (Name, Amount, ABA/Routing number, Account Number, etc.), the file
should also contain:
--Company Name
--Company Identification
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Field Map in ACH Universal as Appears in the ACH File
Company
Name

Company Name - Origination Acct
(On-The-Fly)

Batch header (5 - 20)

Company
Identification

Company ID - Origination Acct (On-
The-Fly)

Batch header (41 - 50)

ACH File

When the ACH File is created, it is batched taking into account the Company
Name and Company ID, thereby enabling you to satisfy NACHA Third Party
Rules and Regulations
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Notes:

The fields below are only accessible in the mapping window if this feature has
been turned on (see Step #1)
Company Name - Origination Acct (On-The-Fly)
Company ID - Origination Acct (On-The-Fly)

If the value of either field (Company Name or ID) is blank/null in the import file,
the transaction is not considered to be a valid transaction (no blanks are
allowed--these are mandatory NACHA fields).

Balanced files (or offset records) can be created using the default information
entered in ACH Setup (screen 4 of 7).
If offset records are required based on the origination account, use our profiles-
based multiple origination account feature.

If you need to perform profile-based file importing, use our profile-based
multiple origination accounts feature.
In addition, use profile-based multiple origination accounts for QuickBooks
automation.

1.7.2.2 Profile based

Profile Based Consolidation of Multiple Origination Accounts -
Third Party Fiduciary NACHA Rules

Creating the accounts
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From the Profile tab, create an Origination Account for each bank account that
you will be using.

Examples:

If you will be creating entries for your (1) Payroll and (2) Accounts Payable bank
accounts, create two origination accounts here--one for each.

If you have a large number of accounts, and you would rather import an Excel
(or CSV) file with this information, follow this link to 'Import Origination
Accounts'.

If you are creating the Origination Accounts one at a time, you will be presented
with the following:

Header tab
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Offset tab

Only fill in the information in the Offset tab if your bank notifies you that they
require an offset record.  
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When finished adding information, click Save.

A dialog box will be displayed.  If you need to add more origination accounts,
click Yes.  If finished adding accounts, click No.  You can always add more
accounts at another time.

Need to edit an account?

From the Profiles tab select View/Edit in the Origination Accounts (Multiple)
section.

1. Select the record
2. Click 'Edit' from the Reports menu.

This will bring up the Origination Accounts.  After updating, click save.
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1.7.2.2.1  Importing - Multiple Origination Accts

Importing Multiple Origination Accounts

Rather than adding Multiple Origination Accounts one at a time, you can import
a file with this information.

Prepare a file

Create an Excel or a comma delimited (CSV) that contains as much information
as possible (below).

Start the Multiple Origination Account Import Wizard

From the Profiles tab select Import.
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Follow the Import Wizard prompts. 
At the Mapping screen, map your fields, using the screen shot below as a
template.
Reminder: You may not have all the fields shown below.  That is okay.
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Complete the Wizard as prompted.
1.7.2.2.2  Setup - Multiple Accts

Setup of Multiple Accounts

ACH Setup - Turn 'On' Multiple Origination Accounts feature (only
available in Processor edition)

From the Settings tab select ACH Setup and proceed to the 6th screen.

Check the 'Third-Party' checkbox
Check, if needed, the 'Offset Record' checkbox.  If you do check this box, make
sure that you have an entry in Offset ABA/Routing Number, Offset Account
Number and Offset Description.
Complete the Wizard and save.
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Mapping the 'Origination Account' field in the Transaction Import Wizard

Start the Transaction Import Wizard.  Select a file to import and continue until
you arrive at the Mapping Screen.
Map the field with the lookup values as 'Origination_Account'.  Tip - Click the
'Show all field selections' link.
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Complete the Import Wizard as usual to save the mappings.

Confirmation.
Now, create the ACH file as you normally would -- Go To Create ACH File
Page > Create ACH File.

Your ACH file should have characteristics similar to the file below.
Each batch header contains the information regarding its origination account.



262

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

1.7.3 Copy Settings From Existing Account

Copy Settings From an Existing Account

This page is designed to walk you through the process of copying settings data
from another account and applying them towards a new one.  

1.  From within the software go to 'File' > 'Upsize/Copy Account'.
2.  Select 'Next' on the Wizard.
3.  Next select "..." to browse to the account you want to copy.
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4. Copy all settings and transactions you want to move over to the new account
and click next.

5. If you want to bring over any transactions, choose the appropriate radio
button and select 'Copy Transactions'.
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6. Click 'Next' and then 'Finished'.

1.7.4 Authentication File

Authentication File

Depending how your account is set up, you may need to initiate the
release/processing of transactions.  
While this is typically performed by an IVR (Interactive Voice Response) dial-in
system, some banks may require a secondary file.

Note: This process is only required for a handful of banks.  Unless your bank
specifically requested it, you can skip this topic.

Setup
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From the Settings tab select Transmission Options > Local File tab >
Authentication File sub-tab.

Enter the text that you want sent in the file.

For items that will be dependent on the transmission file, such as amounts and
counts, please use the following tags in your text.  The system will substitute
these tags with the actual values.
[DR$_AMOUNT]
[CR$_AMOUNT]
[DR_COUNT]
[CR_COUNT]

Notes:
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--Tags: Include the brackets, and capitalization

--The ruler on the bottom is a guide for your use and is not used in the file
creation.  Therefore, it is possible that the tag may not be the same length as
the output value you have specified--this is fine.

For example, your bank may require that your amount fields be 15 positions in
length.  However, when you enter the text "[DR$_AMOUNT]" into the line, it only
takes up 12 positions according to the ruler.  This is okay and to be expected. 
Just make sure that you specified 15 positions in the first numerical text box.

--If this feature is activated, it will create an authentication file in the same
location as the ACH transmission file.
You can manually transmit this file, or if you have selected 'FTP' (not WS_FTP)
as the transmission option, it will be automatically sent as well.  Any advanced
modifications, such as name, extension, and other transmission methods will
need to be performed outside of Treasury Software.

Use

Once turned on, the file will automatically be created and transmitted (if FTP is
selected).  No further action is needed on the user's part.

1.7.5 No Write Permissions to Users-Public

No-Write Permissions to Users-Public

Installing on computers where there is no user write permissions to the
\Users\Public folder.

Background

Treasury Software uses a working directory to store account lists, tutorials,
reports and persistent workstation settings from one session to another.

This information is independent of the account databases, and is therefore
needed regardless if the software is on a desktop (brd file), SQL Express or
SQL Server platform.
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By default, Treasury Software creates this working folder at:
C:\Users\Public\Treasury Software

Note: This folder is not created at installation, but is created at the time of first
use

Issue

In certain environments, for security concerns, users are restricted from writing
or modifying data in the C:\Users\Public\ folder.

Steps to resolve this issue

1. Install Treasury Software as usual (this requires administrative rights).

2. Start Treasury Software (while still logged on with administrative rights).

3. Select 'ACH Universal' from the Welcome New User screen--or any account
if you have already created accounts.

4. From the Settings tab select 'Migrate to Remote Desktop Services' to start
the Wizard.  On the second panel of the Wizard, select the directory that you
want to use.
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Complete the Wizard, exit the software, and you are done.  

You can now log off as the administrator.

Summary

You have changed the working directory to the directory of your choice.
In doing so, you have engaged our Remote Desktop feature.  Please make sure
that you have the appropriate license required for this.  
While no data will be written or stored in the C:\Users\Public\Treasury Software
going forward, the 'pointer/shortcut' to the new directory is stored there.  Please
do not delete this folder.  Make sure that the user has read rights to the folder.

Important Reminders:

--Do not delete the files at C:\Users\Public\Treasury Software.  
--The user will need read (not write) access to the C:
\Users\Public\Treasury Software folder.  
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1.7.6 Placing records on hold

Placing Records on Hold

This feature enables you to place transactions on hold, until you are ready to
process them.

How it works

Import records as usual, whether from an integrated accounting package,
Excel, a comma delimited file, or even from another ACH file.

Run an Untransmitted ACH Records report and select the records to
place on hold.

Select the record(s) and then select the red button.

The records you select will be placed on hold and will not be included in an
ACH file.
The next time you run the report, you can see the status of the records in the
first column:

Run an Untransmitted ACH Records report and select the records to
release for payment

Select the record(s) and then select the green button.
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Notes:

--This feature is available in ACH Universal 2013 and later.
--Records placed on hold and subsequently released are classified as manually
added for audit trail purposes, and can be reviewed in the Manually Added
report, as well as the Transmission Log details.

1.7.7 Federal Reserve Bank Transmissions (FRB)

Federal Reserve Bank Transmissions (FRB)

Are you a bank and sending files directly to the Federal Reserve?

If so, please note that you reverse the ID numbers in the File Header (1
record).  
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1.7.8 Same Day ACH

Same Day ACH

The ACH network started accepting these same-day transmission files on
September 23, 2016 (for Originator's credits/payments out).  
On September 23, 2017, the ACH network will begin accepting same-day
transmission files for Originator's debits/deposits in.

Important concepts with Same-Day ACH:

--The effective date has always, and will continue, to control whether it is same
day or not.

--The features noted here are to satisfy the requirements of many banks that
are requiring the cutoff code in the descriptive date field (positions 70 - 75) of
the batch header (5 record).

1. Setting the effective / transaction date

If you are including a date within your import file, simply map the field as 'Date'.
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If you do not have a date within your import file, the system will use the default
date.  To set the default date, start the ACH File Setup Wizard and update the
default date on the fourth panel to read 'Same Day'.
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2. Populating the batch header's descriptive date field (70 - 75) with a
cutoff indicator

In addition to setting the effective date to today, many banks will want you to
insert a cutoff indicator into the batch header.
This indicator will either be a code for Same Day at 1:00 p.m. (SD1300) or for
5:00 p.m. (SD1700):
SD1300
SD1700

If you need to set this field with the cutoff time indicator, navigate to the Same
Day ACH options in the toolbar and check the top box, and select a default
cutoff time.

Notes: 

--ACH Universal will only insert the default cutoff indicator for those
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transactions that have an effective date for that day and that are not IAT
(International) transactions.
--International transactions are never valid Same Day ACH transactions.
--The NACHA Rules are phasing in debits and credits over a three year period
and currently have a $25,000 transaction limit.  

Rare - Mixing cutoff times

If you need to specify some transactions for the 1:00 p.m. cutoff and some for
the 5:00 p.m. cutoff (rare), you can map the column as the "Same Day /
Descriptive Date" field and populate that field as either SD1300 or SD1700. 
Each record must be populated.

If your in-house system is unable to prepare the file with SD1300 and SD1700,
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but can create an indicator, you can enter this into the Same Day ACH Option
window as well.
Each record must be populated.

1.8 Email

Email Notification

ACH Universal enables you to notify your customers, employees and vendors
of ACH transactions.
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--Each email only contains information regarding their transaction.

and the email template (body) can be fully configured by you.

--You do not need everyone's email to use this feature.  

For example, if you are collecting funds from your customers, but only a
percentage have provided you with their email address, that's okay.
ACH Universal will send out emails for the transactions with an email address,
and simply skip the others.

--Includes check stub information

If consolidating your records, or using QuickBooks, easily include one
consolidated email to each customer, employee or vendor.

--Send by Outlook, our hosted email, or any SMTP server
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Does it work with QuickBooks?

Yes, and there is a special integration feature that enables you to send the 'stub'
information for vendor payments.

Other types of emailing

Do you need to email the ACH file to your bank, or do you need to notify them,
(or an internal colleague) by email that you've created an ACH file?  If so, see
email notification at the file level.

1.8.1 Email Setup

Setting Up Email Notification

From the Home tab select Email > Email Setup.
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Welcome screen

Covers basic concepts and reminds users that they will need ACH Universal
Corporate or Processor level editions.  
Check the box to activate the feature and click 'Next'.

At this screen you have two main choices:
--Outlook Integration
--Advanced setup

This page follows the instructions for Outlook.  See the next page for the
Advanced setup.
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Note: If you have Outlook (or Outlook/Exchange)--always select the
Outlook option. 
 

Settings - Subject line and cc/bcc

Enter the subject line.
If another user needs to be cc'ed / bcc'ed enter it now.

Notes: 
--If you cc yourself, you will 'spam' yourself.  Remember, the email will be in
your Outlook 'Sent' mail folder.
--The 'From' address will always be your default Outlook profile.
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Email body (template)

Here you can fully customize the email message/body.

Please note the tags below (capitalized and within brackets) - such as [DATE],
[AMOUNT], etc.
These tags merge data from the transaction into the email body.
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After pressing Next you will be on the Check Stub screen.  Here you can
consolidate ACH transactions into one ACH transaction so
that only one email goes out.
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With the exception of the To: field (which is automatically filled in by ACH
Universal), all fields will be used for each email notification.  

CC Comma-separated list of email addresses to be copied. 

BCC Same as cc, except the notified party will be unaware of the copy. 
(Quickbooks users should always use bcc rather than cc.)

Subject Provide a subject for the email.  It should indicate the purpose of the
email. For example, "Transaction pending by TL Supply"

From
Email:

List the email addresses to be used as the reply-to email.  The
recipient can reply to this address. This address will be used to catch
bounced emails.

From
Name:

The name to use for the email.  Recommended is to use your
organization name or subgroup instead of a person. 

Click Next.

You will be be on the email template screen (Figure 3 below). 
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Note: There are different templates--one for debits and one for credits.

Information on this tab will be used for notification regarding all debit or credit
transactions. A basic notification email is provided by default.  You may
customize the email as you see fit by editing directly in the window.  Click the
Credit tab to modify settings for credit notifications.

There are variables available for use in the emails to provide customer-specific
information.  This list is available in the Help/Tags tab as well as at List of
Transaction Tags.

Note: The Memo tag holds the information for QuickBooks vendor 'stub'
information.

When finished editing all tabs, click Next.

In Figure 4 (below), you will provide the settings needed to transmit emails
using the email account you listed earlier.  These settings can be obtained from
your email client (for example, Outlook) or from your system administrator. 
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Enter the name of your SMTP server into the textbox.  Click the 'Security -
Authentication' tab.  
You will see Figure 5 (below).

Exchange Server:
1. Configure these panels to connect to your SMTP port.
2. Initially test with an internal address (within your domain)
3. Tip: The Exchange console setting under the Server Transport--choose the
internal connector.
4. Tip: Exchange's Network tab--add the IP address of the computer that will be
sending emails to the Exchange Server.

Security - Authentication panel

Enter your email credentials on the left side ('Outgoing email server requires
authentication').

Tip: Are you only able to send emails internally (to your domain), but fail when
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sending outside your domain?  If so, check your settings here. Make sure 'My
outgoing server requires authentication' is checked, and your User Name and
Password are correct.

If your SMTP server is configured with either SSL or TLS (gmail), then check
the box and leave 'explicit' as your initial setting.

When all settings are entered, go back to the Server Name tab and click Test
Email Setting.  Enter your email address.  If your settings are correct, you will
receive a system-generated test message.  If your settings are not correct, ACH
Universal will display a message.

When everything is correct, click Next.

Preferences 

You will be on the final screen.
The first two options are for our users integrating with QuickBooks:
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1. QuickBooks stub information - Check this to populate the Memo field with the
check stub information from within QuickBooks.

Important - Remember to have the '[MEMO]' tag placed in the body of the email
in the Debit (or Credit) template.  See Screen number 4 above.

2. QuickBooks account information - Typically unchecked for QuickBooks
users, this will display in the [MEMO] field your chart of account name for each
line item detail.

3. To transmit emails automatically, enable the 'Automatically... ' checkbox. 
These emails will be transmitted on a workstation level when you exit ACH
Universal.  If you do not check this box, you can trigger the email blast from the
Home tab by selecting Email > Send.

Click Finish to complete email setup.

How to enter email addresses



288

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

If you are:
--importing transactions, map 'ACH_Email_Address' to identify the email
address column.
--using ACH Universal Profiles, make sure that an email address is entered in
the Profile
--integrating with QuickBooks, enter an email address in the QuickBooks
Vendor, Employee or Customer profile.

Note: It is also possible to enter email addresses manually before transmission.
 See  Editing Untransmitted Records for more information.

Troubleshooting

Can't get an email out?  

1. Check that your anti-virus software is not blocking you.
Norton Anti-virus and other packages may quarantine the file:
TreasurySoftware_email.exe 
when it attempts to send  out emails.  Make sure that you add this file to your
'white' list.

2. Confirm that there are no firewalls, such as Microsoft Windows Firewall, that
could be blocking you.

3. If using Exchange server, make sure that you have proper permissions, and
that your computer IP address has been added to the sender's list.

1.8.2 List of Transaction Tags

List of Transaction Tages - Overview

Below are the tags you can use in email notifications to tailor each email to the
individual recipient.  To use the tag, insert it into the appropriate space in the
email.  

Transaction Tags

Tag Definition

[DATE] Effective transaction date
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[AMOUNT] Transaction amount

[NAME] Name of party receiving the notification

[ID] An identification number for the receiving party.  For
example, employee ID or vendor ID.  Do not use
Social Security number. If you must use the SSN,
see [ID_LAST4]

[ID_LAST4] Uses only the last 4 digits of [ID]. Useful when a
Social Security number must be used to mask the
majority of the number.

[ACCOUNT] For backward compatibility.  Does exactly the same
as [ACCOUNT_LAST4]

[ACCOUNT_LAST4] Display only the last 4 digits of the account number.

[ABA] ABA/Routing number

[BATCH_DESCRIPTION] Description of the batch containing this transaction. 
Rarely used.

[ACH_CHECKINGORSA
VINGS]

Displays 'Checking' or 'Savings' for the appropriate
account type

[ADDENDA] Display the transaction's addenda record, if any. 
Maximum length of 255 characters.

[EMAIL] Display the email address being notified

1.9 Remote Desktop Services (RDS)

Remote Desktop Services - RDS (formerly called Terminal
Services)
and Citrix Server

This topic covers both clustered and single server configurations.

Overview

Treasury Software is a 'client-server' application, in that there is a front-end,
also called an executable, and a back-end where the data is stored.
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In a sense, one can even think of Microsoft Excel as being a client-server
application, in that the program is installed on each user's computer, and that
the data is stored in a back-end spreadsheet. 

Treasury Software Server (back-end)

In Treasury Software, the data can be stored in our single-user desktop
database, or it can be stored on a SQL Server.
Using SQL Server enables many users, each running the client on different
computers, to access a central database. 
The limitation of this scenario is that if there are 20 users, the software needs to
be installed on 20 different computers.

What if you have an application server, or if you only want to install the software
once and have your users remote into this one computer?  Use our Remote
Desktop Services (or RDS) feature.

Treasury Software Client (front-end)

By default, Treasury Software can only be used on any given machine in a non-
concurrent manner.

However, with the introduction of our Remote Desktop Services feature, you
can configure an application server, or any computer, to enable multiple users
to concurrently use the software, 

Note: This feature is available with SQL Express and SQL Server platform
licenses.

Setup:

To start the Remote Desktop Services Wizard - enter into any account and
select the Settings tab > Migrate to Remote Desktop Services, Citrix. Select
Next.

Tip: To minimize your time, enter license codes and migrate to SQL prior to
enabling Remote Desktop Services.
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Select a Working Directory

Your users need a working directory to save transmission and report files,
export to Excel, and archive import files.
By default, the system uses a directory tree in the Users\Public folder to make
sure all users have access.

However, if non-Treasury Software users have access to this computer, it may
be a security risk to leave the directory tree in this path.
We would then recommend selecting another location, and securing it for your
Treasury Software authorized users.

Clustered environments:  Make sure that you select a drive location on a non-
clustered server.
Note: Treasury Software does not support working directories for desktop
platform databases on a different computer.

Click Next.
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Confirm and complete the migration.

Click Next
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Congratulations! - Click Finish.

**** Exit and re-enter into Treasury Software to initialize your changes ****
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1.9.1 RDS - Maintenance

Remote Desktop Services - Maintenance

How it works

Prior to enabling this feature, Treasury Software creates a directory tree in the
Users\Public folder.
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The software uses the file 'accounts_201201.brd'  to hold (where 201201 is the
year-version number), amongst other items: account catalog information, the
SQL Server name, the SQL ID and password (RSA encrypted).

The 'accounts_201201.brd' file is user specific.  It is not designed for concurrent
use.
Therefore, this would not be the correct infrastructure for multiple users.

To accommodate multiple users, the software needs to create an
accounts_201201.brd for each user.

Once Remote Desktop Services is turned on, the system will look into the 
c:\Users\Public\Treasury Software\Users directory for a user's file.
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The syntax for the account would be accounts_[Windows login id]
_[version].brd.  

When a user starts the software for the first time, the software looks to see if
they have a file.  If not, the system will create the file in the c:
\Users\Public\Treasury Software\Users directory.

The system will use c:\Users\Public\Treasury Software\accounts_201201.brd
as a template and copy it to the directory.  The system will also insert the user's
windows login ID to the newly copied file.

Using the example above, after migrating to Remote Desktop Services and
having four users log in, the system will create four account files in the Users
folder of Treasury Software.

Once the software creates the user accounts, by design, there is no active link
between these files and the template.

Maintenance:

Normal Maintenance - Leave Remote Desktop Services On

For all normal maintenance, leave Remote Desktop Services on and repeat the
entry with the users.
This includes license keys, new accounts, etc.

Non-recurring Maintenance - Turn Remote Desktop Services Off



297

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

What if there is a global change for all users, such as a new SQL Server?

1. Turn off Remote Desktop Services in Treasury Software (File > Maintenance
> 'Other' tab > 'Reset Remote Desktop Services' button).  A password will be
required.  Exit and re-enter into the software.
2. Enter into Treasury Software and make your changes.
3. Delete the user's (typically all) files in \users\public\Treasury Software\users\
using Windows Explorer
4. Turn Remote Desktop Services in Treasury Software on (File > Migrate to
Remote Desktop Services)

When the users log back in, the updated accounts_201201.brd from the root
will be used as a template for each user.  This file will, of course, have the
updates.

1.9.2 RDS - Directory Location

Remote Desktop Services - Directory Location

Why does it matter?

By default, the software creates the working directory tree in
\Users\Public\Treasury Software.
If you are creating ACH files or running reports, a copy of this information will
remain in this tree structure (\Archives, \Reports). 

If this computer is accessible to non-Treasury Software users, this would
provide these users with access to sensitive information.

To prevent this, we recommend using the Remote Desktop Wizard to create a
new directory for your company.  This folder structure would then be locked
down to other users by your network administrator.

If you have not yet migrated to Remote Desktop Services within
Treasury Software, you will have the ability to select the parent directory in the
Wizard.
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If you already migrated to Remote Desktop Services within Treasury
Software:

1. Turn off Remote Desktop Services in Treasury Software.  From the Settings
tab select Maintenance > Other >Reset Remote Desktop button.  A password
will be required.  Exit and re-enter into the software.

2. Enter into Treasury Software and start the Wizard again (Settings tab >
Migrate to Remote Desktop Services)
Select your target directory and complete the wizard.

Note: Treasury Software only supports SQL Express and SQL Server when a
working directory location is selected on another computer.

1.9.3 RDS - Clustered Servers

Remote Desktop Services - Clustered Servers

There is no difference in the use of clustered servers versus single servers.

Below are tips to minimize the work during installation and maintenance.

Installation

1. Install the software on one server.  We will later refer to this as the 'original'
server.
2. Start the software.  Upon starting Treasury Software, it will copy the working
directory tree to C:\Users\Public\Treasury Software.  We will refer to this
directory as the 'root'.
3. In the root will be br_201201.txt (where 201201 is the year-version).

If you open it, you'll see the last three lines as:
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***Note - Never manually update this file.***

This tells you:
Citrix=False
You have not enabled Remote Desktop Services yet.

CitrixTestDrive=False
If you are using a directory other than the default directory.  If you continue to
use c:\Users\Public\Treasury Software as the default directory, this will be
'False'.  If you change the directory, it will 'True'.
If you have not yet enabled Remote Desktop Services, this will be False.

CitrixTestDriveUserPath=x:
If you are not using the default location, this will hold the new location of the
working directory.

What you'll want to do is update all of your settings on one server, and then
copy this file, along with some other files, to the other servers (details to follow).

4. Migrate to SQL Server (Settings tab > Migrate to SQL Express, SQL Server).
 Enter your license ID.  Enter all information that you can (you can always
update later).  Exit and re-enter the software.
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5. Migrate to Remote Desktop (Settings tab > Migrate to Remote Desktop
Services).
Select a non-clustered location for your working files.  Exit and re-enter the
software.
If you look at the BR201201.txt file now, you'll see the updates:

Finished with the first server.  Repeat this for all the other servers in the
cluster.

1. Install the software on the next server (current server).

2. Copy the entire directory tree from the original server to the current server.
Specifically, copy from the original server C:\Users\Public\Treasury Software\
to the current server C:\Users\Public\Treasury Software\.
Include all the subdirectories.

Test this for permissions before you go to the next server.  Simply start
Treasury Software on the current server and make sure it loads and exits
properly.

Note: This can only be done with SQL Express and SQL Server platforms.  It
will not work with the Desktop edition.
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Once you have tested, repeat with the balance of your servers.

At this point, you have set up the servers exactly the same.

No other maintenance is needed.

1.10 QuickBooks Pro, Premier and Enterprise

You can create ACH (also known as NACHA) files directly from
your QuickBooks data.

ACH Universal allows you to easily create ACH transactions for:
• Direct Deposit for employees
• Collections from customers
• Payments to vendors and governmental agencies

Starting with ACH Universal 2011, ACH enables direct integration with
QuickBooks, enabling you to store your banking data on each profile in
QuickBooks.
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Benefits of direct connection:

--Simple to install and use. Doesn't change the way you work with QuickBooks.
 Keeps all of your processes the same.  Pay vendors and employees, collect
from customers as you currently do.

--Create ACH files for your bank with 'one-click'

--Avoids duplication of processes and transmissions

--Full control over payments and collections with your bank.  Enables you to
temporarily hold a transaction, stop a transaction, and even resend a
transaction.  

--Assists with the transmission of the ACH file to your bank.  Your bank, not a
processor, will handle the transactions.

--Send email notifications to your customers, employees and vendors.  Send a
detailed payment stub to your vendors including invoice number, net pay
amount and discount taken.  
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   Date        Bill Paid    Disc Taken     Ref. No.
----------  ------------  ------------     ------------
03/05/2011     $5,555.00         $0.00     510      
03/05/2011       $385.89         $5.99     511      

Direct Integration is available if you are on QuickBooks
--Professional,
--Premier, or
--Enterprise.  
The editions must be 2003 or later and US-based.  

Direct Integration is also available with QuickBooks Online.

Not on one of these packages?  Don't worry--many of these features are
available with our Treasury Software profiles-based integration.

QuickBooks® is a registered trademark of Intuit

1.10.1 Setup - QuickBooks based profiles

Setup - QuickBooks Based Profiles

Step-by-step checklist 

ACH Universal and QuickBooks are installed on the same computer. 
 
Note: If you have a multi-user edition of QuickBooks, you do not need to install
ACH Universal on all of the other computers.  Just install it on the computers
that will be creating ACH files.  For now, just install on one.

Need to download?  Go to http://www.treasurysoftware.com/download/index.aspx

Start Treasury Software and at the 'Welcome New User' screen, enter into
ACH Universal (top selection).
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Create a new account in ACH Universal

From the main menu select File > New Account

The top option “Create an Account and Add it to your Catalog” should already
be selected.  Click Next.
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Enter a name for the account. This name is strictly internal and should help you
identify the purpose of the account. For example, if you are using ACH
Universal for payroll, you might name the account Payroll.  Once the name is
entered, click Next.

Congratulations! You have finished creating the account. Click Finish to begin
using this account. 

If prompted to edit/modify your transmission information, click No.

Congratulations!  You are done with your basic setup.

Next step - Connect to your QuickBooks company

QuickBooks® is a registered trademark of Intuit

1.10.1.1 Connect to QuickBooks

Connect to QuickBooks

First time connection (a one-time setup)

Before you begin, confirm that:
--ACH Universal and QuickBooks are both running on the same computer, and 
--With QuickBooks open, you are logged in as the administrator for the
QuickBooks company you want to work with and you are in single-user
mode.

Start the connection process

Enter into your account and select the QuickBooks tab > QuickBooks
Integration.
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Switch to your QuickBooks window

If nothing appears to be happening, QuickBooks is waiting for you to grant
permissions.  

Click on your Windows toolbar to access QuickBooks.

The first time ACH Universal attempts to connect to your QuickBooks company,
you will be prompted by QuickBooks to grant access.  

Note: You can leave the bottom check box un-checked.
Please grant access to continue.
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QuickBooks will prompt your confirmation. 
Click 'Done'.
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Note: If you do not grant access, you will be unable to continue.

Congratulations, you have connected.

Note: If you upgrade Treasury Software, change versions in QuickBooks, or
install the software on a new computer, you may be prompted to grant
permissions again.

Next step - Integration Wizard

Troubleshooting - Can't connect?
See Troubleshooting connections

QuickBooks® is a registered trademark of Intuit
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1.10.1.2 Integration Wizard

Integration Wizard

Once you have connected to your QuickBooks company, you can complete the
Integration Wizard.

Reminder:  You should be in single-user mode in QuickBooks with only
one QuickBooks company open for the initial setup.

Enter into your account and select the QuickBooks tab > QuickBooks
Integration.

Note: This is the same menu choice you selected earlier to establish a
connection.  Once a connection has been made, the settings are automatically
saved--it is a one-time setup.

Welcome to the QuickBooks Integration Wizard

Click 'Next'.
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View the list of your QuickBooks accounts - select your bank account

Have more than one origination account?  We'll cover this in settings.
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Confirm that 'QuickBooks profiles' is selected, and that the profiles you
want to work with are checked.

This step will create three Custom Fields in your profiles.
QuickBooks Pro, Premiere and Enterprise should leave the default top option
selected. (See below)

If a profile group is unchecked, and it is one you need, stop here and close the
Wizard.  You may need to remove some existing custom fields for that profile
group.

[Note: If you are using QuickBooks Online, select ACH Universal profiles.] 
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You must be in single-user mode and logged in as an Admin.  If you need to,
make the changes in QuickBooks, then close QuickBooks and re-enter.
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Click 'Finish' to save your settings



314

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

In QuickBooks - enter banking information

Now working in QuickBooks, enter in the banking information as shown above
for the customers, employees and vendors that you want to collect from or pay
electronically.

To enter banking information for:

Customers - From the QuickBooks main menu select Customers > Customer
Center.  
Double click on the customer, and then select the 'Additional Info' tab.  Enter
their banking info, then click 'Save'.

Employees - From the QuickBooks main menu select Employees > Employee
Center.  
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Double click on the employee, and then select the 'Additional Info' tab.  Enter
their banking info, then click 'Save'.

Vendors - From the QuickBooks main menu select Vendors > Vendor Center.  
Double click on the vendor, and then select the 'Additional Info' tab.  Enter their
banking info, then click 'Save'.

Next step - ACH Setup - Entering your company's info

1.10.1.3 ACH Setup

ACH Setup

Access the ACH Setup Wizard by clicking either the ACH Setup icon on the
ACH Universal home page (below), or on the ACH Setup icon under Settings,
in the top toolbar.
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Welcome to the ACH Setup Wizard
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Enter the 'file header' info (see below).  This identifies you and your bank.

1. If you received this information from your bank, enter it exactly as noted.

2. Otherwise, if you have already created ACH files using Notepad or another
software process, and you have access to this file, ACH Universal can import
the settings from that ACH file.  Simply click on the link 'Populate header entries
from an existing ACH file'.

3. Or, you will enter this manually. Follow the text in the Wizard.
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Enter the 'batch header' info.  This is often a subset of the file header.

1. If you received this information from your bank, enter it exactly as noted.

2. Otherwise, if you clicked on the link 'Populate header entries from an existing
ACH file', do not modify your entries.  Your entries have been populated.

3. Or, if you entered the prior screen manually, click on the 'Auto-fill' link.  This
will populate your entries based on your earlier entries.

Leave the Standard Entry Class as defaulted (PPD), unless noted otherwise.
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Finish the Wizard

If your bank requested a balanced file, or an offset record, check the box at the
top of this screen and enter the information.
Click 'Finish' to save your work.
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Next step - Create an ACH file - for testing or sending to your bank

1.10.1.4 Troubleshooting-Setup

QuickBooks Troubleshooting - Setup

When setup is successfully completed, three custom fields should have been
created within QuickBooks (see below).

However, if the software brought you to this page, the setup didn't create the
three fields needed.
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To fix/check this, we need to go to QuickBooks

In QuickBooks, navigate to either the Customer, Employee or Vendor Center.
In this example, we'll navigate to the Vendor Center.

The first profile (vendor) will be displayed by default.  Simply click on the edit
button on the upper right.
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On the profile window, click on the Additional Info tab, then 'Define Fields'
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The three field names that should appear exactly as shown are:
- Bank Account Number
- ABA Routing Number
- CHK/SAV

If you had a typo or had to re-enter a field, you can stop here, close the edit
window and try the Integration Wizard again.
Tip: Don't forget to check the boxes for the profiles you want to display
(Customers, Employees, Vendors).

I don't have any of ACH Universal's fields.

You may not have enough available custom fields.
The maximum number of custom fields in use (checked boxes) for each profile
type (Customers, Employees, Vendors) is 7 for Pro and 12 for Enterprise.
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To fix:  Uncheck fields that you do not need.  

Pro and Premiere users:
As there is a 7 field limit, the most check-marks that you can have in a column
is 4 (as ACH Universal will need to create 3 in each profile).

Enterprise users:
As there is a 12 field limit, the most check-marks that you can have in a column
is 9 (as ACH Universal will need to create 3 in each profile).
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Tip: You only need to unmark check-boxes for the profile types (Customers,
Employees, Vendors) that you will be using with ACH Universal.

Once you have updated the fields, click OK and close the profile edit window.

In ACH Universal, you can reselect the QuickBooks Integration Window and
click 'View Transactions'.  You will get the same message as before, but on the
following screen you can opt to re-run the Wizard (please do so to complete).

Note:
If you have upgraded, and did not have a CHK/SAV field, you can over-ride this
verification:
Select the Settings tab > click 'Import, System' > 'Import' tab > QuickBooks
suppress field warning > select 'suppress'.

1.10.2 Creating ACH Files

Creating ACH Files

Once you have completed your setup, you can create ACH files.

If you just need to send a Test file:

1. Change your 'From' and 'To' dates to historical/old transactions which you
have already fulfilled.  You can then send that ACH file up to your bank for
testing.

2. Just starting out and don't have any historical data?  See our Utilities tab to
create a pre-note file.

Step 1. Adjust dates, if needed, and then click on the 'View transactions'
button.

This will display all available records within the date range.  
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Step 2. After reviewing the records, click the 'Send to ACH Universal'
button.
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Congratulations!  Note the location of the ACH file.

The file will always be saved at this location.
Want to change the location, or see archived ACH files?  Go to our Creation
page.
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Transmission

Once the file is created at your location, it must be transmitted to your bank to
be fulfilled.  
Otherwise, it's like writing a check, but not mailing the check.

Next step - Transmitting the ACH file

1.10.3 Transmitting ACH files to your bank

Transmitting ACH Files

How you transmit to the bank depends entirely on your bank's options or
directions for receiving the files.

To view the options available to you through ACH Universal, select the Settings
tab then Transmit to Bank.
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There are five choices available as a transmission method.

Methods

None The ACH file will be created and archived, but it will not be
transmitted.  You must transmit the file manually.

FTP After creation, ACH Universal will transmit the file to the FTP server
you specify.  This should be your bank's FTP server.  Includes SSL
capability.  Contact your bank for information on their requirements. 

Web
Upload

After creation, your default Internet browser will be started to a
specified web page that corresponds to your bank's upload portal. 
Upload the created file.
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Email ACH Universal will email the created file as an attachment to the
email addresses specified. This method is not recommended as it is
unsecured.

Other For integration with third party utilities.  Enables the use of SSH, SSL
with certificates and OpenPGP. Note: OpenPGP is not the same as
PGP.  

Web upload

The vast majority of our clients upload the ACH file through their bank's web
portal.
If this is the case with you, select the third option 'Web Upload', and enter your
bank's URL address to login.

Then, whenever you create an ACH file, ACH Universal will open an instance of
your default browser to that login page.  Think of it as an 'electronic sticky-note
reminder'.

See Changing File Transmission Method to set up the transmission method as
required by your bank.

1.10.4 Paying some vendors by check - some by ACH

Want to pay some vendors by paper checks - and some by ACH?

Yes, it's easy to do with ACH Universal.  

ACH Universal can write back a unique reference number to QuickBooks, using
a different numbering sequence - even alphanumeric (such as ACH100,
ACH101, etc...).

This enables you to run ACH transactions first - then when you go to
print vendor checks - those processed by ACH Universal will not print
paper checks.
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Note: This feature is designed for Vendor payments.  Employee payroll checks
cannot access this feature due to security set by QuickBooks.

One-time Setup
Turn ON - From within the QuickBooks Integration Window, click on Settings >
ACH Settings > Other Settings and check the box below.
Want to set additional options?  Click on the 'Write back Options' - and this will
open the settings screen (2nd screen shot).
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Write Back Options
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1.10.5 Holding and resending transactions

Holding and Resending Transactions - Advanced Record Control
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From the QuickBooks Transactions window (from the QuickBooks tab >
QuickBooks Integration), once you click in 'View Transactions', several
advanced record control options appear.

Note: All of the check boxes are checked by default.

Hide transactions missing banking information

As you may not be collecting and paying electronically from all of your
customers, employees and vendors, this option suppresses those profiles who
you are not paying or collecting from electronically.

Example: You have 50 employees and 40 of them have signed up for Direct
Deposit.  
By default, when viewing this screen, only the 40 employees on Direct Deposit
will be displayed, as these are the electronic transactions you will be creating.
If you want to view the other 10 employees who will be paid by paper check,
uncheck the box.
Note: Viewing the other 10 will have no effect when creating an ACH file.  They
will not be included in the ACH file as these employees do not have their
banking information stored in their profile.

Hide transactions already processed

If the date range you select includes a previously processed transaction, by
default ACH Universal will suppress displaying the transaction.

Note: Viewing previously transmitted transactions will have no effect when
creating an ACH file.  They will not be included in the ACH file, as these
records would be considered duplicates.

Caution:  If you are using a multi-user version of QuickBooks, but only a
single-user version of ACH Universal, not all transactional history may
be in your desktop audit trail.  
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Electronic transactions processed by others will not be marked as duplicates
(already imported) in your system.

You can accommodate for this by marking these records as 'Do not transmit'.

Advanced Record Control

To use any of these Advanced Record Controls - first select the transactions
(the row will highlight in blue), and then click on one of these buttons.

Do not send (temporary)
Enables you to temporarily hold a transaction from being sent to ACH Universal
and, therefore, not being included in the ACH file.
Caution - This is a temporary marking.
If 'View transactions' is clicked, or the report is re-run, your selections will be
reset.

Example of use: A customer authorizes you to draft funds from their account,
but at the last minute asks you to wait another day to perform the draft.

Do not send (permanent)
Enables you to permanently hold a transaction from being sent to ACH
Universal and, therefore, not being included in the ACH file.
Your selections are saved to the ACH Universal database.  Clicking 'View
transactions' or re-running the report has no effect on your selection.

Example of use: You received goods from a vendor and created the payment in
QuickBooks.  
However, before processing, you realize the goods are damaged and the
vendor is not being cooperative. Select this transaction and place it on
permanent hold.
When you have come to terms with your vendor, you can mark it to be paid by
using the 'Send' button described below.

Send (over-ride)
Enables you to resend a transaction that (ACH Universal says) you have
already sent, or to send a transaction that you have placed on hold.

Example of use:
--You marked a transaction as 'Do not send (permanent)', but now want to
release payment.  Use this button.
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--If you sent a payment to a vendor or employee, but the transaction was
returned as they closed their bank account and neglected to tell you.  You can
resend the transaction using this button.

QuickBooks® is a registered trademark of Intuit

1.10.6 International (IAT)

Creating ACH-IAT files from within QuickBooks.

With this feature, you can create a NACHA compliant ACH-IAT file to upload to
your bank.

One-time setup
1. Create a new account within ACH Universal
Click on File > New Account.
Note: You will need to create a separate account within ACH Universal, apart
from your typical transactions.

We recommend that you call the new account 'International' or similar to help
you distinguish it from your other accounts.

2. Click on the QuickBooks Integration icon to start the Wizard.
During the setup wizard:
--select the ACH Universal Profiles option, and
--check the box 'Process only International transactions'
continue and complete the wizard.

When finished, simply close the QuickBooks Integration Wizard to continue.
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3. Enter your banking information for the IAT record.
On the Home tab, click on the lower half of the Add a Record icon.  From the
drop down, select International.

The International Window will open.
On the left-side, enter your banking information as appropriate.
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3a. Click on 'Save to Profile'
3b. Then, click on 'Set this profile as the default'

4. Enter your vendor's banking information for the IAT record.
When finished, click 'Save to profile'.

To add a new profile, click on the name drop down on the top and select <<Add
a Profile>>.

Continue adding as many international profiles are as needed.
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Important:  The names that you enter MUST MATCH EXACTLY as to as you
have entered the name within QuickBooks.

Daily use
Enter transactions into QuickBooks as usual.

When you are ready to create your transmission files:
1. Within ACH Universal, enter into your 'typical' account.
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When you create your 'typical' transmission file - the International transactions
will not be included in it.

2. After you complete step 1 - within ACH Universal, switch to your
'International' account.
When you create your 'International' file - only the International transactions will
be included.

Transmit both files to your bank as instructed.

Release notes:
This feature will be fully released on May 15, 2018.
The release applies to QuickBooks Pro, Premier and Enterprise.
The release will not initially support encryption.

1.10.7 Settings - ACH Universal

Settings - ACH Universal

The Settings tab can be accessed from the ACH Universal main menu -
QuickBooks > QuickBooks Integration > Settings tab.

Within the Settings tab, by default, the General and Advanced tabs are
available.

General tab

In the General tab, you can add or change the QuickBooks bank account that
holds your transactions.
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Common Settings
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1.10.8 Troubleshooting-Connections

QuickBooks Troubleshooting - Connections

Note: You must be logged on in QuickBooks as an administrator and in
single-user mode (just the first time). 

If nothing appears to be happening, QuickBooks is waiting for you to grant
permissions.  
Check to see if there is a pop-up screen in QuickBooks prompting you to grant
access.
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Click on your Windows toolbar to access QuickBooks.

Please grant access to continue.

If not, confirm the following:

1. In QuickBooks, you must be logged on as an administrator (repeated
from above).

2. Switch to QuickBooks single-mode and have only one QuickBooks
company open.

If you changed either #1 or #2, completely exit out of QuickBooks and restart
QuickBooks.
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Steps #1 and #2 account for virtually all connection issues.  Below are some of
the additional steps that our support department may check for in rare
occurrences.

3. Is there a pop-up or notification in QuickBooks?  If so, close the pop-
up.

Note: If you have been prompted to update QuickBooks, please do so.  You will
not be able to connect until you have updated.

4. Is QuickBooks installed on the same computer as Treasury Software?

5. Are you running a QuickBooks Pro, Premier, or Enterprise edition -
U.S. version - of QuickBooks 2003 or later?

6. Have you or your administrator turned off access to the QuickBooks
database?

From within QuickBooks, select from the main menu Edit > Preferences >
Integrated Applications > Company Preferences.  Verify that the checkbox to
disable integration remains unchecked.
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7. Using Vista?

Vista's User Access Control must be enabled.  This is a limitation under Vista
only.
From your Windows Operating System, select Control Panel > User Accounts >
User Access Control.

8. Do you have proper security rights in QuickBooks to grant access?  

Check this by entering into a sample account within QuickBooks.  Then try to
connect from within Treasury Software.  If you can connect to the Sample
account, but not your other account, this is a permissions issue.  Have your
QuickBooks administrator grant access to Treasury Software.

QuickBooks® is a registered trademark of Intuit

1.10.9 QuickBooks Security

QuickBooks Security

The default user security enables all users for all versions of QuickBooks
to run Treasury Software.

This page is for Enterprise users who grant specific user permissions, and
want to make sure that each user has the lowest level of rights granted.

From within QuickBooks select Company > Users > Set Up Users and Roles
....
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On the pop up window, select Role List > the role you want to edit (in this
example Accountant14) and then 'Edit'.
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There are only two 'Areas and Activities' that ACH Universal requires: Centers
and Reports.

Centers

Click on the plus sign next to Centers.  ACH Universal requires at least 'Partial'
access for all three areas within Centers.  Even if you're not utilizing all three
areas, follow the instructions as the system needs to loop through each,
regardless (at that point, the system will see you're not using it).
Note: For Customer Center, the 'View Balance' needs to be checked.
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Reports

Click on the plus sign next to Reports.  ACH Universal requires at least 'Partial'
access for:
-Accountant & Taxes
-Customers & Receivables
-Employees & Payroll
-Vendors and Payables

Even if you're not utilizing all areas, follow the instructions as the system needs
to loop through each, regardless (at that point, the system will see you're not
using it).
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Click OK to save your work.

You're all set!

Reminder:  We've documented above the minimum permissions to use ACH
Universal.  For the initial setup, please use a QuickBooks admin account.

QuickBooks® is a registered trademark of Intuit

1.10.10 Direct Deposit

Direct Deposit with QuickBooks Integration
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During the initial Integration set up, three fields are automatically created in

each employee’s profile. These fields are Bank Account number, ABA /

Routing number, and the Checking or Savings field.

When these fields are filled, ACH Universal knows the employee is to be paid

by Direct Deposit, rather than by check. Once banking information is complete

for all employees paid by direct deposit, you’ll be ready to run your first payroll.

Payrolls containing both direct deposit and check payments can be processed

with one of two methods:

1. Method one is to run a single payroll. If you’re already running payroll this

way, your current process won’t change.  However, checks will be

printed for all employees--both those paid by Direct Deposit as well as

those paid by check. This means the checks printed for employees on

Direct Deposit must be voided.

2. Method two is to run two payrolls--one for the employees paid by Direct

Deposit and one for those paid by check. We highly recommend using

this method, first, because you won’t need to void checks and, second,

because it creates a clearer audit trail.  While this option requires some

initial set up, the QuickBooks Scheduled Payroll feature makes it easy.

You simply separate employees into two groups according to how they

are paid--one group for those getting checks and one group for those

paid by Direct Deposit--and run payroll for both. 
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If you want to use Method Two (above) and simplify your payroll, this is how you

can set up groups quickly and easily using Scheduled Payments.

To create a scheduled payroll group, from QuickBooks main menu select:

Employee > Add or Edit Payroll Schedules.
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On the Payroll Schedule List screen, select: Payroll Schedule > New. We will

call our group No Checks but you can choose any name. Select your payroll

frequency, enter the next period end date and payroll date, then Okay to finish.

 Repeat this process to create a second group called Print Checks for the

employees receiving checks.
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Next, assign each employee to a group. Select Employee Center and Edit

Employee.
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From the Change tabs drop down, select: Payroll and Compensation Info. 

This employee signed up for direct deposit, so we’ll select No Checks in the

payroll schedule drop down.     
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Repeat this process to assign each employee to a group according to how

they’ll be paid. As a reminder, our custom banking fields were created on the

Additional Information tab. ACH Universal uses the information in these

fields to create your ACH Direct Deposit file. If an employee’s Bank Account

and ABA Routing number haven’t been entered, a transaction will not be

created.

Now we’re ready to process our payroll. If you’re processing a single payroll

and haven’t divided your employees into groups, at this point you’ll process

your payroll as you normally would. If you’re processing payroll for two groups,

from the main menu select Employees > Pay Employees > Scheduled

Payroll.
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First select the No Checks group. Enter hours or update the payroll as you

would during any normal payroll process. 
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From the Bank Account drop down confirm that the checking account

selected during Integration setup is the default account. 

On the next screen change the Paycheck Option from 'Print paychecks from

QuickBooks' to 'Assign check numbers to handwritten checks'. While the

check number field can contain more characters, keep it simple and enter DD,

for Direct Deposit.
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As a reminder: perhaps the single most important detail to remember when

processing payroll is to always be sure 'Assign Check Numbers' is selected

when running direct deposit. Note also the Net Pay total.  You’ll use this as a

control total to confirm your direct deposit / ACH control totals.  

To process payroll for the paper check group, follow the same steps with two

exceptions: First, set the print option to Print checks (not "Assign Check

Numbers") from within QuickBooks, and second, select to 'print paychecks',

not 'pay stubs'. 

 Go to ACH Universal. From the main menu select QuickBooks > QuickBooks Integration.
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Assign the date range and then select View transactions.  Only the direct deposit payroll

transactions should appear in the window.  
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Confirm the totals and count, and then Send to ACH Universal to create your ACH file. We

can view the file if we want to check it one last time. When done, transmit it to your bank as you

would any other ACH file.

QuickBooks® is a registered trademark of Intuit
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1.10.11 Pay Cards

Pay Cards

Starting, or thinking of paying your employees with a pay card?  No problem.
ACH Universal enables you to electronically pay your employees, whether they
have a bank account or a pay card.

What's a pay card?

A Pay Card is a reloadable debit card, with either with the Visa or MasterCard
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logo. 
It is an alternate way for employees that do not have bank accounts to receive
their pay electronically. It takes the place of paper paychecks and works in a
similar manner as a debit/credit card. 

Each payday the Pay Card is reloaded with the employee’s net salary and
employees have the option of withdrawing money from ATM's or using it to
purchase goods and services.

I'm working with a pay card provider now - what are the next steps for
me?

1. Contact your pay card provider for account information.
Your pay card provider will provide you the details on how to pay your
employees.  In other words, they will explain how to 'load' each card with the
employee's net pay.  This information will include the Routing Number (also
known as the ABA number) of the bank processing the cards.

They will also include a detailed list of the issued pay cards with:
--each employee's name
--a unique account number for each pay card

2. Contact your bank to request ACH file service.
Call you bank and ask for the Treasury Services department.
Once you are speaking with a representative from the Treasury Services
department, let them know that you would like to upload an ACH (a.k.a.
NACHA) file.  Explain that this will be used for ACH payments (credits).

Tips: 
--When calling your bank's Treasury Services department, avoid the use of the
terms 'payroll' and 'direct deposit' as they may transfer you to the wrong
department, as they may provide payroll services like ADP and Paychex.
--Do not call or visit your local branch as they are typically focused on retail
(consumer) banking, as opposed to business banking, and may not be familiar
with ACH file services.

Once you are signed up for ACH File service, they will provide you with certain
information that needs to be included in an ACH file.  

Once you have the information from #1 and #2 above, proceed to the next step.
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3. Set up ACH Universal
Our support staff can walk you through the following two steps.  In addition, the
software has built-in training videos which cover these two steps:

a. Run the ACH File Setup Wizard to enter key banking information.

b. Enter your employee's account information
Within ACH Universal, you'll run the QuickBooks Integration Wizard - which will
create three fields in each employee's profile within QuickBooks.
Bonus: The software can also create these fields in your vendor and customer
profiles so you can pay and collect from these groups as well.

Congratulations.  You're all set.

QuickBooks® is a registered trademark of Intuit
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1.10.12 Email - QuickBooks

1.10.12.1 Email Overview - QuickBooks

Email Overview - QuickBooks

ACH Universal enables you to send individual emails for any QuickBooks
initiated transaction.

Reduces 'Returns for Insufficient Funds' collections from clients.
Typically used by utilities, municipalities and others who collect funds from
consumers on a recurring basis, but with a non-standard amount.

'Electronic remittance stub' - cuts down on vendor calls
Lets the vendor know which invoices you are paying.

Create your own personalized template that will be sent out to each individual -
with only their information.

Email setup
Please setup email if you have not done so already:
Setup and configure ACH Universal's email

QuickBooks specific details
The most significant advantage of using ACH Universal to email notifications, is
the ability for the email to contain the check 'stub' information.

Make sure that you have elected to click on the 'stub' checkbox on the last page
of the Email setup (see above link):
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As an example, below is what your email can look like.

Sending out 'item' details?  ACH Universal can accommodate this as well:
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Note:  ACH Universal is able to email Vendor detail information down to the level QuickBook gives
that information such as detail Expense and Item information in a check that is written.  Bill Pay
stub information is not available to be emailed to clients due to Quickbooks does not show that
detail in the bill to be paid screen.

Payroll stub information
You can send payroll stub information through QuickBooks (not through ACH
Universal).
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Then, 

The emails will be password protected

You can then send out the emails from the QuickBooks main menu File > Send
Forms.
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1.10.13 Testing

Want to take ACH Universal for a test run?

If so, this page is for you.  

Steps:

1. If you haven't done so already, download the software from the link below
and install on the same computer that QuickBooks is running on.
http://www.treasurysoftware.com/download/index.aspx 

2. Start the software to arrive at the 'Welcome New Users' page and click on
ACH Universal

3. You will be brought to our Getting Started page.  
We recommend viewing the 5-minute tutorial video on the right (Getting Started
with QuickBooks).

http://www.treasurysoftware.com/download/index.aspx
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4. Start QuickBooks and enter into a company.  
You can use either the service-based business or product-based business
(QBW file) to follow along on this demo.
In the example below, we are using the sample company, Larry's Landscaping
& Garden Supply (service-based business).
Note: For the initial setup, you must be in single-user mode with admin rights.
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5. In ACH Universal, click the 'QuickBooks' tab on the main menu, then
QuickBooks Integration.

6. This will prompt QuickBooks to display a security authorization window--it
will be flashing in your taskbar.  
Click the icon in your taskbar to view the Application Certificate form below.
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You can opt for either the 3rd option (typical), or the 4th option (advanced/rare,
only if you will be running our software when QuickBooks is not running).  
Make your selection and complete the Wizard.

7. The QuickBooks Integration Wizard will now be displayed.
Click Next.
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Your bank accounts and Undeposited Funds account for the open QuickBooks
company will be displayed.
For the demo, we are selecting Checking as it contains the most transactions.
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ACH Universal creates three custom fields within each Customer, Employee
and Vendor profile in the QuickBooks company.
As we are in a sample QuickBooks company, the option to populate these fields
with sample data is checked.
For this demo, leave the default settings as is and click next.
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A reminder that--just for the initial setup--you should be in single-user mode
with admin permissions.

Note: While creating the fields is fairly quick, populating the sample account
with data can take a few minutes.
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Click Finish to complete the wizard.
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8. Creating an ACH file

The software will now display the transactions available for transmission from
within the QuickBooks bank account that was selected in the Wizard.  Click
'Send Transactions to ACH Universal' to create an ACH file.
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Click Yes when prompted to view the file.

Your file will look similar to the screen shot below.
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Congratulations.  You've successfully created an ACH file from your
QuickBooks data.

If this were a 'live' production run, you would then upload this file to your bank.

Where is the data stored?

In QuickBooks:
ACH Universal created three custom fields in QuickBooks when you ran the
Integration Wizard.  Typically one would enter the banking data here, although
in this demo ACH Universal populated sample banking data for you.
To see an example in QuickBooks, go to the Vendor Center, click to edit a
vendor, and click on the Additional Info tab.
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To see data stored in ACH Universal:
From the Home tab > click Delete Records > then from the 2nd drop down
select 'All Periods'. Click Run.
Reminder: Select 'All Periods' from the drop down as QuickBooks' sample
accounts are future dated.
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Want more information, or would you like to schedule a live demo with Treasury
Software Support?
Please contact us at 866 226-5732 or online.

1.10.14 Plan B- ACH Universal based profiles

Plan B - ACH Universal-based Profiles 

http://www.treasurysoftware.com/contact-us/index.aspx


385

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

 
**** This method keeps the banking information in ACH Universal rather
than in QuickBooks (preferred).****
       Only use this option if there is an issue (rare) in using our integration
window.

Integration with QuickBooks can be based on storing your Customers',
Employees' and Vendors' banking information in either:
--QuickBooks, or
--ACH Universal

Generally, QuickBooks-based storage is preferred, as this avoids the need to
create a corresponding profile within ACH Universal.

However, there are a number of advantages for using ACH Universal-based
storage, including:
--Speed of processing
--Access to all features within ACH Universal, including recurring transactions,
reversing transactions, multiple origination accounts, and other ACH formats.

In general, if you are on QuickBooks Pro, Premiere or Enterprise, use our
QuickBooks based profiles integration method.
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In QuickBooks®

One-time setup:  Create a new sub-account of your existing bank account.
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On an ongoing basis:  Use the new sub-account that you created for your
electronic transactions.

In ACH Universal

ACH Universal enables you to automatically pull the transactions from
QuickBooks and create an ACH file (also called a NACHA file).
This ACH file contains the payment and collection instructions that your bank
will need to carry out your electronic funds transactions.
ACH Universal can automatically transmit the file to your bank (FTP, SSL, etc.),
or you can simply upload it through the bank's web site.

ACH Universal:
--Protects you from duplicate transactions by integrating and tracking
QuickBook's transaction ID
--Stores all of your customers', employees', and vendors' banking information
--Provides you with a full audit trail of all transactions
--Enables you to manage untransmitted transactions (on temporary hold,
permanent hold, etc.)

QuickBooks® is a registered trademark of Intuit

1.10.14.1 Setup - QuickBooks

Use QuickBooks based profiles if you are on QuickBooks Pro, Premiere or
Enterprise.

To use ACH Universal's integration package, you will need to have installed on
your computer:
--QuickBooks Pro, Premiere, or Enterprise - 2003 or later
--ACH Universal 2011.0.4 (build 109) or later

QuickBooks - Setup
1. Create a sub-account of your Bank account
2. Enable bank account selection
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Start QuickBooks and open the company you want to work with.

1. Create a sub-account of your Bank account
From the QuickBooks main menu select Lists > Chart of Accounts.
On the lower left corner select Accounts > New
Select 'Bank', then 'Continue'

Enter the name of your sub-account (we recommend something descriptive like
'ACH', 'EFT', 'Direct Deposit', etc...), check the 'sub-account' box and select
your bank account that your ACH bank service is with.
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If prompted, select 'No.

2. Enable bank account selection
Depending on your edition, this feature may be turned on/off by default.

From the QuickBooks main menu select Edit > Preferences > Payments >
Company Preferences.  Clear the 'Use undeposited funds' checkbox.
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Note: QuickBooks documentation has this feature listed in 'Sales & Customers',
rather than 'Payments'.  The location may be updated in a future release of
QuickBooks.

QuickBooks® is a registered trademark of Intuit

1.10.14.2 Advanced setup

Use QuickBooks based profiles if you are on QuickBooks Pro, Premiere or
Enterprise.

To reach Advanced Setup, from within your account that you created select
'QuickBooks' > 'QuickBooks integration' > Settings > Advanced.

Typically, these settings do not need to be changed.
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Effective Date
As you operate your business, each transaction date is recorded per your
wishes in QuickBooks.
Sometimes you pre-date or post-date transactions, which is fine.

However, when electronic transactions are sent to your bank, they are typically
expecting the date you send them to be in the future - as this is the 'effective
date' of the transaction.

To minimize any chance of post-dated transactions, ACH Universal's default
setting is the latter of the QuickBooks date and the next business date (as
displayed in the second option).

You can over-ride this setting as needed here.

Send transactions to ACH Universal
The default setting, and for ease of use - is to create a file once transactions are
sent from QuickBooks to ACH Universal.

However, you may prefer to over-ride this setting if:
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--you are editing records in ACH Universal after sending them from
QuickBooks
--you are manually creating records in ACH Universal
--there are internal control measures which require another individual to create
the file
--bank procedures require batch totals - which you would get from ACH
Universal
or any other advanced situation.

Default From/To Date 
The transactions page displays by default from 90 days in the past to 90 days in
the future.
This range should cover any post-dated entries (90 days in the past), as well as
any future entries - such as payroll.

If you are constantly changing the default dates on the report, you can save
yourself some time and change the default range here.

QuickBooks® is a registered trademark of Intuit

1.10.14.3 Importing Transactions Alt

Use QuickBooks based profiles if you are on QuickBooks Pro, Premiere or
Enterprise.

To reach this transactions screen, from within the account you created select
the QuickBooks tab > QuickBooks integration > Settings > Advanced.

This screen is a 'Window' into your QuickBooks data.  By default, it displays all
records in your QuickBooks account(s) that need be electronically transmitted.
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Step #1 - View transactions
The grid by default displays records which you have not yet processed.  You
can change the From and To dates, as well as the default date range (details
below).

In a basic situation, the system will display your new transactions - and all of
them can be sent to ACH Universal.  ACH Universal will then create an ACH
file, which is sent to your bank.

Profiles in ACH Universal
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In QuickBooks you, or a colleague, have created profiles for each of your
Customers, Employees and Vendors.  This profile contains basic information
that you need to mail checks and invoices to - such as street address, city, etc...

In a similar fashion, ACH Universal maintains profiles - but keeps only banking
information, such as their routing / ABA number and account number.

No Profile field
If the 'No Profiles' checkbox is checked, this means that you have created a
transaction in QuickBooks, but ACH Universal has not created a profile on this
entity (customer, employee or vendor).

In order to pay/collect from this entity, you are going to need to create a profile
and complete it.  
ACH Universal helps you do this easily.  We'll show you in Step #2.

Note: Transactions marked 'No profile' cannot be electronically fulfilled.  The
system 'remembers' that you have not electronically fulfilled this transaction and
will display this each time until the profile is complete.  At that time, the
checkbox will no longer be marked and the transaction will be completed.

Profile info missing (not setup) 
If the 'Profile info missing' checkbox is selected, this means that the profile has
been created, but you will need to finish it.

Note: Transactions marked 'Profile info missing' cannot be electronically
fulfilled.  The system 'remembers' that you have not electronically fulfilled this
transaction and will display this each time until the profile is complete.  At that
time, the checkbox will no longer be marked and the transaction will be
completed.

Summary counts and totals
The summary counts and totals include all transactions which have completed
profiles, have not yet been sent and have not  been marked to be held.
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Step #2 - Transmit to ACH Universal

Click on the 'Send transactions to ACH Universal' button to create an ACH file
with the eligible records in the grid.  You can then transmit the ACH file to your
bank.

However, any records are marked as 'No profile', or 'Profile info missing' will
not be included in the ACH file.

To get these records fixed (unmarked), you will need to either create a profile
for them, or fill in missing information for their profile.  You can see at a glance
the records that need to be addressed by clicking on the 'Attention needed ...'
button in red text.  For information on how to fix these records, please see
either:
Adding Profiles
Editing Profiles

QuickBooks® is a registered trademark of Intuit

1.10.14.4 Holding and over-riding records

Use QuickBooks based profiles if you are on QuickBooks Pro, Premiere or
Enterprise.

In a perfect world, all of the transactions that you create in QuickBooks are to be
sent for immediate electronic processing.

As we know, this is not always the case.  Sometimes payments are held
temporarily - or permanently canceled and sometimes payments need to be
resent.

Marking records
ACH Universal provides you with the tools to do this.  Uncheck the checkbox to
display your record controls (circled in red).
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Holding transactions - Temporary
Select the record(s) and click on 'Mark - Do not Import (temporary)'.
This will mark the records as 'Do Not Import' during the current submission to
ACH Universal.

The records will be automatically displayed as available to be transmitted the
next time your view the records.

Notes:
--If you re-run or refresh the grid prior to transmission, this will clear your
marked records.  You will need to re-mark them.

Holding transactions - Permanent
Select the record(s) and click on 'Mark - Do not Import (permament)'.

If you no longer want a transaction to be transmitted electronically, you can
mark the record(s) as 'Mark - Do not Import (permanent)'

Marking records 'Do not transmit' stop the transactions from being imported
now - or in the future.

If in the future, you decide that you need to process this record, see the
instructions below for 'Mark - Import (over-ride)'.
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Mark - Import (over-ride).
Select the record(s) and click on 'Mark - Import (over-ride)'.

Use 'Mark - Import (over-ride)' if you need to:
--process a transaction that you previously put on a permanent hold, or
--you need to re-transmit a record.  

An example of re-transmission: If a bank account number that a vendor gave
you was wrong - and the original transaction was returned.  You can then use
the over-ride feature to re-transmit this.

Note: In order to select a record, you'll need to view it.  However by default,
previously transmitted records and those placed on permanent hold - are
suppressed from being displayed.  See the section below to display these
records.

Displaying previously transmitted and permanent 'on-hold' records
By default, ACH Universal will suppress displaying previously transmitted and
permanent 'on-hold' records.  To display these records, un-check 'Hide
transactions already imported'.

Why would I want to view these records?
Typically, you would not want to view these records - that is why we suppress
them by default.
However, you would want to display these records for:
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--1. If you need to re-transmit a transaction that originally failed.
--2. If you need to transmit a record that you placed on permanent hold.

QuickBooks® is a registered trademark of Intuit

1.10.14.5 Profiles

Profiles

QuickBooks
QuickBooks maintains profiles for each customer, employee and vendor.

QuickBooks Vendor Profile

ACH Universal



399

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

Like QuickBooks, ACH Universal also maintains profiles for each customer,
employee and vendor.
However, there is very little overlap - ACH Universal's goal is to stores banking
information.  

ACH Universal Profile

As QuickBooks does not have the ability to store and report this banking
information for each customer, employee and vendor - ACH Universal will do it
for you.

ACH Universal provides the ability to import customer, employee and vendor
information from a spreadsheet, as well as manually enter them one at a time.

As you are reading this, you are probably using QuickBooks - there is an
additional way to auto-create profiles from your QuickBooks data.  Please see
Auto-creation of Profiles.
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QuickBooks® is a registered trademark of Intuit

1.10.14.5.1  Adding

Auto-adding profiles from QuickBooks into ACH Universal

While you can always import profiles from a spreadsheet and manually enter
them one at a time - ACH Universal enables QuickBooks users to auto-create
profiles.
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How do I know whether I am missing profiles?
ACH Universal will automatically prompt you on the transactions screen (see
below)

When you click on the link above, the system will take you to the Profiles > Add
screen, which you can then simply click 'Add Profiles into ACH Universal'.

How does the system know which profiles are needed?
The system scans your current transactions and looks to make sure each
transaction can be associated with a profile.  When it finds a transaction without
a profile, it adds it to the auto-create list.

What actually happens during the auto-create process?
ACH Universal creates a profile with that entity's (customer's, employee's or
vendor's) name.
You can then follow up and enter the entity's bank account number, ABA/routing
number - and any other banking information needed

I just auto-created profiles, but I still can't create a transaction.  The transactions
are marked as 'Profile info missing'. What do I do?
You created a profile, but did not yet finish updating it with the ABA/Routing
number and account number.

To complete the process, please see editing profiles.
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QuickBooks® is a registered trademark of Intuit
1.10.14.5.2  Editing

This window provides you with a list of incomplete profiles.

Click on the link to go to the 'Profiles – Information Missing' report (build 111
and above) to run the report.  Then click on the 'Edit Record' button on the
toolbar to update your profiles.
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QuickBooks® is a registered trademark of Intuit

1.11 QuickBooks Online Edition

Using QuickBooks Online Edition (QBOE) to create ACH
NACHA transmission files

QuickBooks Online integrates seamlessly with ACH Universal, but it does so in
a slightly different way than the installed version of QuickBooks.

Vendor, employee, and customer Profile names are automatically imported to
ACH Universal, but in QuickBooks Online the ABA/Routing and Account
information for those Profiles are set up and retained in the ACH software.  (In
the installed version of QuickBooks, the  Profile data is retained in the
QuickBooks account.)

Please refer to the instructions at each tab:

· QBOE Setup

· QBOE Importing Transactions

· QBOE Profiles

· QBOE Creating ACH File

1.11.1 QuickBooks Online Setup

Quickbooks Online Setup

Create a new account in ACH Universal.  
The steps to create a new account - from the main menu select File > New
Account
The top option “Create an Account and Add it to your Catalog” should already
be selected.  Click Next, and go through the wizard.
The account name is for internal use and should help you identify the purpose
of the account.
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Congratulations! You have finished creating the account. Click Finish and you
will begin using this account. 

Next:  Connect to Quickbooks Online

Once an account is created in ACH Universal, you'll want to continue working in
that new account.  Go to the Quickbooks tab, and click on the "Online Edition"
of QuickBooks Integration.

An Account wizard will pop up --

Step 1. Enter the QuickBooks Online Company ID and "Authorize".  This will
connect your QBOE to ACH Universal.  
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Step 2.  Once authorized, the bank account(s) will populate and you'll choose
the account you want to use for payments or collections in ACH Universal--and
"Save Bank Account".
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Now, you are ready to transfer transactions and set up your Profiles for
vendors, employees, and/or customers!

1.11.2 QuickBooks Online Importing Transactions

Importing Transactions from QuickBooks Online

It is necessary for transactions to appear in the QuickBooks Bank Register for
them to import to ACH Universal. In other words, bills must be paid, checks
written, and deposits processed in QuickBooks first.
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You'll go to the Quickbooks Tab, and select the transactions to process by date
range, and click "View Transactions".

ACH Universal will automatically populate the employees, customers, and/or
vendors for processing within that date range.  
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At this point, the three individuals' names have been populated under the
"Profiles" tab.  This is where you will include their ABA/Routing numbers and
Account numbers.  (Once the information is retained, you will only see the last
four digits of the Account number.)  Only new vendors/employees/customers
will sync over in future imports.

1.11.3 QuickBooks Online Profiles

Creating Profiles in ACH Universal 
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Profiles hold the banking information for each of your Customers, Employees
and Vendors that you want to pay or collect from electronically.

When importing transactions from QuickBooks Online, the Profile names will
automatically transfer over to ACH and can be seen under the "Profiles" tab.
The first time Profiles are transferred, it will be necessary to manually add their
ABA/Routing and Account numbers next to their names. After that, the
information will be retained in ACH and only the last four digits of the Account
number will be seen.  If the Profile is already in the system, it will not overwrite
or add to ACH Universal during the next import.
[Note:  Any Profiles that do not have ABA/Routing and Account numbers
entered will have a check-mark "Missing banking profile info" on the
Transactions page.]

Here, the names automatically transferred over to the Profiles section and we
entered the banking information for John and Sandy:

1.11.4 QuickBooks Online Creating ACH File

Creating the ACH File
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Once all Profiles have ABA/Routing and Account information, you'll check the
control totals for accuracy, and then "Create ACH File".

When you click "Create ACH File", you will be creating a TXT file that will look
similar to this:
(There are various formats available and your bank should provide their
formatting requirement.)

Then, you will login to your bank's website and upload this file, or transfer the
file per your bank's instructions.
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1.11.5 QuickBooks Online FAQs

Frequently Asked Questions

Where do I find the Company ID in QuickBooks?
   There is a gear icon in the top right corner of the QuickBooks page--click on

that gear .  Under "Your Company", go to "Account & Settings", and then 
"Billing & Subscription".  The Company ID appears at the top of the page.

The transactions won't come over from QuickBooks to ACH when I click
"View Transactions"--what is wrong?

   Be sure the items to import appear in the QuickBooks Bank Register.  If bills
have not yet been paid, for instance, ACH will not find the transactions.

1.12 Security

 Security

Treasury Software practices the concept of 'Defense in Depth' (also known as
Castle Approach), in which the system has multiple layers of controls.

Security includes:
--Database encryption using AES-256
--Encrypt within QuickBooks qbw
--Password Protection
--SQL Server security
--Full Audit Trail
--Automated Backups
--Segregation of Duties
--SSH-FTP encrypted transmission
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Many of the options are available in the Settings tab.

Please see the help pages in this chapter for additional information.

1.12.1 Users / Access Control

There are two components to Treasury Software access control:
--client-based
--server-based

Server based security - 'Gold Standard'
Server-based security is Microsoft SQL Server based and is first addressed
during account creation and setup.  It centers around the user's Windows or
SQL Server login ID and the membership of the groups/roles that the individual
belongs to.  

Based on the membership, the user will have access to or be denied to the
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various SQL Server databases.  There is a one to one relationship between
databases and accounts.

SQL Server is maintained according to your corporate security policies outside
of Treasury Software by your database administrator (DBA) with Microsoft's
SQL Server Management Studio.

Treasury Software products on SQL Server, with SQL Server security
maintained - is the strongest form of security we can deliver.  SQL Server is
required by many Government agencies and according to corporate bank
policy.   SQL Server security is often viewed as the 'Gold Standard' of security.

Client-based security
The following help pages cover client-based security.

Treasury Software also provides two levels of client based security:
--user authentication - simple access to software
--feature-level access - segregation of duties - requires SQL Server with and
Treasury Software Enterprise license

Holistic Approach
While we are proud of our client-based security features - if only client-based
security is implemented - it will merely be an inconvenience to those seeking to
commit fraud.

Security is only as effective as the weakest link in the chain.

Locking down the 'front door' (client), only to leave the 'back door' (server-data)
open is not an ideal security model.

Adding to security concerns - The input to Treasury Software is an unprotected
file - typically a spreadsheet, and the output for ACH Universal and Positive Pay
is an ASCII file.
 

Client workstation access control
For those environments requiring high security, we highly recommend the use
of Windows Operating System and Network Operating System based features,
to limit physical and remote access to the Treasury Software client.
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Note: All Treasury Software security is applied on an account by account
basis...

1.12.1.1 Setup

Menu selection and Setup-login

Menu Selection
The security menu selection by default is hidden.  Please note: The
displaying/suppression of the menu choice has no effect on the security level.

To view the menu choice, from the main menu select the Settings tab > Import,
System and turn 'Suppress Security Menu' to 'Display'.  You will then need to
exit and re-enter this account (display is on a per account basis).

Login - setup
To access the login screen, from the main menu select File > Security >
Security Administration

Default User nameadmin
Default Password password

Once logged in (only an admin can pass through setup security), you will be at
the security main page.
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Prompt User Integrate with Windows
Authentication Challenge screen

prompting the user to
login each time the user
starts the software and
then determines whether
access should be
granted. 

Uses the Windows Login
ID to authenticate and
then determines whether
access should be
granted. 

Segregation of duties Same challenge screen as
above, plus
grants/restricts access to
features on a per user/role
basis.

Only available on SQL
Server with a Treasury
Software Enterprise

Same authentication as
above, plus
grants/restricts access to
features on a per user/role
basis.

Only available on SQL
Server with a Treasury
Software Enterprise
license.
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license.

Multiple Accounts - Security is applied on an account by account basis
If you have more than one account, you will need to enter into each account you
want to protect and make your security selection.

Tips:
--Do not put security on the Sample account (do not place 'real' account
numbers, etc.. in the sample setup)
--Change the default admin password
--Use a Windows Operating Screen screen saver with password protection

Note: All Treasury Software security is applied on an account by account
basis.

1.12.1.2 Users-Add

Users
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Adding Users - click 'Add'
If using Windows authentication - enter the user's Windows login name and
leave the password blank.
Otherwise, simply enter the the login name and password that will be entered.

Authentication security - All users will be assigned to the admin group.
Segregation security - Assign users to their roles.

Delete, Edit and Print
Use as prompted

Tips: 
Change the password on the 'Admin' account.
Users can switch from account to account as long as their name is listed as a
user in each account.
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Note: All Treasury Software security is applied on an account by account
basis.

1.12.1.3 Segregation of duties

Segregation of duties security is available on SQL Server platforms with an
Enterprise license from Treasury Software

Setup - Enable display of options
On some systems, you may need to opt to view the Segregation of Duties.
From the main menu select the Settings tab, then the 'Import, System' button.
On the System tab, locate the Suppress Security Segregation of Duties - and
elect Display.
Click 'Close', and then exit and re-start the software/
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First time configuration
Upon restarting the software, select the 'Settings' tab, then Access Control.
When the form below is presented, select either method of authentication
(integrate with Windows is recommended), then click 'Update'.
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At this point, three additional tabs will be displayed:
Roles
Users
Permissions

Roles
All users will be assigned to a Role.
In the panel, you can add Roles (a.k.a. Groups), as well as delete and edit.

Note: The built-in Role 'Admin' is unique in that it:
--provides its members with the ability to enter this Security Setup.
--has access to the account

Users
Each user will need to be added here.
Note: If you are using Windows Authentication, you do no need to enter a
password for them to access the account - however, if you assign the user to
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the Admin role - they will need a password to access this setup window.

Permissions
Permissions are granted on a role by role basis
1. Select the role
2. Grant access, if appropriate
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3. Grant rights in the other tabs.

Notes:
--Check the 'Access to the Account' checkbox to allow the user entry into the
account.  Leaving this unchecked is the same as removing them from the user
list.  Use this checkbox when there is a temporary vacancy and you do not want
to reset the permissions.
--Your tabs will differ slightly based on your applications that you are running.  

Screen shots of permissions



423

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

Note: All Treasury Software security is applied on an account by account
basis.

1.12.1.3.1  Permissions

Segregation of Duties - Permissions

Below are screen shots of the available duties.

Remember: Permissions are granted on an account by account basis.
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1.12.1.3.2  Roles

Segregation of duties security is available on SQL Server platforms with an
Enterprise license from Treasury Software.
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Notes:
--You only need to maintain roles for Feature level security.
--You cannot delete the admin role.  

Tip:  Create roles before you add users.  This way, you only need to be in users
once (you don't have to go back).

Note: All Treasury Software security is applied on an account by account
basis.

1.12.2 Encryption - Database

Database Encryption.

Database encryption of sensitive data

Encryption - To protect from unauthorized access
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ACH Universal encrypts account numbers using the most secure symmetrical
encryption algorithm available (AES-256). AES is used by the U.S. and
Canadian governments as their standards for encrypting data.

Hashing - Insertion/change protection
Each record is hashed - and the hash is encrypted - to insure that records
remain unchanged and that no records are inserted by circumventing the
system.

To enable
Click on the Settings tab and then 'Encrypt Databases'

The Database Encryption window will be displayed.
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Notes:
--Either feature may be enabled at any time.

--To maintain security - once turned 'On', the features require Treasury
Software Support to turn 'Off'.

--These features are available in all platforms (Desktop, SQL Express and SQL
Server), as well as all editions.
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Reminder: All Treasury Software security is applied on an account by
account basis.

.

1.13 Reference

Overview

ACH Universal is used to create and transmit ACH files.  The structure of an
ACH file is a standard governed by NACHA.  For more information on the file
structure, see ACH File Structure

All ACH transactions are associated with a Standard Entry Class Code,
sometimes called an SEC Code.  This code defines several aspects of the
transaction, such as authorization and type of account being used.  For
example, most company payroll transactions use the PPD code.  See List of
Standard Entry Class Codes for information on all the codes to assist in
determining which code to use for your specific situation.

See the Glossary for definitions of terms common throughout ACH files in
general and in ACH Universal.

1.13.1 Backup SQL Accounts

Backup SQL Accounts

This page is for backing up account databases when you're using our SQL
Express or SQL Server platforms.

Overview:
You can backup your accounts manually through the user interface and you can
backup the databases from the command line prompt.
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Manual Backups
1. Confirm that you are running Treasury Software from the same
computer that is hosting the SQL Express/Server.
If you are not sure, click on the Settings tab > Maintenance > SQL tab.  The
SQL server will be listed here.
The SQL Server name should either start with your computer name or be
'(local)'.

2. Start Treasury Software in 'Run as Administrator' mode.
You can do this by navigating to the installation directory and right clicking on
BRCOM.exe, for example:
C:\Program Files (x86)\Treasury Software\version 2014 01\BRCOM.exe
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3. Click File > Backup.
Check the accounts you want to backup and specify the output location of the
compressed backup (zip) files.
Click 'Backup Databases' to start the backup
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Done with manual backup.

Initiating a Backup from a command line.
1. Confirm that you are running Treasury Software from the same
computer that is hosting the SQL Express/Server.

The command line must be triggered from the computer that has both Treasury
Software installed on it and that is hosting the SQL Express/Server.

If you are not sure, click on the Settings tab > Maintenance > SQL tab.  The
SQL server will be listed here.
The SQL Server name should either start with your computer name or be
'(local)'.
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2. Create a backup using the manual process (above) first to confirm that
you have proper rights.
This is critical in confirming local drive permissions.

3. Command line syntax and requirements
The executable TSBackup.exe runs the backup process.
It is located at the default (and should not be moved) installation directory, for
example:
C:\Program Files (x86)\Treasury Software\version 2014 01\TSBackup.exe

It accepts 2 parameters (each within double quotations):
Parameter 1 is the path where the files will be backed up,
Parameter 2 is the list of accounts (comma delimited) to be backed up.

Example:
Sample command line with parameters - where the names of the accounts are
Checking, Payroll and Depository are written to the folder C:\Backup.:
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"C:\Program Files (x86)\Treasury Software\version 2014 01\TSBackup.exe" "C:
\Backup" "Checking,Payroll,Depository"

4. Requirements:
The system requires access to write a log file to either (version dependent):
C:\Users\Public\Treasury Software\Logs
C:\Program Files (x86)\Treasury Software\version 2014 01\

Reminder: The computer must already have been successfully connected to
SQL Express/Server and be running from the same computer hosting the SQL
Express/Server.

5. Set the TSBackup.exe's property to 'Run as Administrator'
Right click on the 
C:\Program Files (x86)\Treasury Software\version 2014 01\TSBackup.exe
and select Properties.
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Then click on the Compatibility tab > Check 'Run this program as an
administrator > Save.
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6. Running the command line 
You can trigger the command line and parameters from Windows Task
Scheduler, a desktop shortcut, a batch file or from any software package that
enables you to 'shell out' to the system.

Tip: If you receive any pop-up confirmation windows from the system UAC, you
may want to alter the UAC level.
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Done.  Please let us know if we can help.

1.13.2 ACH File Structure and Setup

An ACH file uses a precise format to guarantee transactional integrity. 
Internally, an ACH file uses a single digit between 1 and 9 to indicate a type of
entry in the file.  

1 File Header

5 Batch Header

6 Batch Entry

7 Batch Entry Addenda

8 Batch Footer

9 File Footer

All information in an ACH file is created by ACH Universal based on either
information in an imported file or on settings stored in ACH Universal to identify
your company in the file.

If you need to modify any stored settings, see Account Setup
If you need to create a new account, see Creating An Account

File Header - 1

The file header contains information regarding an account's ACH transactions. 
For example, if you create two ACH files, one each out of two different ACH
Universal accounts, you will by definition have two ACH files.  

Information contained in the file header includes:
· Immediate Destination Code (Usually your bank's ABA)
· Immediate Origin ID (Assigned by your bank to identify your company's ACH

files. Usually federal tax ID)
· Immediate Destination Name (Name of your bank)
· Immediate Origin Name (Name of your company, as listed in bank records)

All this information comes from settings created during Account Setup.

Batch Header - 5
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A batch creates a logical separation of transactions in an ACH file.  For any list
of transactions, batches are separated by:
· Date
· Standard Class Entry Code
· Origination Account (if desired)

There is no way to change the first two as they are a feature of the ACH format.
 However, you can choose to separate batches by origination account if
needed. See LINK Separating batches by origination account for more
information.

There can be multiple batches per file, but there will always be a minimum of
one batch.

Batch Entry - 6

A batch entry is simply one transaction. In order, a batch entry includes:
· Transaction Code (identifying type of transaction)
· Routing/ABA Number for transaction party
· Account Number for transaction party
· Amount of transaction
· Name of transaction party

The first, Transaction Code, is automatically generated by ACH Universal
based on the transaction.  The others are contained in file imports, either
transaction or profile. 

There can (and most likely will) be multiple batch entries per batch.

Batch Entry Addenda - 7

A batch entry addenda record, or addenda, is extra information on a transaction
that may be necessary for the transacted party.  If you need to use an addenda,
your bank or transaction party will inform you beforehand.  In PPD+/CCD+
format files, addenda records are limited to 1 per transaction.  The addenda
can be a maximum of 80 characters.  In CTX files, there is no practical limit to
the number of addenda records per transaction.  

Batch Footer - 8 

A batch footer denotes the end of a batch.
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File Footer - 9

A file footer denotes the end of the file.  It contains information marking the file
end and any padding needed to create proper file width.  
 

1.13.2.1 File ID Modifier

File ID Modifier

The File ID Modifier is located in the File Header Record, position 34, and can
be numeric (0-9) or alphabetic (A-Z).

It is used by the financial institution to differentiate between multiple files
transmitted on the same day.

For example, the first file transmitted on particular day will have the value of '1'.
 The second will be '2', the third '3' and so on.
On the next day, the file modifier is automatically reset back to '1' for the first
file.

While some banks show an example of A, B, C - in their documentation, you
can use 1, 2, 3 just the same.

1.13.3 Glossary

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

A

ARC A Standard Entry Class Code that allows an ACH debit to be created
from a consumer check sent through standard U.S. mail or drop
box.1

Addenda
Record

A record type used to carry supplemental information for account
holder identification or to provide payment information to Receiver
and RDFI.
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B 

Batch

C 

Credit An Originator transfers funds to a
Receiver's account.  Example: A
consumer using automatic bill pay
through their cable company.

Consumer Account An account held by a person for
personal or family use. 

D 

Debit Funds are collected from a Receiver's
account and transferred to an
Originator's account, regardless of
which party initiated transaction. 
Example: A cable company can debit



442

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

consumer accounts each month for
monthly billing.

E 

Entry An electronic record representing a
transfer of funds.

F

G

H

I

J

K

L



443

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

M

N

O 

Originator The transaction party that initiates an
ACH entry.  Requires arrangement with
a Receiver.  Originator may be a
company or a consumer.

Originating Depository Financial
Institution

Also called ODFI.  Institution that
receives payment instructions and
forwards to ACH system. An institution
can be a Receiving Depository
Financial Institution (RDFI) without
acting as an ODFI.  However, must
agree to act as RDFI if institution
wishes to originate entries.

ODFI See Originating Depository Financial
Institution

P

Payee A party to whom funds are payable
PBR Standard Entry Class Code used for transmission of consumer

cross-border debits and credits1

POP Standard Entry Class Code used for in-person purchase of
goods or services by consumers.  Require written authorization
and account information from source document (example: a
check) obtained from consumer at point-of-purchase. Source
document is voided and used only for transmission information.1

PPD Standard Entry Class Code used for pre-arranged payment and
deposit entries.  Most common uses are direct deposit and bill
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payment.  Requires standing authorization.1

Prenotification A zero-dollar entry transmitted solely to verify Receiver's account
information and inform party of upcoming transaction

R 

Receiver The transaction party that has
authorized an Originator to initiate an
ACH entry.  The Receiver can be a
consumer or a company.1

Receiving Depository Financial
Institution

Also called RDFI.  The institution that
receives ACH entries from the ACH
system and posts to accounts of
Receivers.1

RDFI See Receiving Depository Financial
Institution

Returns An entry returned by either DFI or the
ACH system because it cannot be
processed.

Reversals Any entries sent to reverse a previously
transmitted erroneous entry.  For
example: A company that pays an
employee the incorrect amount would
submit a reversal. 

RCK Standard Entry Class Code used for a
single debit for representing a check
returned by check collection system for
insufficient funds.

S 
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Standard Entry Class Code A three-letter code that identifies a
specific payment application. See List
of Standard Entry Class Codes for the
complete list.  Also called SEC Code.

T 

TEL Standard Entry Class Code used for
single debits to a consumer account. 
Requires oral authorization obtained by
telephone.  Can only occur when there
is a preexisting relationship between
two parties or the Receiver initiates the
phone call.1

U

V

W

X

Y
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Z

1 2005 ACH Rules by National Automated Clearing House Association

1.13.4 Standard Entry Class Codes (SEC Codes)

Standard Entry Class Codes, or SEC Codes, are all the valid payment methods
as prescribed by NACHA.  Each SEC Code defines the type of transaction
(debit or credit), type of account (corporate or consumer), and any information
specific to the format (such as single/recurring, terminal location, or check
number).

The most common SEC Codes are CCD and PPD, which are credits and
debits done against corporate and consumer accounts respectively.  These are
used for direct deposit, payments to vendors, and collections from customers.

1.13.4.1 List of Standard Entry Class Codes

Standard Entry Class Codes

A Standard Entry Class Code (SEC Code) identifies a specific payment
application.  The code incorporates type of payment (debit or credit), account
nature (consumer or corporate), and record format used to carry format. 
Implicit in the code is how authorization is arranged (standing, oral, type of
transaction, etc).

The list can be broken into three parts: Consumer codes, Corporate codes, and
codes that can work on both types of accounts. 

Consumer

Consumer transactions are most commonly credits, such as payroll, retirement,
dividend, and interest payments.  There are also debit applications as well. 
These often include insurance premiums, mortgage payments, utility payments,
and other similar payments.  Transactions be be single or recurring.  Below is
the list of consumer codes with short description.  See the full definition of each
code for more information.

AR
C

Single debits based on a check received through U.S. mail or dropbox.

BO
C

Allows creation of single debits for a point-of-purchase check during back
office conversion.
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IAT International

PO
P

Debit for in-person purchase of goods or services

PPD Prearranged payments and deposits, most often on a recurring basis
(payroll, bill payments)

RC
K

Single debits used to represent check that was processed and returned
due to lack of funds

TEL Single debits authorized via telephone.  

WE
B

Single or recurring debits authorized via Internet.

Corporate

Corporate transactions  are most commonly corporate trade payments, state
and Federal tax payments, and financial electronic data interchange (EDI).  See
full definition of each code for more information.

CC
D

Credits or debits where funds are distributed or consolidated between
corporations.

CTX Corporate Trade Exchange. 

1.13.4.2 ARC - Accounts Receivable Entry

The ARC Standard Entry Class Code enables users to convert a consumer check received in the mail
or at a dropbox location to a single entry ACH Debit for the payment of goods or services.

The consumer's check (source document) is used to collect the account number, routing number, check
serial number, and dollar amount for the transaction.

At a minimum, you will need to import an amount, account number, Routing number, payee/payor
name, and the check number for each transaction.  Map the fields as listed below:

· Name as Name
· Amount as Amount
· Check as ACH_Check
· Account number as Bank_Account_Number
· Bank Routing Number as ABA_Routing_Number
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1.13.4.3 BOC - Back Office Conversion

The BOC Standard Entry Class Code enables users to convert a consumer check to a single entry
ACH Debit for the payment of goods or services in a back-office conversion.

The consumer's check (source document) is used to collect the account number, routing number, check
serial number, and dollar amount for the transaction.

At a minimum, you will need to import an amount, account number, Routing number, payee/payor
name, and the check number for each transaction.  Map the fields as listed below:

· Name as Name
· Amount as Amount
· Check as ACH_Check
· Account number as Bank_Account_Number
· Bank Routing Number as ABA_Routing_Number

1.13.4.4 CCD/CCD+ - Cash Concentration or Disbursement

Cash Concentration or Disbursement can be either an ACH credit or debit where funds are transferred
between corporate entities. 

The format can support a limited amount of payment related data with the funds transfer while also
being capable of a stand-alone funds transfer.

The mappings for required fields to use CCD are:
· Name as Name
· Amount as Amount or Amount_Reverse_Sign (use Amount if amounts are being paid out and are

negative OR are being collected and are positive, otherwise Amount_Reverse_Sign)
· Account number as Bank_Account_Number
· Routing Number as ABA_Routing_Number)

CCD+ is simply a CCD transaction that includes an addenda record.  An addenda includes additional
information about the transaction, but is not required for ACH processing.  This can include identification
numbers, region codes, or anything considered necessary on the Receiver's end.

1.13.4.5 CIE - Customer Initiated Entry

The CIE Standard Entry Class Code is limited to credit transactions where the consumer initiates the
payment, typically to a company for payment through some type of bill payment service provider.

The mappings for required fields to use CIE are:
· Name as Name
· Amount or Amount_Reverse_Sign
· Account number as Bank_Account_Number
· Routing Number as ABA_Routing_Number)

CIE+ is simply a CIE transaction that includes an addenda record.  An addenda includes additional
information about the transaction, but is not required for ACH processing.  This can include identification
numbers, region codes, or anything considered necessary on the Receiver's end.
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1.13.4.6 CTX - Corporate Trade Exchange

The Corporate Trade Exchange or CTX format supports transferring of funds, either credits or debits,
within a trading partner relationship utilizing a full ANSI ASC X12 message or when payment related
UN/EDIFACT information is sent with the funds transfer. 

Multiple addenda records contain the ANSI or UN/EDIFACT information.

ACH Universal requires CTX transactions be done via profiles.  Account and routing numbers for each
payee are stored as a profile in ACH Universal and then looked up via name or ID number when
importing transactional information. 

The mappings for remaining fields required to use CTX are:
· Name as ACH_Name_Internal (Profile Lookup)
· Amount as Amount_Payment_RMR
· Invoice as Invoice_Number_RMR

While optional, it is recommended to map a Purchase Order number as PO_Number_RMR.

See CTX-EDI for more information on working with the CTX format.

1.13.4.7 IAT - International

The IAT Standard Entry Class Code is used for the transmission of International cross-border credit
and debit ACH entries.   

The IAT format handles both inbound and outbound (into and out of the US).  The format contains
detailed information unique to cross-border payments.

Why is IAT-International ACH/NACHA so important?
Starting September 18, 2009, the Automated Clearing House network will stop processing CBR/PBR -
Cross Border Payments and only accept IAT transactions for International payments.

The new IAT format will contain enough information to comply with programs administered by the
Office of Foreign Assets Control (OFAC), and with the Bank Secrecy Act's 'Travel Rule'. Please note
that ACH Universal provides for both Gateway and Secondary OFAC screening indicators, ACH
Universal and Treasury Software does not screen the OFAC SDN list.

What ACH Universal Pro generates
A NACHA compliant file in IAT format.  Specifically to IAT it includes:
(number represents the NACHA record type code)
5 - IAT Company/Batch Header record
6 - IAT Entry Detail record
7 - Seven mandatory addenda records
7 - Up to two IAT addenda records for supplemental remittance information
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7 - Up to five IAT addenda records for foreign correspondent banks

Note: There is a maximum of 12 addenda records able to be transmitted per NACHA guidelines.

ACH Universal Pro input
As there are over 25 new data fields in the new addenda records, the data input requirements are that
much greater.

There are three methods to importing data:
1. Direct entry into the screen below in a single non-profile mode
2. Direct entry into the screen below in using pre-populated templates for originator, receiver - or both.
3. Batch import of transactions

You may key the detail in as needed.  The movie below demonstrates the use of profiles.  
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... or import data 'On-the-Fly' from Excel or a comma delimited (csv) file format - just like any other
transaction for ACH Universal. 

This enables batch processing of IAT-ACH International transactions from web servers and other third
party databases. For more information on 'On-the-Fly' importing - see Importing.

Create ACH/NACHA files with IAT-International transactions

Whether you are domestic or foreign, creating inbound or outbound entries - or whether you are a
corporate entity, bank or governmental agency - ACH Universal's Pro edition can help you easily create
IAT transactions for International commerce.

Setup
Header
Enter into an account.  From the main menu select File > ACH Setup.  Follow the prompts and enter
the information regarding your header information and Gateway Operator (GO). Click Next until you are
at the last page.

Foreign Correspondent Banks
On the last page of the ACH Setup Wizard, select the 'International' tab.  
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If you will be utilizing any Foreign Correspondent banks, enter them here.  Check the box if you would
like to have these entered into your transactions by default.

Click Finish.

Enter transactions
From the main menu select Edit > Enter an International Transaction (IAT).

Overview of manual input screen
There are four distinct areas
1. Top of the window contains transactional information such as date, amount, debit vs. credit
2. Left side is the originator's information
3. Right side is the receiver's information
4. Second tab - Foreign Correspondent Banks and OFAC (click on the link in the lower left of the
screen titled 'Foreign Correspondent Banks and OFAC screening'
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1. Top of the window contains transactional information such as date, amount, debit vs. credit
Enter date, Debit/Credit, amount as appropriate.

Notes:
For Variable-to-Fixed transactions the foreign amount is required, the exchange rate is not used.
For Fixed-to-Variable transactions the foreign amount is not used, the exchange rate is required.   Per
NACHA the system will over-write the foreign amount of outbound transactions with zero's.  For inbound
transactions, the foreign amount should contain the amount in the originating currency
For Fixed-to-Fixed transactions, the foreign amount is required, the exchange rate is used.  The system
will over-write the exchange rate/reference field with blanks per NACHA.

By definition, transactional information changes with each payment and are not saved as part of any
profile.
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2. Left side is the originator's information
Enter the information as appropriate.  Please take note of the [Foreign] Exchange Indicator (FV, VF,
FF) and the [Foreign] Exchange Reference.

When finished, enter a profile name in the drop down box (at the top of the section), and then click on
'Save to profile'.  You can update a profile at anytime by clicking this save link.  In addition, you can use
the profile as a template by changing the profile name and then clicking 'Save to profile' link.  Both the
originator's and receiver's profiles work the same.

3. Right side is the receiver's information
Enter the information as appropriate.  Please note that the additional remittance information used in the
IAT remittance records (record 7-17) is part of the receiver's profile and can be stored for future use.
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4. Second tab - Foreign Correspondent Banks and OFAC (click on the link in the lower left of
the screen titled 'Foreign Correspondent Banks and OFAC screening'
OFAC screening - ACH Universal Pro does not provide OFAC screening - therefore by default a space
is entered to indicate no screening has been made.  If your financial institution has provided you with a
third party process to screen OFAC settings, you may adjust them here.

Foreign correspondent banks - The banks entered in the International tab of the ACH Setup will be
displayed here.  A checkbox indicates that a bank will be included in the 7-18 addenda record.

NACHA limitation
NACHA allows for up to five foreign correspondent banks, but this limit will be decreased in a one to
one ratio based on the number of additional remittance records are included.

IAT by the numbers - NACHA allows for
--7 mandatory addenda records
--maximum of 2 additional remittance records (optional)
--maximum of 5 foreign correspondent bank records (optional)
--A total maximum of 12 addenda records

Importing Data
The import process for IAT is identical to that of any other format.  The difference is that there are over
40 fields used in the process.
We recommend for this topic to reference the sample data included with ACH Universal Corporate and
use this as a template.

1.13.4.8 POP - Point of Purchase Entry

The POP Standard Entry Class code is used by Originators as a method of payment for the in-person
purchase of goods and services by consumers. The Single Entry debits are created by the originator
based on written authorization and account information from a source document (check) obtained from
the consumer at the point-of-purchase. 

The source document is voided by the merchant and returned to the consumer at the point-of-purchase
is used to collect the information required to create the ACH Debit entry to the consumer's account.

The mappings for remaining fields required to use POP are:
· Name as Name
· Account number as Bank_Account_Number
· Routing  Number as ABA_Routing_Number
· Amount as Amount or Amount_Reverse_Sign
· Check as ACH_Check
· City as Term_City_POP
· State as Term_State_POP
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1.13.4.9 PPD/PPD+ - Prearranged Payment and Deposit Entry

The PPD Standard Entry Class Code is used for credits and debits involving consumer accounts based
on a standing authorization.  There are two many ways PPD is used:

Direct Deposit - Direct Deposit is a credit program that transfers funds into a consumer's account at
the Receiving Depository Financial Institution. The amount deposited can be from a variety of products,
such as payroll, interest, pension, dividends, etc.

Pre-Authorized Bill Payment - Preauthorized payment is a debit program enabling companies with billing
operations to collect funds from consumers thorough the electronic transfer of bill payment entries. For
example, monthly payments of household utility bills can be collected through a PPD.

The mappings for required fields to use PPD are:
· Name as Name
· Amount as Amount or Amount_Reverse_Sign (use Amount if amounts are being paid out and are

negative OR are being collected and are positive, otherwise Amount_Reverse_Sign)
· Account number as Bank_Account_Number
· Routing Number as ABA_Routing_Number

PPD+ is simply a PPD transaction that includes an addenda record.  An addenda includes additional
information about the transaction, but is not required for ACH processing.  This can include identification
numbers, region codes, or anything considered necessary on the Receiver's end.

1.13.4.10 RCK - Represented Check Entry

A re-presented check entry is a single ACH debit used by originators to re-present a check processed
through the check collection system and returned due to insufficient or uncollected funds. 

This collection method provides originators the potential to improve processing efficiency and reduce
costs.

The mappings for required fields to use RCK are:
· Name as Name
· Amount as Amount or Amount_Reverse_Sign
· Account number as Bank_Account_Number
· Routing Number as ABA_Routing_Number
· Check as ACH_Check

1.13.4.11 TEL - Telephone Initiated Entry

The TEL Standard Entry Class code is used to originate a Single Entry debit transaction to a
consumer's account based on oral authorization obtained from the consumer over the telephone. 

This type of transaction can only be originated when there is either an existing relationship between the
Originator and Receiver or when the Receiver initiates the telephone call if a relationship does not
previously exist. 

Note: Information below assumes you are using a Profile-Based import.  If you are not (using Ad Hoc
instead), you must also import an account number as ACH_Account and an ABA/Routing Number as
ACH_Routing_ABA.  The below screenshot uses a name-based lookup to link each entry to a
customer, employee, or vendor profile.
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The mappings for remaining fields required to use TEL are:
· Name as ACH_Name_Internal (Profile Lookup)
· Amount as Amount

1.13.4.12 TXP - Tax Payments

TXP is not an SEC Code like the others, but instead, it refers to using a
specially formatted addenda alongside a CCD transaction to make tax
payments to local, state, or the federal government.

For example, companies are required by law to pay the federal 941 tax that
covers Social Security, Medicare, and employee withholding.  These
transactions are regular CCD on an ACH level.  However, each transaction
would include an addenda formatted based a specification outlined by the
taxing authority that contains information about the tax.

See the Tax Payments section for more information

1.13.4.13 WEB - Internet Initiated Entry

The WEB Standard Entry Class code is used for the origination of debit entries (recurring or single) to
a consumer's account based on an authorization that is obtained by the Receiver via the internet. 

The WEB code assists in addressing risk issues inherent to Internet Payments through requirements for
additional security procedures and obligation. 

The mappings for required fields to use WEB are:
· Name as Namea
· Amount as Amount or Amount_Reverse_Sign
· Account number as Bank_Account_Number
· Routing Number as ABA_Routing_Number
· Payment Type as Single_Recurring_WEB

In addition, Payment Related Text can be mapped as one of the Text fields (for example, Text4 or
Text5) to retain the information in ACH Universal.
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1.13.5 Frequently Asked Questions (FAQ)

1.13.5.1 Changing Default Standard Entry Class Code

Overview

In absence of specific instructions to use a certain Standard Entry Class Code
(SEC Code), ACH Universal will use the default SEC Code set during Account
Setup.

The default SEC Code is used unless the code is stipulated directly by
mapping the Class_3_Letters field to a field containing the SEC code. 

See List of Standard Entry Class Codes for the list of SEC Codes and more
information on each one.

From the main menu select File, then ACH Setup. Click the Next button three
times to display screen four (bottom left corner of screen).  At the top of the
screen, you will see Figure 1.

Figure 1 - Default SEC Code

For a non-CTX code, leave the top radio button selected and choose the
desired SEC Code from the dropdown box.  

For a CTX code, select the CTX-EDI Subsets radio button and then choose the
desired transaction set from the dropdown box.  In almost all cases, this will be
the EPN STP 820 set (currently shown).

Click Next two more times, then click Finish to exit the ACH Setup window and
save your changes.

1.13.5.2 Changing Profile Lookup Field

Overview

The profile lookup field is used by ACH Universal to match transactions to a
specific profile.  By default, ACH Universal uses the name field.
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In most situations, it is preferable to perform the lookup using an ID number
instead of name.  This is most commonly an employee ID or vendor ID.  Note:
For CTX transactions, you must use name.

Follow the steps below to change the default to use an ID lookup.

Steps

Select File from the main menu, then ACH Setup.

Click Next 4 times.  In the bottom left, you will see "Screen 5 of 6."

The top of the screen will look like Figure 1 (below).

Figure 1 - ACH Setup Profile Lookup

Click the radio button next to ID Number.

Click Next again, then Finish.

At this point, ACH Universal will use ID Number for the profile lookup.

In both the profile and transaction files, map the appropriate field containing the
ID number as ACH_ID_Internal (Profile Lookup).

1.13.5.3 Changing Debit and Credit Text

Overview

Debit and Credit text is used in conjunction with the Sign field to identify
whether a transaction in a file is a debit or a credit.  Follow the steps below to
enter the debit and credit text for your data.

Steps

From the main menu select File, then Options, then General.  
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In the "Text for Debit" field, enter the text to identify a debit transaction.  The
default is "debit".

In the "Text for Credit" field, enter the text to identify a credit transaction.  The
default is "credit".

When finished, click Close to save your changes.

1.13.5.4 I want to pay my vendors. What will they see on their bank statements?

Regardless as to whether you are collecting or paying funds, the other party will see the following
information:
· Amount
· Your company name
· Description of transaction (Entered during ACH Setup, usually describes transaction purpose, such

as AutoPay.)
· Effective transaction date
· Actual transaction post date
· Individual ID Name from the detailed transaction
· Individual ID Number from the detailed transaction

Your vendors may or may not see any addenda information, depending solely on the service provided
to them by their bank.
Of course the statement will also include other fields, such the amount and actual posting date to the
account.

1.13.5.5 I am collecting from customers. How do I know the funds went into my account?

Your bank tracks each transaction that you have submitted and will notify you of any transactions which
was unable to be completed.

For example, if an account has been closed, or if you are debiting funds and the account balance is
insufficient, you will be notified by your bank. This report can be printed/faxed or can be sent
electronically in an ACH Return file. Regardless of the format, the returned items will contain a standard
three-digit return code (an 'R' and two numeric digits).

In addition, your bank may offer optional services which will allow you to track all transactions, rather
than a negative-confirmation scenario. 

See Returns for more information.

1.13.5.6 I am on the Desktop platform with 1 workstation license. If I purchase an
additional workstation, can I share data?

Q: I'm on the Desktop platform and have 1 workstation.  If I purchase an
additional workstation license, can I share data between the two?

A: No. You will need to upgrade to the SQL Server Express or SQL Server
Platform.  With multiple workstations you can have a separation of data (payroll
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on one workstation, checking on another), but the two are unable to share
between them.  

1.13.5.7 What is an account?

Q: What is an account?

A: An account is the ACH Universal front-end to a database that stores all the
data you import.  For example, a Payroll account access a Payroll database
(either a .brd on the Desktop platform or a Payroll database on the SQL Server
platform).  This manual uses the term "account" instead of "database" because
that is how ACH Universal refers to them.

1.13.5.8 I have one source file but multiple databases. How do I split the file into the correct
database?

Q: I have one source file, but multiple ACH Universal databases. How do I split
the file into the appropriate database?

A: Use an import filter.  See Filtering Imports.

1.13.5.9 I have a non-standard date format. How do I use it?

Q: I have a non-standard date format.  How do I use it in ACH Universal?

A:  A non-standard format is a format which isn't supported by your Windows (Control Panel, Regional
Settings) Settings.

A date format of 31/12/2002 is non-standard in the United States, but is standard in the United
Kingdom.

To import non-standard formats, use a Custom Date Import (CDI).

From the main menu, select File, then Options, then General.  

In the Import tab, set  "Custom Date Import (CDI) G/L:" to On

Select Format, (31/12/2002, 2002/12/31, etc...)

Select a separator, (slash, colon, hyphen, none)

If the date is embedded within another field, see My date field is embedded within text.               

1.13.5.10 My date field is embedded within text. How do I import it?

Q: My date field is embedded within text.  How do I import it?

Use a Custom Date Import (CDI).

From the main menu, select File, then Options, then General.  

In the Import tab, set  "Custom Date Import (CDI) G/L:" to On
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In "CDI: Source Format G/L", select your date format from the dropdown box  (31/12/2002,
2002/12/31, etc...)

In "CDI: Separator G/L", select your separator, (slash, colon, hyphen, none)

In "CDI: Embedded Start G/L" enter the date's first position (counting from the left) within the field.  For
example, when date is in a field by itself, this position is 0. If there were three characters prior to the
start of the date, you would enter 4.

1.13.5.11 My bank requires a login record

Q: My bank requires a login record.  How do I set up ACH Universal to provide
one?

A: A login record, if used by the bank, is the very first line in an ACH file, even
before the file header record.  It is used by the bank to identify the sender. 
Distinct from ACH identification, the bank will use this information for
processing and tracking purposes.  

1.  Obtain the specific login record from the bank.
2.  Start the software, load the account you have created in ACH Universal
3.  Select the File menu, then Options, then Transmit to Bank
4.  Scroll to the Local File tab.
5.  Key in the login record exactly as specified by the bank into the textbox
labeled "Login record"
6.  Click Close to save your changes.

ACH Universal will now include the login record in every ACH file made in that
account.

1.13.5.12 ADO/MDAC Re-Installing

1 – Yes…After a clean install, the first error message received was the
“SwitchPrograms_SampleData” after clicking the ACH Universal Sample Account Demo from the
welcome new users screen.

ADO  - FAQ - http://support.microsoft.com/kb/183606 (link on the page is to the MDAC download)

MDAC Downloads - http://msdn2.microsoft.com/en-us/data/aa937730.aspx

1.13.6 Maintenance - Desktop

Overview
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The articles in this section provide information on backing up and restoring your
database (Desktop platform only) as well as  how to upgrade ACH Universal
and apply current service packs.

Database 

See Database Backup for information related to scheduling and working with
database backups.

See Restore Database for information on how to restore a database from a
backup.

Archiving

See Database Archiving for information on archiving records.  This is for
efficiency rather than backup purposes.

Upgrades and Service Packs

See Upgrade ACH Universal for steps on upgrading ACH Universal to the most
recent version. 

See Download Service Pack for steps on how to download and install the most
recent service pack.

1.13.6.1 Database Backup

Overview

Backing up is a necessary part of working with all data.  By backing up ACH
Universal on a regular basis, your data will be current in the event of an
emergency and you will minimize data loss.  Note: This article only applies to
the Desktop platform.  Contact your Database Administrator for procedures and
policies regarding SQL Server backups. 

Database backups are safeguards against unforeseeable computer errors (file
corruption, system failure).  By creating regular database backups, the chance
of data loss is minimized as there will be a regular backup in place.  ACH
Universal is set by default for automatic backups.  This can be turned off (not
recommended) or your own backups scheduled according to your own needs. 

Internal Database Storage
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ACH Universal stores all information for each account in a .brd file.  There is 1
brd file for each account and they share the same name.  For example, if you
create an account named Payroll, there will be a Payroll.brd database file that
contains all the data imported into that account. Never place the brd file on a
network drive and attempt to share it among multiple workstations.  Multiple
workstation licenses should only be used for totally separate database files
(through totally separate accounts).  If you need to share data, you must use the
SQL Server platform. 

Regardless of using ACH Universal's default backup policy or implementing
your own schedule, the backups are numbered automatically by ACH Universal
for identification.  The most recent backup will always have the extension .br1. 
The next most recent backup will have the extension .br2 and the third most
recent backup will have the extension .br3.  If a database restoration is needed,
restore using the br1 file first (as it is the most recent).  By default the backups
will be placed into the same directory as the .brd.  It is highly recommended
that the backups are always stored in the same directory with the brd file.

Automatic Backups (not for disaster recovery)

By default ACH Universal will backup your database in a pre-determined
schedule.

Note: The program uses this as a protection against database corruption. 
These backups are stored on the same drive as the production database, and
therefore will not proved for any protection on a hard drive crash or if there is
any damage to the computer.

It is highly recommended to leave this option on.  If you wish to turn it off:
From the main menu, select File, then Options, then General.  
Select the System tab. Change the "Backup data on exit" option to No. Click
Close to save your changes. 

Manual Backups - Disaster recovery
From the main menu, select File > Backup.

We highly recommend backing up to a server that is backed up off-site.
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1.13.6.2 Restore Database

Overview

Follow the steps below on the Desktop platform to restore a database backup.  For example, if the
database becomes corrupted, restoration would be required.

Database Restoration Procedures

Please follow the steps at:
http://www.treasurysoftware.com/support2-corrupt-database.html

1.13.6.3 Download Service Pack

Updates 

A Service Pack update is an in-cycle release that modifies some features of
ACH Universal.  This is distinct from an upgrade which requires a setup file be
downloaded and used.  The Service Pack can be downloaded and installed
automatically through ACH Universal.

Download Service Pack

From the Help tab, select Software > One Click Update.

If you have an Internet connection, click Yes to proceed with the download. 

ACH Universal will automatically download and install the newest service pack
if not already installed.

When prompted, close and restart ACH Universal to complete the service pack
installation.

1.13.7 Legacy Help

We are proud of our continual development of ACH Universal.

This folder contains help topics relevant to older versions of ACH Universal. 
While the screens and instructions may not apply to your version, we have
included them to support our existing client base.

1.13.8 Banking Features

Banking Features Top  Previous  Next

http://www.treasurysoftware.com/support2-corrupt-database.html
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ACH Universal enables users to create NACHA compliant files for use with Fedline and other
systems.
 
In addition to standard origination (PPD, CCD, etc...) transactions, the Processor Edition now
incorporates the features from the Banking Edition, including:
--Returns, and
--Notification of Changes
 

To create ACH Return files - you need a Processor edition of ACH Universal.
 
Note: If you are a client of a bank - you will want to view the client-side of returns.

 
 

1.13.8.1 Returns

Returns Setup   Previous  Next

  

Important - Returns (as are Notification of Changes) are kept
in a separate account within ACH Universal.
 

Setup:
1. Create a new account for Returns.
From the ACH Universal main menu select 'File', 'New Account', then select the option button
'CREATE' .  We suggest, and for this narrative, we will name the new account: Returns
 

 
2. ACH Setup Wizard
From the main menu select File > ACH Setup and navigate to the 3rd panel of the wizard (below) and
select XXX - Returns.
Notes: 
--Do not select any other options for this account - ie., do not make any entries for offset records,
etc...
--Exit and re-enter ACH Universal as prompted after completing this setup wizard.
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Don't forget to exit and re-enter the software as prompted.

Reminder: To create ACH Return files - you need a Processor edition of ACH Universal.

1.13.8.1.1  Returns - Manually adding records

Returns Use - Creating a return  Previous  Next

Once you have setup a 'Returns' account, you can enter transactions that you have received from
other financial institutions.
 
Creating a return record
 
1. Access the 'Add Record(s)' Window
Enter into the 'Returns' account within ACH Universal.
From the ACH Universal main menu select 'Edit', 'Add Record(s)'.
 
2a. Recommended method - copy and paste from the original ACH instructions



468

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

Open the original ACH transaction in a text editor such as Notepad.  Locate and copy the transaction.
 Note: Transaction records start with a '6'.
 
Click on the 'Paste Detail' (2nd link).  This will automatically populate the necessary fields for your
detail.
 
Then, return to the text editor and locate the batch header for this transaction.  Copy the batch
header.  Return to the 'Add Record(s)' window and click on the 'Paste Header' (1st link).  This will
automatically populate the necessary fields for your header information.

Note: The order in which you copy and paste is academic (5 record vs. 6 record).
 
Below is a sample batch header (row starting with '5') and transaction line (row starting with '6').  We
have included the first two lines as a ruler to help with the column positions (1 through 94).  Of
course, the ruler rows are not part of the ACH file.
 
       1         2         3         4         5         6         7         8         9  

1234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234

 

5220YOUR COMPANY                        1657777777PPDAUTOPAY   060815060815   1202881060000001

622248238184130009783        0000725152               AROUND THE HORN         0202881060000001

 

 
 
2b. Manually enter the original ACH information - not recommended
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Alternatively, you may manually enter the information into the window.  Please note that this method
is not recommended, as the information must be EXACTLY as originally transmitted.  Any
typographic error may result in a rejection of your return.
 
 
3. Return Code
On the bottom left of the 'Add Record(s)' window, select the Return Code (ie. Insufficient funds,
etc...).  Click 'Save' when finished.
 
 
When finished ....
Create and transmit the records from this account.  Please remember that these records will be in a
separate file from your 'regular' ACH transactions, and the file will have a different name (see 'File',
'Options', 'Transmit to Bank', 'Local File' for the name and location of this file).
 
Notes:
--Returns are created in the 'Add Record(s)' window and may be edited/modified before transmittal.
--There is no import functionality through the import wizard for returns.
 

Reminder: To create ACH Return files - you need a Processor edition of ACH Universal.

1.13.8.1.2  Returns - Importing records

In addition to manually entering the return records, they can be imported through the Import Wizard.
 
 
How do I start - Where do I get my data from?
 
If you have an in-house IT group that is supplying you with data - it should contain the information in the
chart at the end of this page.

The only way to get this data is to have access to the original ACH file.  You can parse this yourself, or
use our ACH-2-Excel conversion utility.

Example 
1. Use our built-in ACH-2-Excel conversion utility (from the main menu 'File', 'ACH File Conversion') to
create a comma delimited file.
 

2.  Import the entire comma delimited file created with ACH-2-Excel into your core processing system
or other database table.

The table should have an additional column for the Return Code.  Include the 'R' and leading 0 if
needed.  Therefore, the return code 1 - Insufficient funds, would be in your database as R01.

Note: Adding the column should be performed programmatically in your database and not in Excel.  If
the file is opened in Excel, it will convert the trace numbers into exponential notation - making them
unusable.

Once you have marked the records with the Return Code, export this to a comma delimited file.

Of course, not all records in the file you imported into your database are to be returned (at least we
hope not).  You will only want to export those with a return code.
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As an example, we have used ACH-2-Excel to convert an ACH file into a csv file.  Programmatically, we
have edited the file and removed the last field and substituted it with the return code (R01, R02, etc...). 
This file can be imported directly into ACH Universal.

3. Enter into the 'Returns' account within ACH Universal.  Start the import wizard and import your file.

Tips:
--If you used ACH-2-Excel to make your file - select the 'ACH NACHA RETURNS' mapping template. 
The columns will be in the correct order and position.

Note: When you select 'ACH NACHA RETURNS' for the first time, the system may warn you that the
mapping template has more fields than the file you are importing.  This is fine, as the additional field is
used only in Notification of Changes.

--When selecting the template - mark it as the default, by checking the default checkbox.  This is
required if you are going to perform any type of automation.

Assuming you have retained our file layout from ACH-2-Excel and simply added one additional field
(Return Code), this will map all the columns as shown below.
 
 
Notes:
--It is NOT necessary to map each column in order to generate a notification.  Banks vary widely in
their requirements of data - but of course, failure to include the information can result in their rejection. 
This is bank dependent.  The more information provided to the originator, the easier it will be for them
log your notice.
--The column in green, is the field to map to in ACH Universal.
--The middle column is a description, along with location of where the data was obtained from
First number - which record - header record '5', or the detail record '6'.
Second and third numbers - the start and end position within the record
--The last two entries, ReturnNOC_Code and Corrected_Data_Resend, are not from the original ACH
transaction.  The parenthesis in the last two lines refer to their location in the new  file.
 
 

http://www.treasurysoftware.com/Help-references/Transactions_To_Be_Returned.txt
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Note: The last line - Corrected_Data_Resend is not used in the Return file (only used in Notification of
Changes). 
 

Reminder: To create ACH Return files - you need a Processor edition of ACH Universal.

1.13.8.1.3  Returns - Creating files

Creating files

Create and transmit the records from this account.  Please remember that these records will be in a
separate file from your 'regular' ACH transactions, and the file will have a different name (see 'File',
'Options', 'Transmit to Bank', 'Local File' for the name and location of this file).
 

Automation
You may automate this process using our command line interface. 

Reminder: To create ACH Return files - you need a Processor edition of ACH Universal.

1.13.8.1.4  Returns - Processing from an ACH File

Returns - Processing from an ACH File

ACH Universal can create an ACH Return from from many sources.  
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This help page contains instructions if you are receiving an ACH file and need
to create returns based on a subset (hopefully small) of them.

Reminder: This functionality requires the Processor edition of ACH
Universal.

One-time setup

1. Create a new account to work in.
From the main menu select File > New > Create an account - and then
complete the wizard.
Note: In this example, we named the account 'Returns'.

2. Default the account to create ACH Return files
From the program Home Page, click ACH File Setup, then next.
Enter your header information here. 
Note: If you don't have your header information, you can skip this and come
back at any time.  It is not needed to create a file, but of course - you'll need to
enter it before sending to the FRB or your processor.

When finished, select 'Advanced Setup - Access all setup options' to enable the
'Next' button to continue.  Click Next.
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Select 'Returns (uses original class)'. Click Next, then Finish.
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3. Prepare sample/test data
On the Home tab, click ACH-2-Excel.  
On the form, select an ACH file to convert.  Once selected, allow the conversion
to continue.
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A spreadsheet will open with the converted data.  Format column H (Trace
number) as a number to avoid the values being displayed in Exponential
Notation.
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For this sample, add a column to the rightmost field - and enter return codes.  
Note: Enter the 'R' plus a leading digit if applicable.  For example, for
Insufficient Funds, enter R01 as below.

Save the file as an Excel file.

4. Set your mappings.
Click on Import Transactions to start the wizard.
Select the Excel file you just saved in the previous step and click Next.

In the upper right corner, select the mapping template 'ACH NACHA
Returns'
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Warning: There is a similar named template called 'ACH Returns', depending
on your version - you can use this as well.

Also check the 'Save as default'

This mapping template is used for a variety of purposes, so we're going to
modify it now for our use.
We're going to unmap four fields.  To unmap a field, click on the field.

First click on fields F3 and F4 to unmap them.  Your screen should now look
like:
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Field F5 should be mapped 'Name'.  Map this if needed.

Scroll to fields F31 and F32 and unmap them.

Now, we're going to map three fields.
Select field F32 and from the drop down list select Bank_Account_Number.
Select field F33 and select ABA_Routing_Number.

Click on the 'Show all field selections' (see red arrow below)
Select field F34 and select ReturnNOC_Code



479

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

Click Next, Next and Finish to import and most importantly - to save your
mappings.

Common mapping question:
Q: Amount - Why didn't we map field 2 for amount?  
A: This field is signed.  We already had field 26 mapped which is unsigned - as
the transaction code will supply the debit/credit information. 
Note: There are multiple amount fields for different purposes.

5. Create a test ACH Return File
From the Home page - click on the Go To Create ACH File Page - and then
click on Create (see below).
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Operations
1. Simply prepare the data file as above in step 3.  All other work has
been saved.
Note: Of course, your returns will only be a subset of the entire file.  Delete the
records within Excel that do not need to be returned.

Reminder:
This would be a good time to backup your work.  Click File > Backup.
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Reminder: To create ACH Return files - you need a Processor edition of ACH Universal.

1.13.8.2 Notification of Change

Use 'Notification of Change' when you are the RDFI (receiving financial institution) and you want to
notify the originator (ODFI) of an error in the ACH transaction.  Use a Notification of Change when
you can fulfill the ACH transaction.  Use a Return when you cannot fulfill the transaction.
 
 
Important ********
Notification of Changes (as are Returns) are kept in a separate account within ACH Universal.
 
 
Setup:
1. Create a new account for Notification of Changes.
From the ACH Universal main menu select 'File', 'New Account', then select the option button
'CREATE' .  We suggest, and for this narrative, we will name the new account:
Notification_of_Changes
 
Click through the wizard to complete it.  At the end you will be prompted to enter your transmittal
information.
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Click Yes - Enter Transmittal Information in the ACH Setup Wizard
 
2. ACH Setup Wizard
The information on screens two and three of the ACH Setup Wizard should be the same as the
information from your other account.
 
Hint: For additional reference, cancel the wizard, switch back to your other account and note/print the
entries.  Then go back to the account and re-start the ACH Setup Wizard from the main menu at
'File', 'ACH Setup'.
 
Screen Four - In 'Application - Standard Entry Class Code', the radio button 'All except EDI-CTX'
should be selected.  In the drop down box, select:
COR- Notification of Change
 
Do not make any entries for offset records.
 
Click through the wizard to complete it.  You will be prompted to exit and re-enter the account -
please do so.

Reminder: To create ACH Return files - you need a Processor edition of ACH Universal.

1.13.8.2.1  Notification of Change - Manually adding records

Once you have setup a 'Notification Of Changes' account, you can enter transactions that you have
received from other financial institutions.
 
Creating a Notification Of Changes record
 
1. Access the 'Add Record(s)' Window
Enter into the 'Notification Of Changes' account within ACH Universal.
From the ACH Universal main menu select 'Edit', 'Add Record(s)'.
 
2a. Recommended method - copy and paste from the original ACH instructions
Open the original ACH transaction in a text editor such as Notepad.  Locate and copy the transaction.
 Note: Transaction records start with a '6'.
 
Click on the 'Paste Detail' (2nd link).  This will automatically populate the necessary fields for your
detail.
 
Then, return to the text editor and locate the batch header for this transaction.  Copy the batch
header.  Return to the 'Add Record(s)' window and click on the 'Paste Header' (1st link).  This will
automatically populate the necessary fields for your header information.
 
Below is a sample batch header (row starting with '5') and transaction line (row starting with '6').  We
have included the first two lines as a ruler to help with the column positions (1 through 94).  Of
course, the ruler rows are not part of the ACH file.
 
       1         2         3         4         5         6         7         8         9  

1234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234

 

5220YOUR COMPANY                        1657777777PPDAUTOPAY   060815060815   1202881060000001

622248238184130009783        0000725152               AROUND THE HORN         0202881060000001
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2b. Manually enter the original ACH information - not recommended
Alternatively, you may manually enter the information into the window.  Please note that this method
is not recommended, as the information must be EXACTLY as originally transmitted.  Any
typographic error may result in a rejection of your Notification Of Change.
 
 
3. Notification Of Changes Code
On the bottom left of the 'Add Record(s)' window, select the Notification Of Change Code (ie.
incorrect account number, incorrect ABA number, etc...).  Enter the correct information to the right of
the code.  Click 'Save' when finished.
 
 
When finished ....
Create and transmit the records from this account.  Please remember that these records will be in a
separate file from your 'regular' ACH transactions, and the file will have a different name (see 'File',
'Options', 'Transmit to Bank', 'Local File' for the name and location of this file).
 
Notes:
--Notification Of Changes are created in the 'Add Record(s)' window and may be edited/modified
before transmittal.
--Notification Of Change transactions are batched within the file with a transaction type of 'COR'.

Reminder: To create ACH Return files - you need a Processor edition of ACH Universal.

1.13.8.2.2  Notification of Change - Importing records

In addition to manually entering the Notification of Changes transaction, they can be imported through
the Import Wizard.
 
This functionality, the Bank Merger/ABA utility, is used when banks consolidate and an automated
method is needed to notify the ACH originators of the ABA change.  Of course, the import
functionality can be used for any Notification of Change code.
 
Once you have setup a 'Notification Of Changes' account, you can enter transactions that you have
received from other financial institutions.
 
How do I start - Where do I get my data from?
 
Option #1 - ACH file
By far the quickest and most reliable approach is to get an ACH file from your bank or processor.
 
a. Use our built-in ACH2Excel conversion utility (from the main menu 'File', 'ACH File Conversion') to
create a comma delimited file.
 
b.  Provide the Notification Code and new information
--If you are notifying for updated ABA/Routing numbers or account numbers, simply add them to the
chart (from main menu 'Reports', then 'Notification - List of ABA's' or Notification - List of Accounts'.
Click the plus sign on the toolbar to add).  The system will automatically enter the code and new
information.
--For other Notification of Change codes, add two columns to the comma delimited file.  One for the
code (include the 'c' in the detail) and one for the new information.
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c. Enter into the 'Notification Of Changes' account within ACH Universal.  Start the import wizard and
select the 'ACH NACHA RETURNS' mapping template.  This will map all the columns as shown
below.
 
 
Option #2 - Other computer file
a. If you have an in-house IT group that is supplying you with data - it should contain the information
below (with the exception of the last two lines - ReturnNOC_Code and Corrected_Data_Resend).
 
Notes:
--It is NOT necessary to map each column in order to generate a notification.  Banks vary widely in
their requirements of data - but of course, failure to include the information can result in their
rejection.  This is bank dependent.  The more information provided to the originator, the easier it will
be for them log your notice.
--The column in green, is the field to map to in ACH Universal.
--The middle column is a description, along with location of where the data was obtained from
First number - which record - header record '5', or the detail record '6'.
Second and third numbers - the start and end position within the record
--The last two entries, ReturnNOC_Code and Corrected_Data_Resend, are not from the original ACH
transaction.  The parenthesis refer to their location in the new Notification of Change file.
 
 

 
b.  Provide the Notification Code and new information
--If you are notifying for updated ABA/Routing numbers or account numbers, simply add them to the
chart (from main menu 'Reports', then 'Notification - List of ABA's' or Notification - List of Accounts'.
Click the plus sign on the toolbar to add).  The system will automatically enter the code and new
information.
--For other codes, add two columns to the comma delimited file.  One for the code (include the 'c' in
the detail) and one for the new information.
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c. Enter into the 'Notification Of Changes' account within ACH Universal.  Start the import wizard and
select an unused mapping template.  Map the columns as shown above.
 
 
 
When finished ....
Create and transmit the records from this account.  Please remember that these records will be in a
separate file from your 'regular' ACH transactions, and the file will have a different name (see 'File',
'Options', 'Transmit to Bank', 'Local File' for the name and location of this file).
 
Notes:
--Notification Of Changes are created in the 'Add Record(s)' window and may be edited/modified
before transmittal.
--Notification Of Change transactions are batched within the file with a transaction type of 'COR'.
 

Reminder: To create ACH Return files - you need a Processor edition of ACH Universal.

1.13.8.2.3  Notification of Change - Creating files

Creating files

Create and transmit the records from this account.  Please remember that these records will be in a
separate file from your 'regular' ACH transactions, and the file will have a different name (see 'File',
'Options', 'Transmit to Bank', 'Local File' for the name and location of this file).
 

Automation
You may automate this process using our command line interface. 

Reminder: To create ACH Return files - you need a Processor edition of ACH Universal.

1.13.9 SQL Lockout

SQL Lockout - Resetting the SQL settings

Use this page if you have been up and running using SQL Server - and then
your Network Administrator changed a user's password SQL password - or
other connection information.

Rather than uninstall, reinstall and re-configure Treasury Software, you can
simply reset the SQL Settings.

This article covers:
1. Accessing the 'Reset Connection to Desktop'
2. Reconnecting to SQL
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1. Accessing the 'Reset Connection to Desktop'
a. Start the software at the workstation.
If you have already entered a license code, click on the 'Back to Welcome'
button on the lower left corner.  If you have not entered a license, proceed to
step b.
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b. On the Welcome New Users Page, select Help

c. Select "enter License Codes.
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Tip: While there are a lot of message prompts below - just remember: 
When asked to create an account - click 'No'.
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It will repeat - select No.
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When you restart the software, you will be in desktop mode.
You will only have a Sample account.
Enter into the sample account.

Summary:
While there are a lot of message prompts - just remember: When asked
to create an account - click 'No'.

2. Reconnecting to SQL
From the Ribbon Bar, select Settings > Migrate to SQL Server and follow the
prompts.
Enter the new settings in this process.
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Done.

1.13.10 U.S. Bank Secure Payment

ACH Universal enables you to create files that are compatible with U.S. Bank's
Secure Payment format.

While the Secure Payment format is similar to an ACH file, there are several
differences.  To account for these differences, you will need to enter a custom
code into ACH Universal.

I. Setup
1. Download and install the software:
http://www.treasurysoftware.com/download.aspx

Tip: If you are installing for a multi-user environment, please see additional
documentation at:
http://www.treasurysoftware.com/support2-Install-Center.html

Start the software if you haven't done so already.  

2. Create a new account by selecting File > New Account > Create
Complete the wizard.

3. Enter your custom code obtained from US Bank
You can enter the custom code by selecting the Settings tab then 'Import,
System' to access the Options window.
Then enter your code on the 'CustomCode 1' line, press 'UPDATE', then
'Close'.

http://www.treasurysoftware.com/download.aspx
http://www.treasurysoftware.com/support2-Install-Center.html
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Note: Upon clicking 'Update', you will receive the following message (assuming
you entered the correct code):

4. Enter your Company Information in ACH Setup
You can access the setup wizard from the lower left corner of the program
home page.
Please enter all four line items as supplied by US Bank.
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Congratulations - you're done with the account setup.

II. Creating a file
5. Importing transactions
Click the Import Transactions button on the Home Page to start the Import
Wizard.
Point to your Excel or csv file with the following fields:
Amount
Employee Name
ID_Number

Click next to bring you to the Mapping Window.  Map the fields as noted below.

****IMPORTANT - The amount field must be imported as a credit
(negative).******
Either:
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Have your amounts signed as a negative and map as 'Amount'
or
If your amounts are not signed (positive), map as 'Amount_Reverse_Sign'.
Failure to sign the amount properly will result in an improperly formatted file.

Click Next, review your records and complete the wizard.

6. Create the Secure Payment file
Click on Create ACH File to create the file.
Send this file to US Bank.
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Notes:
--The US Bank Secure Payment utility is different than an ACH file.  Other
features within ACH Universal may not be compatible with this format.
Setting or engaging features not documented on this page - may result in a
Secure Payment file no longer compatible with US Bank specifications.

--This format requires a Processor level license. 

Need additional assistance - please contact Treasury Software Support at 866
226-5732 or contact us.

U.S. Bank and the U.S. Bank logo are registered trademarks of U.S. Bank

1.13.11 RBC Royal Bank of Canada

RBC Royal Bank of Canada

Who should read this page:
This page is for Canadian users who want to originate ACH payments with
RBC - Royal Bank of Canada and the receiving bank is also Canadian.
ACH Universal is fully compliant with the Royal Bank of Canada when the
following option settings are selected.

Note: If a Canadian user wants to have the receiving bank in the US, you'll need
to create an IAT transaction - and these instructions can be found at ACH-IAT.

To originate with the RBC - Royal Bank of Canada:

1. Click on ACH Setup from the Home page of the software.

http://www.treasurysoftware.com/contact.aspx
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2. Click Next until you get to screen 5.  Tip: At screen 2, you'll need to select
'Advanced' to continue.
Enter 'CA' for your Discretionary Data.
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3. Click Next until you arrive at screen 7.  Click on the far right tab Advanced >
Non-standard adjustments > Perform no verification of ABA numbers.
Click Finish.
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4. Finally, RBC uses an embedded login record for security.  Note: If you are
uploading to a correspondent bank, you might not need to include this.
As with all of the settings, consult with your banker.

To enter your login record, click on Settings > Transmission Options > Local
File > General > and enter the login record as shown below.
Click Close when finished.
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You're all set.  Of course, if you are working with a correspondent bank, and
they advise you to skip the login record (or other setting), as always - please
follow their specific instructions.
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1.13.12 CitiDirect NA ACH Global File Format

     

Citibank 

This page is for CitiDirect clients who are on the Global Electronic Customer
Delivery platform.
The format is also referred to as CitiDirect File Import (5.1 latest format), North
America – United States Flat File Import Specification.

If your Citibank account is not on the platform noted above - and it accepts a
standard ACH (a.k.a. NACHA) files - stop here and do not use this page.

ACH Universal™ creates both the ACH Credit and ACH Debit record formats
for CitiDirect.

ACH Universal helps you create EFT files for:
Direct deposit for employees
Collections from customers
Payments to vendors 

ACH (NACHA) vs CitiDirect processes
Unless noted otherwise, all processes are the same for the two formats.  
Please follow the same instructions and videos as the NACHA format.

All major functions of ACH Universal that are used to create ACH files, are also
available to create the CitiDirect files.  This includes:
--Excel and csv file import, and profile-based import
--QuickBooks integration
--Email notification
--Security features including encryption, web and/or SSH transmission and
SQL Server support
--Automation - Software Integration Kit

Notes: 
--Bank accounts should be a one to one match to accounts within ACH
Universal.  If you are using using multiple origination accounts, please create
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an account within ACH Universal for each account, as our multiple origination
account format (stacking) is not applicable for this format.
--ACH-CTX is an EDI format, and this is not supported in the CitiDirect format.

Ready to get started? See our setup page.

   

1.13.12.1 Setup - CitiDirect ACH File Format

How to create CitiDirect ACH Credits and ACH Debits for the
North American Global Platform



504

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

1. Create a new account within ACH Universal
Click File > New Account and complete the Wizard.

2. Start the ACH Wizard.
To start the Wizard, on the Home page, click on the 'ACH Setup' icon on the
lower left of the main screen to start the ACH File Setup Wizard.
Alternatively, on the Home tab, click ACH File Setup.

3. Access the Citibank Options panel.
Please continue to screen 7 of 7 by clicking 'Next'.
Tip: At screen 2, you'll need to select the radio button at the bottom to opt for
'Advanced'.
Click the Advanced sub-tab, then non-standard adjustments.  
Click on the Citibank - Show Options' link.
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4. Complete the Citibank Options panel
Click on 'Activate Citibank format', then enter your bank account number.
Leave the two remaining options on their default setting unless instructed
otherwise. Click OK.
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FAQ
Should I enter any information within the ACH File Setup Wizard (7 screens)?
No, please leave the settings at their default settings - and any entries empty.

Click 'OK' when you're all set.

Sample Output
After you complete the process, your file will look like:

Click on the file - or on this link to open the file in Notepad - CitiDirect-ACH-
DebitandCredit-sample-file

1.13.13 Custom Codes

This section is to document code extensions for clients with whom Treasury
Software Support has been working with.
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Do not enter any custom code unless you have been contacted by Treasury
Software support to do so.

There may be additional procedures, update routines and archiving processes
that run in the background which are not documented in this section.

Treasury Software cannot support the unauthorized use of custom codes for
clients other than those for which this code is intended for.

1.13.13.1 369

Custom Code 369

Do not enter this code unless you have been contacted by Treasury
Software support.  
There may be additional procedures, update routines and archiving processes
that run in the background which are not documented here.

Treasury Software cannot support the unauthorized use of custom codes for
clients other than those for which this code is intended for.

Alternative QuickBooks email address

Before you begin:
A. Backup your QuickBooks data files.
B. Backup your Treasury Software account file (brd files).  Please use either
File > Backup or simply copy using WIndows Explorer to copy the folder C:
\Users\Public\Treasury Software

Did you backup your data - we really mean it!

Next steps:
1. Download and install Treasury Software version 2016, build 606 or later from
http://www.treasurysoftware.com/download/index.aspx

2. Start Treasury Software.  From the main menu select 'File' > 'New Account' >
'Add an Existing Account' to your catalog and select the .BRD (account) file to
add to your catalog. Allow the software to update the account(s) if prompted.
Repeat this step for each .BRD (account) file.  Enter your new license codes.

http://www.treasurysoftware.com/download/index.aspx
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3. Enter into the account in Treasury Software you will be using.
On the main ribbon bar, click Settings > 'Import, System' > then on the pop-up
window - Custom tab (on the far right) > enter 369 in Custom Code 1 > Update.
Close the window when complete.

In QuickBooks
4. Enter into the account in QuickBooks you'll be using.  Enter into the Vendor
Center and select any vendor and edit that vendor.  Select Additional Info tab >
Define Fields.  Create the two additional fields for vendors (and make sure that
you check the box to display):
Email P1
Email P2
Save your work.  When finished it should look like the image below.
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Let's now move your email addresses from Alt Email 1 to the fields Email P1
(and Email P2 for overflow).

5. In QuickBooks, run a Vendor Contact list report by selecting Reports >
Vendors & Payables > Vendor Contact List.
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Add the Alt Email 1 field to the report by clicking on Customize Report >
checking Alt. Email 1.

6. Save this report to Excel.  Note that you will have a column header titled
'Vendor'.

7. In Treasury Software, select QuickBooks > Update Vendors in QB > select
the file and click Next.
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Map only two fields:
Name
ACH_Email_Address
and complete the wizard.
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Note: Do NOT map any other fields.

When finished, you'll get a 'Done' message and this report.
The header will be listed.  Please review for any other vendors.
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Congratulations!!

Setup is complete.  Use the software as usual.  When emailing ACH remittance
emails, the system will use the address in Email P1 (and Email P2) as rollover.

FAQ's
Why are there two fields Email P1 and Email P2?
There are length limitations within QuickBooks, and any emails too long will roll
to the next field.

How I enter new email addresses in?
If they're 21 characters or less, you can simply enter them into Email P1.
However, for simplicity (and having to avoid counting) - you can split them
between both fields at any point.
For example:
Email P1 accounting@
Email P2 treasurysoftware.com

During the email process the system simply concatenates the two fields.

1.13.14 FAQ's

This section has a number of common questions that are asked and we
answer.

1.13.14.1 How do I change the effective date on something I just imported?

If you want to change the effective date on something you just imported follow the steps
below.
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1. Select Untransmitted Records icon from your top menu bar.

2. Select the records you want to change the effective date. To select the row select
where the red arrow is pointing.

3. Select the change date icon   this will allow for you to select a new effective date.

4. Change your date and select Apply Dates
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5. Select the Home icon  to take you back to the main screen to finish importing your
file.

6. Select Go to Create ACH File Page

7. Select Create ACH File and your file will be ready to go to the bank.

1.13.14.2 How to I create a balanced file or offset record or have debits equal credits?

To create a offset record which is also known as having your file balanced can
be done by following the setups below.

Open the account you want to be balanced.

From the top menu select the 'Home'  the select 'ACH Setup' 

Proceed to the 4th screen (into advanced).

First you will want to Enable the offset record, see the red arrow.  
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Input your bank's Routing number and your Account number then if you want put in
your Company name.

Once you are done select Finish.

1.13.14.3 How do I re-import a file I just created?

Have you ever needed to re-import a file that you just created because you had
made a mistake?  This can be done very quickly by following the steps below:

1.  Select the Delete Entire Import icon on the Home tab main menu bar.

2.  Select the import you want to delete.
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3. Once the import is selected look for a red X to delete that import.

4.  Confirm the deletion.

5.  Once the import is gone you can re-import your file.

1.13.14.4 How do I re-import my QuickBook file?

If you need to re-import a file you made using QuickBooks integration, you can
do this by following the steps below:

1.  Select the QuickBooks integration button from the main tool bar.

2.  Select the date range you need to re-import.
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3.  Don't panic the next screen you will be show any transaction.
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4.  When you remove the check mark next to Hide transactions already process
(see red arrow) your transactions will re-appear.

5.  Click and high-lite the transaction you want to re-import and select the Send
(over-ride) button.
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6.  Now your transactions are ready to be imported.  Select Send transactions
to ACH Universal and your file is ready to be sent again.
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1.13.14.5 Why can I not connect to QuickBook?

Are you unable to connect to QuickBooks using the QuickBooks integration
button?  Was it woking just the other day?  There are a couple of questions you
might want to ask yourself or your IT department.

1.  Have you done all your QuickBooks updates?  To verify this let's take a look
at QuickBooks under the Help menu and select Update QuickBooks.



523

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

2.  When the Update QuickBooks box opens select the Update Now tab and
scroll down the list and see if anything needs to be updated.  If it does select
Get Update (see the red arrows)  ** One thing to note if you do not have ADMIN
privileges you will not be able to do this, so you will want to contact your IT
department.



524

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

3.  If there are updates please complete the Update process and exit out of
QuickBooks and Treasury Software then re-enter both applications and try
connecting again.

4.  If there are no updates or doing the updates does not resolve your issue you
will need to remove the Treasury Software certificate from QuickBooks and add
the certificate back into QuickBooks.  To do this you will need to be logged into
QuickBooks as Admin and in Single User Mode.

5.  Once you are logged in as Admin and Single User Mode you will need to
select Edit then Preferences.
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6.  Then select Integrated Applications, then select Company Preferences,
then select Treasury Software and then select Remove
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7.  Then select OK and then confirm the deletion by selecting YES.

8.  Then you will see that Treasury Software certificate is gone.  Once it is gone
you can select OK.
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9.  Exit QuickBooks and Treasury Software, then open Treasury Software and
open QuickBooks and make sure you login as the ADMIN in Single User Mode.
 Now we are going to add the Treasury Software certificate back into
QuickBooks.

10. While is Treasury Software you will want to make sure you are in your
account that you want to integrate with QuickBooks.  Inside of Treasury
Software select QuickBooks from the main menu, then select QuickBooks
Integration.

11.  Look down in your task bar at your QuickBooks icon it should be flashing. 
If it is flashing please select it.
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12.  When you open QuickBooks certificate should be open.  You will want to
select the 3rd option ( Yes, whenever this QuickBooks company file is open). 
Then select Continue!

13.  Then you will want to select DONE on the Access Confirmation page.
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14.  Then the QuickBook Integration Wizard will start up.  You will want to
select Next on this page.
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15.  Then select your account you wish to use, then select Next.
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16.  The on this next screen you won't need to change because you have
already populated your fields.  All you need to do is select Next.
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17.  And you are done so just select FINISH!
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18.  If you are able to successfully re-connect you should see your data being
populated!
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If you have done all these steps and you are still unable to connect your
QuickBooks back to Treasury Software please contact us at:  Contact Support!

1.13.14.6 How do I create a prenote?

Pre-notes are zero-dollar transaction that is transmitted and processed to
ensure you have the proper information for your bank for transmission, as well
as having the proper information for the other party.  In other words, a pre-
notification is a test transaction sent before the transmission of live data..

To create a pre-note using QuickBooks can easily be done by following the
steps below:

From the main menu select QuickBooks the select QuickBooks Integration.

http://treasurysoftware.com/contact-us/index.aspx
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Then you need to select the the Utilities tab and then make sure the Prenote
tab is selected.  

Then you will want to select which item you want to send a pre-note for, either
Customers, Employees or Vendors.  Now you can send one group or all 3, it is
up to you.  Once you make your choice select Display List.

In our example we chose to do just employees.
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Select the Name you want to send the pre-note for, see the red arrow in the
example. Then select Send pre-notes to ACH Universal button.
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Once you select Send pre-notes to ACH Universal your file is created and you
can send it to the bank. (See the example of what a pre-note will look like)
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1.13.14.7 I was able to get into my software yesterday but today I am getting an error?

Were you able to get into your ACH Universal software yesterday and today you
are having trouble.  First you need to know is there an error occurring?  If so
does it read something like this example below?

If you are running the ACH Universal Desktop version of our software you may
have a corrupt database.  You can easily fix this issue by restoring a backup
copy of your database.

1.  From the main menu select File then select Restore
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2.  Then you will need select which database you want to restore, (see the
red arrow) and then select Display Backups.
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3.  Choose a date you want to restore from, (see the red arrow) and then select
Restore.  

( *** NOTE:  If you are using PROFILES you may have to re-create those who
use inserted since the restore date.)
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4.  Once you select Restore the next screen opens all you have to do is select
OK
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5.  This next screen will ask you if your file was restored properly?  
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6.  Open Treasury Software and see if you are able to get into your database.  If
you are not able to get into your database please contact support at:  Contact
Support

1.13.14.8 How can I see the full account number in my report?

Do you want to see the full account number when pulling a report?  That can be
done by following the steps below:

From the main menu select Settings > Import, System

This will open the Import, Systems Options page.  On this page select the
Custom tab.

http://www.treasurysoftware.com/contact-us/index.aspx
http://www.treasurysoftware.com/contact-us/index.aspx
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Enter in the custom code technical support supplied you into the System Entry
2, then select Refresh, then select OK and then Close.
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Then exit out of the software and then restart.  Then select the report you want
to see the full account number.  Then select View, (see RED box)
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Then select Hide/Display Columns
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Place a check next to Account_Number in the Hide/Display Columns box,
(see item circled in Red).  Then you will see the Account Number column
appear, see Green circle.

To close the Hide/Display Columns box select the Red X.



548

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

*** Now one thing to note, we do not recommend keeping this custom code active.  We
recommend you remove it once you are done with your report because of security issues.

1.13.14.9 Why didn’t my file transmit to the bank?

There are a number of different reason's why your file did not transmit to the
bank.  Take a look at the list below to determine why it did not happen.

1st did you contact your bank and see how they wanted you to get the file to
them?

Your bank determines the method on how the file can be sent to them.  See the
image below on the different methods that ACH Universal has to offer, but
again your bank is the one that determines it:
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2nd if the bank wants you to upload the file to them did you log into the banks
web site and upload the file?

If you did not log instructions from the bank regarding logging into your bank
site you need to contact them directly.  They are the ones who can assist you
through this process.  We do not have ID's or password's from the bank.

3rd if you uploaded the file were there any errors?  

If so tell us what the error is by filling out a ticket through our web site at: 
Contact support 

http://treasurysoftware.com/contact-us/index.aspx
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Make sure you supply us a screen shot of what the error is, that way we can
quickly diagnose the issue.  Sometimes the error is a bank error and we will be
happy to point you in the right direction to resolve any types of errors. To
capture a screen shot from your PC you can utilize the key board stocks of
CTRL PRTSCRN and then paste the error in a document and send that to us
though our ticketing system on our site.

4th if you get an error using the automated system SSH-FTP send a screen
shot of the error and we will assist you with resolving this issue.  

1.13.14.10How to make the 5 record a 200

Have you ever needed to make the 5 record read 5200 as opposed to a 5220? 
Follow the instructions and screen shot below to get this completed.

You can enter a 'custom code' and this will force all batches to have a 200 (5200 )

To enter the custom code, please see the attached screen shot - and enter code: 

353
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1.13.15 Debits Company ID Credits Company ID

Assigning Company ID's to Debit batches and another Company ID to
Credit batches

This is required by several banks, including Bank of America (BOA).

From the program home page, click ACH Setup > then navigate through the
wizard to screen 5 of 7.

Check the box to separate debit from credit batches.
Then click the hyperlink to access the form for your Company ID's.

On the Maintain Company ID's page:
--Check the box
--Enter your ID's
--Save
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Upon saving your work on the Maintain Company ID's page, you will return to
the ACH Setup Wizard.
Click Next, Next, Finish to save your work in the wizard.

Now go ahead and import your data and create a file - it will automatically
assign the correct company ID's.



553

ACH Universal                                                                                                                                                                                                         © 2019 Treasury Software

ACH Universal

1.14 Utilities

Utilities

This is a catch all for the various utilities included in all modules.

Please note that not all utilities will be listed, as this listing may be limited to
your license level.

1.14.1 BAI File Creator

BAI File Creator

Use these instructions to create a BAI 2 formatted file from any any imported file
- such as Excel, a comma delimited (csv) file or tab delimited file.

1. Select Bank Positive Pay upon startup

Set the BAI switch (perform only once)
To access:
From the Home tab, select BAI Utilities.
On the BAI Utilities pop up window - select One-time setup within BAI File
Creation
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Set options:
Please enter your identifying information, as well as your client's.
Notes: 
--This can alphanumerical data - it is not limited to the ABA number.
--SAP and Oracle users - you can enter your Company ID - or any thing you
want for the bank book here.
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3. Map the fields of the file that you are importing (perform only
once)
a. Click on the Import Wizard, and select the file containing your transactions. 
The file format can be Excel, comma delimited (csv), tab delimited or any other
format that is supported.
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Tip:  Use the file below as a template:
C:\Users\Public\Treasury
Software\Tutorial\BAI2Excel\TransactionsforBAICreation.csv

b.  Map the columns as appropriate
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The following fields can be mapped:
· Date
· Amount   
· Account Number 
· BAI Originator
· Bank Reference 
· Customer Reference 
· Description
· BAI Code 

Amount field mapping
Map the amount field as 'Amount'  - and confirm that your debits are
credits are correct in the output file (default debit 699, credit 399).
If they are reversed, then map the field as 'Amount_Reverse_Sign' and
re-test.

Amount note: 
(Rare) If you are not using the default BAI codes in setup, but instead you are
including them - in your source Excel or csv file - and Mapping them as 'BAI
Code' - make sure that all of your amounts in the file are absolute (positive).
Why?  The BAI Code if mapped, will change the signs of the amounts to
represent debits/credits.
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Other mapping notes:

--The three description fields - customer reference, bank reference and
text/description - are all optional.

--The import file can contain one or multiple account numbers.  However, if you
need to create BAI files for more than one recipient (ie. if you are a bank and
have multiple clients), you will need to create a new account/database (File >
New Account > Create) for each client.

Complete the Import Wizard.  Your mappings are automatically saved.

4. Create the BAI file
Simply click the Create Issue File button on the 'Create' page.
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1.14.1.1 BAI File Creation Advanced

BAI File Creation - Advanced

Pre-release notes for 2014.0.1 build 414 (September 2014).

New features include:
Default account numbers
Currency code
010 - Opening Ledger 
015 - Closing Ledger
100 - Total Credits
400 - Total Debits
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Access the BAI options window as usual.  There are now three tabs to work
from.

General tab

New features:
Default account number.  If not imported, the system will use the number here.
Note: If no number is imported, and a value is not set, the system will default to
0.

Advanced Tab

New features:
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Include 100 and 400 segments in the 03 account record.  The system will
automatically calculate the amount values.
Currency code for the 03 account record.  Note: Only enter this value for
currencies other than USD.  Reminder, the value should be three characters.

Opening (010) and Closing (015) Ledger

New features:
Include 010 and 015 segments in the 03 account record.

010 Options include:
Always off
Include 010 and Amount if amount <> $0. If amount = $0, then suppress both
010 and amount.
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Include 010 and Amount if amount <> $0. If amount = $0, then display 010, but
suppress amount
Always include both.

015 Options include:
Always off
Include 015 and Amount if amount <> $0. If amount = $0, then suppress both
015 and amount.
Include 015 and Amount if amount <> $0. If amount = $0, then display 015, but
suppress amount
Always include both.

Remember - these amounts must be included with the import file - see
below.
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Importing Opening (010) and Closing (015) Ledger Balances

The system cannot calculate the opening and closing balances.  These
amounts must be imported into the system.

Example for using both 010 and 015:
Create a file with two additional columns, one for each of the values.

Enter the beginning and ending value on at least one record for each 03 record.

Remember: 03 records are created for each Account, by Date.
You may put the beginning and ending values on one, several or all of the
records within each 03 grouping.

If you put different non-zero amounts on different lines within the same 03
grouping, the system will take the last value (not necessarily in your order -
never a good idea).

Map the columns during import
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Create the BAI file as usual.

01,test,test,140902,1223,1,,,2/
02,,test,1,181022,,/
03,445523232,CAN,010,1345624,,,015,1984367,,,,,,100,6830
60,400,0,,,/
16,399,346685,Z,,,Miami/
16,399,336375,Z,,,Fort Lauderdale/
49,683060,4/
03,92384732,CAN,010,380731,,,015,429004,,,,,,100,616600,
400,0,,,/
16,399,262575,Z,,,Boca Raton/
16,399,186250,Z,,,Palm Beach/
16,399,167775,Z,,,Atlanta - Downtown/
49,616600,5/
98,1299660,2,11/
99,1299660,1,13/

SAP Compliance
Using the above features will enable your file to fulfill the requirement for SAP.
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1.14.2 ACH-2-Excel - ACH Conversion Utility

Overview

ACH2Excel is a utility included with ACH Universal used to convert an ACH file to an Excel spreadsheet
(.xls).  You can use it through ACH Universal or through the command line.

ACH2Excel through ACH Universal

Using ACH2Excel through ACH Universal is the most common method.  

From the main menu, select File, then ACH File Conversion.  You will see Figure 1 (below).

Figure 1 - ACH2Excel Input tab

Click the  and browse to the ACH file to be converted.  

To do a quick conversion, click Done.  This will convert the file and load it in Excel (as a csv value).  

To specify file output options, click Output to open the Output tab (Figure 2 below).
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Figure 2 - ACH2Excel Output tab

To output the conversion to a specific click, enable the Output to 'csv' file located in the directory

checkbox, then click the  button to browse to the appropriate directory.  

To import the converted file into ACH Universal for further processing (such as an ACH Return File for
Returns), enable the checkbox. 

Click Done to create the file. 

Command Line Options

BRCom.exe /ACCT="account" /ACH2 /SRCE="input file name" /OUTD="output file name"

/ACCT - specifies account by name
/ACH2 - specifies to use the ACH2Excel utility
/SRCE - specifies file to be used as input (using absolute positioning)
/OUTD - specifies file to be used as output (using absolute positioning)
Valid source files include ARC, CCD, CIE, CTX, DNE, ENR, POP, PPD, RCK, TEL, TRC, TRX, WEB,
XCK. Note: Some formats may require further parsing.

Syntax Example
If Treasury Desktop was installed in the default location:

c:\Program Files\TreasurySoftware\BRCOM.exe /ACCT="sample" /ACH2 /SRCE="C:
\transmit.txt" /outd="c:\testACHdetail.csv"

Reminder:
Turn on/off appropriate settings. From the main menu 'File', 'ACH File Conversion', 'Output' tab -
unselect open in Excel afterwards.
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Notes for all applications:
· The order of the parameters is not significant
· Capitalization is not significant
· When specifying a file name (SRCE), use the full file path and name within quotes. When using
mapped drives, remember that the path should be centric/relative to the machine where Treasury
Desktop is located, not the machine issuing the trigger/command.
· Place the account name in quotes.
Working with multiple users and multiple account:
Each command line trigger - will create an independent instance of the application. There is no limit to
the number of instances.

If processing simultaneous command line requests, use different accounts (Sample1, Sample2, etc...)
to minimize any record locking issues. If this is not an alternative, consider processing sequentially, or
using our Control Panel. 

For Web and Citrix based applications, please contact a Treasury Software support representative.

1.14.3 ACH Edit

ACH Edit™

ACH Edit is a utility within ACH Universal Processor edition, which enables
users to edit and then recreate ACH files.  Transactions can be:
--added
--edited
--deleted

Getting Started (2 steps):
1. Create a new account within ACH Universal Processor edition.
Click File > New Account > Create - and complete the wizard.

2. Turn ACH Edit 'On'.
Click on Home > ACH File Setup > click to screen 6 of the wizard > check 'ACH
Edit'. Complete the wizard to save.
Tip: On the screen 2 will be the default file and batch header settings.  You can
enter this now, or any time before transmitting to your bank.
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Congratulations, you're done with Setup.

Use
1. Import ACH files
Start the Import Wizard using the bottom half of the Import Transactions button
and selecting Import ACH file.
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The Wizard will walk you through several screens including the Mapping
window.  Do not change any of the mappings.

2. View all records - then Add/Edit/Delete records
Click Home > Untransmitted Records > to display all of the records
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Once you've displayed the records, you can add, edit and delete.
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Add

Edit
Select the record, then click 'Edit Record'

Delete
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3. Create the ACH file
Select Home > Go to ACH File Create Page > Click on Create ACH File -
you're all done!
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Notes:
--This feature requires the Processor edition of ACH Universal.

--The import and file creation process can be automated with the included
Software Integration Kit.

--Dates can be updated for multiple records using the 'Change Dates' icon on
the Reports toolbar.  To use the current default date, unmap the 'Date' field
from Field 1 in the import wizard.

1.14.4 Notification of Change ABA Merge Utility

Overview

The Notification of Change Merge Utility enables users to Import an ACH file
and generate Notification of Change transactions for each record which has the
old ABA number.

The Notification of Change (COR) entry will contain the new ABA number as
the corrected data, as well as 'C02' (Updated ABA number) as the NOC code.

After the Notification of Change transactions are created, you can create an
ACH file to send, just like any other ACH file.

Notes: 
--Transactions in the ACH file which do not have the old ABA number are
ignored.
--This utility is only available in the Banking Edition

Setup

We recommend that you print this page prior to starting.

1. Create a new account specifically for this utility
From the main menu select File > New > Create and complete the New
Account Wizard.  When finished, it will prompt you if you want to 'Enter your
transmission information now?'. Click Yes.

2. ACH Setup wizard 
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Note: If you did not select 'Yes' in the step above, simply select File > ACH
Setup to start the wizard.

a. On screen 3 of 7 select COR - Notification of Change. 

b. On screen 7 of 7 click on the 'NOC-COR' tab.

Enter the old and new ABA numbers.

We recommend checking the 'Auto-delete' feature.  This feature addresses the
ACH records you will be importing that do not use the old ABA number.  As
these records are of no use to you, we can provide the housekeeping
functionality to remove them.  However, if you wish to keep them - leave the
checkbox unchecked.  
Click 'Finish' to save your updates.
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c. Import Safety Locks - recommended (not required):
We highly recommend putting the Import Safety Locks 'On'.
From the main menu select File > Options > General > Import tab.  Scroll to the
bottom and turn the Safety Locks 'On'.  
This prevents your users from accidentally trying to import the ACH file from the
main screen icon.  If they try to import from the main screen it will only convert
their ACH file to Excel, it will not import the file.
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Use:
Import ACH file received
Import your ACH file received from the Federal Reserve Bank (or other
processor) from the main menu at Import > ACH File > ACH File.
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Create new ACH file containing NOC's
Click on the 'Create ACH File' button on the home page, then click on the
'Create ACH File' button on the creation page.

Note: The count on the creation page is for all transactions in the file, not just
the NOC transactions.

Done - Congratulations!

1.14.5 BAI-2-Excel Batch Processing

BAI-2-Excel Batch Processing

Use this page if you want to convert many BAI files to comma delimited (csv)
files.  

Using the same conversion engine, the process takes one BAI file and converts
it to:
--a csv file containing the transactional information
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--a second csv file containing the summary information.

Initial Setup

1. Copy the BAI files that you have downloaded from your bank (or any
other source) to a folder on your computer or network.
Our suggestion is to copy only one or two files into this folder during testing.

2. Start Treasury Software - Bank Positive Pay
Create/enter into an account that has been configured for Bank Positive Pay.  
Note: You can check/update this by entering into the account and then selecting
the Settings tab, then Maintenance.  On the Maintenance form click Switch
Programs to check/update.

3. Setup
Once you've confirmed that you are in a Bank Positive Pay account, select BAI
Utilities from the Home tab.
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Then select 'Convert Many Files at a time'.

This will display the screen below.  
1 - Check the box and enter the source and output directories. 
2 - Click Save when done.
Also note the parameters.  You may want to copy these.
3 - Click the bottom hyperlink for documentation on creating a shortcut.
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4. Create a Desktop Shortcut with the parameters that you saved in the
step above
For step-by-step instructions on creating the shortcut, see:
http://www.treasurysoftware.com/support2-Create-Automation-Shortcut.html

Congratulations - You are all set.
Now let's test

Place the source BAI files in your source folder.  Click on the desktop icon.

In the output folder, you should see two (detail and summary/status) csv files for
each BAI file. 

http://www.treasurysoftware.com/support2-Create-Automation-Shortcut.html
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1.14.6 ACH Merge

Merge ACH Files quickly and automatically with Treasury Software's ACH-Merge.

The source / individual files can be from any system or bank, they do not have to be
from ACH Universal.

ACH Merge associates key batch information with each record, enabling you to
recreate the transactions - and their batch header records - exactly as they were.
This is not simply a stitch and copy utility.

Use:
1. Click on ACH File Setup Wizard and enter the information for the file header if
you haven't done so already. This information will be used to create the '1' File
Header and '9' File Control/Footer record.

2. On the Home tab, click on ACH-Merge to open the ACH-Merge window.

3. Enter the folder containing containing the individual ACH files. 

4. Note the location as to where you want the consolidated ACH file to be created.

5. Click Merge. 
Note: The software may minimize into a background operation during this process.
This is normal and to be expected.
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6. View the file!

Process complete!  Confirm activity in reports.

7. Reporting
--a. Activity Receipt Reporting - File level
--b. Unimportable Records report - record level
--c. Import Logs and Transmittal Logs

a. Activity Receipt Reporting - File level
You can receive a popup activity receipt at the file level (see below), which can be
displayed at the end of each ACH Merge. 

Why would a file show as 'False' (skipped / not included in the consolidated file)?

The system will import only ACH files in conformity to NACHA standards.  Non-
standard ACH files may have transactions excluded - or even skipped in their
entirety (depending on the issue) - from the consolidated file.  

To turn on the activity receipt, select the main menu Automation tab* > Software
Integration Kit > scroll down to ACH Merge (Group 16) and highlight the row. Click
on Add/edit. In the popup window, select the Reports tab and fill in as needed.
* If you are still testing in the Sample account, use the 'Samples' tab as opposed to
the 'Automation' tab.

b. Unimportable Records report - record level
After the ACH Merge, you can run the 'Unimportable Records' report to help locate
any exceptions if there is an issue with control totals from the activity receipt (noted
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above) or the Import and Transmittal logs (see below).

Notes: 
--Do not use the 'Unimportable Records - Last Import' report, as this will only provide
you with information from the last individual source file.
--The 'Unimportable Records' report will only contain records from importable files
('Success') which may have been filtered out. Records from files that failed the
import process, such as Excel files, or defective ACH files, etc... will not be listed. 

c. Import Logs and Transmittal Logs
You can check your control totals for the records successfully imported from the
individual source files at 'Import Logs' (displayed below) and for the file created at
'Transmittal Logs'. 

FAQ's
How do I edit/delete some of the records after importing the ACH Files, but before
creating the consolidated file?
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You will not use the ACH-Merge automation utility, but instead import the ACH files
using through the main interface.
Then you can edit/delete the records.
When completed, you can create the consolidated file from the Create ACH file
page.

Note: If the batch headers (5 records) all contain the same company and ID
information, you can perform this with an ACH Universal Corporate license.
However, if the company and ID information is different, you will need an ACH
Universal Processor license.

Does ACH-Merge handle IAT records?
No, ACH-Merge has been designed to handle transactions with up to one addenda
record. While the vast majority of our clients are using it for PPD and CCD Standard
Entry Class codes, we recommend as with any application - fully testing before
moving into production.

Can I use the Sample account for ACH Merge?
No, do not use the sample account as it can reset to conform to the tutorial. Please
create a user account at File > New Account.

Troubleshooting
ACH Merge isn't merging a file. Why not?
Please confirm that your file is in a valid text format by opening it in Notepad or
similar application.
Once loaded, click File > Save As and confirm that the Encoding is set to ANSI. If it
is not in the correct encoding, contact the entity that provided you with the file.

If the file is in a proper text (ANSI) file, test the file using our ACH-2-Excel utility.
From the Home tab, select 'ACH-2-Excel' and select the file. As ACH Merge uses the
same parsing engine as ACH-2-Excel - if the file cannot be parsed, it cannot be
processed. 
Note: A poorly formatted transaction not adhering to NACHA standards may
invalidate the entire file. Contact the entity that provided you with the file.

If you imported an ACH file manually - not through the wizard/automation, please
check the mapping template used during the import process. You can also run an
Untransmitted Records report to review the records which have been imported, but
not yet included in a file.

Of course, please contact our support team at any point if you are unable to
complete the ACH Merge process.
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1.15 Canadian Format

Creating Canadian Payments Association CPA-
005 1464 byte files for Electric Funds Transfers
(EFT)

ACH Universal supports the CPA Standard 005 format, which is accepted
by all major Canadian banks.

Please note that this format differs from US-based NACHA (ACH) formats.

ACH Universal™ helps you create EFT files for:
Direct deposit for employees
Collections from customers
Payments to vendors 

Canadian vs US processes
Unless noted otherwise, all processes are the same for the two formats. 
Please follow the same instructions and videos as the NACHA format.

All major functions of ACH Universal that are used to create US-based files, are
also available to create Canadian based files.  This includes:
--Excel and csv file import, and profile-based import
--QuickBooks integration
--Email notification
--Security features including encryption, web and/or SSH transmission and
SQL Server support
--Automation - Software Integration Kit

Notes: 
--The CPA005 standard is a one account standard, therefore our multiple
origination account format is not applicable.
--The CPA005 does not include a checking / savings account indicator. 
Therefore, you do not need to map / include this field.
--The CPA005 does not support EDI (ACH-CTX).
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--The routing number in Canada must appear as a 9-digit number in ACH
Universal.  If the Institution is only a 3-digit number, you'll add a leading zero.
Example:

When to use this format...
Please use the CPA-005 if:
--Your bank is a Canadian bank and
--You are originating transactions from that bank - and the other party (ie.
customer, employee, vendor) has a Canadian bank account.

Do not use this format...
Do not use this format for cross-border transactions.
For example, if you bank with a US bank - and the other party (ie. customer,
employee, vendor) has a Canadian bank account, do not use this format.
Instead, please use the NACHA (ACH) format, with an International (IAT)
Standard Exchange Class.

Banks
Supported banks:
Royal Bank of Canada (RBC)
Toronto Dominion (TD)
HSBC
Scotiabank
Bank of Montreal (BMO)
and all other Canadian Banks accepting the CPA 005 1464 byte file format

For additional reference, The Canadian Payments Association standard CPA-
005 is located at:
https://www.cdnpay.ca/imis15/pdf/pdfs_rules/standard_005.pdf

Ready to get started? See our setup page.

https://www.cdnpay.ca/imis15/pdf/pdfs_rules/standard_005.pdf
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1.15.1 Setup

Setup

Creating CPA-005 1464 byte files for Electric Funds Transfers
(EFT)

1. Create a new account within the software
Click File > New Account and complete the Wizard.

2. From the Home page, click on the Canadian Format button.

3. Complete the Canadian Options panel
Click on 'Activate Canadian format', then click on your bank and select a five
digit Institution ID.
If your bank is not listed, select 'All Other Banks' and continue.
Enter your company information as requested and then click OK.
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Notes: 
--It is very unusual for you to need to adjust the settings in the 'Bank and Over-
ride codes' section.
--Enter a short (abbreviated up to 15 characters) company name as well as a
long company name ( up to 30 characters) - as either may be displayed on the
other party's bank statement.

FAQ's
Should I enter any information within the ACH File Setup Wizard (7 screens)?
No, please leave the settings at their default settings - and any entries empty.

Testing with my bank - any special settings?
Yes, please enter the following into the 'Over-ride for the File Creation Number'
field (do not enter the apostrophes):
RBC, enter 'TEST'
Scotiabank, enter '0000'

First time creating a file to be sent to the bank - any special settings?
Yes, please enter the following into the 'Over-ride for the File Creation Number'
field:
TD, enter '0001'
BMO, enter '0001'

After you've created the files for the above scenarios, delete the entry from the
'Over-ride for the File Creation Number' field. 

Click 'OK' when you're all set.
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