# Table of Contents

## 1. Bank Positive Pay

1.1 Absolute basics .................................................................................................................... 6

1.2 Getting Started ..................................................................................................................... 7

1.2.1 Download and Install ........................................................................................................ 7
1.2.2 Gathering Data ................................................................................................................ 8
1.2.3 Create and Setup Accounts ........................................................................................... 8
1.2.4 Import Data ................................................................................................................... 11
1.2.5 Create and Transmit File ............................................................................................. 15

1.3 Importing Transactions ...................................................................................................... 17

1.3.1 Entering Transactions Manually ...................................................................................... 18
1.3.2 Deleting An Import ......................................................................................................... 18
1.3.3 Deleting A Single Transaction ....................................................................................... 19
1.3.4 Editing Untransmitted Records .................................................................................... 20
1.3.5 Filtering Imports ........................................................................................................... 21
1.3.6 Mapping Fields - Reference ........................................................................................ 22

1.4 File Creation and Transmission .......................................................................................... 23

1.4.1 Transmission Methods .................................................................................................. 25

1.5 Reporting ............................................................................................................................ 26

1.5.1 General Usage ............................................................................................................... 27
1.5.2 Grouping Data ............................................................................................................... 28
1.5.3 Filtering Data ................................................................................................................ 30
1.5.4 Exporting Data ............................................................................................................. 32

1.6 Automation and Integration ............................................................................................... 32

1.6.1 Scheduler - Basic Automation ....................................................................................... 32
1.6.2 Software Integration Kit - Advanced ........................................................................... 35
1.6.2.1 Settings .................................................................................................................... 36
1.6.2.2 SQL Insertion .......................................................................................................... 40
1.6.3 Command Line Syntax ................................................................................................. 46
1.6.3.1 Command Line Interface ......................................................................................... 47
1.6.3.2 ACH Universal ......................................................................................................... 48
1.6.3.3 ACH-2-Excel ............................................................................................................ 49
1.6.3.4 BAI-2-Excel ............................................................................................................. 49
1.6.3.5 Bank Positive Pay .................................................................................................... 50
1.6.4 For use with QuickBooks ............................................................................................. 51
1.6.4.1 Connecting to a company ......................................................................................... 52
1.6.4.2 Setup - Treasury Software ....................................................................................... 56
1.6.4.2.1 Advanced setup .................................................................................................... 57
1.6.4.3 Importing transactions ........................................................................................... 59
1.6.4.3.1 Holding and over-riding records ......................................................................... 60

1.7 QuickBooks Pro, Premier and Enterprise ......................................................................... 63
Table of Contents

1.7.1 Setup - QuickBooks ................................................................. 64
  1.7.1.1 Connect to QuickBooks_2 ...................................................... 67
  1.7.1.2 Integration Wizard ............................................................... 70
  1.7.1.3 Bank Express Code .............................................................. 72
1.7.2 Creating the Positive Pay File ............................................... 75
1.7.3 Transmitting to your bank .................................................... 78
1.7.4 Holding and resending transactions ....................................... 79
1.7.5 Settings - Bank Positive Pay ................................................ 81
1.7.6 Testing .................................................................................. 82
1.7.7 Troubleshooting-Connections .............................................. 89
1.7.8 QuickBooks Security ............................................................ 91
1.8 QuickBooks Online ................................................................. 95
  1.8.1 QuickBooks Online Positive Pay Setup ................................ 96
  1.8.2 Adding QBOE Transactions ................................................ 99
  1.8.3 Finding Company ID ............................................................. 101
1.9 Security .................................................................................. 103
  1.9.1 Setup .................................................................................. 104
  1.9.2 Users-Add .......................................................................... 106
  1.9.3 Segregation of duties .......................................................... 108
  1.9.4 Roles .................................................................................. 109
1.10 Reference .............................................................................. 110
  1.10.1 Remote Desktop (Terminal Services / Citrix) Platform .......... 110
  1.10.2 How do I stack multiple accounts in one file? ...................... 112
    1.10.2.1 Account Number in file - Multiple Accts ......................... 115
    1.10.2.2 No account number in file - Multiple Accts .................. 118
  1.10.3 Adding Address Lines ........................................................ 121
  1.10.3.1 QuickBooks Tips .............................................................. 123
  1.10.4 Frequently Asked Questions (FAQ) .................................... 123
    1.10.4.1 Changing Debit and Credit Text .................................... 123
    1.10.4.2 Changing File Transmission Method ............................... 124
    1.10.4.3 I am on the Desktop platform with 1 workstation license. If I purchase an additional workstation, can I share data? .................... 130
    1.10.4.4 What is an account? ....................................................... 130
    1.10.4.5 I purchased Positive Pay, but the Main Screen says ACH Universal ................................................................. 130
    1.10.4.6 I have one source file but multiple databases. How do I split the file into the correct database? ........................................ 131
    1.10.4.7 I have a non-standard date format. How do I use it? .......................... 131
    1.10.4.8 My date field is embedded within text. How do I import it? .......................... 132
    1.10.4.9 My bank requires a login record ...................................... 132
    1.10.4.10 ActiveX component can't create object .......................... 132
    1.10.4.11 ADO/MDAC Re-Installing ........................................... 133
  1.10.5 Maintenance - Desktop ..................................................... 133
    1.10.5.1 Database Backup .......................................................... 134
    1.10.5.2 Restore Database .......................................................... 135
# Table of Contents

1.10.5.3 Database Archiving ........................................................................................................... 135  
1.10.5.4 Download Service Pack ..................................................................................................... 137  
1.10.5.5 Desktop Platform Upgrade ............................................................................................... 137  
1.10.6 Legacy Help .......................................................................................................................... 138  
1.10.6.1 Accounts .......................................................................................................................... 138  
1.10.6.1.1 Creating An Account ....................................................................................................... 138  
1.10.6.1.1.1 Account Creation ....................................................................................................... 139  
1.10.6.1.1.2 Account Setup .......................................................................................................... 142  
1.10.6.2 Help on Help ....................................................................................................................... 147  
1.10.6.2.1 Help on Screen Shots .................................................................................................... 148  
1.10.7 Bank Express Codes .............................................................................................................. 150  
1.10.7.1 BMO .................................................................................................................................. 151  
1.10.7.1.1 Downloading the Software ............................................................................................. 152  
1.10.7.1.2 Request License Codes .................................................................................................... 154  
1.10.7.1.3 Software Setup ............................................................................................................... 155  
1.10.7.1.4 Importing your check file ............................................................................................... 160  
1.10.7.1.5 Create and Transmit the Positive Pay File ...................................................................... 168  
1.10.7.1.6 FAQs .............................................................................................................................. 172  
1.10.7.1.7 Support Phone Numbers ............................................................................................... 175  
1.10.7.2 Wells Fargo ......................................................................................................................... 176  
1.10.7.3 Scotia Bank .......................................................................................................................... 177  
1.10.8 FAQ's ................................................................................................................................... 178  
1.10.8.1 I am switching banks but I need to keep my old account .................................................... 178  
1.10.8.2 Can I have a bank express code for my bank? ................................................................... 186  
1.10.8.3 What do I do once I get my Bank Express Code? ............................................................... 187  
1.10.8.4 How do I change the location of my Positive Pay file once it is create? .............................. 195  
1.10.8.5 Why didn’t my file transmit to the bank? ......................................................................... 198  
1.10.8.6 How do you changed bank account numbers? .................................................................. 199

## 2. Utilities

2.1 BAI File Creator .......................................................................................................................... 205  
2.2 BAI Merge .................................................................................................................................. 207  
2.3 ACH2Excel - ACH Conversion Utility ........................................................................................ 217  
2.4 Notification of Change ABA Merge Utility ................................................................................ 219

## 3. Treasury Management

3.1 Integrated Payables (1180) ......................................................................................................... 225  
3.1.1 Setup - Integrated Payables .................................................................................................... 226  
3.2 Commercial Card (1190) .......................................................................................................... 229  
3.2.1 Setup - Commercial Card ..................................................................................................... 231

Index.................................................................................................................................................. 236
Bank Positive Pay
1 Bank Positive Pay

Bank Positive Pay™ creates positive pay transmission files in any bank format.

Get up and running in less than one hour. We highly suggest watching our tutorials - less than 5 minutes in length, and at the end - you'll be able to create a positive pay file for testing with your bank.

1.1 Absolute basics

Welcome new users.

Have you been asked to create a positive pay transmission file to send to your bank?

Bank Positive Pay enables you to create positive pay transmission files from the data in your accounting, payroll or other system.

Easy setup - Bank Express Codes
Bank Positive Pay maintains a library of bank file layouts and transmission information. Contact us for your bank’s code.

We highly recommend that you click the links below to view the tutorials now.

Brevity is critical - and we value your time. The videos are less than 5 minutes in total, and at the end - you will be able to create your transmission file for testing with your bank.
1.2 Getting Started

Steps

Below are the steps to begin using Bank Positive Pay.

1. Download and install the software
2. Gather your data and email us your documentation stating how the bank wants the file formatted
3. Create and setup accounts
4. Import transactions (from Excel or CSV)
5. Create and transmit your positive pay issue file.

Next: Download and install >>

1.2.1 Download and Install

Download Bank Positive Pay

Download Bank Positive Pay from our website at

Your email address is important because the installation password is sent to that address.
Install

After the download is complete, double-click the file to begin installation.

Proceed through the installer by clicking Next. Accept the default settings.

Next Step

Once the installation is complete, you are ready to begin using positive pay.

Next: Gathering Data >>

1.2.2 Gathering Data

Overview

The import (or ‘source’) data files typically would be created from within your accounting software.

They may be as simple as a check register that is saved to Excel or csv (comma delimited). Or, they can be custom written data dumps from third party reporting packages, such as Crystal Reports.

The most popular choices for these files are:
- Excel spreadsheets
- Comma-separate (csv) files
- Tab-delimited files

<table>
<thead>
<tr>
<th>Date</th>
<th>Check #</th>
<th>Account</th>
<th>Vendor/Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/10/2018</td>
<td>46365</td>
<td>Main</td>
<td>Around the Horn</td>
</tr>
<tr>
<td>1/10/2018</td>
<td>46366</td>
<td>Main</td>
<td>Berglunds snabbköp</td>
</tr>
<tr>
<td>1/10/2018</td>
<td>46367</td>
<td>Main</td>
<td>Split Rail Beer &amp; Ale</td>
</tr>
<tr>
<td>1/10/2018</td>
<td>46368</td>
<td>Main</td>
<td>Familia Arquibaldo</td>
</tr>
<tr>
<td>1/10/2018</td>
<td>46369</td>
<td>Main</td>
<td>Santé Gourmet</td>
</tr>
<tr>
<td>1/10/2018</td>
<td>46370</td>
<td>Main</td>
<td>Seven Seas Imports</td>
</tr>
</tbody>
</table>

Basic

At a minimum, you will need to create a file with the following fields:
- Payee name / description
- Amount
- Check number
- Date

It is okay to create a file with additional columns.
In addition, your file may have blank rows, report headers, summation rows, etc... - this is also okay. The system will skip/ignore non-transactional rows and unmapped columns.

1.2.3 Create and Setup Accounts

Start Bank Positive Pay
Important - Please follow these instructions to create your account. We advise not working out of the Sample account.

After you have successfully installed the software you should have a desktop icon that will launch the software.

The Welcome New Users page will load. Select the Option for “Bank Positive Pay”.

Create Account

Click File> New Account to create an account for your testing.
Select the option to “Create an Account and Add it to your Catalog” and click Next.
Enter a name for the account. This name is strictly internal and should help you identify the purpose of the account. For example, if you are using Positive Pay for payroll, you might name the account Payroll. Once the name is entered, click Next.

Congratulations! You have finished creating the account. Click Finish to begin using this account.

If prompted to edit/modify your transmission information, click No.

Next Step
You are now ready to import data.

Next: Import Data >>

1.2.4 Import Data

Obtaining Import Data
Before importing transaction files into Bank Positive Pay, they must be obtained from your accounting package. The exact process depends on the package, but in general you will run an appropriate report, such as a check register, for a given date range and then export this report to an Excel spreadsheet or CSV file. For more information or assistance in this, contact your corporate IT.
Importing Transactions

Click on Import Transactions from the left hand navigation pane to begin the Import Wizard. You can also start the Import Wizard by clicking the Import Transactions icon in the center of the homepage.

Click the Open Folder Icon on the General Ledger Import Wizard.

Select your file to Import and click Open. Common file types are Excel and comma delimited (csv) files. Click Next.
Mapping

The Column Mapping screen allows the user to tell the File Formatter what information is in each column on the import file. Simply Highlight a column, and select the appropriate column mapping from the drop down for the data.
After selecting the Column Mapping, the section about the column names (F1, F2, F3, etc) will switch from Red to Green and list the selected mapping.

Repeat this for all required columns. The required fields are Date, Check number, Amount and Payee (description). When all the necessary columns are mapped, click next to continue the Import Wizard.

**Use Amount_Reverse_Sign when needed**

Negative amounts decrease your balance, and represent checks issued. Positive amounts increase your balance, and typically represent voided checks.

If the Excel or other file that you are importing is displaying the amounts in positive format, and the transactions represent checks issued - then map the field as Amount_Reverse_Sign. This has the effect of multiplying the amount by a negative 1.

**Review Records**

This screen will display a list of the importable rows and invalid rows. To review the list of Importable Records, click on the “+” sign as shown below.

If the “Amount” and “# of Records” columns are correct, click Next and go to Finish.

The grid will display the importable transactions and the basic information.
The Invalid Rows section will list all rows that will not be imported. The software will automatically mark Header rows, footer rows, summation lines, and blank lines as invalid. For each row that is invalid, a check mark will be placed in the appropriate column indicating why the row was invalid.

Once you have verified the importable information is accurate, click Next. If you wish to Cancel the import process and try again, simply hit Cancel.

Click Finish to complete the Import Wizard.

Next Step

You are now ready to create and transmit your file.

Next: Create and transmit the issue file >>

1.2.5 Create and Transmit File

Create and Transmit the issue File

You are now ready for the final step: creating the transmission file and transmitting to the bank.
Click on Create File from the left hand navigation pane or alternatively, click the Create File button in the center of the homepage. Please note prior to 2013 version the Create File icon was

The Create File screen is where the file to be uploaded is created.

The second paragraph lists the transmission method. In almost all cases, you will upload your file to your bank through their website. A transmission method of None will create the positive pay file, at which point you should log on to your bank’s website and submit it to them. Your bank will provide you with instructions for doing so.

The third paragraph displays where the Transmission File will be saved. The default location for the file is the C:\Program Files\Treasury Software\Version Number\To Bank directory (on XP) or C:\Users\Public\Treasury Software\To Bank (on Vista, Windows 7 and Windows 8). The default file name
is the name of the account, followed by an underscore and the word ‘transmit’. The file will always have a .TXT file extension. For example, the account named Payroll would create a transmit file named Payroll_transmit.txt.

The Review Records link on the Right Side Explorer Bar allows you to access the Reports Section for review or deletion of Records.

Click Go To Create File Page to proceed with creating the file.

Next click on Create Issue File.

Positive Pay will ask if you want to view the file. Select Yes if you want to verify the format or review the file. Otherwise click No.

At this point, transmit the file to your bank using their procedures.

Congratulations! You have completed your first transmission file.

If you have any questions, please consult our FAQ. This contains answers to many common questions from first-time users.

Next Step
Review our FAQ for answers to many common questions.

Next: FAQ >>

1.3 Importing Transactions

Overview
Importing is the process that brings data in. There are actually several different ways to bring in data.
1.3.1 Entering Transactions Manually

Overview

While the bulk of records should be imported as files for maximum accuracy and efficiency, there can be situations where entering a record manually is a better choice.

For example, to create a one-time payment for a vendor, it may be easier to input the information directly than to enter it into a file and then import the file.

Manual Records screen

From the main menu, select Edit, than Add Record(s). The New Record screen will be displayed (Figure 1 below).

Basic Information

All fields are required.

Date Select the date the requested processing date. Note: You cannot force a same-day transaction by using the current date. Contact your bank for their exactly time frame.

Check The check number.

Amount The amount of the check.

Description The description of the check.

Click OK.

1.3.2 Deleting An Import

Overview

Follow the steps below to delete an entire file import (every transaction from the imported file). Note: You cannot delete a file that has been transmitted.
1.3.3 Deleting A Single Transaction

Overview

Follow the steps below to delete a transaction, or group of transactions.

Click on the Home tab at the top of the screen and then select Untransmitted Records. If you are using a version prior to 2013 select Edit, then Delete Record(s). Select the transactions (yes, you can select multiple records) to be deleted, then click the button. Click Yes to confirm the deletion, No to cancel.

Records that can be deleted:
You can delete transactions as long as they have not been included in a Bank Positive Pay file.

Records that cannot be deleted:
Once a record has been included in a file - regardless as to whether it was actually transmitted to the bank - the record cannot be deleted.

1.3.4 Editing Untransmitted Records

Overview

Run the Untransmitted Records report. Remember - To protect the audit trail, only untransmitted records can be edited.

Select a Report

From the View tab select 'Untransmitted records'. If you are using a version prior to 2013 you would need to select Reports and then on the drop down menu choose 'Untransmitted Records'. If you are using a version prior to 2013 select Reports > Untransmitted records.

Edit A Record

Select a record to edit, then click on 'Actions' from the reports sub-menu then 'Edit a Record'.

This will then open the Edit screen as below.
Edit information as needed, then click 'OK'. Run the report to see the changes.

Notes:
Records that can be edited:
You can edit transactions as long as they have not been included in a Bank Positive Pay file.

Records that cannot be edited:
Once a record has been included in a file - regardless as to whether it was actually transmitted to the bank - the record cannot be edited.

1.3.5 Filtering Imports

Overview

By using accounts, Bank Positive Pay allows you to create a logical separation of transactions. For example, you can create a Payroll account for direct deposit transactions and a Checking account for vendor payments. Filtering becomes necessary when source files contain transactions for multiple Bank Positive Pay accounts. By filtering the import, transactions are only imported into the proper account.

By definition a filter is only required if you have already created multiple Bank Positive Pay accounts.

Before Beginning

The steps below must be repeated for each Bank Positive Pay account. In the example of Payroll and Checking, the steps must be done once in the Payroll account and once in the Checking account.

Creating the filter
A filter consists of nothing more than an identifier used to distinguish data for one account from other
data. This can be a field containing the text "payroll" and "checking", an account number, or some other
identifier. Each filter must be unique from that of all other accounts.

1. Make sure you are in the proper account.
2. Select the Settings tab then Import, System. If you are using a version prior to 2013 Select File
   from the main menu, then Options, then General.
3. In the textbox corresponding to "Filter Import - GL", enter the identifier you wish to use for the
current account.
4. Click Close.

Repeat these steps for every account you need to filter. The identifiers must be different for each
account.

Using the filter

There are two ways to use the filter. You can schedule imports using the Control Panel for recurring
imports or you can perform the import manually.

Using a manual import filter

Import your transaction file as outlined in Importing Transactions.

Map all fields in the file as usual with one addition: map the field representing the filter text as 'Filter'

Bank Positive Pay will import all transactions from the file into the proper account based on the filter
text. If you do not map Filter the entire import will be brought into the currently open account.

Setting a recurring filter though Control Panel

1. Select Control Panel from the main menu.
2. Select each checkbox corresponding to an account present in the file to be imported.
3. In the "Import Bank Positive Pay File Name" column, browse to and select the source file to be
   imported and filtered. To filter the same file into multiple accounts, select the same file in each drop
down box.
4. Click "Run Now" to immediately do the import.

Note: If you are using the Pro, Pro Plus, or Trading Partner Editions, you can click "Scheduler" to
schedule the import using the Automated Scheduler.

5. When finished, click Close.

1.3.6 Mapping Fields - Reference

The required fields to map in a non-profiles are:
• Payee
• Check number
• Date
• Amount

If you are using profiles for your import, see Profiles.
Amount

Use Amount_Reverse_Sign when needed

Negative amounts decrease your balance.
Positive amounts increase your balance.

If the Excel or other file that you are importing is displaying the amounts in positive format, and the transactions represent payments out - then map the field as Amount_Reverse_Sign. This has the effect of multiplying the amount by a negative 1.

1.4 File Creation and Transmission

Creating a transmission file

From the Home Page, click on the ‘Create File’ icon. Please note prior to 2013 version the Create File icon was
The Create File screen (below) will be displayed.
To create and transmit the file, click

![Create Issue File](image)

Please note if you are using a version prior to 2013 then click on . A dialog box will appear asking if you wish to view the created file. Click Yes to view the file. Note: You can always view the file later.

The file creation and transmission is now complete.

1.4.1 Transmission Methods

Overview

There are five choices available as transmission method. See Changing File Transmission Method to learn how to change methods. To change the transmission method go to the Settings tab then select Transmission Method.

The method you use is based primarily on how your bank requires the file to be transmitted and secondarily, on your company’s policies regarding electronic fund transfers.
Methods

- **None**: The Bank Positive Pay file will be created and archived, but it will not be transmitted. You must transmit the file manually.

- **FTP**: After creation, Bank Positive Pay will transmit the file to the FTP server you specify. This should be your bank’s FTP server. Contact your bank for information on their requirements.

- **SSH - FTP**: After creation, Bank Positive Pay will transmit the file to the SFTP server you specify. This should be your bank’s SFTP server. Contact your bank for information on their requirements and to obtain your bank’s public key. After creation, your default Internet browser will be started to a specified web page that corresponds to your bank’s upload portal. Upload the created file.

- **Email**: Bank Positive Pay will email the created file as an attachment to the email addresses specified. This method is not recommended as it is unsecured.

- **Other**: For backward compatibility only. Used to transmit the file using modem commands.

By default, Bank Positive Pay will use Web Upload and load a generic page on the Treasury Software website. See [Changing File Transmission Method](#) to set up the transmission method as required by your bank.

### 1.5 Reporting

Reporting
Positive Pay has a wide selection of industry standard reports which include transactions, profile listings, audit trail logs and more.

**Basic**
To run a report click on Reports. Select a report, then a period (if applicable), then click ‘Run’.

![Report Interface](image)

**Features**
Once you've run a report, you can change the:
- Columns - add, remove, move, sort
- Grouping - 'Outlook-style' grouping
- Filtering - 'Excel-style' filtering
and save your changes for use next time.

### 1.5.1 General Usage

**Customizing Fields**
You can arrange the fields in any order. To do so, click and drag the column header to its new location.
Custom Layouts
If you prefer your report differently than the default displayed, simply modify the report to the way you want it. The saved layout will retain all information in the current report, including filters, groupings, summary information, and field order.

Afterwards, click on the 'Save' icon.

The next time you run the report, it will displayed per your settings.

Note: To remove the custom layout - click the 'Remove' icon, just to the right of the 'Save' icon.

1.5.2 Grouping Data

Grouping Data

Reports are only useful if they can be interpreted quickly and accurately. It is both cumbersome and error-prone to be forced to scroll through tens or hundreds of records looking for certain ones.

Advanced Reporting allows you to group report data on many different fields to see a breakdown by category.

In Figure 1 (below), the Advanced Reporting grid is displaying the All Records report.
In this case, the records are grouped by Description. To create a grouping, drag the header into the gray bar. It is possible to create multiple groupings. For example, to group by company name inside the date grouping, drag the Description header onto the gray bar. To un-group, drag the header from the bar to a position in the header row.

**Selecting fields**

The number of usable fields depends on your data. Follow the steps below to select the specific fields you wish to view in a report. These fields are retained in a user layout.

There are two ways to open the Field Chooser. One method is to click the button on the toolbar. The other is to click the button in the upper left hand corner of the report grid. Either way, the Field Chooser will be displayed (Figure 2 below).
To make a field visible in the report grid, enable the checkbox.

To hide a field, clear the checkbox.

When finished, click ☒ to close the Field Chooser and apply your changes.

Your changes will be immediately reflected in the report grid.

1.5.3 Filtering Data

Filtering Data

Immediately below the column headers is the filter row. Each field in the report can have its own filter. Select the type of filter for the field and then enter the filter text into the appropriate box.

Selecting Type of Filter

For each field you want to filter, click the corresponding ☑ button. This will display the filter choices.

For numerical filtering, your options are:

- Equals
- Does not equal
- Less than
- Less than or equal to
- Greater than
- Greater than or equal to

Note: The comparisons are based on the sign of the data. For example, if you want to see issued checks larger than $10,000 and all issued checks have negative signs, create a filter of "Less than" and enter -$10000 as the amount.

For textual filtering, your options are all the above, plus:
Textual comparisons use simple text searches for the filter text, with the exception of "Matches Regular Expression" which uses regular expressions to create matches. Regular expressions, while powerful, create an extra layer of complexity and normally are not needed for basic text filtering.

**Entering Filter Data**

In the textbox next to the filter type button, enter your filter criteria. As you type, the data in the report will be filtered automatically.

**Summarizing Data**

Advanced Reporting also provides the ability to create data summaries for any fields you wish. The summary information available is:

- Count (number of records)
- Minimum
- Maximum
- Sum
- Average

These summaries are stored as a part of user layouts and can be exported with the report data if you wish to retain them.

To turn on summaries, select View from the main menu, then Enable Summary. A $\Sigma$ will be displayed in each field. To enable summary information for a field, click the $\Sigma$ in the field header.

The Select Summaries box will be displayed. Below is the box for the Amount field. All other fields have Count, Maximum, and Minimum available.

To turn on a summary value, enable the checkbox. When finished, click OK.

The summary information will be displayed after the last row of report data.
To turn off summaries, select View from the main menu, then Disable Summaries. Summaries are stored as a part of the user layout. Summaries are automatically disabled when you switch reports.

1.5.4 Exporting Data

Your report data can be exported from Advanced Reporting to an Excel spreadsheet or a CSV file. Note: You can export to Excel without having Excel installed, but it must be installed in order to view the exported file.

All export options are accessible through the Export option on the main menu. These options are:

- **Excel Export - All Records**: Export all displayed records. Records filtered out will not be included. All visible columns will be exported.
- **Excel 'Copy' - Selected Records**: Export all manually selected records. All visible columns will be exported.
- **CSV Export - All Records**: Same as Excel Export - All Records, but exports to a CSV file.
- **CSV Export - Selected Records**: Same as Excel ‘Copy’ - Selected Records, but exports to a CSV file.
- **Data Dump - All Records, All Columns**: Exports all records (regardless of filter) and all columns (visible and not visible) to a txt file.

Also under the Export menu is the option "Open Excel when exporting to Excel or CSV." Leave this checked if you wish to load the exported file immediately in Excel (Note: Excel must be installed). To export to a file but not view the file, select the option to uncheck it.

1.6 Automation and Integration

Overview

Automation tools are used to enable greater processing efficiency. You can use the Scheduler to schedule file imports and transmissions. You can use Custom Import Menus to import either single files or entire directories and process everything with one simple mouse click.

1.6.1 Scheduler - Basic Automation

Overview

The Scheduler is used to schedule single file imports and file transmission. If you need to schedule multiple files during the same
Process

There are two steps to scheduling an automated file import and transmission (from now on called a job).

1. Create the job. This would be the account to be used and the file to be imported.
2. Running the job. This instructs Bank Positive Pay on time and frequency the job should be run.

Create the job

Select Automation > Basic Automation from the main menu. The below figure will be displayed.

All the accounts are shown in the grid. In this case, Test Pos Pay and test have been created for live data. They both can be scheduled to run at the same time, or you can choose to schedule just one account. Note: It is not possible to schedule them at different times and days using the Scheduler. See Custom Import Menus if you need this type of setup.

To create a job:

Enable the checkbox in the Import column of the account you wish to use.

Click the gray box under the Import G/L File Name to browse for the source file to be imported.

Select how you wish the system to handle transmission of the Positive Pay file. Your choices are:
- No (Positive Pay file is created, but not transmitted. You must transmit manually).
- Only when new records imported
- Yes, always (On every job, the file is transmitted using the method you set in)

Schedule the job

Click the Scheduler button.
A screen will pop up requiring a Windows username and password. The Scheduler will use this username and password to schedule the job. You may leave the password blank, but the job may not run due to lack of authorization as required by Windows.

After entering username and password, click Next.

The Scheduler will now be displayed (Figure 1 below).

![Figure 1 - Scheduler](image)

To schedule a job to run once a day on certain days and at certain times, select the check boxes for each day and then enter the time in Start Time textbox.

If you need to schedule a job to run multiple times per day, click the "Repeat throughout the day" button.

Information shown in Figure 2 (below) will be displayed in the Scheduler window.

![Figure 2 - Repeat throughout day](image)

Click the checkbox.

The job can be scheduled to run in increments of hours or minutes. Enter the length of time between job runs and then select hours or minutes from the dropdown box.

In the textbox on the right side, you can specify the end time for the schedule.
For example, ABC Company wants to run their job every 30 minutes, but only between 11 AM and 3PM.

In Figure 1, ABC would set the start time to 11:00 AM and choose the appropriate days. In Figure 2, ABC would enable the checkbox, then enter 30 into the first textbox, change dropdown to minutes, and put 3:00PM in the remaining textbox.

When completed, click Finish.

1.6.2 Software Integration Kit - Advanced

This section is devoted to accounting software developers and other third party developers (including end-users) who are looking to integrate Treasury Software applications into a seamless and automated process for their users.

Our Software Integration Kit (SIK), unlike most automation development kits, is included directly in the runtime edition - and is available to both power users and software developers in a Graphical User Interface.

Treasury Software's SIK includes full automation tools to seamlessly:
--import any file
--import all files within a directory
--archive (move) the imported files
--preserve the audit trail of archived files (append the file name of each file with a date/time stamp to insure that each file is uniquely named in the archive directory)
--provide summary reporting

and, of course

--perform any Treasury Software core module process including:
----ACH and Positive Pay file creation
----ACH and Positive Pay file transmission
----Automated Transaction Matching (ATM) for bank reconciliation

Note: The Software Integration Kit is referenced as the 'Custom Import Menu Setup' in some documents - and will be used here interchangeably.

Select the Settings tab then Software Integration Kit. If using a version prior to 2013 select Automation > Advanced - Software Integration Kit.

You can have up to 20 integration routines per account. Select one that is not being used and click 'Add/Edit'.
1.6.2.1 Settings

Settings pages - Basic, Advanced and Automation
Visible - Check this box if you want this process to be available to the user from the main menu (Import submenu). This checkbox only drives visibility - it does not activate or inactivate a process.

**What do you want to import?**

File - select the file
Folder - point to a folder. Note: Each of the files should have the same format.
SQL Integration - ‘Data has been placed into a SQL table by another process (see SQL Integration)

Tip:
If you only want to import one file, but the file name is dynamic (keeps changing), then use the folder option.

**Mapping Templates**
Each custom process has its own custom import layout. For example, here in the 1st process, the system defaults to the Custom Menu #1 template in the drop down list. The 2nd custom process will have a Custom Menu #2, and so on.

This enables each custom process to have its own file layout.

**Bank Reconciliation only**
There will be two Custom Menu layout drop down lists. One is for the G/L (on the left), the other is for
the Bank data (on the right). If automating both bank and G/L imports - create a separate process for each (and keep each set of files in a different folder if using the folder import).

**Fixed Width formats**
If a fixed width files is to be imported, the file needs to be parsed. In a similar manner, a second row of drop down lists will be displayed - these are for fixed width files only. To display the second row of drop down lists, click on 'Unsupported file formats' hyperlink on the second page.

**Archive**
This is used to preserve the audit trail and keep the original import file available for future research and review.

The file is moved to the archive directory after a successful import. We recommend appending the file name with a date/time stamp, as this will make the file name unique, and insure that when the file is copied into the archive directory it will not over-write any existing files.
Note: Fixed width text files are not supported in the archive process.

Tip: Confirm that the user triggering the custom process will have rights/privileges to the archive directory - as it will be performed under their security profile.

**File format**

Notes:
Tabular - includes Excel, comma delimited (csv) and tab delimited files.

Fixed width file notes:
Select tabular - and also click the hyperlink 'Unsupported file formats' to display the second row of mapping templates.

**Automation - Third Page**

![Automation - Software Integration Kit (Custom Menus)](image)

**Command Line Group**

This enables the process to be triggered from the Command Line Interface.

Processes are triggered by the numeric value set here. Therefore, all twenty processes could be called from a single command line - assuming all has the same value.
The basic syntax for the trigger is:
[path]\BRCOM.exe /ACCT="sample" /MENU /AUTO=1

- Account (database) - /ACCT
- Include to activate (static to trigger) - /MENU
- Group to use (numeric value in the Command Line Group number box) - /AUTO

This example triggers the Custom Import Menu group #1 (AUTO=1) for the 'sample' account.

**Chaining multiple processes:**
Select a numeric value in the Command Line Group number box. When passed to the program, it will trigger sequentially all custom menu selections with the same value.

**Example:**
You want to trigger three import processes and then create and transmit an Positive Pay file.
Import process 1 - Import a single payroll file
Import process 2 - Import all trade payable files in a directory
Import process 3 - Import all customer collection files in a directory

Create three separate custom menus, with all having the same Command Line Group number (1). As the processes are sequenced based on the process order (from the list top to bottom), make sure they are in sequence, as the last one will contain the automation process.

On Import process 3 (only), select the 'Custom Action After Import' to 'Positive Pay File - Create and Transmit'.

**Custom Action after import**
This can be:
ACH File - Create and Transmit
Positive Pay File - Create and Transmit
Automated Transaction Matching
Select as needed.

**Custom Date Formats**
Enables you to import non-standard date formats.

*Question - How do you know if the format is a custom format?*
Try opening the source file in Excel. If Excel opens the file and the date looks appropriate, you do not need to enter any settings. However, if Excel has a problem interpreting the date - so will Treasury Software.

**1.6.2.2 SQL Insertion**
The SQL Integration feature enables other software systems to push data directly into a Treasury Software SQL Server (not SQL Express) based platform. This eliminates the need for 'pass-thru' files.

This feature requires an advanced knowledge and skill set with SQL Server. It is best used for high volume and highly automated environments.

We highly recommend printing out these instructions for reference.

**Overview**
1. You will populate data into the Treasury Software holding table. The holding table exists in each SQL Server database.
2. Then, when Treasury Software is triggered, it will move the data from the holding table into a permanent table and create an ACH file.

Settings

1. **Start the Software Integration Kit.**
Select the Automation tab > Software Integration Kit.

Select an unused process and click Add/edit.

| Processes |

Automation - Software Integration Kit (Custom Menus)

Automation - This account

This window enables you to create and edit an automated process - including importing, matching, file creation and transmission, as well as reporter. To start, simply select a process and click 'Add/edit.'

<table>
<thead>
<tr>
<th>Name</th>
<th>Group</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selection 1</td>
<td>0</td>
</tr>
<tr>
<td>Selection 2</td>
<td>0</td>
</tr>
<tr>
<td>Selection 3</td>
<td>0</td>
</tr>
<tr>
<td>Selection 4</td>
<td>0</td>
</tr>
<tr>
<td>Selection 5</td>
<td>0</td>
</tr>
<tr>
<td>Selection 6</td>
<td>0</td>
</tr>
<tr>
<td>Selection 7</td>
<td>0</td>
</tr>
<tr>
<td>Selection 8</td>
<td>0</td>
</tr>
</tbody>
</table>

2. **Basic tab:**
   --Check the 'Visible' box (described later) and name this process (example Daily Processing)
   --Select 'SQL Insertion'.****
   --Click the 'SQL Insertion - Select Fields' link *****

Note: As the mapping templates are not used, you can leave the default.
3. **SQL Insertion tab**

After you click the 'SQL Insertion - Select Fields' link, you will be brought to the SQL Insertion tab and can select the top selection 'SQL - Insertion'.

When complete, select the Automation tab.
4. Automation tab
Select a non-zero command line group number (typically 1).
Select an action from the drop down list (Positive Pay File - Create and Transmit).
Copy the command line noted below. You will use this line to trigger moving this process.

Click ‘Save’ when complete.
Note: Do not make any other changes in the other tabs.
Specifically, leave the default file format to 'tabular' and do not enable archiving.
Fields:
Populating data into the Treasury Software holding table. The following fields exist in each Treasury Software created SQL Server database.
Notes:
-- All fields are text fields and located in the table `tblHoldingGLIntegration`.
-- All are mandatory unless otherwise noted.
-- You can add records as often as you want.
-- The table is automatically cleared (deleted) each time you trigger the Software Integration Kit to run.
-- Strip out special characters (especially apostrophes) in the Description/Name.

**IMPORTANT:** Issued checks should have negative amounts. Voided checks should have positive amounts.

<table>
<thead>
<tr>
<th>Field name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Mandatory fields</strong></td>
<td></td>
</tr>
<tr>
<td>Amount</td>
<td>Issued checks should have negative amounts. Voided checks should have positive amounts. Regardless of sign, always include a decimal point as needed. Do not include commas or dollar signs.</td>
</tr>
</tbody>
</table>
### Date
The effective date, in MM/DD/YY format. Note: The month and day can be one or two digit, the year can be two or four digit. International format? - Use your local regional settings.

### Description
Name of receiving party

### CheckNumber
Check Number

---

**Testing**
After you have performed your one-time setup, and then populated your data, you can test your work. Start the Software Integration Kit, select the process, and then click ‘Run’. Complete the import wizard.

Upon a successful import, the Positive Pay file will be automatically created. The file can typically be found (by default) at:
C:\Users\Public\Treasury Software\To Bank

**Note:** Your data that you populated will be cleared out of the tblHoldingGLIntegration.

**Need a test SQL script to populate the table?**
Tip: Start SQL Server Management Studio and click on 'New Query' (make sure that you’re in the right database). Then copy the script below.

```sql
INSERT into tblHoldingGLIntegration (tblHoldingGLIntegration.Amount, tblHoldingGLIntegration.Description, tblHoldingGLIntegration.Date, tblHoldingGLIntegration.CheckNumber) VALUES
("-123.45", 'ABC Company', '12/31/2016', '1001')
```
Production
Trigger the Software Integration Kit using the command line noted in the Automation tab.

General notes
--This feature requires SQL Server (not SQL Express), and access to the Software Integration Kit.

--This integration is designed to be run in an automated fashion. If you trigger the import manually via the menu structure as noted in testing - once you are at the review records screen, the records have been removed from the temporary holding table.

1.6.3 Command Line Syntax

The Treasury Desktop™ contains a rich command line interface, that allows for full automation from other applications.

While the command line interface compliments a number of features which are available in our in our point and click 'Control Panel', the interface allows for full customization and control of output files location/names.
Differences between Control Panel and Command Line automation

**Control Panel**
1. Triggers are preset - at standard date/time and standard intervals.
2. Cannot programmatically change file names. Must specify source files or output files.
3. Ease of use - has a point and click interface.

**Command Line Interface:**
1. Triggers - Can be triggered on command.
2. Full control over both source files and output files. Can programmatically change file names.
3. The command line requires an intermediate to advanced knowledge of systems.

### 1.6.3.1 Command Line Interface

**Overview**

The Command Line interface is used to schedule import and transmission jobs through the Windows scheduling system. This is similar to using the Scheduler, but by using the Command Line you are able to schedule multiple jobs and do not have to load ACH Universal to do so.

**Command Line Options**

```
BRCom.exe /ACCT="account" /ACHX [/XMIT] /SRCE="file name"
```

- **/ACCT** - specifies account by name
- **/ACHX** - specifies to use the ACH Universal module
- **/XMIT** - directs ACH Universal to create and then transmit the file after creation
- **/SRCE** - specifies file to be imported (using absolute positioning)

**Example:**

```
c:\Program Files\TreasurySoftware\BRCom.exe /ACCT="sample" /ACHX /XMIT /SRCE="C:\aaavb\1000\Tutorial\GLData\ACH_with_Accounts.xls"
```

This example imports a source file named ACH_with_Accounts.xls at the specified absolute position into the Sample account in ACH Universal (ACHX). After import, the system creates and transmits (XMIT) the NACHA file.

Valid source files include comma delimited text files, tab delimited text files, fixed width text files and Excel worksheets.

**Notes for all applications:**

- The order of the parameters is not significant
- Capitalization is not significant
- When specifying a file name (SRCE), use the full file path and name within quotes. When using mapped drives, remember that the path should be centric/relative to the machine where Treasury Desktop is located, not the machine issuing the trigger/command.
- Place the account name in quotes.

**Working with multiple users and multiple account:**

Each command line trigger - will create an independent instance of the application. There is no limit to the number of instances.
If processing simultaneous command line requests, use different accounts (Sample1, Sample2, etc...) to minimize any record locking issues. If this is not an alternative, consider processing sequentially, or using our Control Panel.

For Web and Citrix based applications, please contact a Treasury Software support representative.

1.6.3.2 ACH Universal

**ACH Universal**
(ACH File Software)
· Account - /ACCT
· Data Import (include to activate) - /ACHX
· ACH File Creation and Transmittal (include to activate) - /XMIT
· Source File for import - /SRCE

**Syntax Example**
If Treasury Desktop was installed in the default location:

c:\Program Files\TreasurySoftware\BRCOM.exe /ACCT="sample" /ACHX /XMIT /SRCE="C:\aaavb\1000\Tutorial\GLData\ACH_with_Accounts.xls"

This example imports a source file (identified with SRCE) for ACH Universal (ACHX). After import, the system creates and transmits (XMIT) the NACHA file. This example takes place in the sample account (ACCT).

Valid source files include comma delimited text files, tab delimited text files, fixed width text files and Excel worksheets.

**Notes for all applications:**
· The order of the parameters is not significant
· Capitalization is not significant
· When specifying a file name (SRCE), use the full file path and name within quotes. When using mapped drives, remember that the path should be centric/relative to the machine where Treasury Desktop is located, not the machine issuing the trigger/command.
· Place the account name in quotes.

Working with multiple users and multiple accounts:
Each command line trigger - will create an independent instance of the application. There is no limit to the number of instances.

If processing simultaneous command line requests, use different accounts (Sample1, Sample2, etc...) to minimize any record locking issues. If this is not an alternative, consider processing sequentially, or using our Control Panel.

For Web and Citrix based applications, please contact a Treasury Software support representative.
1.6.3.3  **ACH-2-Excel**

**ACH2Excel**
- Account - /ACCT
- Data Import (include to activate) - /ACH2
- Source File for import - /SRCE
- Output File - /OUTD

Valid source files include ARC, CCD, CIE, CTX, DNE, ENR, POP, PPD, RCK, TEL, TRC, TRX, WEB, XCK. Note: Some formats may require further parsing.

**Syntax Example**
If Treasury Desktop was installed in the default location:

```
c:\Program Files\TreasurySoftware\BRCOM.exe /ACCT="sample" /ACH2 /SRCE="C:\transmit.txt" /outd="c:\testACHdetail.csv"
```

Reminder:
Turn on/off appropriate settings. From the main menu 'File', 'ACH File Conversion', 'Output' tab - unselect open in Excel afterwards.

**Notes for all applications:**
- The order of the parameters is not significant
- Capitalization is not significant
- When specifying a file name (SRCE), use the full file path and name within quotes. When using mapped drives, remember that the path should be centric/relative to the machine where Treasury Desktop is located, not the machine issuing the trigger/command.
- Place the account name in quotes.

Working with multiple users and multiple account:
Each command line trigger - will create an independent instance of the application. There is no limit to the number of instances.

If processing **simultaneous** command line requests, use different accounts (Sample1, Sample2, etc...) to minimize any record locking issues. If this is not an alternative, consider processing sequentially, or using our Control Panel.

For Web and Citrix based applications, please contact a Treasury Software support representative.

1.6.3.4  **BAI-2-Excel**

**BAI2Excel**
- Account - /ACCT
- Data Import (include to activate) - /BAI2
- Source File for import - /SRCE
· Output File Detail - /OUTD
· Output File Summary - /OUTS

A valid source file would be any file formatted in BAI version 2.

Syntax Example
If Treasury Desktop was installed in the default location:

c:\Program Files\TreasurySoftware\BRCOM.exe /ACCT="sample" /BA12 /SRCE="C:\aaavb\1000\Data\citi.txt" /OUTD="c:\testdetail.csv" /OUTS="c:\testSumm.csv"

Reminder:
Turn on/off appropriate settings. From the main menu 'File', 'BAI File Conversion', 'Output' tab - unselect open in Excel afterwards.

**Notes for all applications:**
- The order of the parameters is not significant
- Capitalization is not significant
- When specifying a file name (SRCE), use the full file path and name within quotes. When using mapped drives, remember that the path should be centric/relative to the machine where Treasury Desktop is located, not the machine issuing the trigger/command.
- Place the account name in quotes.

Working with multiple users and multiple account:
Each command line trigger - will create an independent instance of the application. There is no limit to the number of instances.

If processing simultaneous command line requests, use different accounts (Sample1, Sample2, etc...) to minimize any record locking issues. If this is not an alternative, consider processing sequentially, or using our Control Panel.

For Web and Citrix based applications, please contact a Treasury Software support representative.

---

**1.6.3.5 Bank Positive Pay**

**Bank Positive Pay**
- Account - /ACCT
- Data Import (include to activate) - /POSP
- ACH File Creation and Transmittal (include to activate) - /XMIT
- Source File for import - /SRCE

Syntax Example
If Treasury Desktop was installed in the default location:
c:\Program Files\TreasurySoftware\BRCOM.exe /ACCT="sample" /POSP /XMIT /SRCE="C:\aaavb\1000\Tutorial\GLData\Check Register 2003-04-08.csv"

This example imports a source file (identified with SRCE) for Bank Positive Pay (POSP). After import, the system creates and transmits (XMIT) the positive pay file. This example takes place in the sample account (ACCT).

Valid source files include comma delimited text files, tab delimited text files, fixed width text files and Excel worksheets.

**Notes for all applications:**
- The order of the parameters is not significant
- Capitalization is not significant
- When specifying a file name (SRCE), use the full file path and name within quotes. When using mapped drives, remember that the path should be centric/relative to the machine where Treasury Desktop is located, not the machine issuing the trigger/command.
- Place the account name in quotes.

Working with multiple users and multiple account:
Each command line trigger - will create an independent instance of the application. There is no limit to the number of instances.

If processing simultaneous command line requests, use different accounts (Sample1, Sample2, etc...) to minimize any record locking issues. If this is not an alternative, consider processing sequentially, or using our Control Panel.

For Web and Citrix based applications, please contact a Treasury Software support representative.

### 1.6.4 For use with QuickBooks

#### Overview

**In QuickBooks®**
One-time setup - Create a new sub-account of your existing bank account.

**In Bank Positive Pay**
Bank Positive Pay enables you to automatically pull the transactions from QuickBooks and create a Positive Pay file.

This Positive Pay file contains the payment data your bank requests in the format that they require.
Bank Positive Pay can automatically transmit the file to your bank (FTP, SSL, etc...), or you can simply upload it through their web site.

Bank Positive Pay:
--Never writes to your QuickBooks data file
--Protects you from duplicate transactions by integrating and tracking QuickBook's transaction ID
--Stores all of your customer's, employee's, and vendor's banking information
--Provides you with a full audit trail of all transactions
--Enables you to manage untransmitted transactions (temporary holding, permanent holding, etc...)

QuickBooks® is a registered trademark of Intuit

1.6.4.1 Connecting to a company

First time connection

Start the connection process by selecting the Home tab then QuickBooks integration. If you are using a version prior to 2013 from the main menu select QuickBooks > QuickBooks Integration.

If nothing appears to be happening, QuickBooks is waiting for you to grant permissions. Click on your Windows toolbar to access QuickBooks.

The first time Bank Positive Pay attempts to connect to your QuickBooks company, you will be prompted by QuickBooks to grant access. Note: You can leave the bottom check box un-checked. Please grant access to continue.
QuickBooks will prompt your confirmation. Click ‘Done’.
Note: If you do not grant access, you will be unable to continue.

Please switchback and grant access within QuickBooks to continue.

Congratulations, you have connected
General note:
--Remember, QuickBooks must be running on the same computer as Bank Positive Pay.

Subsequent connections - automatic

When in Bank Positive Pay, and selecting QuickBooks Integration - the system will automatically present to you any records that need to be processed. You will not need to perform any of the steps above.

Note: If you upgrade Treasury Software, change versions in QuickBooks, or install the software on a new computer - you may be prompted to grant permissions again.

Subsequent connections - If QuickBooks is not open in a company
Simply open your QuickBooks company and then click ‘Connect’.
Once you have connected to a QuickBooks company for the first time, you will be prompted to select the QuickBooks account that has your electronic data in it.

QuickBooks® is a registered trademark of Intuit
1.6.4.2.1 Advanced setup

To reach Advanced Setup, from the Home tab select QuickBooks Integration > Settings > Common Settings.
If you are using a version prior to 2013 click on QuickBooks > QuickBooks Integration > Common Settings.

Typically, these settings do not need to be changed.
Effective Date
As you operate your business, each transaction date is recorded per your wishes in QuickBooks. Sometimes you pre-date or post-date transactions, which is fine.

However, when electronic transactions are sent to your bank, they are typically expecting the date you send them to be in the future - as this is the ‘effective date’ of the transaction.

To minimize any chance of post-dated transactions, Bank Positive Pay’s default setting is the latter of the QuickBooks date and the next business date (as displayed in the second option).

You can over-ride this setting as needed here.

Send transactions to Bank Positive Pay
The default setting, and for ease of use - is to create a file once transactions are sent from QuickBooks to Bank Positive Pay.

However, you may prefer to over-ride this setting if:
--you are editing records in Bank Positive Pay after sending them from QuickBooks
--you are manually creating records in Bank Positive Pay
--there are internal control measures which require another individual to create the file
--bank procedures require batch totals - which you would get from Bank Positive Pay or any other advanced situation.

Default From/To Date
The transactions page displays by default from 15 days in the past to 15 days in the future. This range should cover any post-dated entries (15 days in the past), as well as any future entries - such as payroll.

If you are constantly changing the default dates on the report, you can save yourself some time and change the default range here.
QuickBooks® is a registered trademark of Intuit

1.6.4.3 Importing transactions

To reach this transactions screen, from the Treasury Software main menu select the Home tab > QuickBooks Integration.
If you are using a version prior to 2013 select QuickBooks > QuickBooks Integration > Transactions.

This screen is a 'Window' into your QuickBooks data. By default, it displays all records in your QuickBooks account(s) that need be electronically transmitted.

Step #1 - View transactions
The grid by default displays records which you have not yet processed. You can change the From and To dates, as well as the default date range (details below).

```
<table>
<thead>
<tr>
<th>Date</th>
<th>Ref</th>
<th>Name</th>
<th>Debit</th>
<th>Credit</th>
<th>Memo</th>
<th>CB Account Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>12/01/15</td>
<td></td>
<td>Reyes Properties</td>
<td>$1,200.00</td>
<td></td>
<td></td>
<td>10100 Checking</td>
</tr>
<tr>
<td>12/05/15</td>
<td></td>
<td>Express Delivery Service</td>
<td>$35.00</td>
<td></td>
<td></td>
<td>10100 Checking</td>
</tr>
<tr>
<td>12/10/15</td>
<td></td>
<td>Pottery Hardware Supply</td>
<td>$157.59</td>
<td></td>
<td></td>
<td>10100 Checking</td>
</tr>
<tr>
<td>12/20/15</td>
<td></td>
<td>Davis Business Associate</td>
<td>$2,100.00</td>
<td></td>
<td></td>
<td>10100 Checking</td>
</tr>
<tr>
<td>01/11/17</td>
<td></td>
<td>East Bayshore Auto Mall</td>
<td>$525.77</td>
<td>Monthly Truck Pay</td>
<td></td>
<td>10100 Checking</td>
</tr>
<tr>
<td>01/15/17</td>
<td></td>
<td>Bank of America</td>
<td>$3,456.32</td>
<td>941 Deposit</td>
<td></td>
<td>10100 Checking</td>
</tr>
<tr>
<td>01/15/17</td>
<td></td>
<td>Federal Treasury</td>
<td>$100.00</td>
<td>FUTA Payment</td>
<td></td>
<td>10100 Checking</td>
</tr>
<tr>
<td>01/15/17</td>
<td></td>
<td>State Board of Equalitar</td>
<td>$208.59</td>
<td>State Unemployment</td>
<td></td>
<td>10100 Checking</td>
</tr>
<tr>
<td>01/15/17</td>
<td></td>
<td>State Fund</td>
<td>$1,214.31</td>
<td>Muller's Company</td>
<td></td>
<td>10100 Checking</td>
</tr>
<tr>
<td>01/15/17</td>
<td></td>
<td>State Board of Equalitar</td>
<td>$308.34</td>
<td></td>
<td></td>
<td>10100 Checking</td>
</tr>
<tr>
<td>01/15/17</td>
<td></td>
<td>QuickBooks MasterCard</td>
<td>$12,352.99</td>
<td></td>
<td></td>
<td>10100 Checking</td>
</tr>
<tr>
<td>01/15/17</td>
<td></td>
<td>CA Oil Company</td>
<td>$9521.00</td>
<td></td>
<td></td>
<td>10100 Checking</td>
</tr>
<tr>
<td>01/15/17</td>
<td></td>
<td>State Board of Equalitar</td>
<td>$3,148.88</td>
<td>ASCID 12345678</td>
<td></td>
<td>10100 Checking</td>
</tr>
<tr>
<td>01/27/17</td>
<td></td>
<td>Sergeant Insurance</td>
<td>$712.56</td>
<td>786-35</td>
<td></td>
<td>10100 Checking</td>
</tr>
<tr>
<td>01/31/17</td>
<td></td>
<td>Bayshore Water</td>
<td>$24.00</td>
<td>Monthly Water - Fr</td>
<td></td>
<td>10100 Checking</td>
</tr>
</tbody>
</table>
```

Step 2: Send transactions to Bank Positive Pay

Send transactions to Bank Positive Pay

Step #1 - View transactions
The grid by default displays records which you have not yet processed. You can change the From and To dates, as well as the default date range (details below).
In a basic situation, the system will display your new transactions - and all of them can be sent to Bank Positive Pay. Bank Positive Pay will then create a transmission file, which is sent to your bank.

**Summary counts and totals**
The summary counts and totals include all transactions which have completed profiles, have not yet been sent and have not been marked to be held.

**Step #2 - Transmit to Bank Positive Pay**
Click on the 'Send transactions to Bank Positive Pay' button to create a file with the eligible records in the grid. You can then transmit the file to your bank.

QuickBooks® is a registered trademark of Intuit

**1.6.4.3.1 Holding and over-riding records**

In a perfect world, all of the transactions that you create in QuickBooks are to be sent for immediate electronic processing.

As we know, this is not always the case. Sometimes payments are held temporarily - or permanently canceled and sometimes payments need to be resent.

Marking records
Bank Positive Pay provides you with the tools to do this. Uncheck the checkbox to display your record controls (circled in red).
**Holding transactions - Temporary**
Select the record(s) and click on 'Mark - Do not Import (temporary)'.
This will mark the records as 'Do Not Import' during the current submission to Bank Positive Pay.

The records will be automatically displayed as available to be transmitted the next time you view the records.

Notes:
--If you re-run or refresh the grid prior to transmission, this will clear your marked records. You will need to re-mark them.

**Holding transactions - Permanent**
Select the record(s) and click on 'Mark - Do not Import (permanent)'.

If you no longer want a transaction to be transmitted electronically, you can mark the record(s) as 'Mark - Do not Import (permanent)'.

Marking records 'Do not transmit' stop the transactions from being imported now - or in the future.
If in the future, you decide that you need to process this record, see the instructions below for 'Mark - Import (over-ride)'.

**Mark - Import (over-ride).**
Select the record(s) and click on 'Mark - Import (over-ride)'.

Use 'Mark - Import (over-ride)' if you need to:
--process a transaction that you previously put on a permanent hold, or
--you need to re-transmit a record.

An example of re-transmission: If a bank account number that a vendor gave you was wrong - and the original transaction was returned. You can then use the over-ride feature to re-transmit this.

Note: In order to select a record, you'll need to view it. However by default, previously transmitted records and those placed on permanent hold - are suppressed from being displayed. See the section below to display these records.

Displaying previously transmitted and permanent 'on-hold' records
By default, Bank Positive Pay will suppress displaying previously transmitted and permanent 'on-hold' records. To display these records, un-check 'Hide transactions already imported'.


**Why would I want to view these records?**

Typically, you would not want to view these records - that is why we suppress them by default. However, you would want to display these records for:

--1. If you need to re-transmit a transaction that originally failed.
--2. If you need to transmit a record that you placed on permanent hold.

---

**QuickBooks® is a registered trademark of Intuit**

**1.7 QuickBooks Pro, Premier and Enterprise**

Bank Positive Pay enables you to create positive pay transmission files directly from your QuickBooks data.
Benefits of Direct connection:
--Simple to install and use. Doesn't change the way you work with QuickBooks. Keeps all of your processes the same.

--Create positive pay files for your bank with 'one-click'

--Avoids transmitting duplicate records.

Direct Integration is available if you are on QuickBooks:
--Professional, or
--Premier, or
--Enterprise.
The editions must be 2003 or later and US-based.

Not on one of these packages, see QuickBooks Online Edition.

QuickBooks® is a registered trademark of Intuit

1.7.1 Setup - QuickBooks

Step-by-step checklist

Confirm that Bank Positive Pay and QuickBooks are installed on the same computer.
Note: If you have a multi-user edition of QuickBooks, you may need our multi-user platform if you'll be creating positive pay files from more than one computer.
The instructions below assume a simple desktop installation.

Need to download? Go to http://www.treasurysoftware.com/download.aspx

Start Treasury Software and at the 'Welcome New User' screen, enter into Bank Positive Pay.
Create a new account in Bank Positive Pay to work in.
From the main menu select File > New Account - and you'll open the Account Wizard.
The top option “Create an Account...” should already be selected. Click Next.
Enter a name for the account. This name is strictly internal and should help you identify the purpose of the account. For example, if you are using it for payroll, you might name the account Payroll. Once the name is entered, click Next.

Congratulations! You have finished creating the account. Click Finish to begin using this account.

If prompted to edit/modify your transmission information, click No.

Congratulations. You are done with your basic setup.

Next step - Connect to your QuickBooks company
1.7.1.1 Connect to QuickBooks

First time connection (this is a one-time setup)

Before you begin, confirm that:
--Bank Positive Pay and QuickBooks are both running on the same computer, and
--QuickBooks - you are logged in as the administrator for the QuickBooks company you want to work with.

Note: For normal use, you do not need to be logged on as an admin, only during setup.

Start the connection process
Enter into your account and select QuickBooks Integration.

Switch to your QuickBooks window
If nothing appears to be happening, QuickBooks is waiting for you to grant permissions. Click on your Windows toolbar to access QuickBooks.
The first time Bank Positive Pay attempts to connect to your QuickBooks company, you will be prompted by QuickBooks to grant access. Note: You can leave the bottom check box un-checked. Please grant access to continue.

QuickBooks will prompt your confirmation. Click ‘Done’.
Note: If you do not grant access, you will be unable to continue.

Please switchback and grant access within QuickBooks to continue.
Congratulations, you have connected.

Note: If you upgrade Treasury Software, change versions in QuickBooks, or install the software on a new computer - you may be prompted to grant permissions again.

Next step - Integration Wizard

Troubleshooting - Can't connect?
See Troubleshooting connections

QuickBooks® is a registered trademark of Intuit

1.7.1.2 Integration Wizard

Integration Wizard

Once you have connected to your QuickBooks company, you can complete the Integration Wizard.

Enter into your account and select QuickBooks Integration.
Note: This is the same menu choice you selected earlier to establish a connection. Once a connection has been made, the settings are automatically saved - it is a one time setup.

View the list of your QuickBooks accounts - Select your bank account
Have more than one origination account? We'll cover this in settings.
Click 'Save' to save your settings

Next step - Bank Express Code - entering your bank's layout

1.7.1.3 Bank Express Code

What's a Bank Express Code?

Each bank has their own format on how they want to receive the file - and many larger banks have multiple layouts due to bank mergers and acquisitions.

To save you time, Treasury Software maintains a library of hundreds of layouts. These layouts are identified by a number we call a 'Bank Express Code'.
**How do I get a Bank Express Code for my bank?**
Contact [Treasury Software support](#) and include a copy of the layout that your bank sent you.

**Entering your Bank Express Code.**
Clicking on the Setup icon on the Home page (below)

**Sample**

![Sample Image](image)

**Enter your Bank Express Code**
Enter your code, then click 'Update Bank Information'.
Then click Yes. You're all set.
Next step - Create a file - for testing or sending to your bank

1.7.2 Creating the Positive Pay File

Once you have completed your setup, you can create ACH files.

**Tip: Need to just send a test file now?**
Change your ‘From’ and ‘To’ dates to historical/old transactions which you have already fulfilled. You can then send that file up to your bank for testing.

**Step 1. Adjust dates, if needed, and then click on the 'View transactions' button.**
This will display all available records.
If you need to hold or resend a transaction, see our advanced options features.
2. After reviewing the records, click the 'Send to Bank Positive Pay' button.
Congratulations - Note the location of the positive pay file. The file will always be saved at this location. Want to change the location, or see archived ACH files? Go to our creation page.
Transmission
Remember: Once the file is created at your location, it must be transmitted up to your bank.

Next step - Transmitting the Positive Pay file

1.7.3 Transmitting to your bank

 Transmitting Positive Pay Files

How you transmit to the bank depends entirely on your bank’s options for receiving the files.

To view the options available to you through Bank Positive Pay, select the Settings tab then Transmit to Bank.
There are five choices available as a transmission method.

Methods

None  The file will be created and archived, but it will not be transmitted. You must transmit the file manually.

FTP  After creation, Bank Positive Pay will transmit the file to the FTP server you specify. This should be your bank’s FTP server. Includes SSH capability. Contact your bank for information on their requirements.

Web Upload  After creation, your default Internet browser will be started to a specified web page that corresponds to your bank’s upload portal. Upload the created file.

Email  Bank Positive Pay will email the created file as an attachment to the email addresses specified. This method is not recommended as it is unsecured.

Other  For integration with third party utilities (legacy). Not for new users.

Web upload  
The vast majority of our clients upload the Bank Positive Pay file through their bank’s web portal. If this is the case with you, select the third option ‘Web Upload’, and enter your bank’s URL address to login.

Then, whenever you create a file, the system will open an instance of your default browser to that login page. Think of it as an ‘electronic sticky-note reminder’.

See Changing File Transmission Method to set up the transmission method as required by your bank.

Next step - Holding and resending transactions

1.7.4  Holding and resending transactions

Holding and resending transactions - Advanced Record Control

From the QuickBooks Transactions window (from the Home tab > QuickBooks Integration), once you click in ‘View Transactions’, several advanced record control options appear.
Hide transactions already processed
If the date range you select includes a previously processed transaction, by default Bank Positive Pay will suppress displaying the transaction.

Note: Viewing previously transmitted transactions will have no effect when creating a file. They will not be included in the file, as these records would be considered duplicates.

Caution: If you are using a multi-user version of QuickBooks, but only a single-user version of Bank Positive Pay - not all transactional history may be in your desktop audit trail. Transactions processed by others will not be marked as duplicates (Already Imported) on your system.

You can accommodate for this by marking these records as 'Do not transmit'.

Advanced Record Control
To use any of these Advanced Record Controls - first select the transactions, and then click on the button.

Do not send (temporary)
Enables you to temporarily hold a transaction from being sent, and therefore - not being included in the positive pay file.
Caution - This is a temporary marking.
If 'View transactions' is clicked, or the report is re-run, your selections will be reset.

Do not send (permanent)
Enables you to permanently hold a transaction from being sent.
Your selections are saved to the database. Clicking 'View transactions' re-running the report has no effect on your selection.

Send (over-ride)
Enables you to resend a transaction that you have already sent, or to send a transaction that you have placed on hold (on this screen).
1.7.5 Settings - Bank Positive Pay

The Settings tab can be accessed from the main menu - QuickBooks Integration > Settings tab.

Accounts tab
In the Accounts tab, you can add or change the QuickBooks bank account that holds your transactions.

Common Settings
1.7.6 Testing

Want to take Bank Positive Pay for a test run?

If so, this page is for you.

Steps:
1. If you haven't done so already, download the software from the link below and install on the same computer that QuickBooks is running on.

2. Start the software to arrive at the ‘Welcome New Users’ page
   Click on Bank Positive Pay
3. You will be brought to our Getting Started page. We recommend viewing the 5 minute tutorial video on the right (Getting Started with QuickBooks).

4. Start QuickBooks and enter into a company. You can use either the service based business or product based business company (qbw file) to follow along on this demo.
In the example below, we are using the sample company, Larry’s Landscaping & Garden Supply (service based business).

Note: For the initial setup, you should be in single-user mode with admin rights.

5. In Bank Positive Pay, on the Home tab of the main menu, click 'QuickBooks Integration'.

6. This will prompt QuickBooks to display a security authorization window - it will be flashing in your taskbar.
Click the icon in your taskbar to view the Application Certificate form below.

You can opt for either the 3rd option (typical), or the 4th option (advanced - rare, only if you will be running our software when QuickBooks is not running). Make your selection and complete the wizard.

7. The QuickBooks Integration Window will now be displayed. Your bank accounts and Undeposited Funds account for the open QuickBooks company will be displayed. For the demo, click on 'Checking' as it contains the most transactions, then the selection button (>>) and Save.
8. Creating a Positive Pay file
The software will now display the transactions available for transmission from within the QuickBooks bank account that was selected.
Click 'Send Transactions to Bank Positive Pay' to create the file.
Click Yes when prompted to view the file.

View the file?

Would you like to view the file?
The file is located at C:\Users\Public\Treasury Software\To Bank\sample_account_transmit.txt

Your file will look similar to the screen shot below.
Congratulations - you've successfully created a positive pay file from your QuickBooks data.

If this were a 'live' production run, you would then upload this file to your bank.

Advanced Topic

9. Where is the data stored?
From the Home tab > click Delete Records > then from the 2nd drop down select 'All Periods'. Click Run.
Reminder: Select 'All Periods' from the drop down as QuickBooks' sample accounts are future dated.
Want more information, or would like to schedule a live demo with Treasury Software Support? Please contact us at 866 226-5732 or online.

1.7.7 Troubleshooting-Connections

Troubleshooting - Can't connect?

Number #1 issue - QuickBooks - You must be logged on in QuickBooks as an administrator (just the first time).
If nothing appears to be happening, QuickBooks is waiting for you to grant permissions.

Check to see if there is a pop-up screen in QuickBooks prompting you to grant access.

Click on your Windows toolbar to access QuickBooks.

Please grant access to continue.

If not, confirm the following:

1. **QuickBooks** - You must be logged on in QuickBooks as an administrator (repeated from above).

2. **Switch to QuickBooks single-mode and have only one QuickBooks company open.**

If you changed either #1 or #2, completely exit out of QuickBooks and restart QuickBooks.

Steps #1 and #2 account for virtually all connection issues. Below are some of the additional steps that our support department may check for in rare occurrences.
3. Is there a pop-up or notification in QuickBooks? If so, close the pop-up.

Note: If you have been prompted to update QuickBooks, please do so. You will not be able to connect until you have updated.

4. Is QuickBooks installed on the same computer as Treasury Software?

5. Are you running a QuickBooks Pro, Premier, or Enterprise edition - US version of QuickBooks, 2003 or later?

6. Have you or your administrator turned off access to the QuickBooks database?
   From within QuickBooks, select from the main menu Edit > Preferences > Integrated Applications > Company Preferences. Verify that the checkbox to disable integration remains unchecked.

7. Using Vista?
   Vista's User Access Control must be enabled. This is a limitation under Vista only.
   From your Windows Operating System, select Control Panel > User Accounts > User Access Control

8. Do you have proper security rights in QuickBooks to grant access?
   Check this by entering into a sample account within QuickBooks. Then try to connect from within Treasury Software. If you can connect to the sample account, but not your other account - this is a permissions issue. Have your QuickBooks administrator grant access to Treasury Software.

1.7.8 QuickBooks Security

QuickBooks Security

The default user security enables all users for all versions of QuickBooks to run Treasury Software.

This page is for Enterprise users who grant specific user permissions, and want to make sure that each user has the lowest level of rights granted.

From within QuickBooks select Company > Users > Set Up Users and Roles ....
On the pop up window, select Role List > the role you want to edit (in this example Accountant14) and then 'Edit'.
There are only two 'Areas and Activities' that ACH Universal requires: Centers and Reports.

**Centers**
Click on the plus sign next to Centers. ACH Universal requires at least 'Partial' access for all three areas within Centers. Even if you're not utilizing all three areas - follow the instructions as the system needs to loop through each regardless (at that point, the system will see you're not using it).

Note: For Customer Center, the 'View Balance' needs to be checked.
Reports
Click on the plus sign next to Reports. ACH Universal requires at least 'Partial' access for:
Accountant & Taxes
Customers & Receivables
Employees & Payroll
Vendors and Payables

Even if you're not utilizing all areas - follow the instructions as the system needs to loop through each regardless (at that point, the system will see you're not using it).
Click OK to save your work.

You're all set!

Reminder: We've documented above the minimum permissions to use ACH Universal. For the initial setup, please use a QuickBooks admin account.

1.8 QuickBooks Online

Using QuickBooks Online Edition (QBOE) to create Positive Pay transmission files
QuickBooks Online integrates seamlessly with Positive Pay, but it does so in a slightly different way than the installed version of QuickBooks.

Checks are automatically imported from QuickBooks Online to Positive Pay.

Please refer to the instructions at each tab:

- **QBOE Positive Pay Setup**
- **QBOE Importing Positive Pay Transactions**

### 1.8.1 QuickBooks Online Positive Pay Setup

**Quickbooks Online Setup**

**Create a new account in Positive Pay.**

The steps to create a new account - from the main menu select **File > New Account**

The top option “Create an Account and Add it to your Catalog” should already be selected. Click Next, and go through the wizard.

The account name is for internal use and should help you identify the purpose of the account.
Congratulations! You have finished creating the account. Click Finish and you will begin using this account.

**Next: Do you need a Bank Express Code see the choices below, if not move to connecting?**

- [What is a Bank Express code](#) and what does it look like?
- What do I do when I get my Bank Express Code, where do I [set it up](#)?

**Next: Connect to Quickbooks Online**

Once an account is created in Positive Pay, you'll want to continue working in that new account. Go to the Quickbooks tab, and click on the "Online Edition" of QuickBooks Integration.

An Account wizard will pop up --

**Step 1.** Enter the QuickBooks Online **Company ID** and "Authorize". This will connect your QBOE to Positive Pay (if you don't know your ID click [here](#))
Step 2. Once authorized, the bank account(s) will populate and you'll choose the account you want to pull checks from to create your file—and "Save Bank Account".
Now, you are ready to transfer your checks to create your Positive Pay file!

1.8.2 Adding QBOE Transactions

After you have entered in all your checks into your QuickBooks online company you are ready to import them into Positive Pay. Open your Treasury Software to your Positive Pay account and then select the QuickBooks Online icon off the main menu bar.
Then select your date range and then select View Transactions.

Then a list of checks will populate below. Don't forget to double check your totals, (see the green circled items).

Once you verified your totals select the Create Positive Pay file button.
Then your file will be create.

View the file?

File created. Using the Internet Browser which has just opened, upload the file:
C:\Users\Public\Treasury Software\To
Bank\PositivePay_CheckRegister_transmit.txt

Would you like to view the file?

Don't forget you need to send this to the bank!

1.8.3 Finding Company ID

Finding your Company ID in QuickBooks Online

Log into QuickBooks Online, if you haven't done so already.
Click on 'Settings' (the gear icon) in the upper right corner.

From the pop-up menu select 'Accounts and Settings'

On the left navigation bar, select 'Billing & Subscription'.
You will see the Company ID displayed.
1.9 Security

There are two components to Treasury Software security:
--client-based
--server-based

**Server based security - 'Gold Standard'
**
Server-based security is Microsoft SQL Server based and is first addressed during account creation and setup. It centers around the user’s Windows or SQL Server login ID and the membership of the groups/roles that the individual belongs to.

Based on the membership, the user will have access to or be denied to the various SQL Server databases. There is a one to one relationship between databases and accounts.

SQL Server is maintained according to your corporate security policies outside of Treasury Software by your database administrator (DBA) with Microsoft’s SQL Server Management Studio.

Treasury Software products on SQL Server, with SQL Server security maintained - is the strongest form of security we can deliver. SQL Server is required by many Government agencies and according to corporate bank policy. SQL Server security is often viewed as the 'Gold Standard' of security.

**Client-based security**
The following help pages cover client-based security.

Treasury Software also provides two levels of client based security:
--user authentication - simple access to software
--feature-level access - segregation of duties - requires SQL Server with and Treasury Software Enterprise license

**Holistic Approach**
While we are proud of our client-based security features - if only client-based security is implemented - it will merely be an inconvenience to those seeking to commit fraud.
Security is only as effective as the weakest link in the chain.

Locking down the ‘front door’ (client), only to leave the ‘back door’ (server-data) open is not an ideal security model.

Adding to security concerns - The input to Treasury Software is an unprotected file - typically a spreadsheet, and the output for ACH Universal and Positive Pay is an ASCII file.

Client workstation access control
For those environments requiring high security, we highly recommend the use of Windows Operating System and Network Operating System based features, to limit physical and remote access to the Treasury Software client.

Note: All Treasury Software security is applied on an account by account basis.

1.9.1 Setup
Menu selection and Setup-login

Menu Selection
The security menu selection by default is hidden. Please note: The displaying/suppression of the menu choice has no effect on the security level.

To view the menu choice, from the main menu select File > Options > General > System tab and turn ‘Suppress Security Menu’ to ‘Display’. You will then need to exit and re-enter this account (display is on a per account basis).

Login - setup
To access the login screen, from the main menu select File > Security > Security Administration

![Security Setup Login](image)

Default User name admin
Default Password password

Once logged in (only an admin can pass through setup security), you will be at the security main page.
Security Setup. Please select a security option, then press 'Update' and follow the prompts.

**Security settings are for this account only!**

### Security Options

**Disable Security**
- No Security

**Security – Authentication. Only allow registered users access to the software**
- Prompt User to Login
- Integrate with Windows login ID

**Security – Segregation of duties. Grant/limit access at the feature level. Includes Authentication security (above). Requires SQL Server and a Processor level license.**
- Prompt User to Login
- Integrate with Windows login ID

### Authentication

- **Prompt User**
  - Challenge screen prompting the user to login each time the user starts the software and then determines whether access should be granted.

- **Integrate with Windows**
  - Uses the Windows Login ID to authenticate and then determines whether access should be granted.

### Segregation of duties

- **Prompt User**
  - Same challenge screen as above, plus grants/restricts access to features on a per user/role basis.

- **Integrate with Windows**
  - Same authentication as above, plus grants/restricts access to features on a per user/role basis.

Only available on SQL Server with a Treasury Software Enterprise license.

Only available on SQL Server with a Treasury Software Enterprise license.
Multiple Accounts - Security is applied on an account by account basis
If you have more than one account, you will need to enter into each account you want to protect and make your security selection.

Tips:
--Do not put security on the Sample account (do not place ‘real’ account numbers, etc.. in the sample setup)
--Change the default admin password
--Use a Windows Operating Screen screen saver with password protection

Note: All Treasury Software security is applied on an account by account basis.

1.9.2 Users-Add

Users
Adding Users - click 'Add'
If using Windows authentication - enter the user’s Windows login name and leave the password blank. Otherwise, simply enter the login name and password that will be entered.

Authentication security - All users will be assigned to the admin group.
Segregation security - Assign users to their roles.

Delete, Edit and Print
Use as prompted

Tips:
Change the password on the ‘Admin’ account.
Users can switch from account to account as long as their name is listed as a user in each account.
Note: All Treasury Software security is applied on an account by account basis.

1.9.3 Segregation of duties

Segregation of duties security is available on SQL Server platforms with an Enterprise license from Treasury Software

Permissions
Permissions are granted on a role by role basis

Notes:
--Check the 'Access to the Account' checkbox to allow the user entry into the account. Leaving this unchecked is the same as removing them from the user list. Use this checkbox when there is a temporary vacancy and you do not want to reset the permissions.
--Your tabs will differ slightly based on your applications that you are running.
Note: All Treasury Software security is applied on an account by account basis.

1.9.4 Roles

Segregation of duties security is available on SQL Server platforms with an Enterprise license from Treasury Software.

Notes:--You only need to maintain roles for Feature level security.--You cannot delete the admin role.

Tip: Create roles before you add users. This way, you only need to be in users once (you don't have to go back).

Note: All Treasury Software security is applied on an account by account basis.
1.10 Reference

1.10.1 Remote Desktop (Terminal Services / Citrix) Platform

Remote Desktop (Terminal Services / Citrix) Platform

For the purposes of this help page, the term 'Remote Desktop' will include Terminal Services and Citrix.

Installation

For instructions on initial setup and system requirements, please see our Installation check list at:
http://www.treasurysoftware.com/support2-Installation-Citrix.html

Turn On/Off

To turn Remote Desktop on or off:
Enter into an account and from the main menu select File > Maintenance > 'Remote Desktop' tab.
Check / (uncheck) the ‘Enable’ check box. Exit and re-enter into the system.

Understanding Remote Desktop Mode

Simple (non-Remote Desktop Mode)

In a simple desktop or SQL Server environments, when a user starts Treasury Software, the system looks for a settings file which contains a catalog of accounts, Treasury Software licensing information, as well as user-based preferences.

Typically only one settings file is on a computer. This file is opened in 'exclusive' mode - in that multiple users should not read/write to the file. While this is not an issue when a computer is in use by one person - it needs to be addressed if the computer is a Remote Desktop Server.

Remote Desktop Mode

Once Treasury Software is turned 'on' for Remote Desktop Mode, the system will protect the original settings file. Remember - the settings file is user specific. More than one user should not access the file at a time.

WARNING - Unexpected results will occur if Treasury Software is installed on a Remote Desktop Server and Treasury Software's Remote Desktop Mode is not turned 'on'.

Technical discussion - 'Under the hood'

Simple

In a simple environment, the settings file is accounts.brd and is located at c:\Program Files\Treasury Software\version xxxx\accounts.brd (or for Windows 7 .c:\Users\Public\Treasury Software\accounts.brd)

Remote Desktop

When the system is 'switched' to Remote Desktop, the system protects the accounts.brd from being accessed.
As each user starts Treasury Software for the first time, the system creates an accounts.brd specific for that individual, and it is placed in the \users directory.

Notes:
The accounts.brd file is appended with their login id.
The users directory will either below the Program Files\Treasury Software tree (Windows XP), or in the Users\Public\Treasury Software tree (Vista, Windows 7).

Planning - 'When' to turn on Remote Desktop mode
Remember: The system's accounts.brd is used as a template for each user's accounts.brd file. Everything that you do in the system PRIOR to a user logging in for the first time will be included in that new user's accounts.brd.

Therefore:
If you create two new accounts (ie. Checking and Saving) prior to any users logging in - each user when logging in for the first time - will have Checking and Savings accounts in their catalog.

As a corollary, if you are the system administrator and make changes to the system, such as entering new license codes - this information will:
--not be available to existing users (their accounts.brd's have already been created)
--will be available to any new users, as the system will use the updated accounts.brd as a template.

Making system changes after users have already logged in
1. Make Treasury Software temporarily unavailable to users.
2. Enter into Treasury Software through the Remote Desktop as an administrator - not as a user through a published application (Citrix).
3. Enter into an account.
4. Turn off the Remote Desktop function (File > Maintenance > Remote Desktop).
5. Exit, and then re-enter Treasury Software. Enter into an account. Confirm that the Remote Desktop function is off.
6. Perform any maintenance, add any licenses, or add any accounts as needed.
As a reminder - you are now updating the accounts.brd file. This will be used as a template for each of your users.
7. Turn the Remote Desktop function back 'on' (File > Maintenance > Remote Desktop).
8. Exit the software.

Optional
If you want to force this change to all existing users, you will need to delete the user settings files. Then, once each user logs in - the system will create a new settings file for them (using the newly updated settings file as a template).

Warning - Deleting the user's settings files will reset all of their settings to the default settings file (which you just updated).
This includes:
--License information
--Account catalogs
--SQL Server server name and authentication method (no effect if using Windows Authentication)
--Minor settings

To delete the user's settings files - using Windows Explorer - delete the contents of the \users directory.
The files in the folder will have a syntax of [login id]_accounts.brd.

The \users directory can be located at c:\Program Files\Treasury Software\version XXXX XX\users\
If the folder is empty (on Vista or later), then look to the c:\Users\Public\Treasury Software\users\ directory.

9. Make Treasury Software available again to your users.

For some reason, if there is a setting that you missed - or wish to change - you can repeat this process.

1.10.2 How do I stack multiple accounts in one file?

How do I stack multiple accounts in one file?

How do I stack multiple accounts in one transmission file?

First configure Bank Positive Pay as if you were only transmitting one account - that means entering the Bank Express Code, entering transmission settings, etc...

Perform at least one full test of importing and file creation.

Overview
The process for multiple origination account file creation is essentially the same as for a single file creation. The differences are:
--the 'Origination Field' will be substituted as the output field (instead of 'bank account number').
--you'll need to specify which account each transaction is associated with. How you perform this, will depend on your data. We provide options below.

We also recommend that you create a new account to work in with Bank Positive Pay, as each transaction will need to be associated with an account.

I. Setup the transmission file format (output)

The steps below will change the field
From: Bank Account Number
To: Origination Account

From the main Ribbon Bar > Settings > Transmission Options > Transmission File Format (data) tab > Detail Records.
The Record Detail window will be displayed.
1. Locate the 'Bank Account Number' field - and select it.
2. Change the selection in the drop down selector to Origination Account.
Save your changes.
Select No - and close the pop-up windows.
Skip this section unless you have headers/footers (rare)

a. Enter the header format using the 'Header - Top' as a guide. Note: Substitute 'Origination Account' for 'Bank_Account' in the Batch Header.
b. Switch back to 'Header - Top' and delete the mapping template. Click 'Done'.
   Click on 'File Footer'. Change the drop down selection box from 'Footer - Bottom' to 'Batch Footer'.
c. Enter the footer format using the 'Footer - Last Line' as a guide. Note: Substitute 'Origination Account' for 'Bank_Account' in the Batch Footer.
d. Switch back to 'Footer - Last Line' and delete the mapping template. Click 'Done'.
   Note: You can have any combination of headers and footers, as specified by your bank.

II. Setup the Import Mapping

Please select a method to follow below, based on your data. Please note that they are not necessarily mutually exclusive.

Depending on your data, you will have three options on how to associate a check issued with an account:

a. Account number is embedded within the Excel/csv file imported.
b. There is no account number within the Excel/csv file imported.

1.10.2.1 Account Number in file - Multiple Accts

Account Number in file - Multiple Accounts

If your Excel/csv file contains the account numbers (looks like this) - it's relatively easy.
Setup
From the Settings tab > Transmission Options > Transmission File Format tab
--Select 'Multiple Accounts' option (radio button)
Click close when completed.
Import Mapping
During the import process, select the field containing your account numbers and then map it as 'Origination Accounts'.
Complete the import as usual.
This is a one-time mapping process. All future imports will pick up the data as indicated.

1.10.2.2 No account number in file - Multiple Accts

If your Excel/csv file does not contain account information, please follow the steps here.

Setup and add accounts to the accounts table
From the Settings tab > Transmission Options > Transmission File Format tab
--Select ‘Multiple Accounts’ option (radio button), and then
--click the link to Manage Multiple Accounts
Upon clicking the link to Manage Multiple Accounts, you'll see the following window.

Click ‘Add’ and then enter an account nickname (used internally only) and the full account number. Repeat for as many accounts are needed. Click ‘Save’
Close both windows when complete.

**Import Process**

During the import process, you'll be able to associate each file with an account.

At the column mapping screen, there will now be a drop down selector for the account. Select the account during import and then continue as usual.
Create the file as usual.

1.10.3 Adding Address Lines

Address lines, also known as Payee Name lines, can be easily added to your positive pay file.

Setup (one-time)
1. **Enter your Bank Express Code.**
   This will configure the positive pay output file and any internal options needed. You can enter your Bank Express Code on the program's home page.

2. **Import your check data**
   If you're importing an Excel or csv file - please map the fields below as needed:
Available fields:
Address_Line_1
Address_Line_2
Address_Line_3

In addition, you can map the following three fields when a third address line is not available.
Address_City
Address_State
Address_Zip

or

**Importing from QuickBooks**
There is nothing that you need to do - other than entering your Bank Express Code in step #1.

[QuickBooks tips on minimizing exceptions](#)
1.10.3.1 QuickBooks Tips

QuickBooks tips

Make sure that you follow the QuickBooks standard address syntax.

After you enter/edit a vendor's address field, click on the edit button within QuickBooks - and then confirm the edit.

This will place the City, State and Postal Code (Zip) in standard format.
Note: This format is the city, followed by a comma, space, state, space and then the zip code.

1.10.4 Frequently Asked Questions (FAQ)

1.10.4.1 Changing Debit and Credit Text

Overview

Debit and Credit text is used in conjunction with the Sign field to identify whether a transaction in a file is a debit or a credit. Follow the steps below to enter the debit and credit text for your data.

Steps
From the main menu select File, then Options, then General.

In the "Text for Debit" field, enter the text to identify a debit transaction. The default is "debit".

In the "Text for Credit" field, enter the text to identify a credit transaction. The default is "credit".

When finished, click Close to save your changes.

1.10.4.2 Changing File Transmission Method

Overview

After creating a Positive Pay file from your data, it must be transmitted to your bank to be processed.

Contact your bank to find out how they wish to receive your Positive Pay files. Follow the instructions below to set up transmission methods based on their preference.

Loading Transmission Options

Select File from the main menu.

Select Options, then Transmit to Bank

Transmission Options screen will be displayed (Figure 1 below).
There are five possible methods of transmitting a file to your bank:

<table>
<thead>
<tr>
<th>Method</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>The file will be created but not transmitted.</td>
</tr>
<tr>
<td>FTP</td>
<td>Transmit via FTP built into Bank Positive Pay. See Settings to modify the FTP settings.</td>
</tr>
<tr>
<td>Web Upload</td>
<td>Transmit via a bank web page portal. Type the portal address into the textbox for Bank Positive Pay to load the page automatically in your default browser.</td>
</tr>
<tr>
<td>Email</td>
<td>Transmit via email sent by Bank Positive Pay. Not recommended.</td>
</tr>
<tr>
<td>Other</td>
<td>Transmit using an optional method, including modem. Rarely used.</td>
</tr>
</tbody>
</table>

**FTP**

FTP, File Transfer Protocol, is a method of transferring files. In most situations, you will upload your files to a specific directory on the FTP server that only you have access to. This secures your files from parties other than the bank from being able to access them.

To modify FTP settings, click the Settings link listed with FTP in Figure 1, or click the FTP tab. Figure 2 (below) will be displayed.
Figure 2 - FTP Options

All information on this page must be obtained from your bank.

The host name is usually in a format as shown above and resembles a website URL.

Username and password allow you access to a specific directory on the FTP server. Enter all the information and click Test Login to verify that login information and host name has been entered correctly and is functioning.

If your bank gave you a specific directory to upload your file into, enter it in the Target Directory textbox.

If your bank gave you a specific name to use for the file, enter it into the Target Filename textbox. This will not affect the name of your Bank Positive Pay file on your local hard drive. If your bank did you provide you with a name, enter a logical name for the file.

FTP Advanced Options

In addition to the general FTP options, there are some advanced options available that increase transmission security via Secure Sockets (SSL) and specific port numbers. This information must be provided to you by the bank. Do not change any of these options unless the bank specifically requests them.

Click Advanced to display the FTP Advanced Options (Figure 3 below).
Secure Sockets Layer, or SSL, is a method of encrypting a transmission stream. To enable it at your bank's request, click the Bank Uses SSL Security checkbox. Select the type of SSL by clicking the appropriate radio button. Unless notified specifically by the bank, leave Automatic selected.

A Remote Port Number specifies a very specific port number. This offers the FTP server security from outside threats. Click Change Port and enter the port number provided by the bank, if any.

If the bank requests a bank transfer mode different than ASCII, click the appropriate radio button.

**Email**

To set up email transmission, click Settings corresponding to Email or select the Email tab. Note: Email transmission is rare and not recommended as it is not secure.
In the To: textbox, list the email addresses the file should be transmitted to. At least one of these should be the email address supplied by your bank for this purpose.

In the CC: textbox, list the email addresses you want to copy on the email. To send yourself a copy, list your email address or leave the Always send a copy to myself checkbox selected. For other people in your organization that need a copy, see Notification below.

In the From: textbox, list the email address to show as originating the email. This may be your personal email address or an address set up specifically for this purpose.

Enter a Subject to use for each transmission.

Enter the file name to be used for the transmission, regardless of the its name on your local hard drive. This does not rename your local copy.

Enter your mail server. For example, mail.server.com or smpt.server.com.

To configure appropriate settings for the mail server, select the Email Advanced tab.

**Email Advanced**

In this tab, you will configure the advanced settings of your mail server. After clicking the Email Advanced tab, you will see Figure 5 (below).
If you use a Windows program to download your email, such as Outlook or Thunderbird, you can retrieve most of these settings through Tools, then Options.

If your SMTP requires authentication for outgoing emails, click the checkbox.

For SMTP servers (most commonly used server type for sending email), enter the username and password.

For POP servers (rare for sending email), enter the server name, username, and password.

If your SMTP server uses a port other than port 25, enter it into the textbox.

Click Close.

**Notification**

Settings in the Notification tab are for setting up email addresses that should be notified of file transmissions. For example, if the process of creating and transmitting is automated, you may want an email sent to your personal address automatically notifying you that this has occurred.

Click the Notification tab to display it (Figure 6 below).
To enable notification, click the checkbox.

Enter the email addresses that need to receive the notification in the To: textbox.

Enter the email address to use as the From address in the From: textbox.

Enter an appropriate subject.

1.10.4.3  I am on the Desktop platform with 1 workstation license. If I purchase an additional workstation, can I share data?

Q: I’m on the Desktop platform and have 1 workstation. If I purchase an additional workstation license, can I share data between the two?

A: No. You will need to upgrade to the SQL Server Express or SQL Server Platform. With multiple workstations you can have a separation of data (payroll on one workstation, checking on another), but the two are unable to share between them.

1.10.4.4  What is an account?

Q: What is an account?

A: An account is the Bank Positive Pay front-end to a database that stores all the data you import. For example, a Payroll account access a Payroll database (either a .brd on the Desktop platform or a Payroll database on the SQL Server platform). This manual uses the term "account" instead of "database" because that is how Bank Positive Pay refers to them.

1.10.4.5  I purchased Positive Pay, but the Main Screen says ACH Universal

Q: I purchased a license for Positive Pay, but the Main Screen says ACH Universal.

A: Select the Settings tab > Maintenance > Switch Programs.
If you are using a version older than 2013. Select File from the main menu, then Programs. Select Positive Pay Only and click Continue.

1.10.4.6 I have one source file but multiple databases. How do I split the file into the correct database?

Q: I have one source file, but multiple Positive Pay databases. How do I split the file into the appropriate database?

A: Use an import filter. See Filtering Imports.

1.10.4.7 I have a non-standard date format. How do I use it?

Q: I have a non-standard date format. How do I use it in Bank Positive Pay?

A: A non-standard format is a format which isn't supported by your Windows (Control Panel, Regional Settings) Settings.

A date format of 31/12/2002 is non-standard in the United States, but is standard in the United Kingdom.

To import non-standard formats, use a Custom Date Import (CDI).

From the main menu, select File, then Options, then General.

In the Import tab, set "Custom Date Import (CDI) G/L:" to On

Select Format, (31/12/2002, 2002/12/31, etc...)

Select a separator, (slash, colon, hyphen, none)

If the date is embedded within another field, see My date field is embedded within text.
1.10.4.8 My date field is embedded within text. How do I import it?

Q: My date field is embedded within text. How do I import it?

Use a Custom Date Import (CDI).

From the main menu, select File, then Options, then General.

In the Import tab, set "Custom Date Import (CDI) G/L:" to On

In "CDI: Source Format G/L", select your date format from the dropdown box (31/12/2002, 2002/12/31, etc...)

In "CDI: Separator G/L", select your separator, (slash, colon, hyphen, none)

In "CDI: Embedded Start G/L" enter the date's first position (counting from the left) within the field. For example, when date is in a field by itself, this position is 0. If there were three characters prior to the start of the date, you would enter 4.

1.10.4.9 My bank requires a login record

Q: My bank requires a login record. How do I set up Bank Positive Pay to provide one?

A: A login record, if used by the bank, is the very first line in an Bank Positive Pay file, even before the file header record. It is used by the bank to identify the sender. Distinct from Bank Positive Pay identification, the bank will use this information for processing and tracking purposes.

1. Obtain the specific login record from the bank.
2. Start the software, load the account you have created in Bank Positive Pay.
3. Select Settings > Transmission options. If you are using a version prior to 2013. Select File menu > Options > Transmit to Bank.
4. Scroll to the Local File tab.
5. Key in the login record exactly as specified by the bank into the textbox labeled "Login record"
6. Click Close to save your changes.

Bank Positive Pay will now include the login record in every Bank Positive Pay file made in that account.

1.10.4.10 ActiveX component can't create object

This is an environment issue typically related to:
--failed installation
--ActiveX component became unregistered
--lack of permissions/rights to the user
--another software package (other than Treasury Software) was installed after ours, and their settings over-wrote ours.

Steps:
**Elevate rights**

1. View the error and confirm that the first error that they are seeing is related to this. If there is another error prior to this, address the other error first.

2. Have their IT representative log into their workstation with administrator rights. See if the issue can be re-created.
If the issue was not re-created - it is a permissions issue. Have their IT rep elevate the user’s rights. Pay attention to the rights in the c:\Program Files\Treasury Software directory (and subdirectory). Stop here.

If the issue was not re-created, continue with #3.

**Attempt to re-register the component**

3. Identify the component that is not working (lookup the line code) and attempt to register it.

If the Operating System is later than Windows XP, please follow the instructions for registering a component at: [http://www.treasurysoftware.com/support2-Vista-register-dlls.html](http://www.treasurysoftware.com/support2-Vista-register-dlls.html)

**If this is a new installation - uninstall and reinstall. Otherwise perform an upgrade.**

If this is a new installation and the software has not worked before:

4. If they are on desktop, backup their c:\Program Files\Treasury Software\version 201X XX\data directory to the their network.

5. Uninstall through the Control Panel. When finished - delete the c:\Program Files\Treasury Software directory

6. Download a current copy of Treasury Software and install it. It is critical that you watch the installation of the software and confirm that there were no errors during the installation. It is possible to have an error and 'click through it' to continue.

Test the new installation. If there is still an error, escalate the issue at this point.

### 1.10.4.11 ADO/MDAC Re-Installing

1 – Yes…After a clean install, the first error message received was the “SwitchPrograms_SampleData” after clicking the ACH Universal Sample Account Demo from the welcome new users screen.

ADO - FAQ - [http://support.microsoft.com/kb/183606](http://support.microsoft.com/kb/183606) (link on the page is to the MDAC download)


### 1.10.5 Maintenance - Desktop

**Overview**

The articles in this section provide information on backing up and restoring your database (Desktop platform only) as well as how to upgrade ACH Universal and apply current service packs.

**Database**

See Database Backup for information related to scheduling and working with database backups.

See Restore Database for information on how to restore a database from a backup.

**Archiving**

See Database Archiving for information on archiving records. This is for efficiency rather than backup purposes.
Upgrades and Service Packs

See Upgrade ACH Universal for steps on upgrading ACH Universal to the most recent version.

See Download Service Pack for steps on how to download and install the most recent service pack.

1.10.5.1 Database Backup

Overview

Backing up is a necessary part of working with all data. By backing up Bank Positive Pay on a regular basis, your data will be current in the event of an emergency and you will minimize data loss. Note: This article only applies to the Desktop platform. Contact your Database Administrator for procedures and policies regarding SQL Server backups.

Database backups are safeguards against unforeseeable computer errors (file corruption, system failure). By creating regular database backups, the chance of data loss is minimized as there will be a regular backup in place. Bank Positive Pay is set by default for automatic backups. This can be turned off (not recommended) or your own backups scheduled according to your own needs.

Internal Database Storage

Bank Positive Pay stores all information for each account in a .brd file. There is 1 brd file for each account and they share the same name. For example, if you create an account named Payroll, there will be a Payroll.brd database file that contains all the data imported into that account. Never place the brd file on a network drive and attempt to share it among multiple workstations. Multiple workstation licenses should only be used for totally separate database files (through totally separate accounts). If you need to share data, you must use the SQL Server platform.

Regardless of using Bank Positive Pay default backup policy or implementing your own schedule, the backups are numbered automatically by Bank Positive Pay for identification. The most recent backup will always have the extension .br1. The next most recent backup will have the extension .br2 and the third most recent backup will have the extension .br3. If a database restoration is needed, restore using the br1 file first (as it is the most recent). By default the backups will be placed into the same directory as the .brd. It is highly recommended that the backups are always stored in the same directory with the brd file.

Automatic Backups (not for disaster recovery)

By default Bank Positive Pay will backup your database in a pre-determined schedule.

Note: The program uses this as a protection against database corruption. These backups are stored on the same drive as the production database, and therefore will not proved for any protection on a hard drive crash or if there is any damage to the computer.

It is highly recommended to leave this option on. If you wish to turn it off:
From the main menu, select File, then Options, then General.
Select the System tab. Change the “Backup data on exit” option to No. Click Close to save your changes.

Manual Backups - Disaster recovery

From the main menu, select File > Backup.

We highly recommend backing up to a server that is backed up off-site.
1.10.5.2 Restore Database

Overview

Follow the steps below on the Desktop platform to restore a database backup. For example, if the database becomes corrupted, restoration would be required.

Database Restoration Procedures

Please follow the steps at:

1.10.5.3 Database Archiving

Database Archiving

Archiving is used to move older records from your main account database to a separate archive database. This offers improved speed and efficiency in working with the main database. The archived records are still accessible through ACH Universal for reports as needed. Archived records can also be restored to the main database should the need arise.

Before archiving records, you must create an account to hold the archive. The archive account name should match its main counterpart with "_archive" appended to the name. For example, the archive account for an account "Payroll" should be "Payroll_archive." See Creating An Account for steps in this process.

Select File from the main menu, then Archive/Restore. Click the Archive/Restore tab. You will see Figure 1 (below).

![Archive/Restore Window](image-url)

- Archive/Restore
  - Allows the user to manage database records by moving older records to a separate 'archive' account.
  - Each account in your system has a corresponding 'archive' account, in which records may be moved to (archive), or from (restore).
  - To perform research with records which have been archived, you do not necessarily need to restore them. You can open the archive account, just as you would a regular account, and run reports.
The textbox shows that the archived records will be stored in Payroll_archive.brd. All records up to 8/31/2007 will be archived. All records after that date will remain in the current account database (in this case, Payroll).

When the settings are correct, click Start. A prompt will appear containing the number of records to be archived. Click Yes to archive the records, No to cancel.

When the archive is finished, click OK on the confirmation box. Click Done.

**Restoring Archived Records**

Follow these steps to restore archived records to the main database.

Select File from the main menu, then Open/Select Account.

Select the archive database (ends in "_archive").

Select File from the main menu, then Archive/Restore. Select the Archive/Restore tab. You will see Figure 2 (below).

![Archive/Restore](image)

The textbox will show the main account database name (in this case, Payroll). Select the beginning restore date. All records more recent then this date will be restored to the main database.

When the settings are correct, click Start.

Click Yes to confirm the restore or No to cancel. A message will be displayed confirming the restore has been completed. Click OK.
1.10.5.4 Download Service Pack

Updates

A Service Pack update is an in-cycle release that modifies some features of Bank Positive Pay. This is distinct from an upgrade which requires a setup file be downloaded and used. The Service Pack can be downloaded and installed automatically through Bank Positive Pay.

Download Service Pack

Automatic:
From the Help tab select Software > One Click Update.
If you are using a version prior to 2013. From the main menu select File > Updates > Service Pack > Automatic.

If you have an Internet connection, click Yes to proceed with the download.

Bank Positive Pay will automatically download and install the newest service pack if not already installed.

When prompted, close and restart Bank Positive Pay to complete the service pack installation.

If you have any issues with the automatic process please try the manual process.

Manual:
From the Help tab select Software > Manual Update.
If you are using a version prior to 2013. From the main menu select File > Updates > Service Pack > Automatic.

Please follow the steps outlined on the form.

1.10.5.5 Desktop Platform Upgrade

Overview
Bank Positive Pay upgrades are released periodically to enhance functionality and offer new features.

Please follow the steps at our Support Center:
1.10.6 Legacy Help

We are proud of our continual development of Bank Positive Pay.

This folder contains help topics relevant to older versions of Bank Positive Pay. While the screens and instructions may not apply to your version, we have included them to support our existing client base.

1.10.6.1 Accounts

Overview

All data imported into Bank Positive Pay are organized around an account. The account represents a bank account used in the Bank Positive Pay files for making payments or receiving payments. This can be a checking account, depository account, or even a savings account.

Read Before Proceeding!

Never use the Sample account for live data. This account is for demonstration purposes only. Every time Bank Positive Pay is started, data in the Sample account is automatically deleted. This includes any live data. Avoid possible data loss and always use an account created and set up specifically for your organization's data. See Creating An Account to begin that process.

1.10.6.1.1 Creating An Account

Why create an account?

Bank Positive Pay with a built-in account, Sample. Do NOT use this account for live data. The data imported into Sample is deleted every time the program is started. From the standpoint of your organization's data, this is not what you want. The first step in using Bank Positive Pay is to create an account for your company data. If you need multiple accounts, follow the steps for each account.

Steps

There are actually two parts to creating an account in Bank Positive Pay.

1. Create the account
   In this step, you give the account a name and set the accounting period.
2. Setup the account
   In this step, you fill out the specifics of the account: Bank account number, Bank ABA/Routing Number, and other information that identifies your company in the ACH file.

The steps must be done in this order and both steps are required for an Bank Positive Pay file to be created.

Next Step

Create the account
1.10.6.1.1.1 Account Creation

Overview

Account Creation is the first step in the process of creating an account for your company data in Bank Positive Pay.

Create Account

Select File from the main menu, then New Account. You will see the Account Creation Wizard (Figure 1 below).

![Welcome to the Account Creation Wizard](image)

Each account contains its own settings and can be customized to fit your needs.

Each option has already been set to the most common settings (defaults).

Add an Account

- CREATE an account and ADD it to your catalog. Always select this option if you are the only one using this system.
- ADD an EXISTING account to your catalog. Select if another user created the account.

The two choices are:

- Create a new account and save it to the local catalog (most common choice)
- Open an already created account and add to local catalog

Leave the default and click Next.

Name The Account

On the next screen (Figure 2 below), name the account.
Create the Account

The Account name:
--will be presented on all reports
--will identify the account in the Account Selector
--is used as the file name on your hard drive (no special characters please)
--needs to be unique from other account names already in the program
--is the only setting in this Wizard that cannot be easily changed

Account Name |

Enter the name of your bank account (for example 'checking', 'payroll', 'Slate_Bank', etc.)

Best practice is to use a name that is descriptive of its purpose (for example, 'Checking' for a checking account instead of 'Account 1').

There are only 3 rules for names:
• Start account names with a letter, not a number
• Spaces are not allowed. Use an underscore or internal capitalization for clarity
• It must be unique from other accounts

Set Accounting Periods
On the next screen (Figure 3 below), set the accounting periods used for the account. Months, the default, is the most common choice. Note: May not be visible in all versions.

Click Next.
Accounting Periods

Your account has been created and the Accounting Periods have been set to Months by default.

Accounting Periods can be monthly, 13 periods of 4 weeks each, 4-4-5, weekly, daily, or any custom accounting period that you use.

- **Accounting Periods**
  - Months [default]
  - Other Accounting Periods
    - Setup periods now

Notes:
- Periods are optional with Positive Pay.
- Periods are needed if using Account Reconciliation in addition to Positive Pay.

---

**Switch to New Account**

The next screen (Figure 4 below) allows you to switch to the newly created account and begin using it or stay in the current account. You can always switch to the new account at any time later.

Click Finish.
Congratulations!

You have successfully set up the 'Checking' account.

From here

- Switch accounts and work in 'Checking'.
- Continue working in your current account.

Proceed to Account Setup

The final screen (Figure 5 below) that appears during the account creation process allows you to proceed immediately to Account Setup (click Yes) or skip setup at this time.

Would you like to enter/modify your ACH transmission information now? (Yes - recommended)

Note: This would be the information that you received from your bank. You can always enter or modify your entries from the main menu at 'File', 'ACH Setup'

Next Step

Account Setup

1.10.6.1.1.2 Account Setup

Overview
In Account Setup, you will enter account information to identify your organization's bank account in the ACH file.

**Required**

You must have already completed [Account Creation](#).

**Steps**

Select File from the main menu, then ACH Setup.

The ACH Setup Wizard will be displayed. Click Next.

In Figure 1 (below), you will begin to enter the information that identifies your organization in the ACH file. This is used by your bank, which is processing the ACH file, to identify the proper account to use for the transactions. Unless explicitly stated, all fields are required.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Immediate Destination Code</td>
<td>It is typically your bank's ABA/Routing number (total 9 digits). Used in File Header (record 'I' positions 5-13)</td>
<td>202881066</td>
</tr>
<tr>
<td>Immediate Destination Name</td>
<td>The name of your bank or service provider. Maximum of 23 characters. Used in File Header (record 'I' positions 41-63)</td>
<td>Bank of Any Town</td>
</tr>
<tr>
<td>Immediate Origin ID</td>
<td>Assigned by your bank. Typically either an ABA # or your Federal ID. Max 10 digits, typically only 9 used. Used in File Header (record 'I' positions 14-23).</td>
<td>130009783</td>
</tr>
<tr>
<td>Immediate Origin Name</td>
<td>Your company's name, as listed in the bank's records. Maximum of 23 characters. Used in File Header (record 'I' positions 64-86)</td>
<td>Your Company</td>
</tr>
</tbody>
</table>

**Immediate Destination Code**

The ABA or Routing Number of the bank processing the ACH file. For example, if you are transmitting the file to ABC Bank, it would be the ABA or Routing Number of ABC Bank.

**Immediate Destination Name**

The name of the same bank from Destination Code. Maximum length is 23 characters.

**Immediate Origin ID**

This is bank-assigned. In most cases it is your organization's Federal Tax ID number, although sometimes it is the ABA Number. You must obtain this from the bank.

**Immediate Origin Name**

Your company's name, as listed in the bank's records. Maximum length is 23 characters.

After filling out each field, click Next.
Company Name - Your company’s ‘short’ name which will be displayed on your customer’s, employee’s, vendor’s bank statements. Max of 16 characters. Used in Batch Headers/Records (‘5’ positions 5-20)

Company ID - Identifies your company, division or sub-unit. Typically will be your Federal ID with a leading ‘1’ (total 10 digits). Can also be your DUNS with a leading ‘3’, or bank assigned with a leading ‘9’. Often, based on the Immediate Origin Entry. Used in Batch Headers/Records (‘5’ positions 41-50 and ‘8’ positions 45-54)

Originating DFI - Typically your Immediate Destination code, without the trailing check digit 8 digits (records ‘5’ positions 80-87, ‘6’ positions 88-87 and ‘8’ positions 88-87)

Pre-fill common entries

Advanced Batch Processing (optional)

- Separate Batches by Origination Account - Multiple Source (Origination) Accounts - Typically used by payroll processors and other service bureaus handling multiple source/origination accounts. [default un-checked]

Company Discretionary Data (not displayed on recipient’s statement), Batch Header (record ‘5’, positions 21 – 40)

---

**Company Name**
Can be the same as Immediate Origin Name from the previous screen, but Company Name is limited to 16 characters. This is the name that will show on customer, employee, and vendor bank statements.

**Company ID**
In most cases, this is the Federal Tax ID. If you entered ABA Number for Immediate Origin ID on the previous screen, you should most likely enter the Federal Tax ID here. If you entered the Tax ID before, you can enter it again.

**Originating DFI**
In most cases, this is the same as the Immediate Destination ID from the previous screen with the last digit left off (making this 8 digits).

**Pre-fill Common Entries**
Click this link to fill the information in the above fields with information based on that entered in the previous screen. For example, Company ID will match Immediate Origin ID and Company Name will be the first 16 characters of Immediate Origin Name. Using this link is strictly optional.

**Advanced Batch Processing**
Check the box to separate file batches by origination account. In the textbox, enter any discretionary data you wish to include. For more information on this topic, see LINK Using multiple origination accounts

When finished, click Next.
### Application - Standard Entry Class Code

Select the primary (default) NACHA format you will be using.

- [ ] All except CTX-EDI
- **☐ CTX-EDI Subsets**

**Default NACHA format is the PPD format. To change the default to a different format, select it from the dropdown box. To use CTX, select the CTX-EDI Subsets radio button. This will use the EPN-STP 820 format.**

- **PPD - Personal**
- **EPN STP 820**

### Offset Record - 'Balanced' Files (only if requested by your bank)

- **Offset record required**
- Offset ABA/Routing #: **156533466**
- Offset Account #: **888224413**

### Preferences - These have not been pre-determined by your bank

- Default text to be included on your Customer’s, Employee’s, Vendor’s bank statement (a.k.a. Batch Description). A simple entry such as: Dues, Payroll, ePay will suffice. (10 characters max)
- **AutoPay**

- Default effective date. Automatically assigns the next available banking day, if a Saturday or Sunday is selected.
- **Next day**

---

**Figure 3 - ACH Setup (Screen 4 of 6)**

**Application - Standard Entry Class Code**

The default NACHA format is the PPD format. To change the default to a different format, select it from the dropdown box. To use CTX, select the CTX-EDI Subsets radio button. This will use the EPN-STP 820 format.

For information on other non-CTX formats, see LINK NACHA Formats

For information on CTX, see LINK CTX

**Offset Record**

If your bank requires an offset record, click this checkbox.

In Offset ABA/Routing #, enter the ABA or Routing Number for your organization's bank.

In Offset Account #, enter your organization's bank account number.

Only use an offset record if your bank notifies you that it is required.

**Preferences**

In the Default Text field, enter the description of the transaction that will show on customer, employee, and vendor bank statements. For example, you might enter "Payroll" for a direct deposit payment to an employee.

In the Default Effective Date dropdown box, select when you want the bank to process the transactions or what the bank instructs you to enter. For example, some banks want an ACH file two days prior to processing. In that case, change the dropdown to Two Days.

Note: The bank’s rules determine the exact date of processing. Contact your bank for their exact policies.

When finished, click Next.
Profile Lookup
ACH Universal has full support of profiles for creating payments. Profiles are not required by ACH Universal, however, as it is capable of ad hoc payments. When using profiles, the lookup can be done by Name or by ID Number (most common). You must ensure that the lookup field contains unique records.

Checking or Savings Accounts
If your file contains a field that differentiates an account between a checking account and a savings account, enter the appropriate checking account text into the textfield. ACH Universal will interpret all other text as indicating a savings account.

Consumer or Corporate Accounts
Similar to Checking or Savings Account text above, use text in this field to identify a consumer account. All other text in that field will cause ACH Universal to treat the record as a corporate account.

Pre-notification
Pre-notifications are used to test a transmission to ensure all settings are correct before transmitting live data. A pre-note is indicated in your data by a 0 amount. In the dropdown box, select the transaction type you wish to test (DR - collecting funds or CR - paying funds).

When finished, click Next.

The next screen is the last screen in the process. In most cases, you can simply click Finish. For information on the additional options, see ACH Setup - Advanced Options LINK.

You have finished creating and setting up an ACH Universal account. You can now begin importing data into the account and transmitting ACH files.

Next Step
Importing Transactions
1.10.6.2 Help on Help

Help on Help

This page is intended to help us deliver a consistently formatted help page to our users.

Overview
We have users with different needs - some just want the facts (for task based help), and others want to gain a full understanding of the various options. This creates a balancing act as to what and how much detail we display in the help topics.

As an example - when designing the software’s user interface, we are constantly balancing ease of use vs. full control.

If we put all of the option switches and settings out in the initial software interface, the average user might get overwhelmed and think that this is too complicated - and they’d be right.

We try to only initially display the switches that the average user would need for ease of use.
If a power user needs more granular control - we provide them a screen with the additional option settings and switches.

In a similar manner - when writing help, we need to maintain a balance between ease of use for ‘task based’ users and a full step-by-step reference guide for detailed review.

Topic page creation / formatting:
When naming the topic page, please keep in mind good SEO practices (no cramming, etc...). Repeat the name of the topic at the top of the page (important for those printing). Please skip a line before typing.

The first sentence or paragraph should be a summary of what this page intends to tell the user.
Think of this as a marketing proposition - as to the benefits of the feature and this page.

If a topic is similar to other features - ie. ‘Creating reversal records’ vs. ‘Return Files’ - please note that on the page - and point them to possible other pages.

If you are creating multiple pages on a topic, please create a new folder.
Please leave enough white space at the top for ease of reading.

Content

1. Re-use of topics. Please link to existing topics as needed (do not copy or write your own).
For example, if a user needs to perform a backup - you can provide them with a basic File > Backup command in the text, and then provide them with an internal link to the detailed backup page, such as this.

Please do NOT re-write the backup page in your topic, as it:
--takes the conversation off course as to the underlying topic,
--you’re rewriting something that already exists (may conflict with something that already exists)
--if we change that function in the future, we might not be able to find all instances to update.
If the topic does not already exist (such as backup), this would be an excellent time to add one. Note: Do not copy portions of our existing help file to new locations. This may cause us to be penalized by the search engines for 'duplicate content', as well as require us to maintain multiple sets of instructions - if we update, etc...

2. Use screen shots when possible
Many users don't read, they search/skim. Golden rule - each page should have at least one graphic or screen shot.

Screen shots are a major topic, we'll address separately.

3. Fonts, colors etc...
Please stick with the black and the default font for all text. That way, we can change the default font from Arial to anything we want in one setting. Use bold and larger sized font as needed for headings. Exception: When writing on a screen shot - you'll want to to use something that stands out, such as red.

When working with FAQ's, the question should be in italics and the answer should be in the regular font. Remember: We want to draw their eyes to the short (shorter) questions. That is what they are scanning for. Therefore, if you bold or do any other formatting, it should be on the question, not the answer.

1.10.6.2.1 Help on Screen Shots

Help on Screen Shots

This page is intended to help us deliver a consistently formatted help page with concise screen shots to our users.

Overview
As many users search/skim - visual aides are critical.

They provide a 'landmark' to the user - they can say to themselves - “that's the spot where I'm at”.

There's no right or wrong, here are some thoughts below.

Again, it's a balancing act between getting to the point and not overwhelming / cluttering the file vs. providing detailed information.

If displaying steps in a process, start with a screen shot of our Home Page (do not start with the Welcome New User screen). The one exception to this is in our Getting Started help.

Do not show common or easily understood screen shots. For example, if there is a pop-up message stating 'Press OK to continue', you do not need a screen shot of it. Simply note it in the narrative.

You can start the first screen shot on the tab they need to go to. You do not need to point to the tab. For example, if the user needs to start the Maintenance window, see below, note:
--we show the Home Page in the background
--the first arrow is FROM the Settings tab (we do not need to point them to the tab)
--the arrows are red, and 'thin' - a setting of about 3 in Snag it. We do not need to make the arrows thicker, as we are not trying to draw attention to the arrow.

Arrows
For showing logic flow, use thin arrows, preferably red (for consistency).
If you need the user to take an action and click on a button to take action, feel free to make it thicker.

Screen shots
Please resize the screen shot so it doesn't go over 820 pixels in width (or so). Otherwise, the shot will be truncated in the initial window display and the user will need to scroll right and left to read all of the text on the page.

After your initial screen shot orienting the user and providing landmarks on how to get to a panel or popup window - feel free to zoom in and only show the popup window.

In general, do not truncate popup windows or panels - it is better to resize them.
If there is no choice, use a graphic effect in Snag it to show that it was cut off.

Write critical and major points the user needs on the screen shot. Assume the user may not be reading the text.

If there are multiple steps on one screen shot, include numbers to indicate the order.

Use Snag-it's feature to capture the entire popup window - including the border. This frames the context of the graphic.

If we're asking the user to enter data into fields (ie. ACH setup) - make sure that there is data in the fields.
Also, make sure that your narrative data matches your screen shots (if you mention 10 transactions in the narrative, make sure the screen shot shows 10).

1.10.7 Bank Express Codes

Bank Express Codes

Our Bank Express Codes enable you to layout your positive pay file format with our library of bank-tested templates.

Let us know the bank you are transmitting to - and the format that they’ve assigned to you (many banks have more than one format) - and we’ll send you a three or four digit code that corresponds to that layout.

Treasury Software maintains an extensive list of positive pay transmission formats for banks of all sizes.

Please contact our support department to find out your code.
Check Issue File Formatter

Made available by Treasury Software Corporation

Introduction
Welcome to Check Issue File Formatter, a check issue file creation and transmittal software package provided by Treasury Software Corporation.

In order to participate in the BMO Harris anti-fraud Positive Pay service, as well as certain Account Reconciliation services, you need to regularly send the bank a list of the checks you issue from your checking account.

You have elected to use Treasury Software to create check issue files required for transmission to BMO Harris Bank.

Please proceed to the "Downloading the Software" section.

Download the Software

Requesting License Codes

Software Setup

Importing Your Check File

Creating and Transmitting the Positive Pay File to BMO Harris Bank

FAQ's

Obtaining additional Support - Phone Numbers
1.10.7.1.1 Downloading the Software

Download the Software
Ready to install? Please visit the following link to download the software.

On the download request page, enter your email address and select ‘Positive Pay’ - then click ‘Submit’.

After entering your email address and selecting Positive Pay you will need to click on the download link.

**Most users - click ‘Run’**
If you have advanced needs, click ‘Save’.

The installation process will start:
You will be prompted to Accept the terms of the license agreement before you can continue.

Complete the InstallShield Wizard accepting the default settings until complete. The Treasury Software icon will be saved on your Desktop.
Congratulations. The software is installed.

1.10.7.1.2 Request License Codes

REQUEST LICENSE CODES

This initial session will enable you to create your initial check issue file that you will send to the bank but you will not be allowed to use the software after an initial 7 use trial period. In order to use the software to format your check issue file on an ongoing basis, you will need to submit a request for license codes from the following web page:

http://www.treasurysoftware.com/zserver87514649352491113.aspx

The License Request Page

Enter the information requested - and select from the drop down list your bank contact. Then click on 'Submit'.

Once the request is approved by your BMO Harris Bank representative, you will receive a license via email.
1.10.7.1.3 Software Setup

INITIAL SOFTWARE USE

Follow the steps below to initiate the Positive Pay software.
1. Double click the Treasury Software Desktop icon
2. Click the Treasury Software icon. The Welcome New Users page will load.

The Welcome New Users page will continue to display until the software is licensed. After licensing the software, the program will load to the home page.
Entering License Codes
This initial session will enable you to download the file format software to create your initial check issue file that you will send to the bank but you will not be allowed to use the software after an initial 7 use trial period. In order to use the software to format your check issue file on an ongoing basis, you will need to submit a request for license codes from the following web page:
http://treasurysoftware.com/zserver87514649352491113.aspx

When the license code is emailed to you, access the software and select File > Enter/remove License Codes. The License Code entry box will appear.

Enter the License ID and password, and click the Register “key.” You are now a licensed user. Select “Close.”
**Entering Bank Express Code**

1. On the Bank Positive Pay home page, select the Setup icon
The following pop-up window will be displayed.
   - Type **875 if you are sending positive pay** information only and not payee information (the “Bank Name” BMO Harris Bank” will populate).
   - Type **876 if you are sending Payee information** for Payee Positive Pay (the “Bank Name” BMO Harris Bank” will populate).

Click the Update Bank Information button.

3. Click Yes.

4. Enter the account number in the Your Bank Account Number field and enter the three digit bank number 028 or 029 in the Your Bank Number field.

Note: This number will be assigned to you by BMO Harris Bank.
3. Click OK on the “Update successful” message box. This indicates the program has been updated to use the BMO Harris Positive Pay format. Notice that the Bank Name field text changed from “Treasury Software” to “BMO Harris Bank” after entering Bank codes 875 or 876. This text change means the Express Code has been entered successfully.

4. Click Close.

Please proceed to the next section "Importing the Data".

1.10.7.1.4 Importing your check file

Import Check File Data
Using the Check Register Import Wizard: follow this process to import check issuance transaction data to create a check issue file for upload to the bank.

Importing from QuickBooks™? See our QuickBooks Integration Wizard.

1. Start the Check Register Import Wizard by clicking the Import Check Register icon in the center of the homepage or by selecting Import Transactions off the top menu.

2. To import check data, you can browse and click “Select File” under the Folder icon.
To select a file to import, select your file and click Open. Common file software types are Excel® (.xls), Access®, Comma Delimited (.csv or .txt), tab delimited (.txt) and text (.txt).

Notice the path and file name have now been populated in the General Ledger Import Wizard window. Click Next to continue.
The “Select a worksheet or range” screen is designed to allow the user to select the appropriate worksheet from an Excel® file that contains the data to be imported. If you can see your data from the Excel® file in the grid, simply click the Next button.

If prompted to select a worksheet then please do so.

If you choose source data from a Microsoft® Excel® file, data can be copied directly from the Excel® spreadsheet and pasted directly to the software by selecting the Paste button.
The screen below shows the check issue data pasted from an Excel® Spreadsheet.

Click the Next button.
3. The General Ledger Column Mapping screen (below) enables the user to identify what information is contained in each column on the import file. Simply highlight a column, and then select the appropriate column mapping from the drop down for the data.

**Be sure to map the required columns:**
- Date
- Check Number
- Amount/Amount Reverse Sign.

In addition, if you are enrolled in Payee Positive Pay, map: Payee (Description)

![General Ledger Column Mapping](image)

**Amount notes:** The system expects issued (cut/printed) checks to be negative and voided checks to be positive. If your issued / cut checks are displayed as 'negative', simply map them as 'Amount'.

However, if your issued / cut checks are shown as a positive amount - map the field as 'Amount Reverse Sign'. Example, in the screen below - the checks are displayed as 'positive, therefore we mapped the column as 'Amount Reverse Sign'.

**Reminder:** Payee names should be mapped as Payee (Description) for those who are creating check issue files with payee name data.
4. Mapping notes:
   • Debits: when importing debits as positive transactions, map the column for the amounts as
     Amount_Reverse_Sign. This ensures
     that the debits will be viewed as balance decreasing transactions.
     • Account numbers are not required in the input data, and do not need to be mapped.
     • Optional (the system automatically defaults the correct RA and VA) - Action indicator: Identify
       void or deleted items. The action indicator should be included in the source data that is loaded to the
       File Formatter software within a separate column:
       - Register Adds: Default, no action necessary.
       - Register Deletes: Action indicator of “D”.
       - Void Adds: Opposite +/- of default items.
       - Void Deletes: Opposite +/- of default items and action indicator of “D”.
       • You need to map the columns only one time (or whenever you change the format of the input
         data).
       • The section above the column field numbers (Field 1, Field 2, Field 3, etc.) switches from red
         to green (as shown in the screen below) and lists the selected mapping. Repeat for all required
         columns.

IMPORTABLE RECORDS

1. The “Review records” screen displays a list of the importable rows and invalid rows. To review the
   list of Importable records, click on the + (plus sign). The records listing will expand and display a list of
   importable checks, and the basic check information.
The invalid row is the row of column headings. The File Formatter automatically marks header rows, footer rows, summation lines, and blank lines as invalid. For each row that is invalid, a check mark will be placed in the appropriate column indicating why the row was invalid. In the screen shot below, the invalid row was the column header - and therefore didn't contain valid transactional data.

2. Once you have verified the importable information is accurate, click the Next button. If you wish to cancel the import process and try again, simply click the Cancel button.

3. Click Finish to complete the General Ledger Import Wizard.
Please proceed to the next section "Create and Transmit the File".

1.10.7.1.5 Create and Transmit the Positive Pay File

Positive Pay File

Creating and transmitting a positive pay file to BMO Harris.

1. Select “Create File” to create the check issue file and begin upload process.
2. Click the Go To Create File Page and then click on Create Issue File to create the Positive Pay file.

The created file will be saved as noted in the third paragraph displayed on the screen above.

• The first paragraph on the screen indicates how many records will be included in the transmission file (in this example, there are 605 records).

• The second paragraph indicates the selected transmission method. (This will always be Web Upload.)
• The final paragraph displays where the transmission file will be saved. The default directory for the file is the C:\Users\Public\Treasury Software\To Bank. The default file name is the name of the account, followed by an underscore and the word ‘transmit’. The file will always have a .TXT file extension.

3. The program provides you the option to view the recently created file. Select the Yes button if you want to view and verify the file format.

4. The Check Issue File created is displayed below.

5. After file creation a web browser will then open to the BMO Harris Online Banking for Business (OLBB) login screen: https://www21.bmo.com
6. After you login to Online Banking for Business, select the Account Information tab and navigate to File Transfer Facility (FTF).

7. Click Send File to initiate the file upload process.
   - Select the appropriate Product and Document type from the dropdown menu
   - Browse to attach your file
   - Click Send File to upload your file.
8. To view a history of sent and received files, go to Account Information tab > File Transfer Facility > File History.

1.10.7.1.6 FAQs

Frequently Asked Questions

Do I use Amount or Amount Reverse sign?

How do I delete a record?

How can I delete an entire import?

Do I use Amount or Amount Reverse sign?

Amount is used when the records on the file are issued checks, and the amount on the import file is
listed as a negative amount. Amount_Reversal_Sign is used when the records on the file are issued checks, and the amount on the import file is a positive amount. The File Formatter requires Issued Checks to have a negative amount, and Void Checks to have a positive amount.

I entered the wrong Bank account number and/or Bank number. How do I fix this?
Click the Settings tab > Enter Bank Express Code. Select the Resume Startup tab and click the Resume button. This will re-enter the Account Creation wizard and bring you to the page where the Account Number and Bank Number are entered. Correct the entries as needed, click Next, and then click Finish to save the changes.

How do I change where the Issue File is saved?
Click the Settings tab > Transmit to Bank. Select the Local File tab, and modify the Transmission file location textbox. The Transmission File Location must include both a file name and extension (.TXT).

How do I delete a record?
Select the View tab > All Reports. From the drop down select the All Records Report and choose a date range. Now select a record in the grid, and click the Red X on the toolbar.
How can I delete an entire import?
From the Home tab select Delete Entire Import. Highlight the import you wish to delete and click the Red X on the toolbar. Deleting an import will remove all records from that import file from the File Formatter database.

When Importing an Excel® file, my dates convert from MM/DD/YY to numbers. How do I avoid this?
Close the Excel® file when you are importing it into the File Formatter. When the Excel® file is open during the import process, Excel® converts the dates to Julian format, which will be rejected by the File Formatter for an “Invalid Date.”

Can I manually add a record without importing? Yes. Click Edit > Add Record and enter in the check information on the form. When finished, click OK.
I need to resend a transaction to the bank, how do I do this? From the Home tab select Delete Entire Import. Highlight the import you wish to delete and click the Red X on the toolbar. Deleting an import will remove all records from that import file from the File Formatter database. Now you can reimport your data and create the file.

How do I enter my license codes? Click File > Enter/remove License Codes. Enter in the License ID and License Password and click the Register button. If prompted to complete the Authentication process, please follow the instructions provided on the screen.

Can I also select the ACH Universal or Bank Reconciliation option to format a check file to transmit to BMO Harris Bank? No. The Bank Positive Pay file option is the only option for selection by BMO Harris Bank clients.

Check Issue File Formatter is software offered by Treasury Software Corporation. BMO Harris Bank N.A. and Treasury Software Corporation are separate legal entities, which are not affiliated with each other in any way by common ownership, management, control, or otherwise. The content, availability, and processing accuracy of the Treasury Software products are the responsibility of Treasury Software Corporation. BMO Harris Bank N.A. makes no representations or warranties as to the suitability, fitness, accuracy, completeness or timeliness of the information provided, including any information or service provided by Treasury Software Corporation.

Third party web sites may have privacy and security policies different from BMO Harris. Links to other web sites do not imply the endorsement or approval of such web sites. Please review the privacy and security policies of web sites reached through links from BMO Harris. Microsoft®, Excel® and Access® are registered trademarks of Microsoft Corporation in the United States and/or other countries. Banking deposit and loan products and services are provided by BMO Harris Bank N.A. and are subject to bank and credit approval. BMO HarrisSM and BMO Harris BankSM are trade names used by BMO Harris Bank N.A. Member FDIC.

1.10.7.1.7 Support Phone Numbers

Additional Support

Treasury Software - all questions related to the software and use If you have questions regarding the check file creation and formatting process call 1.866.226.5732 or access online help at http://www.treasurysoftware.com/contact-us/index.aspx

BMO Harris Bank If you have questions on how to upload your file via the FTF module of BMO Harris Online Banking for Business, call the Client Services Help Desk at 1.866.867.2173.
1.10.7.2 Wells Fargo

This format is identical to 915, but it is used when there are multiple accounts, and the transmission record needs to include the 'master' account number, and not the account number in the detail.

Note: Of course when transmitting the master account, the header record account number, and the account number in the detail will be the same.

Master bank account number
This should be the same number in all of your accounts.

Bank number
Typically a 3 digit number, but in no case larger than 5. Again this should be the same in all of your accounts.

Full sign on record
Again, this should be the same for all of your accounts. It will have been provided by your bank and should be similar to $ADD ID=ABCDEFGH BID=COMPANY ARP INPUT FILE'

Bank account number - detail
This is for the account you are working in. This will be the 'variable' between each account.

---

How does this look in the transmission file output?
Bank Express Code 918

1.10.7.3 Scotia Bank

**Scotia Bank Positive Pay**

Bank Express Codes: Please contact your representative for codes.

Note: There are two formats - CAN and USD. The only difference between the two is the currency field in the header ('A') record, positions 35 - 37. The Canadian format is auto-populated with CAD, the US with USD.

**Setup and use**

The vast majority of Bank Express Codes don't require a help page - but the format here is a bit involved - if you choose.

You'll need to map (at a minimum):
- Date
- Check Number
- Amount

In addition, while an optional field, we would also recommend:
- Payee/Description

**All other fields are optional.**

Only if you choose to map the optional fields - which relate back to 'Payee Image Zones' (refer back to Scotia documentation), then map the fields per the following chart:

<table>
<thead>
<tr>
<th>Treasury Software</th>
<th>Scotia Bank</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text1</td>
<td>Payee Image Zone 1</td>
</tr>
<tr>
<td>Text2</td>
<td>Payee Image Zone 2</td>
</tr>
</tbody>
</table>
1.10.8 FAQ's

Enter topic text here.

1.10.8.1 I am switching banks but I need to keep my old account

If you ever decide to switch banks we recommend that you keep your old banks Positive Pay account until the account is completely closed. What we suggest for you is to create a new account. You first will need to get the new banks file format and then we will send you the new bank express code. Once you receive your Bank Express Code from Treasury Software you will want to setup your Positive Pay software. To setup your software please do the following:

1. First let's setup a new account. You will want to first select File then select New Account
Sample

Add a Record

Import Check Register

New Account
- Open Account
- Delete Account
- Recent Accounts
- Upsize / Copy Account
- Backup
- Restore
- Fix
- Enter / Remove License Codes
- Exit
2. Select **Create an account + ADD it to your catalog**

3. Enter in the Name you want to call the account and make sure you select Positive Pay. (See below) Then select the **Next** Button
4. Once your account is created select the SETUP icon on the main page.
5. Select the **Bank Code tab** and enter in the bank express code into the bank code box and then select **Update Bank Information**
6. Then select YES to apply the code.
7. Then enter in the information on the next screen. This information may be your bank’s routing number, account number or even a bank number. Now your "bank number" will come from the bank. Then select NEXT to finish the wizard.
8. Then select Finish to create your Positive Pay Account!
NOTE: Once your account is created make sure you back up your account!

From the main menu, select File > Backup!

1.10.8.2 Can I have a bank express code for my bank.

If you need a bank express code for your bank you will need to do the following for us:

1. Let us know what bank you are going to be working with each day.

2. Send us the bank file layout that your bank accepts.

If you are wondering what the bank file layout may be well that is the setup of how your bank will accept your file. This normally comes in a written document from the bank. It states the parameters of the width and justification of each item they want in the file. A example of what we are looking for is below:
### Detail Record

<table>
<thead>
<tr>
<th>FIELD NO.</th>
<th>FIELD DESCRIPTION</th>
<th>LENGTH</th>
<th>POSITION</th>
<th>VALUE</th>
<th>FORMAT</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Account number</td>
<td>12</td>
<td>01-12</td>
<td>Numeric</td>
<td>Right Justified</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Zero Filled</td>
</tr>
<tr>
<td>2</td>
<td>Record Type Code</td>
<td>1</td>
<td>13</td>
<td>Alpha</td>
<td>0 - Outstanding</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>V - Void</td>
</tr>
<tr>
<td>3</td>
<td>Check / Serial Number</td>
<td>10</td>
<td>14-23</td>
<td>Numeric</td>
<td>9(10)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Right Justified</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Zero Filled</td>
</tr>
<tr>
<td>4</td>
<td>Amount</td>
<td>12</td>
<td>24-35</td>
<td>Numeric</td>
<td>9(10)WDD</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Right Justified</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Zero Filled</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>No decimal, commas</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>or dollar signs</td>
</tr>
<tr>
<td>5</td>
<td>Date</td>
<td>6</td>
<td>36-41</td>
<td>Numeric</td>
<td>MMDDYY</td>
</tr>
<tr>
<td></td>
<td></td>
<td>8</td>
<td>36-43</td>
<td></td>
<td>YYMMDD</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>MNDDYYYY</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>YYYYMMDD</td>
</tr>
</tbody>
</table>

3. Once you get that document please contact our [Support department](#) and send it to us.

4. If we do not have your bank format on file we will be happy to setup the file format and assign it a Bank Express Code. The development team creates and publishes these codes on Monday.

1.10.8.3 **What do I do once I get my Bank Express Code?**

Once you receive your Bank Express Code from Treasury Software you will want to setup your Positive Pay software. To setup your software please do the following:

1. First let’s setup a new account. You will want to first select **File** then select **New Account**
2. Select Create an account + ADD it to your catalog

3. Enter in the Name you want to call the account and make sure you select Positive Pay. (See below) Then select the Next Button
4. Once your account is created select the SETUP icon on the main page.
5. Select the **Bank Code tab** and enter in the bank express code into the bank code box and then select **Update Bank Information**
6. Then select YES to apply the code.
7. Then enter in the information on the next screen. This information may be your bank's routing number, account number or even a bank number. Now your "bank number" will come from the bank. Then select NEXT to finish the wizard.
8. Then select Finish to create your Positive Pay Account!
NOTE: Once your account is created make sure you back up your account!

From the main menu, select File > Backup!

1.10.8.4 How do I change the location of my Positive Pay file once it is create?

Have you ever wanted to change the default location of your Positive Pay file? By default the location of your file is located at C:\Users\Public\Treasury Software\To Bank\"Account name" .txt

You can change the location by following the steps below >

1. From the main menu select the Go To Create File Page icon.
2. Then select **Change transmission file name/location** on the right side of your screen (see the red arrow).
3. Select the location where you want the file to go. This is the file that you want to send to the bank!

4. Once the location has been changed select Close!
1.10.8.5 Why didn’t my file transmit to the bank?

There are a number of different reasons why your file did not transmit to the bank. Take a look at the list below to determine why it did not happen.

1st did you contact your bank and see how they wanted you to get the file to them?

Your bank determines the method on how the file can be sent to them. See the image below on the different methods that ACH Universal has to offer, but again your bank is the one that determines it:

![Transmission Options](image)

2nd if the bank wants you to upload the file to them did you log into the banks web site and upload the file?

If you did not log instructions from the bank regarding logging into your bank site you need to contact them directly. They are the ones who can assist you through this process. We do not have ID’s or password’s from the bank.
3rd if you uploaded the file were there any errors?

If so tell us what the error is by filling out a ticket through our web site at: Contact support

Make sure you supply us a screen shot of what the error is, that way we can quickly diagnose the issue. Sometimes the error is a bank error and we will be happy to point you in the right direction to resolve any types of errors. To capture a screen shot from your PC you can utilize the key board stocks of CTRL PRTSCRN and then paste the error in a document and send that to us though our ticketing system on our site.

4th if you get an error using the automated system SSH-FTP send a screen shot of the error and we will assist you with resolving this issue.

1.10.8.6 How do you changed bank account numbers?

Have you ever been in the situation where you need to change bank account numbers because of one reason or another? You can do this in Positive Pay by doing the following steps:

Open to account you want to change the bank account.

Select the SETUP icon on the main page.
Then select the **Resume Startup** tab then select **Resume**
Resume the Startup Wizard

CAUTION: Make sure that you are already in the account that you wish to continue setting up. Use only if you stopped the original setup (needed additional information).

Enter in your **Bank Account Number** and then select **Next**
Please enter the information below, as requested for BMO Harris Bank.

Your Bank Account Number: 9595959595
Your Bank Number: 029

If the information is not available, simply press the 'Cancel' button. Your work up till now will be saved. Do not use this account until you enter this information.

To return to this screen at a later time, on the Settings tab, click the 'Import, System' control, then the 'Resume Startup' tab.

Then select **Finish**
Congratulations!

You have successfully set up the 'My POSITIVE PAY' account.

From here:
- Switch accounts and work in 'My POSITIVE PAY'.

Then select **CLOSE**!
Utilities
Utilities

2 Utilities

Utilities

This is a catch all for the various utilities included in all modules.

Please note that not all utilities will be listed, as this listing may be limited to your license level.

2.1 BAI File Creator

BAI File Creator

Use these instructions to create a BAI 2 formatted file from any imported file - such as Excel, a comma delimited (csv) file or tab delimited file.

1. Select BAI Utilities upon startup

2. Set the BAI switch (perform only once)

From the main menu select File > Options > General > System tab

Switch on the BAI format, and enter your ID and the receiver's ID.

Close the form when finished.
3. Map the fields of the file that you are importing (perform only once)
   a. Click on the wizard you wish to use.
Tip: Use the file Excel2BAI.xls located in the as a template. Please see the below location of this file.

Windows XP: Program Files\Treasury Software\version 201X xx\Tutorial\ACHData\Windows7 and later:C:\Users\Public\Treasury Software\Tutorial\ACHData

Updated 1/29

2.2 BAI Merge

Merging BAI files

Yes, you can merge multiple BAI files into a single BAI file with BAI File Creator.

Setup overview:
--Turn on BAI.
--Map the import template.
--Set up an automation template
--Create a desktop shortcut
Step-by-step instructions:
1. Enter into an account that has been created for the Bank Positive Pay module. If you haven’t done so already, click File > New Account.

2. Enter into Bank Positive Pay, and click on BAI Utilities. Then click on ‘One-time setup’.

3. Check the box ‘Create BAI Files’

Also, enter in the balance of your information. Include a default account number. Click Save, then close the window.
4. On the Home tab > click on the lower half of the Import Transactions button > select Import BAI Files. Select a BAI file and continue the wizard until you’re at the Mapping Window.
5. Select the template 'Excel 2 BAI', check the save box. Map the fields as noted below. Do not map any other fields.

Click Next - and then 'No' when prompted to map a check number.
Then click 'Next' and 'Finish' to complete the Wizard.

6. On the Settings tab > click on Software Integration Kit > select the first selection > click Add/Edit
On the Basic tab - enter as below:
On the Advanced tab - enter as below:
On the Automation tab - enter as below:
7. Open Windows Explorer, navigate to:
C:\Program Files (x86)\Treasury Software\version 2017 01 (or whatever build you are on)

Right click on BRCOM.exe and select as below:

Copy this to Notepad, Word etc...
8. Right click on the desktop icon > select Properties > Shortcut and copy in the parameters, so that the entire target looks like: "C:\Program Files (x86)\Treasury Software\version 2017 01\BRCOM.exe" /ACCT="BAI Test" /MENU /AUTO=1

Click Apply

Right Click on the icon
Now we're ready to test!

**Tip:**
Reminder - The system will NOT import/merge files that you've already imported/merged with - so please rename the files as needed.
Close the software.

Click on the icon to run it.

Check your output folder (typically C:\Users\Public\Treasury Software\To Bank\).

Troubleshooting:
--Make sure that you rename your source BAI files after each test (the system checks for duplicate file names).
--Confirm that you have uses left in your trial license and/or you have entered license codes.

2.3 ACH2Excel - ACH Conversion Utility

Overview

ACH2Excel is a utility included with ACH Universal used to convert an ACH file to an Excel spreadsheet (\xls). You can use it through ACH Universal or through the command line.

ACH2Excel through ACH Universal

Using ACH2Excel through ACH Universal is the most common method.

From the Welcome New Users screen select ACH-2-Excel.
If you are using a version prior to 2013 select File > ACH-2-Excel.
Click the "..." and browse to the ACH file to be converted.

To do a quick conversion, click Done. This will convert the file and load it in Excel (as a csv value).

To specify file output options, click Output to open the Output tab (Figure 2 below).

**Figure 2 - ACH2Excel Output tab**
Utilities

To output the conversion to a specific click, enable the Output to ‘csv’ file located in the directory checkbox, then click the ... button to browse to the appropriate directory.

To import the converted file into ACH Universal for further processing (such as an ACH Return File for Returns), enable the checkbox.

Click Done to create the file.

Command Line Options

BRCom.exe /ACCT="account" /ACH2 /SRCE="input file name" /OUTD="output file name"

/ACCT - specifies account by name
/ACH2 - specifies to use the ACH2Excel utility
/SRCE - specifies file to be used as input (using absolute positioning)
/OUTD - specifies file to be used as output (using absolute positioning)

Valid source files include ARC, CCD, CIE, CTX, DNE, ENR, POP, PPD, RCK, TEL, TRC, TRX, WEB, XCK. Note: Some formats may require further parsing.

Syntax Example

If Treasury Desktop was installed in the default location:

c:\Program Files\TreasurySoftware\BRCom.exe /ACCT="sample" /ACH2 /SRCE="C:\transmit.txt" /OUTD="c:\testACHdetail.csv"

Reminder:

Turn on/off appropriate settings. From the main menu ‘File’, ‘ACH File Conversion’, ‘Output’ tab - unselect open in Excel afterwards.

Notes for all applications:
· The order of the parameters is not significant
· Capitalization is not significant
· When specifying a file name (SRCE), use the full file path and name within quotes. When using mapped drives, remember that the path should be centric/relative to the machine where Treasury Desktop is located, not the machine issuing the trigger/command.
· Place the account name in quotes.

Working with multiple users and multiple account:
Each command line trigger - will create an independent instance of the application. There is no limit to the number of instances.

If processing simultaneous command line requests, use different accounts (Sample1, Sample2, etc...) to minimize any record locking issues. If this is not an alternative, consider processing sequentially, or using our Control Panel.

For Web and Citrix based applications, please contact a Treasury Software support representative.

2.4 Notification of Change ABA Merge Utility

Overview

The Notification of Change Merge Utility enables users to Import an ACH file and generate Notification of Change transactions for each record which has the old ABA number.
The Notification of Change (COR) entry will contain the new ABA number as the corrected data, as well as 'C02' (Updated ABA number) as the NOC code.

After the Notification of Change transactions are created, you can create an ACH file to send, just like any other ACH file.

Notes:
--Transactions in the ACH file which do not have the old ABA number are ignored.
--This utility is only available in the Banking Edition

Setup

We recommend that you print this page prior to starting.

1. Create a new account specifically for this utility
   From the main menu select File > New > Create and complete the New Account Wizard. When finished, it will prompt you if you want to 'Enter your transmission information now?'. Click Yes.

2. ACH Setup wizard
   Note: If you did not select 'Yes' in the step above, simply select ACH Setup Wizard from the Home tab. If you are using a version prior to 2013 select File > ACH Setup to start the wizard.

   a. On screen 3 of 7 select COR - Notification of Change.
b. On screen 7 of 7 click on the ‘NOC-COR’ tab.

Enter the old and new ABA numbers.

We recommend checking the ‘Auto-delete’ feature. This feature addresses the ACH records you will be importing that do not use the old ABA number. As these records are of no use to you, we can provide the housekeeping functionality to remove them. However, if you wish to keep them - leave the checkbox unchecked. Click ‘Finish’ to save your updates.

c. Import Safety Locks - recommended (not required):
We highly recommend putting the Import Safety Locks ‘On’.
From the main menu select File > Options > General > Import tab. Scroll to the bottom and turn the Safety Locks ‘On’.
This prevents your users from accidentally trying to import the ACH file from the main screen icon. If they try to import from the main screen it will only convert their ACH file to Excel, it will not import the file.
Import ACH file received
Import your ACH file received from the Federal Reserve Bank (or other processor) from the main menu at Import > ACH File > ACH File.

Create new ACH file containing NOC’s
Click on the ‘Create ACH File’ button on the home page, then click on the ‘Create ACH File’ button on the creation page.

Import Safety Locks
Disables imports from the home page icons. Requires the user to start an import from the main menu. Highly recommended when using custom import menus (software integration kit) or non-standard imports (from the main menu).
Note: The count on the creation page is for all transactions in the file, not just the NOC transactions.

Done - Congratulations!
Treasury Management
3 Treasury Management

Treasury Software supports many types of transmission files, including those for:
--Integrated Payables
--Card Services
--Wire transfers
and more.

These formats are included within our Bank Positive Pay Automation edition.

Within this help category are Bank Express Codes relating to different formats.

3.1 Integrated Payables (1180)

Regions Bank Integrated Payables

Treasury Software can now integrate with QuickBooks to create an Integrated Payables file that is compatible with Regions Bank (SunGard processing).

The output file can be then uploaded to Regions OnePass™.

Treasury Software creates a file with the following fields:
--Payment Amount
--Payment Number
--Check Date
--Payee/Vendor Name
--Payee/Vendor Address
--Payee/Vendor Address Line 2
--Payee City
--Payee State
--Payee Zip
--Payee/Vendor Number
--Remittance information

Unique field
The fourth field (Payee/Vendor Name) meets the requirements of SunGard/Regions Bank in being unique to each vendor, as this is pulled from the profile name (Vendor name) within QuickBooks.

Sample File

Integrated Payables with Treasury Software's Bank Positive Pay
While the Integrated Payables and Positive Pay files have different formats, the processes are virtually identical. Unless noted otherwise, all processes are the same for the two formats.

Please follow the same instructions and videos within our Bank Positive Pay module.

Ready to get started? See our setup page.

3.1.1 Setup - Integrated Payables

How to create Regions Bank (SunGard) Integrated Payables files from QuickBooks

1. Upon start up, enter into Bank Positive Pay from the Welcome New User page
2. From the Home page, click Setup. Enter in 1180 and click Update - complete the Wizard. Close the popup window.
3. Create a new account within ACH Universal
   Click File > New Account and complete the Wizard.

4. Open QuickBooks to the company that you want to use.
   From the Home tab in Treasury Software, click QuickBooks Integration to start the Wizard and see your data.

   You'll be prompted by QuickBooks to allow Treasury Software access to the company file (qbw). Please allow so, third option.
Continue the Wizard to view your data.

When viewing your data, you can also create an Integrated Payables file.

The above is an overview to get set up. Please see our video tutorials and instructions for Bank Positive Pay.

3.2 Commercial Card (1190)
Treasury Software can now integrate with QuickBooks to create an Commercial Card flat file that is compatible with Regions Bank (Encompass AOC-Solutions processing).

The output file can be then uploaded to Regions OnePass™.

Treasury Software creates a file with the following fields (all required fields are populated):
- MerchantCode (Required)
- InvoiceNumber (Required)
- InvoiceDate (Required)
- InvoiceAmount (Required)
- TaxAmount
- DiscountAmount
- FreightAmount
- ClientPaymentCode
- ClientReferenceNumber
- Description
- UDF1Label
- UDF1Value
- UDF2Label
- UDF2Value
- UDF3Label
- UDF3Value
- UDF4Label
- UDF4Value

**Unique field**
The first field (MerchantCode Name) meets the requirements of Regions Bank in being unique to each vendor, as this is pulled from the profile name (Vendor name) within QuickBooks.

**Sample File**

![Sample File](image)
Commercial Card with Treasury Software's Bank Positive Pay
While the Commercial Card and Positive Pay files have different formats, the processes are virtually identical. Unless noted otherwise, all processes are the same for the two formats.

Please follow the same instructions and videos within our Bank Positive Pay module.

Ready to get started? See our setup page.

3.2.1 Setup - Commercial Card

How to create Regions Bank (Encompass AOC Solutions) Commercial Card files from QuickBooks

1. Upon start up, enter into Bank Positive Pay from the Welcome New User page

2. From the Home page, click Setup. Enter in 1190 and click Update - complete the Wizard. Close the popup window.
3. Create a new account within ACH Universal
   Click File > New Account and complete the Wizard.

4. Open QuickBooks to the company that you want to use.
   We're now going to create a field to identify the vendors that you want to pay with Commercial Card.
   Select any vendor and click edit.
   Go to the Additional Info tab, then click Define Fields.
Type in the word Payables. Check the Vendor column. Click OK, then OK again.

Select a vendor and click edit. Go to the Additional Info tab, click Define Fields.

Type in: Payables
This will create a field within QuickBooks called Payables. Enter in the word Card for any vendors that you want to pay with Commercial Card.

Flag the vendors that you want to pay by card, by entering the word Card in their profile.

5. Now switch back to Treasury Software - we're going to integrate the two systems. From the Home tab in Treasury Software, click QuickBooks Integration to start the Wizard and see your data.

You'll be prompted by QuickBooks to allow Treasury Software access to the company file (qbw). Please allow so, third option.
Continue the Wizard to view your data.

When viewing your data, you can also create an Commercial Card file.

The above is an overview to get set up. Please see our video tutorials and instructions for Bank Positive Pay.

Treasury Software technician note:
The Bank Express Code will auto-populate the custom code 367. This code is needed to read the value in the QuickBooks Payables field.
Index

Transaction
  Delete  19
  Edit  20
Transmit file to the bank  15
Transmitting ACH file  124
Tutorials  6

- U -

Updates  137
Upgrade to new version  137

- V -

Videos  6